lam-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210
  1. #
  2. # Copyright (c) 2001-2003 The Trustees of Indiana University.
  3. # All rights reserved.
  4. # Copyright (c) 1998-2001 University of Notre Dame.
  5. # All rights reserved.
  6. # Copyright (c) 1994-1998 The Ohio State University.
  7. # All rights reserved.
  8. #
  9. # This file is part of the LAM/MPI software package. For license
  10. # information, see the LICENSE file in the top level directory of the
  11. # LAM/MPI source distribution.
  12. #
  13. # $Id: lam-generic.spec,v 1.3 2003/05/30 22:08:07 jsquyres Exp $
  14. #
  15. %define _sysconfdir /etc/lam
  16. %define _romiodocdir /usr/share/lam/doc
  17. Summary: LAM/MPI (Local Area Multicomputer) programming environment
  18. Summary(ja): MPIメッセージパッシング形式の並列アプリケーション作成環境
  19. Name: lam
  20. Version: 7.1.4
  21. Release: 3%{?_dist_release}
  22. License: BSD
  23. Group: Development/Libraries
  24. Source: lam-%{version}.tar.gz
  25. Patch: lam-helppath.patch
  26. URL: http://www.lam-mpi.org/
  27. ExcludeArch: ia64
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. BuildRequires: gcc-gfortran
  30. Provides: mpi
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. %description
  34. LAM (Local Area Multicomputer) is an MPI programming environment and
  35. development system for heterogeneous computers on a network. With
  36. LAM/MPI, a dedicated cluster or an existing network computing
  37. infrastructure can act as one parallel computer solving one problem.
  38. LAM/MPI is considered to be "cluster friendly", in that it offers
  39. daemon-based process startup/control as well as fast client-to-client
  40. message passing protocols. LAM/MPI can use TCP/IP and/or shared
  41. memory for message passing (different RPMs are supplied for this --
  42. see the main LAM web site for details).
  43. LAM features a full implementation of MPI-1 (with the exception that
  44. LAM does not support cancelling of sends), and much of MPI-2.
  45. Compliant applications are source code portable between LAM/MPI and
  46. any other implementation of MPI. In addition to providing a
  47. high-quality implementation of the MPI standard, LAM/MPI offers
  48. extensive monitoring capabilities to support debugging. Monitoring
  49. happens on two levels. First, LAM/MPI has the hooks to allow a
  50. snapshot of process and message status to be taken at any time during
  51. an application run. This snapshot includes all aspects of
  52. synchronization plus datatype maps/signatures, communicator group
  53. membership, and message contents (see the XMPI application on the main
  54. LAM web site). On the second level, the MPI library is instrumented
  55. to produce a cummulative record of communication, which can be
  56. visualized either at runtime or post-mortem.
  57. %prep
  58. %setup -q
  59. # Otherwise, this directory shows up on security reports
  60. chmod -R o-w $RPM_BUILD_DIR/lam-%{version}
  61. %build
  62. %configure \
  63. --with-rpi=usysv \
  64. --with-fc=gfortran \
  65. --enable-shared \
  66. --enable-static \
  67. --sysconfdir=%{_sysconfdir} \
  68. make %{?_smp_mflags} all
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. %makeinstall
  72. rm -f $RPM_BUILD_ROOT/usr/include/mpi++.h
  73. ln -s mpi2c++/mpi++.h $RPM_BUILD_ROOT/usr/include/mpi++.h
  74. # Rename the ROMIO doc files so that we can install them in the same
  75. # doc root later, and not overwrite LAM's doc files.
  76. for file in README README_LAM COPYRIGHT; do
  77. mv $RPM_BUILD_DIR/lam-%{version}/romio/$file \
  78. $RPM_BUILD_DIR/lam-%{version}/romio/romio-$file
  79. done
  80. mv $RPM_BUILD_DIR/lam-%{version}/romio/doc/users-guide.ps.gz \
  81. $RPM_BUILD_DIR/lam-%{version}/romio/doc/romio-users-guide.ps.gz
  82. # remove unused files
  83. rm -f $RPM_BUILD_ROOT/%{_libdir}/lib*.la
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %files
  87. %defattr(-,root,root)
  88. %doc LICENSE HISTORY INSTALL README
  89. %doc examples
  90. %doc doc/*.pdf
  91. # Need to fix ROMIO install script to install its docs in the Right place
  92. %doc %{_romiodocdir}
  93. %config %{_sysconfdir}
  94. %{_bindir}/*
  95. %{_mandir}/*/*
  96. %{_includedir}/*
  97. %{_libdir}/lam
  98. %{_libdir}/*.a
  99. %{_libdir}/*.so
  100. %{_libdir}/*.so.*
  101. #%{_datadir}/lam/lam-shell-setup.*
  102. #%{_datadir}/lam/lam_module.tcl
  103. %changelog
  104. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 7.1.4-3
  105. - rebuild with gcc-5.4.0
  106. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.1.4-2
  107. - rebuild with VineSeed environment
  108. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 7.1.4-1vl5
  109. - fixed typo of last changelog release number
  110. - removed lib*.la
  111. * Sun Aug 24 2008 Shu KONNO <owa@bg.wakwak.com> 7.1.4-0.1vl5
  112. - applied new versioning policy, spec in utf-8
  113. - updated lam to 7.1.4
  114. - added japanese summary
  115. * Sun Dec 30 2007 Shu KONNO <owa@bg.wakwak.com> 7.0-1vl2
  116. - updated gcc-g77 to gcc-gfortran in BuildRequires
  117. - added "--with-fc=gfortran" to %%configure
  118. * Thu Aug 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.0-1vl1
  119. - based on new upstream
  120. (http://www.lam-mpi.org/download/files/lam-7.0-1.src.rpm)
  121. - rebuild with new toolchains
  122. * Thu Dec 21 2000 Jun Nishii <jun@vinelinux.org>
  123. - 6.3.3b47-1vl2
  124. - build with gcc
  125. * Thu Dec 21 2000 Jun Nishii <jun@vinelinux.org>
  126. - 6.3.3b47-1vl1
  127. - use macros for spec
  128. - correct path of helpfile
  129. * Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  130. - 6.3.3b47
  131. * Thu Aug 17 2000 Trond Eivind Glomsrød <teg@redhat.com>
  132. - 6.3.3b28, which should match the release. One known
  133. problem on SCO, otherwise none. This includes
  134. fixing some programs which didn't work in the
  135. last build.
  136. * Thu Jul 27 2000 Harald Hoyer <harald@redhat.com>
  137. - fixed the install process, that the lam tools have the
  138. right path set. make all;make DESTDIR install is
  139. our friend.
  140. * Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  141. - a new and better world without dirty tricks necesarry.
  142. All hail the 6.3.3beta (beta 20 - all my requests and
  143. patches seem to be in now :)
  144. * Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
  145. - substituted some old dirty tricks for new ones to make
  146. it build. More needed.
  147. - Removed C++ (won't build) and ROMIO (who cares) support
  148. * Thu Jun 15 2000 Trond Eivind Glomsrød <teg@redhat.com>
  149. - ugly tricks to make it use %%{_mandir}
  150. - patch to make it build with current compiler and glibc
  151. - don't build on IA64
  152. * Tue Apr 25 2000 Trond Eivind Glomsrød <teg@redhat.com>
  153. - changed RPI to usysv - this should be good for
  154. (clusters of) SMPs.
  155. * Wed Mar 28 2000 Harald Hoyer <harald@redhat.com>
  156. - patched scheme Makefile
  157. * Tue Mar 28 2000 Harald Hoyer <harald@redhat.com>
  158. - new subminor version
  159. - patched Makefile to build otb daemons, to satisfy conf.otb and build all
  160. stuff
  161. * Sat Mar 04 2000 Cristian Gafton <gafton@redhat.com>
  162. - fixed the whole tree the hard way - get into each Makefile and fix
  163. brokeness on a case by case basis. Traces of Buildroot should be
  164. erradicated by now.
  165. * Thu Mar 02 2000 Cristian Gafton <gafton@redhat.com>
  166. - put back the mpi2c++ stuff.
  167. * Tue Feb 29 2000 Cristian Gafton <gafton@redhat.com>
  168. - take out the mpi2c++ in a separate package
  169. * Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
  170. - first version of the package