ldns-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353
  1. %{?!with_python: %global with_python 1}
  2. %{?!enable_gost: %global enable_gost 1}
  3. %{?!enable_dane: %global enable_dane 1}
  4. %if %{enable_gost}
  5. %define subdir_conf_opt --disable-rpath --disable-static
  6. %else
  7. %define subdir_conf_opt --disable-rpath --disable-static --disable-gost
  8. %endif
  9. Summary: Lowlevel DNS(SEC) library with API
  10. Summary(ja): 低レベルな DNS(SEC) ライブラリと API
  11. Name: ldns
  12. Version: 1.7.1
  13. Release: 1%{?_dist_release}
  14. License: BSD
  15. Url: http://www.nlnetlabs.nl/%{name}/
  16. Source: https://www.nlnetlabs.nl/downloads/ldns/%{name}-%{version}.tar.gz
  17. Group: System Environment/Libraries
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
  20. BuildRequires: perl, libpcap-devel
  21. %if %{enable_gost}
  22. BuildRequires: openssl-devel >= 1.0.0
  23. %else
  24. BuildRequires: openssl-devel
  25. %endif
  26. %if %{with_python}
  27. BuildRequires: python-rpm-macros
  28. %endif
  29. Requires: libpcap, openssl
  30. Distribution: Vine Linux
  31. Vendor: Project Vine
  32. Packager: iwaim
  33. %if %{with_python}
  34. BuildRequires: python-devel, swig
  35. %endif
  36. %description
  37. ldns is a library with the aim to simplify DNS programing in C. All
  38. lowlevel DNS/DNSSEC operations are supported. We also define a higher
  39. level API which allows a programmer to (for instance) create or sign
  40. packets.
  41. %package devel
  42. Summary: Development package that includes the ldns header files
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. The devel package contains the ldns library and the include files
  47. %if %{with_python}
  48. %package python
  49. Summary: Python extensions for ldns
  50. Group: Applications/System
  51. Requires: %{name} = %{version}-%{release}
  52. %description python
  53. Python extensions for ldns
  54. %endif
  55. %prep
  56. %setup -q
  57. %build
  58. %configure --disable-rpath --disable-static \
  59. %if %{with_python}
  60. --with-pyldns \
  61. %endif
  62. %if !%{enable_gost}
  63. --disable-gost \
  64. %endif
  65. %if !%{enable_gost}
  66. --disable-dane-verify \
  67. %endif
  68. --with-sha2
  69. make %{?_smp_mflags}
  70. make %{?_smp_mflags} drill
  71. make %{?_smp_mflags} examples
  72. make %{?_smp_mflags} doc
  73. %install
  74. rm -rf %{buildroot}
  75. mkdir -p %{buildroot}%{_libdir}/pkgconfig
  76. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
  77. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-drill
  78. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-examples
  79. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
  80. %if %{with_python}
  81. # remove execute perms from python files
  82. chmod a-x %{buildroot}%{python_sitearch}/*py
  83. %endif
  84. # don't package building script in doc
  85. rm doc/doxyparse.pl
  86. #remove doc stubs
  87. rm -rf doc/.svn
  88. #remove double set of man pages
  89. rm -rf doc/man
  90. # remove .la files
  91. rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
  92. %clean
  93. rm -rf %{buildroot}
  94. %files
  95. %defattr(-,root,root)
  96. %{_libdir}/libldns*so.*
  97. %{_bindir}/drill
  98. %{_bindir}/ldnsd
  99. #%{_bindir}/ldns-*
  100. %{_bindir}/ldns-chaos
  101. %{_bindir}/ldns-compare-zones
  102. %{_bindir}/ldns-[d-z]*
  103. %doc README LICENSE
  104. %{_mandir}/*/*
  105. %files devel
  106. %defattr(-,root,root,-)
  107. %{_libdir}/libldns*so
  108. %{_bindir}/ldns-config
  109. %{_libdir}/pkgconfig/*.pc
  110. %dir %{_includedir}/ldns
  111. %{_includedir}/ldns/*.h
  112. %doc doc Changelog README
  113. %if %{with_python}
  114. %files python
  115. %defattr(-,root,root)
  116. %{python_sitearch}/*
  117. %endif
  118. %post -p /sbin/ldconfig
  119. %postun -p /sbin/ldconfig
  120. %changelog
  121. * Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
  122. - updated to 1.7.1.
  123. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-2
  124. - rebuilt with openssl-1.1.1.
  125. * Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.0-1
  126. - update to 1.7.0
  127. - add enable_dane option
  128. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.17-2
  129. - rebuilt with openssl-1.0.2g.
  130. * Mon Mar 9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.17-1
  131. - update to 1.6.17
  132. - drop 'fix compiler warnings and one uninitialized value' patch (Patch1000)
  133. - upstream merged
  134. * Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.16-2
  135. - add 'fix compiler warnings and one uninitialized value' patch (Patch1000)
  136. - from Fedora ldns-1.6.16-6.fc20
  137. * Wed Dec 5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
  138. - new upstream release
  139. * Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
  140. - new upstream release
  141. - move python files to sitearch from sitelib
  142. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
  143. - rebuild with python-2.7.2
  144. * Sat Sep 3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
  145. - new upstream release
  146. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  147. - new upstream release
  148. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
  149. - new upstream release
  150. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
  151. - new upstream release
  152. - add enable_gost flag: default disable
  153. - defined subdir_conf_opt rpm macro
  154. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
  155. - new upstream release
  156. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
  157. - new upstream release
  158. - drop unnecessary installfix patch (Patch1): upstream merged
  159. - drop unnecessary rpathfix patch (Patch2): upstream merged
  160. * Thu Jun 3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
  161. - rebuild with libpcap 1.1.1 on VineSeed
  162. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
  163. - initial build for Vine Linux: based Fedora 1.6.4-2.fc13
  164. * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
  165. - Fix missing _ldns.so causing ldns-python to not work
  166. - Patch for installing ldns-python files
  167. - Patch for rpath in ldns-python
  168. - Don't install .a file for ldns-python
  169. * Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
  170. - Upgraded to 1.6.4.
  171. - Added ldns-python sub package
  172. * Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
  173. - Upgraded to 1.6.3, which has minor bugfixes
  174. * Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
  175. - Upgraded to 1.6.2. This fixes various bugs.
  176. (upstream released mostly to default with sha2 for the imminent
  177. signed root, but we already enabled that in our builds)
  178. * Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
  179. - rebuilt with new openssl
  180. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
  181. - Added openssl dependancy back in, since we get more functionality
  182. when using openssl. Especially in 'drill'.
  183. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
  184. - Updated to 1.6.1
  185. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  187. * Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
  188. - Fixed the ssl patch so it can now compile --without-ssl
  189. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
  190. - Added patch to compile with --without-ssl
  191. - Removed openssl dependancies
  192. - Recompiled with --without-ssl
  193. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
  194. - Updated to 1.6.0
  195. - (did not yet compile with --without-ssl due to compile failures)
  196. * Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
  197. - Updated to 1.6.0
  198. - Compile without openssl
  199. * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
  200. - Memory management bug when generating a sha256 key, see:
  201. https://bugzilla.redhat.com/show_bug.cgi?id=493953
  202. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
  203. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  204. * Tue Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
  205. - Updated to new version, 1.5.0 had a bug preventing
  206. zone signing.
  207. * Mon Feb 9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
  208. - Updated to new version
  209. * Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
  210. - fixed configure flags
  211. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  212. - rebuild with new openssl
  213. * Fri Nov 7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
  214. - Updated to 1.4.0
  215. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
  216. - enable SHA2 functionality
  217. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  218. - re-tag (don't do builds while renaming local repo dirs)
  219. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  220. - Updated to latest release
  221. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
  222. - Autorebuild for GCC 4.3
  223. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
  224. - Rebuild for new libcrypto
  225. * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
  226. - Upgraded to 1.2.2. Removed no longer needed race workaround
  227. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
  228. - Try to fix racing ln -s statements in parallel builds
  229. * Fri Nov 9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
  230. - Added patch for ldns-read-zone that does not put @. in RRDATA
  231. * Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
  232. - Use install -p to work around multilib conflicts for .h files
  233. * Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
  234. - Updated to 1.2.1
  235. - Removed patches that got moved into upstream
  236. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
  237. - Patch for ldns-key2ds to write to stdout
  238. - Again remove extra set of man pages from doc
  239. - own /usr/include/ldns (bug 233858)
  240. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
  241. - Added sha256 DS record patch to ldns-key2ds
  242. - Minor tweaks for proper doc/man page installation.
  243. - Workaround for parallel builds
  244. * Mon Aug 6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
  245. - Own the /usr/include/ldns directory (bug #233858)
  246. - Removed obsoleted patch
  247. - Remove files form previous libtool run accidentally packages by upstream
  248. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
  249. - Commented out 1.1.0 make targets, put make 1.0.1 targets.
  250. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
  251. - Fixed changelog typo in date
  252. - Rebuild requested for PT_GNU_HASH support from gcc
  253. - Did not upgrade to 1.1.0 due to compile issues on x86_64
  254. * Fri Jan 6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
  255. - Upgraded to 1.0.1. Removed temporary clean hack from spec file.
  256. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
  257. - Cannot use make clean because there are no Makefiles. Use hardcoded rm.
  258. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
  259. - Patched 'make clean' target to get rid of object files shipped with 1.0.0
  260. * Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
  261. - added a make clean for 2.3.3 since .o files were left behind upstream,
  262. causing failure on ppc platform
  263. * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
  264. - minor cleanups
  265. * Wed Oct 5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
  266. - reworked for svn version
  267. * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
  268. - Initial version