lilo-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495
  1. %define version 22.6
  2. %define release 0vl1
  3. Summary: The boot loader for Linux and other operating systems.
  4. Name: lilo
  5. Version: %{version}
  6. Release: %{release}
  7. License: MIT
  8. Group: System Environment/Base
  9. URL: http://home.san.rr.com/johninsd/pub/linux/lilo/
  10. Source: http://home.san.rr.com/johninsd/pub/linux/lilo/lilo-%{version}.tar.bz2
  11. SOURCE10: vine30.bmp
  12. Patch0: lilo-21.6-keytab-3mdk.patch.bz2
  13. Patch1: lilo-disks-without-partitions.patch.bz2
  14. Patch9: lilo-22.5.1-unsafe-and-default-table.patch.bz2
  15. Patch20: lilo-22.6-graphic-makefile.patch.bz2
  16. Patch21: lilo-22.5.9-graphic.patch.bz2
  17. Patch22: lilo-22.6-mandir.patch.bz2
  18. Patch26: lilo-22.5.9-longer_image_names.patch.bz2
  19. Patch27: lilo-22.5.8-two_columns.patch.bz2
  20. Patch28: lilo-22.5.9-never-relocate-when-has-partititions.patch.bz2
  21. Patch29: lilo-22.5.9-initialize-Volume-IDs-with-no-fanfare.patch.bz2
  22. Patch30: lilo-22.5.9-test-edd.patch.bz2
  23. Patch31: lilo-22.5.9-exit_code_1_when_aborting.patch.bz2
  24. BuildRequires: tetex, dev86, fileutils, nasm
  25. PreReq: perl
  26. Exclusivearch: %{ix86}
  27. Buildroot: %{_tmppath}/%{name}-%{version}-root
  28. %description
  29. LILO (LInux LOader) is a basic system program which boots your Linux
  30. system. LILO loads the Linux kernel from a floppy or a hard drive, boots
  31. the kernel and passes control of the system to the kernel. LILO can also
  32. boot other operating systems.
  33. %prep
  34. %setup -q
  35. %patch0 -p1
  36. %patch1 -p1
  37. %patch9 -p1
  38. %patch20 -p1
  39. %patch21 -p1
  40. %patch22 -p1
  41. %patch26 -p1 -b .images
  42. %patch27 -p1 -b .two
  43. %patch28 -p1
  44. %patch29 -p1
  45. %patch30 -p1
  46. %patch31 -p1
  47. bzip2 -9 README*
  48. %build
  49. perl -p -i -e "s/-Wall -g/$RPM_OPT_FLAGS/" Makefile
  50. make
  51. (cd doc
  52. make CFLAGS="$RPM_OPT_FLAGS"
  53. dvipdfm -o User_Guide.pdf user.dvi
  54. dvipdfm -o Technical_Guide.pdf tech.dvi
  55. rm -f *.aux *.log *.toc)
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. mkdir -p $RPM_BUILD_ROOT%{_prefix}
  59. make install ROOT=$RPM_BUILD_ROOT
  60. install -d $RPM_BUILD_ROOT%{_bindir}
  61. mv $RPM_BUILD_ROOT%{_sbindir}/* $RPM_BUILD_ROOT%{_bindir}
  62. # graphic addons, keep default options for bmp2mdk
  63. %{__perl} ./bmp2mdk mode:0x103 \
  64. timer:357,610,0,128 \
  65. entry:161,144,0,128,13,54 \
  66. progress:405,167,11,17,128 \
  67. clear:600,800,64+127 \
  68. pos:0,0 \
  69. < %{SOURCE10} > $RPM_BUILD_ROOT/boot/message
  70. install bmp2mdk %buildroot%{_bindir}/lilo-bmp2mdk
  71. mkdir -p %buildroot/%{_mandir}/man{5,8}/
  72. install -m644 manPages/*.5 %buildroot/%{_mandir}/man5/
  73. install -m644 manPages/*.8 %buildroot/%{_mandir}/man8/
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %post
  77. if [ -f /etc/lilo.conf ]; then
  78. chmod 600 /etc/lilo.conf
  79. /sbin/lilo > /dev/null
  80. fi
  81. %files
  82. %defattr(-,root,root)
  83. %doc README* COPYING
  84. %doc doc/*.pdf CHANGES INCOMPAT QuickInst
  85. /boot/message
  86. /boot/diag1.img
  87. /boot/diag2.img
  88. /sbin/*
  89. %{_bindir}/*
  90. %{_mandir}/*/*
  91. %changelog
  92. * Sun Nov 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 22.6.1-0vl1
  93. - new upstream release
  94. - merged with mandrake's lilo-22.6-1mdk
  95. * Tue Sep 21 2004 Pixel <pixel@mandrakesoft.com> 22.5.9-9mdk
  96. - add README.test_bios in patch test-edd
  97. * Thu Sep 9 2004 Pixel <pixel@mandrakesoft.com> 22.5.9-6mdk
  98. - exit_code_1 when aborting
  99. - add patch to build test-edd.b
  100. (build, then define TEST_EDD in first.S, build again, then use first.b)
  101. * Tue Aug 17 2004 Pixel <pixel@mandrakesoft.com> 22.5.9-5mdk
  102. - add patch initialize-Volume-IDs-with-no-fanfare
  103. (to initialize Volume IDs without prompting)
  104. * Fri Aug 6 2004 Pixel <pixel@mandrakesoft.com> 22.5.9-4mdk
  105. - never-relocate-when-has-partititions (lilo tries to skip overwriting the
  106. first 0x40 bytes of the devices when it detects a dos bootsector, alas it can
  107. detect one on the MBR)
  108. * Mon Aug 2 2004 Pixel <pixel@mandrakesoft.com> 22.5.9-3mdk
  109. - lilo-bmp2mdk: accept bmp images with palette bigger than 128 colors *if* colors above 128 are not used
  110. * Fri Jul 30 2004 Pixel <pixel@mandrakesoft.com> 22.5.9-2mdk
  111. - merge in graphic patch21 allgraph (patch23) and progress (patch24)
  112. - add handling of xxx.bmp.parameters in lilo-bmp2mdk
  113. to generate xxx.bmp.parameters use drakxplash2 (until merged in draksplash)
  114. * Fri Feb 6 2004 Juan Quintela <quintela@mandrakesoft.com> 22.5.8-4mdk
  115. - fix compilation with 2.6 headers (should still compile with 2.4 ones).
  116. - longer names are allowed for i686-up-4GB & friends to work.
  117. - 15 -> 31 chars should be enough (it needs to be (2^n)-1.
  118. - getting previous point to work is more difficult that it sounds.
  119. * Wed Jan 7 2004 Pixel <pixel@mandrakesoft.com> 22.5.8-3mdk
  120. - provides bootloader (basesystem now requires "bootloader" instead of lilo)
  121. * Fri Dec 19 2003 Luca Berra <bluca@vodka.it> 22.5.8-2mdk
  122. - shut up if device mapper is not loaded
  123. - glibc 2.3.3 needs <asm/page.h> included
  124. - added device mapper support (optional)
  125. - removed packager tag
  126. * Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 22.5.8-0vl1
  127. - new upstream release
  128. * Wed Nov 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 22.5.7.2-0vl3
  129. - change text color on boot screen
  130. * Tue Nov 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 22.5.7.2-0vl2
  131. - simply install message-graphics as message
  132. * Tue Nov 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 22.5.7.2-0vl1
  133. - new upstream release
  134. - new lilo package based on Mandrake's package.
  135. * Sat Mar 09 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.4.4-8vl6
  136. - update boot graphics
  137. * Sat Sep 08 2001 Toru Sagami <sagami@vinelinux.org> 21.4.4-8vl5
  138. - changed BuildPreReq: tetex, not obsoleted dvipsk
  139. * Fri Mar 09 2001 sagami@vinelinux.org 21.4.4-8vl4
  140. - man-pages are included and added BuildPreReq: dvipsk dev86 fileutils
  141. * Sun Oct 1 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  142. - update boot graphics
  143. * Tue Sep 22 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  144. - update boot graphics
  145. * Tue Sep 22 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  146. - add Vine boot graphics
  147. * Thu Sep 18 2003 François Pons <fpons@mandrakesoft.com> 22.5.7.2-6mdk
  148. - added new picture for 9.2 with progress bar integrated inside.
  149. - fixed critical bug of bmp2mdk generating wrong files if both timer
  150. and progress bar are given.
  151. - added conflicts due to multiple lilo-bmp2mdk defined.
  152. * Thu Sep 18 2003 François Pons <fpons@mandrakesoft.com> 22.5.7.2-5mdk
  153. - fixed critical bug of freeze when an entry is selected by adding a
  154. progress bar in graphical mode when loading files.
  155. * Wed Sep 03 2003 François Pons <fpons@mandrakesoft.com> 22.5.7.2-4mdk
  156. - fixed to keep graphical mode if kernel uses it, else change to
  157. text mode.
  158. * Tue Sep 02 2003 François Pons <fpons@mandrakesoft.com> 22.5.7.2-3mdk
  159. - updated with smarter 9.2 pictures correctly handling multiple entries.
  160. * Thu Aug 21 2003 François Pons <fpons@mandrakesoft.com> 22.5.7.2-2mdk
  161. - updated with newer 9.2 pictures.
  162. * Thu Aug 21 2003 Pixel <pixel@mandrakesoft.com> 22.5.7.2-1mdk
  163. - new release
  164. * Mon Aug 18 2003 Pixel <pixel@mandrakesoft.com> 22.5.7-2mdk
  165. - add disks-without-partitions.patch
  166. * Mon Aug 11 2003 Pixel <pixel@mandrakesoft.com> 22.5.7-1mdk
  167. - new release
  168. * Sun Aug 3 2003 Pixel <pixel@mandrakesoft.com> 22.5.6.1-1mdk
  169. - new release (fix bug cause "L 40 40 ..." at boot)
  170. * Tue Jul 29 2003 Pixel <pixel@mandrakesoft.com> 22.5.6-1mdk
  171. - new release
  172. - BuildRequires: dev86-devel (thanks to bluca at comedia dot it)
  173. * Wed Jun 18 2003 Pixel <pixel@mandrakesoft.com> 22.5.5-1mdk
  174. - new release (with images diag1.img and diag2.img)
  175. * Mon May 12 2003 Pixel <pixel@mandrakesoft.com> 22.5.3-1mdk
  176. - new release
  177. * Mon May 5 2003 Pixel <pixel@mandrakesoft.com> 22.5.2-1mdk
  178. - new release
  179. * Mon May 5 2003 Pixel <pixel@mandrakesoft.com> 22.5.1-2mdk
  180. - add "BuildRequires: nasm"
  181. * Wed Apr 2 2003 Pixel <pixel@mandrakesoft.com> 22.5.1-1mdk
  182. - new release (update patches)
  183. * Wed Feb 05 2003 François Pons <fpons@mandrakesoft.com> 22.4.1-2mdk
  184. - fixed picture with smoother dithering.
  185. * Fri Jan 31 2003 Pixel <pixel@mandrakesoft.com> 22.4.1-1mdk
  186. - new release
  187. * Thu Jan 30 2003 François Pons <fpons@mandrakesoft.com> 22.4-2mdk
  188. - new picture for newer distribution.
  189. * Sat Jan 25 2003 Pixel <pixel@mandrakesoft.com> 22.4-1mdk
  190. - new release
  191. * Mon Nov 4 2002 Pixel <pixel@mandrakesoft.com> 22.3.4-1mdk
  192. - new release
  193. * Thu Oct 10 2002 Pixel <pixel@mandrakesoft.com> 22.3.3-1mdk
  194. - new release
  195. * Wed Aug 14 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 22.3.2-5mdk
  196. - Automated rebuild with gcc 3.2-0.3mdk
  197. * Fri Aug 02 2002 Giuseppe Ghibƒ�<ghibo@mandrakesoft.com> 22.3.2-4mdk
  198. - removed duplicated PostScript files.
  199. - PDF documentation instead of PostScript one.
  200. * Fri Jul 19 2002 Pixel <pixel@mandrakesoft.com> 22.3.2-3mdk
  201. - have bmp2mdk in /usr/bin/lilo-bmp2mdk (in lilo-doc)
  202. * Thu Jul 18 2002 François Pons <fpons@mandrakesoft.com> 22.3.2-2mdk
  203. - updated boot image for 9.0.
  204. * Fri Jul 12 2002 Pixel <pixel@mandrakesoft.com> 22.3.2-1mdk
  205. - new release
  206. * Thu Jun 27 2002 Pixel <pixel@mandrakesoft.com> 22.3.1-1mdk
  207. - new release
  208. * Tue Jun 25 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 22.3-2mdk
  209. - Nuke egcs requirement
  210. - Patch22: Workaround manpath bug that returns /usr/local/man as first
  211. man dir (aka Titi woes)
  212. * Mon May 27 2002 Pixel <pixel@mandrakesoft.com> 22.3-1mdk
  213. - new release
  214. * Tue Feb 07 2002 François Pons <fpons@mandrakesoft.com> 22.2-2mdk
  215. - fixed lost part of image on some hardware (i810).
  216. - very small reduction of graphic patch size.
  217. * Wed Feb 06 2002 François Pons <fpons@mandrakesoft.com> 22.2-1mdk
  218. - 22.2.
  219. * Wed Jan 30 2002 François Pons <fpons@mandrakesoft.com> 22.1-5mdk
  220. - extend message file to 512Kb instead of 64Kb.
  221. * Mon Jan 28 2002 François Pons <fpons@mandrakesoft.com> 22.1-4mdk
  222. - removed ghost property on hilited entry.
  223. - modified color of timer and hilited text to be dimer.
  224. * Fri Jan 25 2002 François Pons <fpons@mandrakesoft.com> 22.1-3mdk
  225. - updated graphic patch to allow simple scrolling.
  226. * Fri Jan 25 2002 François Pons <fpons@mandrakesoft.com> 22.1-2mdk
  227. - updated picture.
  228. * Thu Jan 24 2002 François Pons <fpons@mandrakesoft.com> 22.1-1mdk
  229. - changed picture and extended entry height to 15 instead of 7.
  230. - updated graphic patch with 22.1.
  231. - 22.1.
  232. * Wed Jan 09 2002 François Pons <fpons@mandrakesoft.com> 21.7.5-3mdk
  233. - updated graphic patch (newer bmp2mdk and typo updates in README.graphic).
  234. - new 8.2 boot image.
  235. * Sun Dec 9 2001 Jeff Garzik <jgarzik@mandrakesoft.com> 21.7.5-2mdk
  236. - Patch1: fix build, by including linux/genhd.h not linux/fs.h, and
  237. not including bad defines for older kernels
  238. - s/Serial/Epoch/
  239. * Sun Aug 5 2001 Pixel <pixel@mandrakesoft.com> 21.7.5-1mdk
  240. - new release (how did i miss it?)
  241. - drop the leading 0. from the release number
  242. * Thu Jul 26 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-18mdk
  243. - added another patch from VMWare.
  244. * Tue Jul 24 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-17mdk
  245. - fixed blank chars on timeout boot.
  246. - added patch from VMWare to fix unsupported banked videoram.
  247. - added missing build requires.
  248. * Thu Jul 19 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-16mdk
  249. - new graphic message for next release.
  250. * Tue Jul 03 2001 Thierry Vignaud <tvignaud@mandrakesoft.com> 0.21.7-15mdk
  251. - make /etc/lilo.conf unreadable but for root as it may contain
  252. passwords. (sly0.21.7-15mdk)
  253. * Tue Jun 19 2001 Pixel <pixel@mandrakesoft.com> 0.21.7-14mdk
  254. - make /boot/lilo-* directories belong to lilo
  255. * Tue Jun 19 2001 Stefan van der Eijk <stefan@eijk.nu> 0.21.7-13mdk
  256. - BuildRequires: tetex-dvips tetex-latex
  257. * Fri Jun 01 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-12mdk
  258. - Reworked graphic patch to include needed tools and README and
  259. multi stage2 available.
  260. - Moved pictures in a standalone archive.
  261. * Fri Apr 27 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-11mdk
  262. - Created patch to handle more nicely all lilo stage2 (boot.b).
  263. * Sun Apr 8 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.21.7-10mdk
  264. - Call detectloader with -q.
  265. * Sun Apr 8 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.21.7-9mdk
  266. - By default don't include the boot.b file if there is no exiting
  267. boot.b file then link it to boot-menu.b (this allow to keep
  268. graphical boot menu when upgrading if it set).
  269. * Thu Apr 5 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.21.7-8mdk
  270. - Reinsert manpages in doc packages.
  271. * Thu Mar 22 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-7mdk
  272. - fixed systematic change to text mode.
  273. * Tue Mar 13 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-6mdk
  274. - modified graphic patch to include mode 0x13 (320x200) and
  275. true LF interpretation for display.
  276. * Tue Mar 6 2001 Pixel <pixel@mandrakesoft.com> 0.21.7-5mdk
  277. - merge patch from redhat (mainly CCISS)
  278. * Mon Mar 05 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-4mdk
  279. - used new picture by default.
  280. * Thu Mar 01 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-3mdk
  281. - changed graphic patch license to the one used by LILO so BSD.
  282. * Wed Feb 28 2001 François Pons <fpons@mandrakesoft.com> 0.21.7-2mdk
  283. - created graphic patch as in syslinux-graphic but not
  284. activated by default, use /boot/boot-graphic.b and
  285. /boot/message-graphic for graphic activation (first sample).
  286. * Mon Feb 26 2001 Pixel <pixel@mandrakesoft.com> 0.21.7-1mdk
  287. - new version
  288. * Wed Jan 24 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.21.6.1-2mdk
  289. - Remove argument parsing patch for the new version.
  290. * Tue Jan 2 2001 Pixel <pixel@mandrakesoft.com> 0.21.6.1-1mdk
  291. - new version
  292. * Thu Nov 23 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.21.6-5mdk
  293. - Fix argument parsing.
  294. * Tue Nov 7 2000 Pixel <pixel@mandrakesoft.com> 0.21.6-4mdk
  295. - capitalize summary of -doc
  296. * Mon Nov 6 2000 Pixel <pixel@mandrakesoft.com> 0.21.6-3mdk
  297. - fix keytab lilo so that things like "\n" aren't badly remapped (qc-latin1)
  298. * Thu Oct 12 2000 Pixel <pixel@mandrakesoft.com> 0.21.6-2mdk
  299. - fix-segfault-for-floppy-entry.patch
  300. * Tue Oct 10 2000 Pixel <pixel@mandrakesoft.com> 0.21.6-1mdk
  301. - new version
  302. * Fri Sep 29 2000 Pixel <pixel@mandrakesoft.com> 0.21.5.1-4mdk
  303. - fix keytab-lilo so that keycodes > 59 are not taken into account. -> fix the
  304. '.' giving '<' on french keyboard (should not break anything...)
  305. * Mon Sep 25 2000 Pixel <pixel@mandrakesoft.com> 0.21.5.1-3mdk
  306. - merge in redhat's patches
  307. - fix up "unsafe" <johnsonm@redhat.com>
  308. - add i2o boot support <johnsonm@redhat.com>
  309. - patches for Compaqs SA5300 controller <karsten@redhat.de>
  310. - add bug-fix to not have lilo core-dump on some config files <Florian.LaRoche@redhat.com>
  311. - work around broken 2.4 kernel headers <pbrown@redhat.com>
  312. * Tue Aug 29 2000 Pixel <pixel@mandrakesoft.com> 0.21.5.1-2mdk
  313. - added requires dev86
  314. * Sun Aug 27 2000 Pixel <pixel@mandrakesoft.com> 0.21.5.1-1mdk
  315. - new version
  316. * Wed Jul 19 2000 Pixel <pixel@mandrakesoft.com> 0.21.5-1mdk
  317. - new version
  318. * Wed Jul 19 2000 Pixel <pixel@mandrakesoft.com> 0.21.4.4-2mdk
  319. - use detectloader in %%post to know wether to call lilo or not
  320. - BM
  321. * Mon Jun 12 2000 Pixel <pixel@mandrakesoft.com> 0.21.4.4-1mdk
  322. - new version
  323. * Mon May 8 2000 Pixel <pixel@mandrakesoft.com> 0.21.4.3-1mdk
  324. - new version (RAID patches)
  325. * Thu Apr 27 2000 Pixel <pixel@mandrakesoft.com> 0.21.4.2-2mdk
  326. - new version
  327. * Sat Mar 25 2000 Pixel <pixel@mandrakesoft.com> 0.21.4-1mdk
  328. - bzip'ed README
  329. - separated postscript doc
  330. - really is 21-4 (serial added)
  331. * Wed Feb 23 2000 Pixel <pixel@mandrakesoft.com> 0.22-19mdk
  332. - Really is 0.22 (non <<official>> version with EDD enabled)
  333. (EDD means no more 1024 cylinder problem)
  334. * Fri Feb 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.22-18mdk
  335. - Silly me reuploading and upgrade the ChangeLog.
  336. * Wed Feb 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.22-17mdk
  337. - Add loopdev and second patch (r).
  338. * Tue Oct 19 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  339. - Remove the EBDA patch from zab and put in the EBDA patch
  340. from the VA Research RPM. This fixes the EBDA issues.(r)
  341. - Added ONE_SHOT to the compile options so that the lilo
  342. prompt won't timeout once you hit a key at the boot prompt(r)
  343. * Wed Sep 22 1999 Pixel <pixel@mandrakesoft.com>
  344. - added defattr (no comment)
  345. * Tue Sep 21 1999 Pixel <pixel@mandrakesoft.com>
  346. - patched keytab-lilo.pl (again!) to make it work (better) (changed a regexp)
  347. * Sun Sep 19 1999 Pixel <pixel@mandrakesoft.com>
  348. - added -DONE_SHOT to patch lilo-ebda (that way timeout is disabled as soon as a
  349. key is pressed)
  350. - patched keytab-lilo.pl to make it work (removed bad suffix .map)
  351. * Sun Aug 22 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  352. - Add the patch to boot on Compaq Smart Array 3200.
  353. * Wed Jul 21 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
  354. - recommend manual lilo installation if post fails
  355. * Mon Jul 19 1999 Pablo Saratxaga <pablo@mandrakesoft.com>
  356. - added turkish description
  357. * Mon Jul 19 1999 Thierry Vignaud <tvignaud@mandrakesoft.com>
  358. - Add french description from Gregus <gregus@etudiant.net>
  359. * Wed Jun 23 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  360. - Use the ebda patch from VA-Research.
  361. * Thu Jun 10 1999 Bernhard Rosenkraenzer <bero@linux-mandrake.com>
  362. - Use -DIGNORECASE -DVARSETUP -DREWRITE_TABLE -DLCF_LARGE_EBDA
  363. -DLARGE_EBDA by default. LARGE_EBDA is needed for some SMP systems.
  364. * Mon Apr 12 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  365. - Add patch for Mandrake-6.0.
  366. - Add keyab-lilo.pl to the file-list
  367. * Sat Apr 10 1999 Bernhard Rosenkraenzer <bero@linux-mandrake.com>
  368. - Mandrake adaptions
  369. - bzip2 man/info pages
  370. - add de locale
  371. - handle RPM_OPT_FLAGS
  372. * Sun Dec 6 1998 Matt Wilson <msw@redhat.com>
  373. - updated to release 0.21
  374. - patched to build on 2.1.x kernels
  375. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  376. - translations modified for de, fr, tr
  377. * Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
  378. - updated to release 0.20
  379. - uses a build root
  380. * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
  381. - built against glibc