lilypond-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372
  1. %define buildinfo yes
  2. %define name lilypond
  3. %define iconsdir /usr/share/pixmaps
  4. %define infodir %{_infodir}/%{name}
  5. %define fontdir %{_datadir}/fonts/%{name}
  6. Summary: A typesetting system for music notation
  7. Summary(ja): 楽譜作成プログラム
  8. Group: Applications/Publishing
  9. Name: %{name}
  10. Version: 2.18.2
  11. Release: 2%{?_dist_release}
  12. License: GPLv3
  13. URL: http://www.lilypond.org/
  14. Source0: http://download.linuxaudio.org/lilypond/sources/v2.12/%{name}-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. ## from fc11
  17. Patch12: lilypond-2.21.2-gcc44-relocate.patch
  18. BuildRequires: t1utils ImageMagick-devel gettext texlive-common
  19. BuildRequires: gcc-c++
  20. BuildRequires: bison flex m4
  21. BuildRequires: python-devel >= 2.4.0
  22. BuildRequires: mftrace >= 1.1.19
  23. BuildRequires: texinfo >= 4.8
  24. BuildRequires: texi2html
  25. %if %{?_dist_release} == "vl6"
  26. BuildRequires: guile-devel >= 1.8
  27. %endif
  28. %if %{?_dist_release} >= "vl7"
  29. BuildRequires: guile18-devel >= 1.8
  30. %endif
  31. BuildRequires: ghostscript >= 8.15
  32. BuildRequires: pango-devel >= 1.12.0
  33. BuildRequires: rsync
  34. BuildRequires: texlive-collection-metapost
  35. %if %{?_dist_release} == "vl6"
  36. BuildRequires: texlive-collection-genericrecommended
  37. %endif
  38. %if %{?_dist_release} >= "vl7"
  39. BuildRequires: texlive-collection-plaingeneric
  40. %endif
  41. BuildRequires: dblatex
  42. BuildRequires: potrace >= 1.3
  43. BuildRequires: netpbm-progs
  44. BuildRequires: which
  45. BuildRequires: glibc-devel groff
  46. BuildRequires: fontforge
  47. %description
  48. LilyPond is a music typesetter. It produces beautiful sheet music using a
  49. high level description file as input. Lilypond is part of the GNU project.
  50. LilyPond is split into two packages. The package "lilypond" provides the
  51. core package, containing the utilities for converting the music source
  52. (.ly) files into printable output. The package "lilypond-documentation"
  53. provides the full documentation, example .ly files for various features and
  54. the Mutopia project files (musical equivalent of the Gutenberg project - see
  55. http://www.mutopiaproject.org for details).
  56. If you are new to lilypond, you will almost certainly want to install the
  57. "lilypond-documentation" package in addition to the "lilypond" package.
  58. %description -l ja
  59. LilyPond は GNU プロジェクトで開発されている楽譜作成ソフトです。高解像度の
  60. とてもきれいな楽譜を作ることができます。
  61. LiLyPond は2つのパッケージにわかれています。"lilypond"パッケージがメインパッ
  62. ケージで、楽譜ソースファイル(.ly)を印刷可能な形式に変換するプログラムが入っ
  63. てます。tex, html等に簡単に楽譜を挿入するための lilypond-book コマンドもあり
  64. ます。(Vine用パッケージでは、platexでの利用も可能に変更してあります。)
  65. "lilypond-documentation" にはマニュアルやいろいろなサンプルファイル(.ly)、
  66. Mutopiaプロジェクトによるいつくかのファイルが入ってます。Mutopia プロジェクト
  67. (musical equivalent of the Gutenberg project)については
  68. http://www.mutopiaproject.orgを見てください。
  69. %package -n liblilypond
  70. Summary: Lilypond libraries
  71. Summary(ja): Lilypond ライブラリ
  72. Group: System Environment/Libraries
  73. Requires: lilypond >= %{version}
  74. %description -n liblilypond
  75. Lilypond libs
  76. %package documentation
  77. Summary: LilyPond documentation, examples and Mutopia files.
  78. Summary(ja): LilyPond のマニュアル, サンプル,Mutopiaファイル
  79. Group: Applications/Documentation
  80. Requires: %{name}
  81. %description documentation
  82. The documentation of LilyPond, both in HTML and PostScript, along with
  83. example input files and the files from the Mutopia project.
  84. %description documentation -l ja
  85. LiLyPond のマニュアルです.HTML ,PostScript, PDF の形式のものがあります.
  86. サンプルや Mutopiaプロジェクトによるファイルも入ってます.
  87. %prep
  88. rm -rf $RPM_BUILD_ROOT
  89. %setup -q
  90. # from fc11
  91. %patch12 -p0
  92. %build
  93. %if %{?_dist_release} >= "vl7"
  94. sed -i "s|guile-config|guile-config-1.8|g" aclocal.m4
  95. %endif
  96. autoconf
  97. %configure \
  98. --without-kpathsea \
  99. --disable-checking \
  100. --with-ncsb-dir=%{_datadir}/fonts/default/Type1
  101. %{__make}
  102. %install
  103. %{__rm} -rf %{buildroot}
  104. make install DESTDIR=$RPM_BUILD_ROOT package_infodir=%{_infodir} vimdir=%{_datadir}/vim/vim74
  105. chmod +x $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/python/midi.so
  106. # Symlink lilypond-init.el in emacs' site-start.d directory
  107. pushd $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
  108. mkdir site-start.d
  109. ln -s ../lilypond-init.el site-start.d
  110. popd
  111. # Change encoding to UTF8
  112. pushd $RPM_BUILD_ROOT%{_infodir}
  113. iconv -f iso-8859-1 -t utf-8 music-glossary.info > music-glossary.info.utf8
  114. mv music-glossary.info.utf8 music-glossary.info
  115. sed -e s,lilypond/,, -i *.info
  116. popd
  117. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  118. %find_lang %{name}
  119. mkdir -p $RPM_BUILD_ROOT%{fontdir}
  120. mv $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf/*.otf $RPM_BUILD_ROOT%{fontdir}
  121. rmdir $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
  122. ln -s %{fontdir} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
  123. %clean
  124. %{__rm} -rf %{buildroot}
  125. %files -f %{name}.lang
  126. %defattr(-, root, root)
  127. %doc AUTHORS.txt COPYING DEDICATION INSTALL.txt NEWS.txt README.txt
  128. %doc ROADMAP
  129. %{_datadir}/emacs/site-lisp/site-start.d/%{name}-init.el
  130. %{_datadir}/emacs/site-lisp/lilypond*
  131. %{_datadir}/fonts/%{name}/
  132. %{_bindir}/*
  133. %{_infodir}/*
  134. %{_mandir}/man1/*
  135. %{_datadir}/%{name}/%{version}/
  136. %{_datadir}/vim/vim*
  137. %files -n liblilypond
  138. %defattr(-,root,root)
  139. %{_libdir}/%{name}/%{version}/python/*.so
  140. %files documentation
  141. %defattr(-, root, root)
  142. %{_docdir}/*
  143. %changelog
  144. * Wed Oct 11 2017 Toshiaki Ara <ara_t@384.jp> 2.18.2-2
  145. - rebuild for Vine6
  146. - revert BuildRequires: guile-devel instead of guile18-devel for Vine6
  147. - skip 'sed -i "s|guile-config|guile-config-1.8|g" aclocal.m4' for Vine6
  148. - change BuildRequires: texlive-collection-plaingeneric
  149. instead of texlive-collection-genericrecommended for VineSeed
  150. - change License: GPLv3
  151. - define %%{_fontdir}
  152. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.2-1
  153. - update to 2.18.2
  154. - change BuildRequires: texlive-common instead of tetex
  155. - change BuildRequires: guile18-devel instead of guile-devel
  156. - remove Patch0,10,13
  157. - add BuildRequires: texlive-collection-metapost, texlive-collection-genericrecommended, rsync, dblatex, texi2html
  158. * Thu Apr 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.3-1
  159. - updated LilyPond to 2.12.3
  160. - applied new versioning policy, spec in utf-8
  161. - dropt Patch0: lilypond-platex-2.4.5.patch
  162. - imported patch from fc11
  163. Patch10: lilypond-2.11.65-python26.patch
  164. Patch12: lilypond-2.21.2-gcc44-relocate.patch
  165. Patch13: lilypond-consts.patch
  166. - replaced build, install, pre/post scripts (from fc11)
  167. * Sun Jul 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl2
  168. - rebuilt for VineSeed
  169. * Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 2.4.5-0vl1
  170. - build on Vine 3.1
  171. * Wed Mar 24 2004 Jun Nishii <jun@vinelinux.org> 2.0.3-0vl1
  172. - build for Vine Linux
  173. - many fixes in post/postun scripts
  174. * Fri Mar 12 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.30-1thac
  175. - Updated to latest devel release
  176. * Wed Mar 10 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.29-1thac
  177. - Updated to latest devel release
  178. * Wed Feb 25 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.27-1thac
  179. - Updated to latest devel release
  180. * Thu Feb 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.25-1thac
  181. - Updated to latest devel release
  182. * Tue Feb 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.24-1thac
  183. - Updated to latest devel release
  184. * Fri Feb 13 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.21-1thac
  185. - Updated to latest devel release
  186. - Built against latest pfaedit-040211 and mftrace-1.0.27
  187. - Added requirement for potrace
  188. * Mon Feb 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.20-1thac
  189. - Updated to latest devel release
  190. * Tue Jan 27 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.15-1thac
  191. - Updated to latest devel release
  192. * Sat Jan 24 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.14-1thac
  193. - Updated to latest devel release
  194. * Mon Jan 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.12-1thac
  195. - Updated to latest devel release
  196. * Sun Jan 18 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.11-1thac
  197. - Updated to latest devel release
  198. * Sat Jan 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.10-1thac
  199. - Updated to latest devel release
  200. * Thu Jan 15 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.9-1thac
  201. - Updated to latest devel release
  202. * Fri Jan 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.8-1thac
  203. - Updated to latest devel release
  204. * Tue Jan 06 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.7-1thac
  205. - Updated to latest devel release
  206. * Mon Jan 05 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.6-1thac
  207. - Updated to latest devel release
  208. * Fri Jan 02 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.4-1thac
  209. - Updated to latest devel release
  210. * Sun Dec 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.3-1thac
  211. - Updated to latest devel release
  212. * Sun Dec 21 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.2-1thac
  213. - Updated to latest devel release
  214. * Wed Dec 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.1-1thac
  215. - Updated to latest devel release
  216. * Thu Oct 30 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-2thac
  217. - Rebuilt for Mandrake 9.2
  218. * Fri Oct 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-1thac
  219. - Updated to latest devel release
  220. * Mon Oct 06 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.1-1thac
  221. - Updated to latest devel release
  222. * Thu Sep 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.0-1thac
  223. - Updated to latest devel release
  224. - removed lilypond-words
  225. * Tue Sep 23 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.9-1thac
  226. - Updated to latest devel release
  227. - fixed lilypond.word install
  228. * Wed Sep 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.6-1thac
  229. - Updated to latest devel release
  230. * Thu Sep 11 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.5-1thac
  231. - Updated to latest devel release
  232. - Built against pyton2.3
  233. * Mon Sep 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.4-1thac
  234. - Updated to latest devel release
  235. * Sun Aug 31 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.3-1thac
  236. - Updated to latest devel release
  237. * Thu Aug 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.2-1thac
  238. - Updated to latest devel release
  239. * Wed Aug 27 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.1-1thac
  240. - Updated to latest devel release
  241. - Changed naming to differ from Mandrake cooker
  242. * Mon Aug 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-3mdk
  243. - Fixed documentation path
  244. - Added some of Heikki Johannes Junes suggestions
  245. * Sun Aug 24 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-2mdk
  246. - Added Heikki Johannes Junes fix for confilcting PHP variable
  247. out=/dev/vc/ by adding unset out before compiling
  248. - Compiled with recent guile = 1.6.4 and mftrace = 1.0.17
  249. - Changed icon to lilypond.png
  250. - Added menu and icons again
  251. * Sat Aug 23 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.8.1-1mdk
  252. - removed menu and icons, sync with redhat-spec
  253. * Thu Jun 12 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.23-1mdk
  254. - refreshed dependencies and file list.
  255. * Sat Feb 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.7.12-1mdk
  256. - Built for Mandrake 9.1
  257. * Sun Dec 01 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.9-1mdk
  258. - set menu-items to lilypond-info and lilypond-documentation.
  259. * Sat Nov 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.8-4mdk
  260. - add pre/post-dependencies and menus with icon from source.
  261. * Mon Oct 28 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.4-1mdk
  262. - info, commented menu
  263. * Fri Aug 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.6.0-1mdk
  264. - Adapted from lilypond.redhat.skel and skeleton found in Mandrake's RPM-docs.
  265. - TODO: info (?) and dependencies.
  266. * Fri Jun 01 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.4.2-1mdk
  267. - updated by Michael Brown <mbrown@linux-mandrake.com> :
  268. - Upgraded to 1.4.2
  269. - Changed URL
  270. - Removed /etc/profile.d scripts: all TeX bits are now located properly
  271. - Rearranged documentation
  272. - Tidied spec file
  273. - Updated README.first
  274. * Mon Feb 26 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.3.129-1mdk
  275. - added in contribs by Michael Brown <mbrown@fensystems.co.uk> :
  276. - Removed info files completely (couldn't get info reader to read them)
  277. - TODO: Get this to work at some point (in the meantime, use documentation in lilypond-extras)
  278. * Sat Feb 17 2001 Michael Brown <mbrown@fensystems.co.uk>
  279. - Moved TeX font folders into the system TeX tree (this ensures that the /var/lib/texmf font cache is used instead of current folder)
  280. - Added mktexlsr to post-install and post-uninstall scripts
  281. - Patched scripts in /etc/profile.d to reflect changes to font locations
  282. - Added QuickStart guide and Points to note sections to README.first (well worth reading)
  283. - Fixed install-info and uninstall-info sections to use Mandrake's RPM macros :-)
  284. * Tue Feb 13 2001 Michael Brown <mbrown@fensystems.co.uk>
  285. - First Mandrake package
  286. - spec file heavily adapted from PowerPC contribs.
  287. - Note HTML documentation may contain duff links and may be incomplete. Lots of warnings appear when building HTML docs.
  288. - PostScript documentation is duplicated (how do you get an rpm package to contain a symlink?)
  289. - Created README.first file