lincity-ng-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142
  1. %define alias_ttf /usr/share/fonts/TrueType-vlgothic/VL-PGothic-Regular.ttf
  2. %define name lincity-ng
  3. %define version 2.0
  4. %define release 6%{?_dist_release}
  5. Summary: City Simulation Game
  6. Summary(ja): 都市シミュレーションゲーム
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source: http://download.berlios.de/%{name}/%{name}-%{version}.tar.bz2
  11. License: GNU General Public License
  12. Group: Applications/Games
  13. URL: http://lincity-ng.berlios.de/
  14. Requires: TrueType-vlgothic
  15. Requires: SDL, SDL_image, SDL_mixer, SDL_ttf, SDL_gfx,
  16. Requires: zlib, libxml2, physfs
  17. BuildRequires: SDL-devel, SDL_image-devel, SDL_mixer-devel,
  18. BuildRequires: SDL_ttf-devel, SDL_gfx-devel,
  19. BuildRequires: mesa-libGL-devel, mesa-libGLU-devel
  20. BuildRequires: zlib-devel, libxml2-devel, physfs-devel,
  21. BuildRequires: jam, vorbis-tools
  22. BuildRequires: desktop-file-utils
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. %description
  25. LinCity-NG is a City Simulation Game. It is a polished and improved
  26. version of the old LinCity game. Within the scope of the GoTM
  27. project at happypenguin.org we create a new iso-3d graphics engine
  28. together with completely redone modern gui.
  29. %description -l ja
  30. LinCity-NG は都市シミュレーションゲームです。
  31. 以前の LinCity を精錬し、改善されたバージョンです。
  32. %prep
  33. %setup -q
  34. sed -i "s/CFLAGS += -O3 -g -Wall/CFLAGS += $RPM_OPT_FLAGS/" Jamrules
  35. sed -i "s/CXXFLAGS += -O3 -g -Wall/CXXFLAGS += $RPM_OPT_FLAGS/" Jamrules
  36. %build
  37. #./autogen.sh
  38. # export CFLAGS="$RPM_OPT_FLAGS -fstack-protector" \
  39. # CXXFLAGS="$RPM_OPT_FLAGS -fstack-protector"
  40. %configure
  41. jam
  42. %install
  43. %{__rm} -rf ${RPM_BUILD_ROOT}
  44. jam -s DESTDIR=${RPM_BUILD_ROOT} install
  45. ### to convert the sounds
  46. for i in ${RPM_BUILD_ROOT}%{_datadir}/%{name}/sounds/*.wav; do
  47. oggenc --quiet $i && rm $i
  48. done
  49. # font alias
  50. pushd $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
  51. ln -s %alias_ttf sans-ja_JP.ttf
  52. popd
  53. %clean
  54. %{__rm} -rf ${RPM_BUILD_ROOT}
  55. %check
  56. %{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/lincity-ng.desktop
  57. %post
  58. if [ -x %{_bindir}/update-desktop-database ] ; then
  59. %{_bindir}/update-desktop-database %{_datadir}/applications
  60. fi
  61. %postun
  62. if [ -x %{_bindir}/update-desktop-database ] ; then
  63. %{_bindir}/update-desktop-database %{_datadir}/applications
  64. fi
  65. %files
  66. %defattr(-,root,root)
  67. %doc %{_datadir}/doc/%{name}-%{version}
  68. %{_bindir}/lincity-ng
  69. %{_datadir}/pixmaps/*
  70. %{_datadir}/applications/lincity-ng.desktop
  71. %{_datadir}/lincity-ng
  72. %changelog
  73. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.0-6
  74. - rebuild with gcc-5.4.0
  75. * Tue Jan 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0-5
  76. - rebuild
  77. * Mon Sep 20 2010 IWAI, Masaharu <iwai@alib.jp> 2.0-4
  78. - build with SDL_gfx 2.0.22
  79. - add BuildRequires: mesa-libGLU-devel
  80. - validating desktop file in %%check section
  81. - add %%post and %%postun sections for desktop file
  82. - add BuildRequires: desktop-file-utils
  83. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2.0-3
  84. - added Japanese Summary and description
  85. * Fri May 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.0-2
  86. - added Requires: TrueType-vlgothic
  87. - corrected symbolic link to sans-ja_JP.ttf
  88. * Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-1
  89. - new upstream release.
  90. - changed Group to Applications/Games
  91. * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.2-1vl5
  92. - new upstream release.
  93. - applied new versioning policy
  94. * Wed Jan 02 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl2
  95. - rebuilt for VineSeed
  96. * Thu Sep 06 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl1
  97. - new upstream release.
  98. - update Source:.
  99. - add "BuildRequires: XOrg-gl-devel".
  100. * Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vl1
  101. - initial build for Vine Linux 4.1
  102. - add BuildRequires: vorbis-tools to convert the sounds
  103. * Sun Dec 11 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.2-0vlmp1
  104. - minor version up
  105. * Sun Jul 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.1-0vlmp1
  106. - minor version up
  107. * Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0-0vlmp1
  108. - initial build for Vine Linux 3.2
  109. # end of file