lld-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365
  1. %bcond_without lld_libs
  2. %bcond_with test
  3. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  4. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  5. %define _unpackaged_files_terminate_build 1
  6. Summary: The LLVM Linker
  7. Summary(ja): LLVMリンカー
  8. Name: lld
  9. Version: 12.0.1
  10. Release: 1%{?_dist_release}
  11. Group: programming
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: NCSA
  15. URL: https://llvm.org/
  16. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
  17. # patches
  18. Patch0: 0001-PATCH-lld-CMake-Check-for-gtest-headers-even-if-lit..patch
  19. # Bundle libunwind header need during build for MachO support
  20. Patch1: 0002-PATCH-lld-Import-compact_unwind_encoding.h-from-libu.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: cmake
  23. BuildRequires: ninja
  24. BuildRequires: llvm-devel
  25. BuildRequires: llvm-static
  26. BuildRequires: ncurses-devel
  27. BuildRequires: zlib-devel
  28. Requires: lld-libs = %{version}-%{release}
  29. Requires(post): alternatives
  30. Requires(preun): alternatives
  31. %description
  32. The LLVM project linker.
  33. %if %{with lld_libs}
  34. %package -n lld-libs
  35. Summary: LLD shared libraries
  36. Summary(ja): LLD 共有ライブラリ
  37. License: NCSA
  38. Group: programming
  39. %description -n lld-libs
  40. Shared libraries for LLD.
  41. %package -n lld-devel
  42. Summary: Libraries and header files for LLD
  43. Summary(ja): LLD 用ライブラリとヘッダファイル
  44. License: NCSA
  45. Group: programming
  46. Requires: lld-libs = %{version}-%{release}
  47. %description -n lld-devel
  48. This package contains library and header files needed to develop new native
  49. programs that use the LLD infrastructure.
  50. %endif
  51. %debug_package
  52. %prep
  53. %setup -q -n lld-%{version}.src
  54. %autopatch -p2
  55. %build
  56. # Disable lto since it causes the COFF/libpath.test lit test to crash.
  57. %global _lto_cflags %{nil}
  58. %cmake \
  59. -GNinja \
  60. -DCMAKE_BUILD_TYPE=Release \
  61. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  62. %if %{with lld_libs}
  63. -DLLVM_DYLIB_COMPONENTS="all" \
  64. %endif
  65. -DCMAKE_SKIP_RPATH:BOOL=ON \
  66. -DPYTHON_EXECUTABLE:STRING=%{__python3} \
  67. -DLLVM_INCLUDE_TESTS:BOOL=ON \
  68. -DLLVM_LIT_ARGS="-sv \
  69. --path %{_libdir}/llvm" \
  70. %if 0%{?__isa_bits} == 64
  71. -DLLVM_LIBDIR_SUFFIX=64 \
  72. %else
  73. -DLLVM_LIBDIR_SUFFIX= \
  74. %endif
  75. %{nil}
  76. %cmake_build
  77. %if %{with test}
  78. # Build the unittests so we can install them.
  79. %cmake_build --target lld-test-depends
  80. %endif
  81. %install
  82. rm -rf %{buildroot}
  83. %cmake_install
  84. # This is generated by Patch1 during build and (probably) must be removed afterward
  85. rm %{buildroot}%{_includedir}/mach-o/compact_unwind_encoding.h
  86. # Required when using update-alternatives:
  87. # https://docs.fedoraproject.org/en-US/packaging-guidelines/Alternatives/
  88. touch %{buildroot}%{_bindir}/ld
  89. %if !%{with lld_libs}
  90. rm -rf %{buildroot}%{_includedir}/lld
  91. %endif
  92. %if %{with test}
  93. %check
  94. %cmake_build --target check-lld
  95. %endif
  96. %clean
  97. rm -rf %{buildroot}
  98. %post
  99. /sbin/alternatives --install /usr/bin/ld ld \
  100. /usr/bin/ld.lld 20
  101. %postun
  102. if [ $1 = 0 ]; then
  103. /sbin/alternatives --remove ld /usr/bin/ld.lld
  104. fi
  105. %files
  106. %defattr(-,root,root,-)
  107. %{_bindir}/lld*
  108. %{_bindir}/ld.lld
  109. %{_bindir}/ld64.lld
  110. %{_bindir}/ld64.lld.darwinnew
  111. %{_bindir}/wasm-ld
  112. %ghost %{_bindir}/ld
  113. %if %{with lld_libs}
  114. %files libs
  115. %{_libdir}/liblld*.so.*
  116. %files devel
  117. %{_includedir}/lld
  118. %{_libdir}/liblld*.so
  119. %{_libdir}/cmake/lld/
  120. %endif
  121. %changelog
  122. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  123. - new upstream release.
  124. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  125. - devided lld from llvm.
  126. - new upstream release.
  127. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  128. - enabled to build utils.
  129. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  130. - new upstream release.
  131. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  132. - new upstream release.
  133. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  134. - rebuilt with libffi-3.3.
  135. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  136. - new upstream release.
  137. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  138. - new upstream release.
  139. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  140. - dropped all patches.
  141. - switched build-system to ninja.
  142. - switched python to python3.
  143. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  144. - new upstream release.
  145. - added OpenMP.
  146. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  147. - fixed %%files.
  148. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  149. - new upstream release.
  150. - dropped Patch0, 4, 5, 100 and 200.
  151. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  152. - renamed a subpackage "llvm-libs".
  153. - added a subpackage "lld".
  154. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  155. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  156. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  157. - new upstream release.
  158. - dropped Patch1 and 2: fixed in upstream.
  159. - imported Patch0, 3-5, 100 and 200 from rawhide.
  160. - disabled Patch1002: no longer needed?
  161. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  162. - new upstream release.
  163. - switched to cmake.
  164. - disable ocaml binding as default.
  165. - updated Patch1000 and 1002.
  166. - disabled Patch1000 as default.
  167. - cleanup patches.
  168. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  169. - rebuild with gcc-5.4.0
  170. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  171. - new upstream release
  172. - added BR: ocaml-ctypes
  173. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  174. - new upstream release
  175. - dropt Patch 1, 201 and 1001
  176. - updated Patch 1000
  177. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  178. - updated to 3.5.1
  179. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  180. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  181. - obsoleted clang-doc
  182. - built with ocaml 4.02.1
  183. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  184. - fix <BTS:2832>
  185. - fix configure option "--with-c-include-dirs"
  186. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  187. - update Patch1001: clang-3.5.0-driver-lib64.patch
  188. - update Patch1002: clang-3.5.0-driver-vine.patch
  189. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  190. - update to 3.5.0
  191. - remove Patch11 (clang-hardfloat-hack.patch)
  192. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  193. - rebuild with libffi-3.0.13
  194. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  195. - update to 3.3
  196. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  197. - ld.gold (patch1000,1001)
  198. - add /%{_lib} to ld search path
  199. - add support *-vine-linux gcc (patch1002)
  200. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  201. - update to 3.1
  202. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  203. - updated to 3.0 release
  204. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  205. - added patch 2-4 to support -O4 link-time optimization
  206. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  207. - disable -fno-var-tracking-assignments on ppc
  208. (seems like gcc-4.4.5 still doesn't support this)
  209. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  210. - new upstream release
  211. - add BR: libffi-devel
  212. - add R: libffi-devel to -devel
  213. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  214. - initial build for Vine Linux
  215. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  216. - Update to final 2.7 release
  217. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  218. - Update to first 2.7 pre-release
  219. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  220. - Update to 2.6 pre-release2
  221. - -devel subpackage now virtually provides -static
  222. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  223. - Disable var tracking assignments on PPC
  224. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  225. - Don't adjust clang include dir; files there are noarch (bz#521893)
  226. - Enable clang unit tests
  227. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  228. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  229. - Package Clang's static analyzer tools
  230. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  231. - PIC is now enabled by default; explicitly disable on %%{ix86}
  232. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  233. - First 2.6 prerelease
  234. - Enable Clang front-end
  235. - Enable debuginfo generation
  236. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  237. - Disable assertions (needed by OpenGTL, bz#521261)
  238. - Align spec file with upstream build instructions
  239. - Enable unit tests
  240. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  241. - Only disable PIC on %%ix86; ppc actually needs it
  242. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  243. - Disable use of position-independent code on 32-bit platforms
  244. (buggy in LLVM <= 2.5)
  245. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  246. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  247. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  248. - Remove build scripts; they require the build directory to work
  249. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  250. - Update to 2.5
  251. - Package build scripts (bug #457881)
  252. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  253. - Patched build process for the OCaml binding
  254. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  255. - Update to 2.4
  256. - Package Ocaml binding
  257. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  258. - Add dependency on groff
  259. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  260. - LLVM 2.3
  261. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  262. - fix license tags
  263. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  264. - Fix compilation problems with gcc 4.3
  265. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  266. - Autorebuild for GCC 4.3
  267. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  268. - Fix review comments
  269. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  270. - Initial version