lm-sensors-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189
  1. Summary: Hardware monitoring tools
  2. Summary(ja): ハードウェア監視ツール集
  3. Name: lm-sensors
  4. Version: 3.5.0
  5. Release: 1%{?_dist_release}
  6. %global ver_str %(echo -n "%{version}" | sed -e 's/\\./-/g')
  7. Group: Applications/System
  8. License: LGPLv2+ and GPLv3+ and GPLv2+ and Verbatim and Public Domain
  9. URL: https://github.com/lm-sensors/lm-sensors
  10. Source0: https://github.com/lm-sensors/lm-sensors/archive/lm_sensors-%{version}.tar.gz#/lm-sensors-%{ver_str}.tar.gz
  11. Source1: lm_sensors.sysconfig
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: bison
  14. BuildRequires: flex
  15. BuildRequires: gawk
  16. BuildRequires: kernel-headers >= 2.2.16
  17. %if "%{_dist_release}" >= "vl7"
  18. BuildRequires: libsysfs-devel
  19. %else
  20. BuildRequires: sysfsutils-devel
  21. %endif
  22. BuildRequires: rrdtool-devel
  23. Requires: perl
  24. Requires: initscripts
  25. Requires(post): /sbin/chkconfig
  26. Requires(preun): /sbin/chkconfig
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: shaolin, owa
  30. %description
  31. The lm-sensors package includes a collection of modules for general SMBus
  32. access and hardware monitoring.
  33. %package libs
  34. Summary: Lm_sensors core libraries
  35. Summary(ja): Lm_sensors コアライブラリ
  36. Group: System Environment/Libraries
  37. %description libs
  38. Core libraries for lm_sensors applications
  39. %package devel
  40. Summary: Development files for programs which will use lm_sensors
  41. Summary(ja): lm_sensors を使用するプログラムのための開発用ファイル
  42. Group: Development/Libraries
  43. Requires: %{name}-libs = %{version}-%{release}
  44. %description devel
  45. The %{name}-devel package includes a header files and libraries for use
  46. when building applications that make use of sensor data.
  47. %package sensord
  48. Summary: Daemon that periodically logs sensor readings
  49. Summary(ja): センサーの読み取り値を定期的に記録するデーモン
  50. Group: System Environment/Daemons
  51. Requires: %{name} = %{version}-%{release}
  52. %description sensord
  53. Daemon that periodically logs sensor readings to syslog or a round-robin
  54. database, and warns of sensor alarms.
  55. %prep
  56. %setup -q -n lm-sensors-%{ver_str}
  57. %build
  58. export CFLAGS="%{optflags}"
  59. make PREFIX=%{_prefix} LIBDIR=%{_libdir} MANDIR=%{_mandir} EXLDFLAGS= user
  60. %install
  61. rm -rf $RPM_BUILD_ROOT
  62. make user_install \
  63. DESTDIR=$RPM_BUILD_ROOT \
  64. PREFIX=%{_prefix} \
  65. LIBDIR=%{_libdir} \
  66. ETCDIR=%{_sysconfdir} \
  67. MANDIR=%{_mandir}
  68. ln -s sensors.conf.5.gz $RPM_BUILD_ROOT%{_mandir}/man5/sensors3.conf.5.gz
  69. # add initscript from proc/init
  70. mkdir -p $RPM_BUILD_ROOT%{_initdir}
  71. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sensors.d
  72. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  73. install -m755 prog/init/lm_sensors.init $RPM_BUILD_ROOT%{_initdir}/lm_sensors
  74. install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/lm_sensors
  75. # remove unuse files
  76. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
  77. %clean
  78. rm -rf $RPM_BUILD_ROOT
  79. %post
  80. if [ "$1" = 1 ] ; then
  81. /sbin/chkconfig --add lm_sensors
  82. fi
  83. %{_initdir}/lm_sensors condrestart
  84. %preun
  85. if [ "$1" = 0 ] ; then
  86. %{_initdir}/lm_sensors stop > /dev/null 2>&1
  87. /sbin/chkconfig --del lm_sensors
  88. fi
  89. %post libs -p /sbin/ldconfig
  90. %postun libs -p /sbin/ldconfig
  91. %files
  92. %defattr(-,root,root,-)
  93. %license COPYING
  94. %doc CHANGES CONTRIBUTORS INSTALL README doc
  95. %dir %{_sysconfdir}/sensors.d
  96. %config(noreplace) %{_sysconfdir}/sensors3.conf
  97. %config(noreplace) %{_sysconfdir}/sysconfig/lm_sensors
  98. %config %{_initdir}/lm_sensors
  99. %{_bindir}/sensors
  100. %{_bindir}/sensors-conf-convert
  101. %{_sbindir}/fancontrol
  102. %ifarch %{ix86} x86_64
  103. %{_sbindir}/isadump
  104. %{_sbindir}/isaset
  105. %endif
  106. %{_sbindir}/pwmconfig
  107. %{_sbindir}/sensors-detect
  108. %{_mandir}/man1/*
  109. %{_mandir}/man5/*
  110. %{_mandir}/man8/*
  111. %files libs
  112. %{_libdir}/lib*.so.*
  113. %files devel
  114. %{_includedir}/sensors
  115. %{_libdir}/lib*.so
  116. %{_mandir}/man3/*
  117. %changelog
  118. * Fri May 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.0-1
  119. - updated to 3.5.0.
  120. * Sat Nov 7 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 3.4.0-1
  121. - update to 3.4.0
  122. * Mon Jan 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.3.5-1
  123. - updated to 3.3.5
  124. - built on current VineSeed
  125. - split libraries to libs subpackage
  126. * Tue Apr 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.0-1
  127. - new upstrem release 3.3.0
  128. * Tue Dec 14 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.0-1
  129. - updated lm-sensors to 3.2.0
  130. - added RQ: initscripts
  131. * Tue Mar 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
  132. - updated lm-sensors to 3.1.2
  133. * Tue Oct 20 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.1.1-2
  134. - isadump/isaset only available on ix86/x86_64 archs
  135. * Mon Aug 31 2009 Shu KONNO <owa@bg.wakwak.com> 3.1.1-1
  136. - updated lm-sensors to 3.1.1
  137. - added japanese summary, spec in utf-8
  138. - added %{_initdir}/lm_sensors to %%files
  139. - added %%post, %%preun, %%postun scripts
  140. * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.10.7-1vl5
  141. - new upstream release
  142. - applied new versioning policy
  143. * Sun Nov 25 2007 Shu KONNO <owa@bg.wakwak.com> - 2.10.3-0vl2
  144. - fixed libdir in Makefile (for support lib64)
  145. * Tue May 29 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.10.3-0vl1
  146. - Initial build.