lmdb-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211
  1. # The files themselves are in several subdirectories and need to be prefixed wit this.
  2. %global archive_path libraries/lib%{name}
  3. Name: lmdb
  4. Version: 0.9.24
  5. Release: 1%{?_dist_release}
  6. Summary: Memory-mapped key-value database
  7. Group: Development/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: OpenLDAP
  11. URL: http://symas.com/mdb/
  12. Source0: https://github.com/LMDB/lmdb/archive/LMDB_%{version}.tar.gz
  13. Source1: lmdb.pc.in
  14. # Patch description in the corresponding file
  15. Patch0: lmdb-make.patch
  16. Patch1: lmdb-s390-check.patch
  17. BuildRequires: make
  18. BuildRequires: gcc
  19. BuildRequires: doxygen
  20. %description
  21. LMDB is an ultra-fast, ultra-compact key-value embedded data
  22. store developed by Symas for the OpenLDAP Project. By using memory-mapped files,
  23. it provides the read performance of a pure in-memory database while still
  24. offering the persistence of standard disk-based databases, and is only limited
  25. to the size of the virtual address space.
  26. %package libs
  27. Summary: Shared libraries for %{name}
  28. %description libs
  29. The %{name}-libs package contains shared libraries necessary for running
  30. applications that use %{name}.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Requires: %{name}%{?_isa} = %{version}-%{release}
  34. %description devel
  35. The %{name}-devel package contains libraries and header files for
  36. developing applications that use %{name}.
  37. %package doc
  38. Summary: Documentation files for %{name}
  39. BuildArch: noarch
  40. %description doc
  41. The %{name}-doc package contains automatically generated documentation for %{name}.
  42. %prep
  43. %setup -q -n %{name}-LMDB_%{version}
  44. %patch0 -p1 -b .make
  45. %patch1 -p1 -b .s390-check
  46. %build
  47. pushd %{archive_path}
  48. make XCFLAGS="%{optflags}" %{?_smp_mflags}
  49. # Build doxygen documentation
  50. doxygen
  51. # remove unpackaged files
  52. rm -f Doxyfile
  53. rm -rf man # Doxygen generated manpages
  54. popd
  55. %install
  56. pushd %{archive_path}
  57. # make install expects existing directory tree
  58. mkdir -m 0755 -p %{buildroot}{%{_bindir},%{_includedir}}
  59. mkdir -m 0755 -p %{buildroot}{%{_libdir}/pkgconfig,%{_mandir}/man1}
  60. make DESTDIR=%{buildroot} prefix=%{_prefix} libdir=%{_libdir} mandir=%{_mandir} install
  61. popd
  62. # Install pkgconfig file
  63. sed -e 's:@PREFIX@:%{_prefix}:g' \
  64. -e 's:@EXEC_PREFIX@:%{_exec_prefix}:g' \
  65. -e 's:@LIBDIR@:%{_libdir}:g' \
  66. -e 's:@INCLUDEDIR@:%{_includedir}:g' \
  67. -e 's:@PACKAGE_VERSION@:%{version}:g' \
  68. %{SOURCE1} >lmdb.pc
  69. install -Dpm 0644 -t %{buildroot}%{_libdir}/pkgconfig lmdb.pc
  70. %check
  71. pushd %{archive_path}
  72. rm -rf testdb
  73. LD_LIBRARY_PATH=$PWD make test
  74. popd
  75. %post libs -p /sbin/ldconfig
  76. %postun libs -p /sbin/ldconfig
  77. %files
  78. %{_bindir}/*
  79. %{_mandir}/man1/*
  80. %files libs
  81. %doc %{archive_path}/COPYRIGHT
  82. %doc %{archive_path}/CHANGES
  83. %license %{archive_path}/LICENSE
  84. %{_libdir}/*.so.*
  85. %files devel
  86. %{_includedir}/*
  87. %{_libdir}/*.so
  88. %{_libdir}/pkgconfig/*.pc
  89. %files doc
  90. %doc %{archive_path}/html
  91. %doc %{archive_path}/COPYRIGHT
  92. %doc %{archive_path}/CHANGES
  93. %license %{archive_path}/LICENSE
  94. %changelog
  95. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.24-1
  96. - initial build for Vine Linux.
  97. - new upstream release.
  98. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.23-3
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  100. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.23-2
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  102. * Wed Jan 09 2019 Tomas Krizek <tomas.krizek@nic.cz> - 0.9.23-1
  103. - Updated to 0.9.23
  104. * Mon Nov 05 2018 Jan Staněk <jstanek@redhat.com> - 0.9.22-4
  105. - Import upstream fix for rhbz#1645114
  106. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.22-3
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  108. * Mon Apr 23 2018 Florin Asavoaie <florin.asavoaie@gmail.com> - 0.9.22-2
  109. - Fixed Build Dependencies
  110. - Made build work on CentOS 7 for EPEL
  111. * Tue Apr 10 2018 Jan Staněk <jstanek@redhat.com> - 0.9.22-1
  112. - Updated to 0.9.22
  113. * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.21-4
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  115. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.21-3
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  117. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.21-2
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  119. * Fri Jun 02 2017 Jan Stanek <jstanek@redhat.com> - 0.9.21-1
  120. - Update to 0.9.21
  121. * Mon Mar 20 2017 Jan Stanek <jstanek@redhat.com> - 0.9.20-3
  122. - Add pkgconfig file to devel subpackage
  123. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.20-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  125. * Thu Jan 12 2017 Jan Stanek <jstanek@redhat.com> - 0.9.20-1
  126. - Update to 0.9.20
  127. * Wed Jan 04 2017 Jan Stanek <jstanek@redhat.com> - 0.9.19-1
  128. - Update to 0.9.19
  129. * Wed Feb 10 2016 Jan Stanek <jstanek@redhat.com> - 0.9.18-1
  130. - Update to 0.9.18
  131. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.17-3
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  133. * Mon Dec 28 2015 Jan Vcelak <jvcelak@fedoraproject.org> 0.9.17-2
  134. - Make liblmdb.so a symbolic link to (not a copy of) the versioned DSO
  135. * Thu Dec 03 2015 Jan Staněk <jstanek@redhat.com> - 0.9.17-1
  136. - Update to 0.9.17
  137. * Wed Nov 25 2015 Jan Staněk <jstanek@redhat.com> - 0.9.16-2
  138. - Return the name 'Symas' into description
  139. * Fri Aug 14 2015 Jan Staněk <jstanek@redhat.com> - 0.9.16-1
  140. - Updated to 0.9.16
  141. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.14-2
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  143. * Thu Dec 11 2014 Jan Staněk <jstanek@redhat.com> - 0.9.14-1
  144. - Updated to 0.9.14
  145. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.13-2
  146. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  147. * Fri Jul 18 2014 Jan Stanek <jstanek@redhat.com> - 0.9.13-1
  148. - Updated to 0.9.13
  149. * Mon Jul 14 2014 Jan Stanek <jstanek@redhat.com> - 0.9.11-4
  150. - Changed install instruction to be compatible with older coreutils (#1119084)
  151. * Thu Jun 26 2014 Jan Stanek <jstanek@redhat.com> - 0.9.11-3
  152. - Added delay in testing which was needed on s390* arches (#1104232)
  153. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.11-2
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  155. * Tue May 27 2014 Jan Stanek <jstanek@redhat.com> - 0.9.11-1
  156. - Initial Package