loudmouth-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283
  1. %define with_ssl 1
  2. %define gnutls_ver 1.4.0
  3. Summary: Loudmouth is a Jabber programming library written in C
  4. Summary(ja): C言語で書かれた Jabber プロトコルライブラリ
  5. Name: loudmouth
  6. Version: 1.4.3
  7. Release: 3%{?_dist_release}
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.loudmouth-project.org/
  11. Source0: http://ftp.imendio.com/pub/imendio/%{name}/src/%{name}-%{version}.tar.bz2
  12. Patch0: %{name}-1.4.3-certs_location.patch
  13. Patch1: %{name}-1.4.3-async_assertion.patch
  14. Patch2: %{name}-1.4.3-fix-sasl-md5-digest-uri.patch
  15. Patch3: 0001-Drop-stanzas-when-failing-to-convert-them-to-LmMessa.patch
  16. Patch4: %{name}-1.4.3-glib-compile-fix.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: glib2-devel >= 2.4.0
  19. BuildRequires: check-devel
  20. BuildRequires: libidn-devel
  21. BuildRequires: libasyncns-devel
  22. %if %{with_ssl}
  23. BuildRequires: gnutls-devel >= %{gnutls_ver}
  24. %endif
  25. %description
  26. Loudmouth is a lightweight and easy-to-use C library for programming
  27. with the Jabber protocol. It's designed to be easy to get started with
  28. and yet extensible to let you do anything the Jabber protocol allows.
  29. %package devel
  30. Summary: Development files for %{name}
  31. Summary(ja): %{name} の開発用ファイル
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: glib2-devel
  35. Requires: libidn-devel
  36. Requires: pkgconfig
  37. %if %{with_ssl}
  38. Requires: gnutls-devel
  39. %endif
  40. %description devel
  41. The %{name}-devel package contains libraries and header files for
  42. developing applications that use %{name}.
  43. %prep
  44. %setup -q
  45. %patch0 -p1 -b .certs
  46. %patch1 -p1 -b .async
  47. %patch2 -p1 -b .uri
  48. %patch3 -p1 -b .stanza
  49. %patch4 -p1 -b .glibincl
  50. %build
  51. %configure --enable-static=no \
  52. --with-asyncns=yes \
  53. %if %{with_ssl}
  54. --with-ssl=gnutls
  55. %else
  56. --with-ssl=no
  57. %endif
  58. make %{?_smp_mflags}
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. make install DESTDIR=$RPM_BUILD_ROOT
  62. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  63. # Copy the files from the tarball to avoid the IDs generated by gtk-doc being
  64. # different on different builds
  65. mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
  66. cp -a docs/reference/html/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
  67. %check
  68. make check
  69. %clean
  70. rm -rf $RPM_BUILD_ROOT
  71. %post -p /sbin/ldconfig
  72. %postun -p /sbin/ldconfig
  73. %files
  74. %defattr(-,root,root,-)
  75. %doc ChangeLog NEWS README COPYING
  76. %{_libdir}/libloudmouth*.so.*
  77. %files devel
  78. %defattr(-,root,root,-)
  79. %{_libdir}/libloudmouth*.so
  80. %{_libdir}/pkgconfig/%{name}-1.0.pc
  81. %{_includedir}/%{name}-1.0
  82. %{_datadir}/gtk-doc/html/%{name}
  83. %changelog
  84. * Sat Jan 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.3-3
  85. - added Patch0, 1, 2, 3 and 4 from Fedora
  86. * Wed Mar 7 2012 Daniel Drake <dsd@laptop.org> - 1.4.3-10
  87. - Fix compile against new glib
  88. * Sun Nov 15 2009 Brian Pepple <bpepple@fedoraproject.org> - 1.4.3-7
  89. - Add patch to fix parser that stops on certain stanzas. (#509341)
  90. * Fri Jun 12 2009 Brian Pepple <bpepple@fedoraproject.org> - 1.4.3-5
  91. - Add patch to fix digest uri bug. (#503901)
  92. * Fri Nov 28 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.3-3
  93. - Add patch to search correct location for ssl certs. (#473458)
  94. - Add patch to fix async assertion. (#473436)
  95. - built with gnutls 3.2.20
  96. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.4.3-2
  97. - rebuilt with rpm-4.8.1 for pkg-config
  98. * Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.3-1
  99. - Update to 1.4.3
  100. - build with new gnutls
  101. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
  102. - initial build for Vine Linux
  103. * Thu Aug 28 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.2-1
  104. - Update to 1.4.2.
  105. - Enable libasyncns support.
  106. * Sat Aug 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.1-1
  107. - Update to 1.4.1.
  108. * Wed Jun 25 2008 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  109. - rebuild with new gnutls
  110. * Tue Jun 10 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.4.0-1
  111. - Update to 1.4.0.
  112. * Wed Apr 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.4-1
  113. - Update to 1.3.4.
  114. - Run check test.
  115. - Bump min version needed for gnutls-devel.
  116. - Drop stream-error.patch. Fixed upstream.
  117. - Drop eai-nodata.patch. Fixed upstream.
  118. - Drop connect-fail-sync.patch. Fixed upstream.
  119. - Drop connect-fail-async patch. Fixed upstream.
  120. - Update URL & Source URL.
  121. - Don't generate the gtk-doc docs, and use the ones in the tarball
  122. to avoid having different files in different builds, fixes
  123. multilib problems (#342551)
  124. * Thu Feb 21 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-4
  125. - Fix build with recent GNU libc
  126. * Thu Feb 7 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-3
  127. - Add patches fixing reentrancy problems on connection failure
  128. * Wed Jan 30 2008 Owen Taylor <otaylor@redhat.com> - 1.3.3-2
  129. - Add back stream-error patch, it wasn't fixed in the 1.3 branch
  130. * Fri Jan 18 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.3.3-1
  131. - Update to 1.3.3.
  132. - Drop reconnect-failure patch.
  133. - Drop gnutls compression patch. fixed upstream.
  134. * Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-6
  135. - Ugh. Let's acutally use a valid e-mail addy.
  136. * Thu Nov 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-5
  137. - Add patch to use gnutls compression.
  138. * Mon Nov 12 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-4
  139. - Add reconnect-failure patch. Thanks to Robert McQueen.
  140. * Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-3
  141. - Rebuild.
  142. * Sun Aug 5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-2
  143. - Update license tag.
  144. * Sun Jun 10 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-1
  145. - Update to 1.2.3.
  146. - Drop stream-error patch. fixed upstream.
  147. * Wed May 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-3
  148. - Add patch to fix stream error.
  149. * Tue May 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-2
  150. - Drop BR on libtasn1-devel.
  151. * Mon May 14 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-1
  152. - Update to 1.2.2.
  153. * Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-2
  154. - Fix typo.
  155. * Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-1
  156. - Update to 1.2.1.
  157. * Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-3
  158. - Add necessary requires to devel package. D'Oh!
  159. * Tue Feb 20 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-2
  160. - Add BR on libidn-devel.
  161. - Specify which ssl implementation to use.
  162. * Mon Feb 5 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-1
  163. - Update to 1.2.0.
  164. - Drop mono config option since it's been dropped from the tarball.
  165. * Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-2
  166. - Change source to .gz.
  167. * Mon Sep 11 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-1
  168. - Update to 1.0.5.
  169. * Tue Aug 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-3
  170. - Rebuild for FC6.
  171. - Simplify devel description.
  172. * Thu Jun 29 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-2
  173. - Update to 1.0.4.
  174. - Add devel requires on pkgconfig.
  175. - Drop reentrancy patch, fixed upstream.
  176. * Thu Jun 15 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-5
  177. - rebuild for new gnutls
  178. * Fri May 26 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-4
  179. - Add patch to fix some reentrancy crashes. (Thanks, Havoc)
  180. * Wed Apr 5 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.3-3
  181. - Update to 1.0.3.
  182. - Add BR for gnutls-devel to devel package.
  183. - Disable static libs.
  184. - Add BR for check-devel.
  185. * Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-6
  186. - Remove unnecessary BR (libgcrypt-devel).
  187. * Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-5
  188. - rebuilt for new gcc4.1 snapshot and glibc changes
  189. * Mon Dec 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-4
  190. - Rebuild.
  191. * Wed Aug 31 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0.1-3
  192. - Update to 1.0.1.
  193. * Sun Aug 14 2005 Brian Pepple <bdpepple@ameritech.net> - 1.0-2
  194. - Update to 1.0.
  195. * Mon Aug 8 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-5
  196. - Rebuild due to new gnutls.
  197. * Sat Jul 30 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-4
  198. - Fix description.
  199. * Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-2
  200. - Add dist tag.
  201. * Fri May 13 2005 Brian Pepple <bdpepple@ameritech.net> - 0.90-1
  202. - Update to 0.9.
  203. * Thu May 5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-3
  204. - Adde glib2-devel requires.
  205. * Thu May 5 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-2
  206. - added %%{_includedir}.
  207. - Add libgcrypt-devel BR.
  208. * Sun May 1 2005 Brian Pepple <bdpepple@ameritech.net> - 0.17.2-1
  209. - Initial Fedora build.