lpr-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256
  1. Summary: A utility that manages print jobs.
  2. Name: lpr
  3. Version: 0.50
  4. Release: 7vl3
  5. Copyright: distributable
  6. Group: System Environment/Daemons
  7. Source: lpr-%{PACKAGE_VERSION}.tar.gz
  8. Patch: lpd.init-export-lang.diff
  9. Prereq: /sbin/chkconfig
  10. BuildRoot: /var/tmp/%{name}-root
  11. Summary(ja): プリントジョブ管理ユーティリティ
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. %description
  15. The lpr package provides the basic system utility for managing
  16. printing services. Lpr manages print queues, sends print jobs to
  17. local and remote printers and accepts print jobs from remote clients.
  18. If you will be printing from your system, you'll need to install the
  19. lpr package.
  20. %prep
  21. %setup -q
  22. %patch -p0 -b .vine
  23. %build
  24. %ifarch alpha
  25. # we shouldn't need this with more recent glibc's, but lpq kills remote
  26. # lpd w/o it
  27. make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Dgetline=get_line"
  28. %else
  29. make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
  30. %endif
  31. %install
  32. rm -rf $RPM_BUILD_ROOT
  33. mkdir -p $RPM_BUILD_ROOT/usr/{bin,sbin,man/man1,man/man5,man/man8}
  34. %ifarch alpha
  35. # we shouldn't need this with more recent glibc's, but lpq kills remote
  36. # lpd w/o it and there seems to be a mistake in lpr's makefiles somewhere
  37. make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Dgetline=get_line" DESTDIR=$RPM_BUILD_ROOT install
  38. %else
  39. make DESTDIR=$RPM_BUILD_ROOT install
  40. %endif
  41. chmod -x $RPM_BUILD_ROOT/usr/man/*/*
  42. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  43. install -m755 lpd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/lpd
  44. ( cd $RPM_BUILD_ROOT
  45. mkdir -p ./etc/rc.d/{rc0.d,rc1.d,rc2.d,rc3.d,rc4.d,rc5.d,rc6.d}
  46. ln -sf ../init.d/lpd ./etc/rc.d/rc0.d/K60lpd
  47. ln -sf ../init.d/lpd ./etc/rc.d/rc1.d/K60lpd
  48. ln -sf ../init.d/lpd ./etc/rc.d/rc2.d/S60lpd
  49. ln -sf ../init.d/lpd ./etc/rc.d/rc3.d/S60lpd
  50. ln -sf ../init.d/lpd ./etc/rc.d/rc5.d/S60lpd
  51. ln -sf ../init.d/lpd ./etc/rc.d/rc6.d/K60lpd
  52. mkdir -p ./var/spool/lpd
  53. )
  54. %clean
  55. rm -rf $RPM_BUILD_ROOT
  56. %post
  57. /sbin/chkconfig --add lpd
  58. %preun
  59. if [ $1 = 0 ]; then
  60. /sbin/chkconfig --del lpd
  61. fi
  62. %files
  63. %defattr(-,root,root)
  64. %attr(6555,root,lp) /usr/bin/lpq
  65. %attr(6555,root,lp) /usr/bin/lpr
  66. %attr(6555,root,lp) /usr/bin/lprm
  67. /usr/bin/lptest
  68. /usr/man/man1/lpq.1*
  69. /usr/man/man1/lpr.1*
  70. /usr/man/man1/lprm.1*
  71. /usr/man/man1/lptest.1*
  72. /usr/man/man5/printcap.5*
  73. /usr/man/man8/lpc.8*
  74. /usr/man/man8/lpd.8*
  75. /usr/man/man8/pac.8*
  76. %attr(2755,root,lp) /usr/sbin/lpc
  77. /usr/sbin/lpd
  78. /usr/sbin/lpf
  79. /usr/sbin/pac
  80. %attr(0775,root,daemon) %dir /var/spool/lpd
  81. %config /etc/rc.d/init.d/lpd
  82. %config(missingok) /etc/rc.d/rc0.d/K60lpd
  83. %config(missingok) /etc/rc.d/rc1.d/K60lpd
  84. %config(missingok) /etc/rc.d/rc2.d/S60lpd
  85. %config(missingok) /etc/rc.d/rc3.d/S60lpd
  86. %config(missingok) /etc/rc.d/rc5.d/S60lpd
  87. %config(missingok) /etc/rc.d/rc6.d/K60lpd
  88. %changelog
  89. * Sat Jan 6 2001 Jun Nishii <jun@vinelinux.org>
  90. - 0.50-7vl3
  91. - merge lpd.init-export-lang.diff ([vine-users:030229]) instead of lpd.init-vine.diff
  92. tnanks Masami Ashida <Masami.Ashida@mb7.seikyou.ne.jp for the bug report
  93. and thanks Yasuhide OOMORI <dasen@icntv.ne.jp> for the patch
  94. * Tue Dec 19 2000 Shoji Matsumoto <shom@vinelinux.org>
  95. - add lpd.init-vine.diff
  96. * Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  97. - Eratta from RHSA
  98. * Mon Oct 2 2000 Crutcher Dunnavant <crutcher@redhat.com>
  99. - Fixed bug #11740
  100. - Which was causing deadlocks in the queue in some situations.
  101. - Still possible, though much less likely.
  102. * Mon Sep 25 2000 Crutcher Dunnavant <crutcher@redhat.com>
  103. - Fixed a format string bug in lpd/printjob.c
  104. * Wed Aug 16 2000 Crutcher Dunnavant <crutcher@redhat.com>
  105. - fixed some evil in lpd/printjob.c that treated unspeced command lines
  106. - in the control file as print job files. (print was the default case)
  107. - this keeps lpd from screaming error messages/email when smatter lpd
  108. - servers talk to it.
  109. * Mon Feb 14 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  110. - Fix interoperability with MacOS client (Bug #7593)
  111. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  112. - Remove executable bit from lpq man page (Bug #9035)
  113. - deal with rpm compressing man pages
  114. * Mon Jan 24 2000 Bill Nottingham <notting@redhat.com>
  115. - you're saying core dumps in the spooldir are a bad idea?
  116. * Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
  117. - *sigh*
  118. * Thu Jan 6 2000 Bill Nottingham <notting@redhat.com>
  119. - more security fixes
  120. * Tue Nov 7 1999 Bill Nottingham <notting@redhat.com>
  121. - add a 'custom' parameter 'Z' to cf files (GOMEZ@slib.fr)
  122. * Fri Oct 22 1999 Bill Nottingham <notting@redhat.com>
  123. - oops. slightly overzealous in dropping ids.
  124. * Tue Oct 19 1999 Bill Nottingham <notting@redhat.com>
  125. - fix a stupid typo.
  126. * Fri Oct 15 1999 Bill Nottingham <notting@redhat.com>
  127. - fix some security issues.
  128. * Fri Oct 8 1999 Bill Nottingham <notting@redhat.com>
  129. - squash multiple copies bug, hopefully permanently...
  130. * Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
  131. - chkconfig --del on %preun, not %postun
  132. * Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
  133. - fix suppress headers on remote printers
  134. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  135. - initscript munging
  136. * Mon Aug 2 1999 Bill Nottingham <notting@redhat.com>
  137. - fix multiple copy remote printing
  138. * Thu Jul 29 1999 Bill Nottingham <notting@redhat.com>
  139. - add lp group when exec()ing filter, so .config file with passwords
  140. can be non-world-readable...
  141. * Mon Jul 12 1999 Bill Nottingham <notting@redhat.com>
  142. - fix possible core dumps in lpc (ms@bee.de, #3776)
  143. * Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
  144. - add lp= capability support (#3683)
  145. * Thu Jun 17 1999 Bill Nottingham <notting@redhat.com>
  146. - fixes for job removal (#2676)
  147. * Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
  148. - fix for RS capability (#3217)
  149. * Mon May 10 1999 Bill Nottingham <notting@redhat.com>
  150. - RFC 1179 compliance actually works now...
  151. * Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
  152. - make lpr RFC 1179 compliant
  153. * Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
  154. - increase buffer length for filenames (bug #1676)
  155. * Fri Mar 19 1999 Bill Nottingham <notting@redhat.com>
  156. - change man page to show that -r -s is not supported (bug #717)
  157. * Mon Feb 15 1999 Bill Nottingham <notting@redhat.com>
  158. - security patch from Chris Evans
  159. - fix for remote but not local users (originally from Kevin Sochacki)
  160. * Mon Feb 8 1999 Bill Nottingham <notting@redhat.com>
  161. - build for 6.0 tree
  162. * Thu Oct 1 1998 Bill Nottingham <notting@redhat.com>
  163. - don't ignore SIGCHLD in filters
  164. * Mon Aug 3 1998 Jeff Johnson <jbj@redhat.com>
  165. - build root.
  166. * Fri Jun 26 1998 Jeff Johnson <jbj@redhat.com>
  167. - bring printjob up-to-date (fix problem #564)
  168. * Thu Apr 23 1998 Michael K. Johnson <johnsonm@redhat.com>
  169. - enhanced initscript
  170. * Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
  171. - included new rmjob security fix from BSD
  172. * Sat Apr 18 1998 Erik Troan <ewt@redhat.com>
  173. - included rmjob patches from BSD
  174. * Fri Feb 27 1998 Otto Hammersmith <otto@redhat.com>
  175. - increased buffer for hostname from 32 to 1024, plenty big enough now.
  176. * Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
  177. - added chkconfig support
  178. - changed the initscript name from lpd.init to lpd (all links, too)
  179. * Mon Oct 27 1997 Michael Fulbright <msf@redhat.com>
  180. - Fixed print filters to change to printer's UID so root-squashing wont bite us
  181. * Wed Oct 8 1997 Michael Fulbright <msf@redhat.com>
  182. - Fixed nasty error in getprent() and forked lpd's in startup() which
  183. caused the printcap file to be read incorrectly.
  184. - added #include <string.h> as needed to make compile cleaner.
  185. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  186. - changes for glibc 2.0.4
  187. * Tue Apr 22 1997 Michael Fulbright <msf@redhat.com>
  188. - moved to v. 0.17, then 0.18 (!)
  189. - Fixed bug on Alpha/glibc when printing to a remote queue via a filter
  190. * Fri Mar 28 1997 Michael Fulbright <msf@redhat.com>
  191. - Moved version up to 0.16
  192. - Added input filter support for remote queues
  193. * Wed Mar 05 1997 Erik Troan <ewt@redhat.com>
  194. - Incorporated filter patch into main sources
  195. - Removed RCS logs from source tar file
  196. - Added patched from David Mosberger to fix __ivaliduser on Alpha's
  197. - added -Dgetline=get_line for old glibcs (this means alpha)