lsb-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583
  1. # Define this to link to which library version eg. /lib64/ld-lsb-x86-64.so.3
  2. %define lsbsover 3
  3. %ifarch %{ix86}
  4. %define ldso ld-linux.so.2
  5. %define lsbldso ld-lsb.so
  6. %endif
  7. %ifarch x86_64
  8. %define ldso ld-linux-x86-64.so.2
  9. %define lsbldso ld-lsb-x86-64.so
  10. %endif
  11. %ifarch x86_64
  12. %define qual ()(64bit)
  13. %else
  14. %define qual %{nil}
  15. %endif
  16. %define upstreamlsbrelver 2.0
  17. %define lsbrelver 4.0
  18. %define srcrelease 1
  19. Summary: LSB support for Vine Linux
  20. Summary(ja): Vine Linux の LSB サポート
  21. Name: lsb
  22. Version: 4.0
  23. Release: 6%{?_dist_release}
  24. Group: system
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. License: GPLv2
  28. URL: http://www.linuxfoundation.org/
  29. Source0: %{name}-vine-%{version}.tar.bz2
  30. BuildRoot: %{_tmppath}/%{name}-root
  31. BuildRequires: glibc-static
  32. # dependency for primary LSB application for v1.3
  33. Provides: lsb = %{version}
  34. # dependency for primary LSB application for v2.0, v3.0 and v4.0
  35. %ifarch %{ix86}
  36. %define archname ia32
  37. %endif
  38. %ifarch x86_64
  39. %define archname amd64
  40. %endif
  41. Provides: lsb-core-%{archname} = %{version}
  42. Provides: lsb-graphics-%{archname} = %{version}
  43. Provides: lsb-core-noarch = %{version}
  44. Provides: lsb-graphics-noarch = %{version}
  45. Provides: lsb-printing-%{archname} = %{version}
  46. Provides: lsb-printing-noarch = %{version}
  47. ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x
  48. %ifarch %{ix86}
  49. # archLSB IA32 Base Libraries
  50. Requires: libatk-1.0.so.0
  51. Requires: libc.so.6
  52. Requires: libcrypt.so.1
  53. Requires: libdl.so.2
  54. Requires: libgcc_s.so.1
  55. Requires: libgdk-x11-2.0.so.0
  56. Requires: libgdk_pixbuf-2.0.so.0
  57. Requires: libgdk_pixbuf_xlib-2.0.so.0
  58. Requires: libglib-2.0.so.0
  59. Requires: libgmodule-2.0.so.0
  60. Requires: libgobject-2.0.so.0
  61. Requires: libgthread-2.0.so.0
  62. Requires: libgtk-x11-2.0.so.0
  63. Requires: libm.so.6
  64. Requires: libncurses.so.5
  65. Requires: libpango-1.0.so.0
  66. Requires: libpangoft2-1.0.so.0
  67. Requires: libpangoxft-1.0.so.0
  68. Requires: libpthread.so.0
  69. #Requires: libqt-mt.so.3
  70. Requires: libQtCore.so.4
  71. Requires: libQtGui.so.4
  72. Requires: libQtNetwork.so.4
  73. Requires: libQtOpenGL.so.4
  74. Requires: libQtSql.so.4
  75. Requires: libQtSvg.so.4
  76. Requires: libQtXml.so.4
  77. Requires: libstdc++.so.6
  78. Requires: libutil.so.1
  79. Requires: libz.so.1
  80. %endif
  81. %ifarch x86_64
  82. # archLSB AMD64 Base Libraries
  83. Requires: libatk-1.0.so.0()(64bit)
  84. Requires: libc.so.6()(64bit)
  85. Requires: libcrypt.so.1()(64bit)
  86. Requires: libdl.so.2()(64bit)
  87. Requires: libgcc_s.so.1()(64bit)
  88. Requires: libgdk-x11-2.0.so.0()(64bit)
  89. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  90. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  91. Requires: libglib-2.0.so.0()(64bit)
  92. Requires: libgmodule-2.0.so.0()(64bit)
  93. Requires: libgobject-2.0.so.0()(64bit)
  94. Requires: libgthread-2.0.so.0()(64bit)
  95. Requires: libgtk-x11-2.0.so.0()(64bit)
  96. Requires: libm.so.6()(64bit)
  97. Requires: libncurses.so.5()(64bit)
  98. Requires: libpango-1.0.so.0()(64bit)
  99. Requires: libpangoft2-1.0.so.0()(64bit)
  100. Requires: libpangoxft-1.0.so.0()(64bit)
  101. Requires: libpthread.so.0()(64bit)
  102. #Requires: libqt-mt.so.3()(64bit)
  103. Requires: libQtCore.so.4()(64bit)
  104. Requires: libQtGui.so.4()(64bit)
  105. Requires: libQtNetwork.so.4()(64bit)
  106. Requires: libQtOpenGL.so.4()(64bit)
  107. Requires: libQtSql.so.4()(64bit)
  108. Requires: libQtSvg.so.4()(64bit)
  109. Requires: libQtXml.so.4()(64bit)
  110. Requires: libstdc++.so.6()(64bit)
  111. Requires: libutil.so.1()(64bit)
  112. Requires: libz.so.1()(64bit)
  113. %endif
  114. # gLSB Base/Utility/Stdc++/Graphics Libraries
  115. Requires: libasound.so.2%{qual}
  116. Requires: libatk-1.0.so.0%{qual}
  117. Requires: libcrypt.so.1%{qual}
  118. Requires: libcups.so.2%{qual}
  119. Requires: libcupsimage.so.2%{qual}
  120. Requires: libdl.so.2%{qual}
  121. Requires: libfontconfig.so.1%{qual}
  122. Requires: libfreetype.so.6%{qual}
  123. Requires: libgcc_s.so.1%{qual}
  124. Requires: libgdk-x11-2.0.so.0%{qual}
  125. Requires: libgdk_pixbuf-2.0.so.0%{qual}
  126. Requires: libgdk_pixbuf_xlib-2.0.so.0%{qual}
  127. Requires: libGL.so.1%{qual}
  128. Requires: libglib-2.0.so.0%{qual}
  129. Requires: libgmodule-2.0.so.0%{qual}
  130. Requires: libgobject-2.0.so.0%{qual}
  131. Requires: libgthread-2.0.so.0%{qual}
  132. Requires: libgtk-x11-2.0.so.0%{qual}
  133. Requires: libICE.so.6%{qual}
  134. Requires: libjpeg.so.62%{qual}
  135. Requires: libncurses.so.5%{qual}
  136. Requires: libpam.so.0%{qual}
  137. Requires: libpango-1.0.so.0%{qual}
  138. Requires: libpangoft2-1.0.so.0%{qual}
  139. Requires: libpangoxft-1.0.so.0%{qual}
  140. Requires: libpng16.so.16%{qual}
  141. Requires: libpthread.so.0%{qual}
  142. #Requires: libqt-mt.so.3%{qual}
  143. Requires: libQtCore.so.4%{qual}
  144. Requires: libQtGui.so.4%{qual}
  145. Requires: libQtNetwork.so.4%{qual}
  146. Requires: libQtOpenGL.so.4%{qual}
  147. Requires: libQtSql.so.4%{qual}
  148. Requires: libQtSvg.so.4%{qual}
  149. Requires: libQtXml.so.4%{qual}
  150. Requires: librt.so.1%{qual}
  151. Requires: libSM.so.6%{qual}
  152. Requires: libstdc++.so.6%{qual}
  153. Requires: libutil.so.1%{qual}
  154. Requires: libX11.so.6%{qual}
  155. Requires: libXext.so.6%{qual}
  156. Requires: libXft.so.2%{qual}
  157. Requires: libXi.so.6%{qual}
  158. Requires: libxml2.so.2%{qual}
  159. Requires: libXrender.so.1%{qual}
  160. Requires: libXt.so.6%{qual}
  161. Requires: libz.so.1%{qual}
  162. # gLSB Command and Utilities
  163. Requires: /bin/awk
  164. Requires: /bin/basename
  165. Requires: /bin/cat
  166. Requires: /bin/chgrp
  167. Requires: /bin/chmod
  168. Requires: /bin/chown
  169. Requires: /bin/cp
  170. Requires: /bin/cpio
  171. Requires: /bin/cut
  172. Requires: /bin/date
  173. Requires: /bin/dd
  174. Requires: /bin/df
  175. Requires: /bin/dmesg
  176. Requires: /bin/echo
  177. Requires: /bin/ed
  178. Requires: /bin/egrep
  179. Requires: /bin/env
  180. Requires: /bin/false
  181. Requires: /bin/fgrep
  182. Requires: /bin/gettext
  183. Requires: /bin/grep
  184. Requires: /bin/gunzip
  185. Requires: /bin/gzip
  186. Requires: /bin/hostname
  187. Requires: /bin/kill
  188. Requires: /bin/ln
  189. Requires: /bin/ls
  190. Requires: mailx
  191. Requires: /bin/mkdir
  192. Requires: /bin/mknod
  193. Requires: /bin/mktemp
  194. Requires: /bin/more
  195. Requires: /bin/mount
  196. Requires: /bin/mv
  197. Requires: /bin/nice
  198. Requires: /bin/ps
  199. Requires: /bin/pwd
  200. Requires: /bin/rm
  201. Requires: /bin/rmdir
  202. Requires: /bin/sed
  203. Requires: /bin/sh
  204. Requires: /bin/sleep
  205. Requires: /bin/sort
  206. Requires: /bin/stty
  207. Requires: /bin/su
  208. Requires: /bin/sync
  209. Requires: /bin/tar
  210. Requires: /bin/touch
  211. Requires: /bin/true
  212. Requires: /bin/umount
  213. Requires: /bin/uname
  214. Requires: /bin/zcat
  215. Requires: /sbin/fuser
  216. Requires: /sbin/pidof
  217. Requires: /sbin/shutdown
  218. Requires: /usr/bin/[
  219. Requires: /usr/bin/ar
  220. Requires: /usr/bin/at
  221. Requires: /usr/bin/batch
  222. Requires: /usr/bin/bc
  223. Requires: /usr/bin/chfn
  224. Requires: /usr/bin/chsh
  225. Requires: /usr/bin/cksum
  226. Requires: /usr/bin/cmp
  227. Requires: /usr/bin/col
  228. Requires: /usr/bin/comm
  229. Requires: /usr/bin/crontab
  230. Requires: /usr/bin/csplit
  231. Requires: /usr/bin/diff
  232. Requires: /usr/bin/dirname
  233. Requires: /usr/bin/du
  234. Requires: /usr/bin/expand
  235. Requires: /usr/bin/expr
  236. Requires: /usr/bin/fc-cache
  237. Requires: /usr/bin/fc-list
  238. Requires: /usr/bin/fc-match
  239. Requires: /usr/bin/file
  240. Requires: /usr/bin/find
  241. Requires: /usr/bin/fold
  242. Requires: /usr/bin/foomatic-rip
  243. Requires: /usr/bin/gencat
  244. Requires: /usr/bin/getconf
  245. Requires: /usr/bin/groups
  246. Requires: /usr/bin/gs
  247. Requires: /usr/bin/head
  248. Requires: /usr/bin/iconv
  249. Requires: /usr/bin/id
  250. Requires: /usr/bin/install
  251. Requires: /usr/bin/ipcrm
  252. Requires: /usr/bin/ipcs
  253. Requires: /usr/bin/join
  254. Requires: /usr/bin/killall
  255. Requires: /usr/bin/locale
  256. Requires: /usr/bin/localedef
  257. Requires: /usr/bin/logger
  258. Requires: /usr/bin/logname
  259. Requires: /usr/bin/lp
  260. Requires: /usr/bin/lpr
  261. Requires: /usr/bin/m4
  262. Requires: /usr/bin/make
  263. Requires: /usr/bin/man
  264. Requires: /usr/bin/md5sum
  265. Requires: /usr/bin/mkfifo
  266. Requires: /usr/bin/msgfmt
  267. Requires: /usr/bin/newgrp
  268. Requires: /usr/bin/nl
  269. Requires: /usr/bin/nohup
  270. Requires: /usr/bin/od
  271. Requires: /usr/bin/passwd
  272. Requires: /usr/bin/paste
  273. Requires: /usr/bin/patch
  274. Requires: /usr/bin/pathchk
  275. # better POSIX compatible
  276. Requires: spax
  277. Requires: /usr/bin/perl
  278. Requires: /usr/bin/pr
  279. Requires: /usr/bin/printf
  280. Requires: /usr/bin/python
  281. Requires: /usr/bin/renice
  282. Requires: /usr/bin/split
  283. Requires: /usr/bin/strip
  284. Requires: /usr/bin/tail
  285. Requires: /usr/bin/tee
  286. Requires: /usr/bin/test
  287. Requires: /usr/bin/time
  288. Requires: /usr/bin/tr
  289. Requires: /usr/bin/tsort
  290. Requires: /usr/bin/tty
  291. Requires: /usr/bin/unexpand
  292. Requires: /usr/bin/uniq
  293. Requires: /usr/bin/wc
  294. Requires: /usr/bin/xargs
  295. Requires: /usr/sbin/groupadd
  296. Requires: /usr/sbin/groupdel
  297. Requires: /usr/sbin/groupmod
  298. Requires: /usr/sbin/sendmail
  299. Requires: /usr/sbin/useradd
  300. Requires: /usr/sbin/userdel
  301. Requires: /usr/sbin/usermod
  302. Requires: /bin/mailx
  303. Requires: lsb-release
  304. %description
  305. The Linux Standard Base (LSB) is an attempt to develop a set of
  306. standards that will increase compatibility among Linux distributions.
  307. The lsb package provides utilities needed for LSB Compliant
  308. Applications. It also contains requirements that will ensure that all
  309. components required by the LSB that are provided by Red Hat Linux are
  310. installed on the system.
  311. %prep
  312. %setup -q -n %{name}-vine-%{version}
  313. %build
  314. cd lsb-release-%{upstreamlsbrelver}
  315. make
  316. %install
  317. rm -rf $RPM_BUILD_ROOT
  318. # LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
  319. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT/%{_lib} $RPM_BUILD_ROOT%{_mandir} \
  320. $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb \
  321. $RPM_BUILD_ROOT%{_sysconfdir}/lsb-release.d/ $RPM_BUILD_ROOT%{_sbindir}
  322. make DESTDIR=$RPM_BUILD_ROOT install
  323. cd lsb-release-%{upstreamlsbrelver}
  324. make mandir=$RPM_BUILD_ROOT/%{_mandir} prefix=$RPM_BUILD_ROOT/%{_prefix} install
  325. cd ..
  326. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-%{archname}
  327. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-noarch
  328. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-%{archname}
  329. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-noarch
  330. touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-%{archname}
  331. touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-noarch
  332. # and claim LSB 3.1/3.2 is supported as well
  333. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-%{archname}
  334. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-noarch
  335. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-%{archname}
  336. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-noarch
  337. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-%{archname}
  338. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-noarch
  339. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-%{archname}
  340. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-noarch
  341. for LSBVER in %{lsbsover}; do
  342. ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.$LSBVER
  343. done
  344. mkdir -p $RPM_BUILD_ROOT/bin
  345. # LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
  346. # According to the lsb-core documentation provided by
  347. # http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic.pdf
  348. # it's OK to put non binary in /usr/lib.
  349. ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/install_initd
  350. ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/remove_initd
  351. cp -p lsb_vine_init $RPM_BUILD_ROOT/bin/lsb_vine_init
  352. rm -rf %{buildroot}%{_bindir}
  353. rm -rf %{buildroot}%{_mandir}
  354. %clean
  355. rm -rf $RPM_BUILD_ROOT
  356. %files
  357. %defattr(-,root,root)
  358. %{_sysconfdir}/lsb-vine
  359. %dir %{_sysconfdir}/lsb-release.d
  360. %{_sysconfdir}/lsb-release.d/*
  361. /bin/lsb_vine_init
  362. /usr/lib/lsb
  363. /%{_lib}/*so*
  364. /lib/lsb*
  365. %changelog
  366. * Thu Mar 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-6
  367. - dropped /bin/mailx: provided by mailutils.
  368. - dropped lsb_release: provides by lsb-release.
  369. - dropped scriptlets and triggers.
  370. * Mon Oct 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-5
  371. - dropped dependence on qt3.
  372. - removed stuff for unsuppoted architectures.
  373. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 4.0-4
  374. - rebuild with gcc-5.4.0
  375. * Wed Jan 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0-3
  376. - change Requires: libpng16.so.16 instead of libpng12.so.0
  377. * Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0-2
  378. - require spax instead of pax (more POSIX compatible)
  379. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
  380. - update to LSB4.0
  381. - add Provide lsb-printing{,-noarch}
  382. - add BR: glibc-static
  383. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-1
  384. - initial build for Vine Linux
  385. * Thu Aug 28 2008 Hao Liu <hliu@redhat.com> 3.2-2
  386. - Modify "Requires: /usr/bin/mailx" to "Requires: mailx" (Bug #460249)
  387. * Mon Aug 18 2008 Hao Liu <hliu@redhat.com> 3.2-1
  388. - Port forward to LSB 3.2
  389. - Remove symlink for mailx if user is upgrading from the redhat-lsb of older version
  390. - Since F10 put mailx under /usr/bin, change the corresponding requires
  391. * Tue Aug 5 2008 Hao Liu <hliu@redhat.com> - 3.1-22
  392. - Remove 2 requires which provided by redhat-lsb
  393. - Add comments explaining why hard-coded path is kept
  394. - Resolve some hard-coded path problems
  395. - Add comments explaining why importing '-static' option while compiling redhat_lsb_trigger
  396. - Replace %{_libdir}/lsb with /usr/lib/lsb
  397. - Replace /%{_lib}/* with /%{_lib}/*so*
  398. - Replace /lib/lsb with /lib/lsb*
  399. * Thu Jul 31 2008 Lawrence Lim <llim@redhat.com> - 3.1-21
  400. - remove symlink for mailx (Bug #457241)
  401. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.1-20
  402. - Autorebuild for GCC 4.3
  403. * Wed Oct 3 2007 Lawrence Lim <llim@redhat.com> - 3.1-19
  404. - fix build issue on ppc - (.opd+0x10): multiple definition of `__libc_start_main'
  405. * Fri Sep 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-18
  406. - fix build issue in minimal build root (Bug #265241)
  407. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.1-17
  408. - Rebuild for selinux ppc32 issue.
  409. * Mon Aug 20 2007 Lawrence Lim <llim@redhat.com> - 3.1-16
  410. - update spec file in accordance to feedback provided through merge review - merge-review.patch - #226363
  411. * Wed Jul 18 2007 Lawrence Lim <llim@redhat.com> - 3.1-15.f8
  412. - Resolved: #239842 - /lib/lsb/init-functions shall use aliases but not functions
  413. - forward port the patch from 3.1-12.3.EL which fix #217566, #233530, #240916
  414. * Wed May 2 2007 Lawrence Lim <llim@redhat.com> - 3.1-14.fc7
  415. - fixed Bug 232918 for new glibc version
  416. * Wed Feb 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-13
  417. - fixed Bug 226363
  418. * Wed Nov 29 2006 Lawrence Lim <llim@redhat.com> - 3.1-12
  419. - replaced aliases with functions in /lib/lsb/init-functions; Bug 217566
  420. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 3.1-11
  421. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  422. * Thu Sep 21 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.3
  423. - Fix upgrade issue; Bug 202548
  424. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1-10.2.1
  425. - rebuild
  426. * Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.2
  427. - for some strange reason, ld-lsb-x86-64.so need to be ld-lsb-x86-64.so.3 (LSB3.0) rather than ld-lsb-x86-64.so.3.1 (LSB3.1)
  428. * Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.1
  429. - generate spec file on RHEL5-Alpha system
  430. - fix vsw4 test suite setup by creating symlink for X11 SecurityPolicy and XFontPath
  431. * Thu Jun 22 2006 Lawrence Lim <llim@redhat.com> - 3.0-10
  432. - Rewrite most part of the mkredhat-lsb to obtain information directly via specdb
  433. rather than sniffing through sgml
  434. - remove redundent script and bump up tarball version
  435. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.2
  436. - bump again for double-long bug on ppc(64)
  437. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.1
  438. - rebuilt for new gcc4.1 snapshot and glibc changes
  439. * Fri Jan 13 2006 Leon Ho <llch@redhat.com> 3.0-9
  440. - Migrated back to rawhide
  441. * Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-8.EL
  442. - Added libstdc++.so.6/libGL.so.1 requirement (RH#154605)
  443. * Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-7.EL
  444. - Fixed multilib problem on lsb_release not to read /etc/lsb-release and solely
  445. depends on /etc/lsb-release.d/ (Advised by LSB committee)
  446. - Removed /etc/lsb-release (Advised by LSB committee)
  447. * Mon Aug 1 2005 Leon Ho <llch@redhat.com> 3.0-6.EL
  448. - Made the /etc/lsb-release useful (RH#154605)
  449. - Added redhat_lsb_trigger to fix RH#160585 (Jakub Jelinek)
  450. - Fixed AMD64 base libraries requirement parsing (RH#154605)
  451. * Tue Jul 26 2005 Leon Ho <llch@redhat.com> 3.0-5.EL
  452. - Fixed redhat-lsb's mkredhat-lsb on fetching lib and
  453. cmd requirements
  454. * Mon Jul 18 2005 Leon Ho <llch@redhat.com> 3.0-4.EL
  455. - Rebuilt
  456. * Tue Jul 05 2005 Leon Ho <llch@redhat.com> 3.0-3.EL
  457. - Disabled support for LSB 1.3 and 2.0
  458. * Mon Jun 20 2005 Leon Ho <llch@redhat.com> 3.0-2.EL
  459. - Upgraded to lsb-release 2.0
  460. * Thu Jun 09 2005 Leon Ho <llch@redhat.com> 3.0-1.EL
  461. - Moved to LSB 3.0
  462. * Wed Apr 13 2005 Leon Ho <llch@redhat.com> 1.3-10
  463. - Fixed ix86 package with ia32 emul support
  464. * Tue Feb 01 2005 Leon Ho <llch@redhat.com> 1.3-9
  465. - Sync what we have changed on the branches
  466. Wed Nov 24 2004 Harald Hoyer <harald@redhat.com>
  467. - added post section to recreate the softlink in emul mode (bug 140739)
  468. Mon Nov 15 2004 Phil Knirsch <pknirsch@redhat.com>
  469. Tiny correction of bug in new triggers
  470. * Mon Jan 24 2005 Leon Ho <llch@redhat.com> 1.3-8
  471. - Add support provide on lsb-core-* for each arch
  472. * Fri Jan 21 2005 Leon Ho <llch@redhat.com> 1.3-7
  473. - Add to support multiple LSB test suite version
  474. - Add %%endif in trigger postun
  475. * Thu Nov 11 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-6
  476. - Fixed invalid sln call for trigger in postun on ia64 (#137647)
  477. * Mon Aug 09 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-4
  478. - Bump release and rebuilt for RHEL4.
  479. * Thu Jul 24 2003 Matt Wilson <msw@redhat.com> 1.3-3
  480. - fix lsb ld.so name for ia64 (#100613)
  481. * Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
  482. - use /usr/lib/lsb for install_initd, remove_initd
  483. * Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
  484. - add ia64 x86_64 ppc ppc64 s390 s390x
  485. * Tue Feb 18 2003 Matt Wilson <msw@redhat.com> 1.3-1
  486. - 1.3
  487. * Wed Sep 4 2002 Matt Wilson <msw@redhat.com>
  488. - 1.2.0
  489. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  490. - automated rebuild
  491. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  492. - automated rebuild
  493. * Wed Mar 27 2002 Matt Wilson <msw@redhat.com>
  494. - addeed trigger on glibc to re-establish the ld-lsb.so.1 symlink in the
  495. forced downgrade case.
  496. * Tue Mar 12 2002 Bill Nottingham <notting@redhat.com>
  497. - add initscripts support
  498. * Thu Jan 24 2002 Matt Wilson <msw@redhat.com>
  499. - Initial build.