123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293 |
- Name: libmowgli
- Summary: An algorithm framework
- Summary(ja): アルゴリズムフレームワーク
- Version: 0.7.0
- Release: 2%{?_dist_release}
- Group: System Environment/Libraries
- License: ISC
- URL: http://atheme.org/projects/mowgli.shtml
- Source0: http://distfiles.atheme.org/libmowgli-%{version}.tgz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- %description
- mowgli is a development framework for C (like GLib), which provides high
- performance and highly flexible algorithms. It can be used as a suppliment to
- GLib (to add additional functions (dictionaries, hashes), or replace some of
- the slow GLib list manipulation functions), or stand alone. It also provides a
- powerful hook system and convenient logging for your code, as well as a high
- performance block allocator.
- %package devel
- Summary: Development files for libmowgli
- Summary(ja): libmowgli の開発用ファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- mowgli is a development framework for C (like GLib), which provides high
- performance and highly flexible algorithms. It can be used as a suppliment to
- GLib (to add additional functions (dictionaries, hashes), or replace some of
- the slow GLib list manipulation functions), or stand alone. It also provides a
- powerful hook system and convenient logging for your code, as well as a high
- performance block allocator.
- This package contains the files necessary for writing programs that use
- libmowgli.
- %prep
- %setup -q
- perl -pi -e 's/^\.SILENT:.*$//' buildsys.mk.in
- perl -pi -e "s/-soname=.*'/-soname=\\\$\{LIB\}.\\\$\{LIB_MAJOR\}'/" configure
- %build
- %configure \
-
- make %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %defattr(-,root,root,-)
- %doc AUTHORS COPYING README
- %{_libdir}
|