libomp-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: OpenMP runtime for clang
  6. Summary(ja): clang用OpenMPランタイム
  7. Name: libomp
  8. Version: 12.0.1
  9. Release: 1%{?_dist_release}
  10. Group: system
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: NCSA
  14. URL: https://llvm.org/
  15. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/openmp-%{version}.src.tar.xz
  16. # patches
  17. Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: libffi-devel >= 3.3
  22. #BuildRequires: perl
  23. #BuildRequires: perl-Data-Dumper
  24. #BuildRequires: perl-Encode
  25. # LLVM is not supported on PPC64
  26. # http://llvm.org/bugs/show_bug.cgi?id=3729
  27. ExcludeArch: ppc64
  28. %description
  29. The package contains the OpenMP runtime for clang.
  30. %package devel
  31. Summary: OpenMP header files
  32. Summary(ja): OpenMPヘッダファイル
  33. Group: programming
  34. Requires: clang-devel%{?isa} = %{version}
  35. %description devel
  36. The package contains the OpenMP header files.
  37. %debug_package
  38. %prep
  39. %autosetup -p2 -n openmp-%{version}.src
  40. %build
  41. # LTO causes build failures in this package. Disable LTO for now
  42. %define _lto_cflags %{nil}
  43. %cmake \
  44. -GNinja \
  45. -DLIBOMP_INSTALL_ALIASES=OFF \
  46. -DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{version}/include \
  47. %if 0%{?__isa_bits} == 64
  48. -DOPENMP_LIBDIR_SUFFIX=64 \
  49. %else
  50. -DOPENMP_LIBDIR_SUFFIX= \
  51. %endif
  52. %{nil}
  53. %cmake_build
  54. %install
  55. rm -rf %{buildroot}
  56. %cmake_install
  57. # Remove static libraries with equivalent shared libraries
  58. rm -f %{buildroot}%{_libdir}/libarcher_static.a
  59. %if %{with test}
  60. %check
  61. %cmake_build --target check-openmp
  62. %endif
  63. %clean
  64. rm -rf %{buildroot}
  65. %files
  66. %license LICENSE.txt
  67. %{_libdir}/libarcher.so
  68. %{_libdir}/libomp.so
  69. %files devel
  70. %{_libdir}/clang/%{version}/include/omp.h
  71. %{_libdir}/clang/%{version}/include/omp-tools.h
  72. %{_libdir}/clang/%{version}/include/ompt.h
  73. %{_includedir}/ompt-multiplex.h
  74. %changelog
  75. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  76. - new upstream release.
  77. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  78. - devided libomp from llvm.
  79. - new upstream release.
  80. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  81. - enabled to build utils.
  82. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  83. - new upstream release.
  84. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  85. - new upstream release.
  86. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  87. - rebuilt with libffi-3.3.
  88. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  89. - new upstream release.
  90. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  91. - new upstream release.
  92. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  93. - dropped all patches.
  94. - switched build-system to ninja.
  95. - switched python to python3.
  96. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  97. - new upstream release.
  98. - added OpenMP.
  99. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  100. - fixed %%files.
  101. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  102. - new upstream release.
  103. - dropped Patch0, 4, 5, 100 and 200.
  104. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  105. - renamed a subpackage "llvm-libs".
  106. - added a subpackage "lld".
  107. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  108. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  109. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  110. - new upstream release.
  111. - dropped Patch1 and 2: fixed in upstream.
  112. - imported Patch0, 3-5, 100 and 200 from rawhide.
  113. - disabled Patch1002: no longer needed?
  114. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  115. - new upstream release.
  116. - switched to cmake.
  117. - disable ocaml binding as default.
  118. - updated Patch1000 and 1002.
  119. - disabled Patch1000 as default.
  120. - cleanup patches.
  121. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  122. - rebuild with gcc-5.4.0
  123. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  124. - new upstream release
  125. - added BR: ocaml-ctypes
  126. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  127. - new upstream release
  128. - dropt Patch 1, 201 and 1001
  129. - updated Patch 1000
  130. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  131. - updated to 3.5.1
  132. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  133. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  134. - obsoleted clang-doc
  135. - built with ocaml 4.02.1
  136. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  137. - fix <BTS:2832>
  138. - fix configure option "--with-c-include-dirs"
  139. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  140. - update Patch1001: clang-3.5.0-driver-lib64.patch
  141. - update Patch1002: clang-3.5.0-driver-vine.patch
  142. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  143. - update to 3.5.0
  144. - remove Patch11 (clang-hardfloat-hack.patch)
  145. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  146. - rebuild with libffi-3.0.13
  147. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  148. - update to 3.3
  149. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  150. - ld.gold (patch1000,1001)
  151. - add /%{_lib} to ld search path
  152. - add support *-vine-linux gcc (patch1002)
  153. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  154. - update to 3.1
  155. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  156. - updated to 3.0 release
  157. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  158. - added patch 2-4 to support -O4 link-time optimization
  159. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  160. - disable -fno-var-tracking-assignments on ppc
  161. (seems like gcc-4.4.5 still doesn't support this)
  162. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  163. - new upstream release
  164. - add BR: libffi-devel
  165. - add R: libffi-devel to -devel
  166. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  167. - initial build for Vine Linux
  168. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  169. - Update to final 2.7 release
  170. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  171. - Update to first 2.7 pre-release
  172. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  173. - Update to 2.6 pre-release2
  174. - -devel subpackage now virtually provides -static
  175. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  176. - Disable var tracking assignments on PPC
  177. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  178. - Don't adjust clang include dir; files there are noarch (bz#521893)
  179. - Enable clang unit tests
  180. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  181. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  182. - Package Clang's static analyzer tools
  183. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  184. - PIC is now enabled by default; explicitly disable on %%{ix86}
  185. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  186. - First 2.6 prerelease
  187. - Enable Clang front-end
  188. - Enable debuginfo generation
  189. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  190. - Disable assertions (needed by OpenGTL, bz#521261)
  191. - Align spec file with upstream build instructions
  192. - Enable unit tests
  193. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  194. - Only disable PIC on %%ix86; ppc actually needs it
  195. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  196. - Disable use of position-independent code on 32-bit platforms
  197. (buggy in LLVM <= 2.5)
  198. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  199. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  200. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  201. - Remove build scripts; they require the build directory to work
  202. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  203. - Update to 2.5
  204. - Package build scripts (bug #457881)
  205. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  206. - Patched build process for the OCaml binding
  207. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  208. - Update to 2.4
  209. - Package Ocaml binding
  210. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  211. - Add dependency on groff
  212. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  213. - LLVM 2.3
  214. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  215. - fix license tags
  216. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  217. - Fix compilation problems with gcc 4.3
  218. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  219. - Autorebuild for GCC 4.3
  220. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  221. - Fix review comments
  222. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  223. - Initial version