mod_perl-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235
  1. %define defperlver 5.8.2
  2. %define perlver %(rpm -q perl --queryformat '%%{version}' 2> /dev/null || echo %{defperlver})
  3. %define perlmajor %(echo %{perlver} | cut -f1 -d.)
  4. %define contentdir /home/httpd
  5. Summary: An embedded Perl interpreter for the Apache Web server.
  6. Name: mod_perl
  7. Version: 1.29
  8. Release: 0vl1
  9. Group: System Environment/Daemons
  10. Source0: http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
  11. License: GPL
  12. URL: http://perl.apache.org/
  13. BuildRoot: %{_tmppath}/%{name}-root
  14. Requires: webserver, perl = %{perlver}, perl-libwww-perl, perl-HTML-Parser
  15. BuildPrereq: apache-devel, perl, perl-libwww-perl, perl-HTML-Parser
  16. Prereq: perl
  17. %description
  18. Mod_perl incorporates a Perl interpreter into the Apache web server,
  19. so that the Apache web server can directly execute Perl code.
  20. Mod_perl links the Perl runtime library into the Apache web server and
  21. provides an object-oriented Perl interface for Apache's C language
  22. API. The end result is a quicker CGI script turnaround process, since
  23. no external Perl interpreter has to be started.
  24. Install mod_perl if you're installing the Apache web server and you'd
  25. like for it to directly incorporate a Perl interpreter.
  26. %prep
  27. %setup -q
  28. %build
  29. # Compile the module.
  30. perl Makefile.PL \
  31. USE_APXS=1 WITH_APXS=%{_sbindir}/apxs PERL_USELARGEFILES=0 \
  32. EVERYTHING=1 CCFLAGS="$RPM_OPT_FLAGS -fPIC"
  33. make
  34. # Run the test suite.
  35. make test
  36. %install
  37. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  38. #make pure_install INSTALLDIRS=vendor PREFIX=$RPM_BUILD_ROOT%{_prefix}
  39. make pure_install DESTDIR=$RPM_BUILD_ROOT
  40. # Install the module itself.
  41. mkdir -p $RPM_BUILD_ROOT%{_libdir}/apache
  42. install -c -m 755 apaci/libperl.so $RPM_BUILD_ROOT%{_libdir}/apache/
  43. # Install its manual.
  44. mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/manual/mod/mod_perl
  45. install -c -m 644 htdocs/manual/mod/mod_perl.html \
  46. $RPM_BUILD_ROOT%{contentdir}/html/manual/mod
  47. make -C faq
  48. rm faq/pod2htm*
  49. install -m644 faq/*.html $RPM_BUILD_ROOT%{contentdir}/html/manual/mod/mod_perl/
  50. # Remove the temporary files.
  51. find $RPM_BUILD_ROOT%{perl_sitearch}/auto -name "*.bs" | xargs rm
  52. rm $RPM_BUILD_ROOT%{perl_sitearch}/auto/%{name}/.packlist
  53. %clean
  54. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  55. %files
  56. %defattr(-,root,root)
  57. %doc CREDITS Changes README SUPPORT cgi_to_mod_perl.pod mod_perl.pod
  58. %doc mod_perl_method_handlers.pod mod_perl_traps.pod mod_perl_tuning.pod
  59. %doc INSTALL faq/*.html eg faq
  60. %doc apache-modlist.html
  61. %{contentdir}/html/manual/mod/*
  62. %{_libdir}/apache/libperl.so
  63. %{perl_sitearch}/auto/*
  64. %{perl_sitearch}/Apache*
  65. %{perl_sitearch}/Bundle
  66. %{perl_sitearch}/cgi*
  67. %{perl_sitearch}/mod_perl*
  68. %{_mandir}/man3/*.3*
  69. %changelog
  70. * Tue Jul 6 2004 IWAI, Masaharu <iwai@alib.jp> 1.29-0vl1
  71. - new upstream release
  72. - build with Perl 5.8.2 ( perl-5.8.2-0vl2 )
  73. - update %%install section
  74. - update %%files section
  75. * Sun Nov 3 2002 IWAI Masaharu <iwai@alib.jp> 1.27-6vl0
  76. - upstream release
  77. - add perl-libwww-perl and perl-HTML-Parser in Requires
  78. - add perl-libwww-perl and perl-HTML-Parser in BuildPrereq
  79. - drop ToDo in %%doc
  80. * Sun Jun 2 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.26-6vl0
  81. - first build for Vine
  82. - changed INSTALLDIRS (no use vender)
  83. - use rpm macros
  84. - moved contentdir for Vine Linux
  85. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-6
  86. - rebuild in new environment
  87. * Wed Mar 27 2002 Chip Turner <cturner@redhat.com> 1.26-5
  88. - move to vendor_perl
  89. * Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-4
  90. - rebuild
  91. * Fri Feb 8 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-3
  92. - rebuild
  93. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-2
  94. - turn off large file support, which makes mod_perl think that server request
  95. structures are the wrong size (heads-up from Doug MacEachern and Chip Turner)
  96. * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 1.26-1
  97. - update to 1.26
  98. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.24_01-4
  99. - automated rebuild
  100. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com> 1.24_01-3
  101. - Bump release + rebuild.
  102. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com> 1.24_01-2
  103. - don't include .bs files
  104. * Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 1.24_01-1
  105. - update to 1.24_01
  106. - add URL
  107. * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  108. - rebuild in new environment
  109. * Fri Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  110. - patch to fix bug in Apache::ExtUtils (#17147)
  111. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  112. - remove backup files from docs (#14174)
  113. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  114. - automatic rebuild
  115. * Sat Jun 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  116. - remove workarounds for broken Perl
  117. * Mon Jun 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  118. - get rid of multiple prefixes
  119. * Wed May 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  120. - update to 1.24
  121. - remove pre- and post-install scripts and triggers
  122. * Thu May 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  123. - work around weird Perl version reporting problems with a suitably weird check
  124. * Fri Apr 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  125. - modify to be able to rebuild on both 5.003 and 5.6.0
  126. - update to 1.23
  127. * Thu Mar 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  128. - rebuild with perl 5.6.0
  129. - add perlver macro to spec file to make handling of other perl versions easier
  130. * Thu Mar 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  131. - update to 1.22
  132. * Fri Mar 03 2000 Cristian Gafton <gafton@redhat.com>
  133. - fixed the postun script to check for upgrades. doh
  134. - add triggerpostun to fix older versions of the package
  135. * Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  136. - make perl a prereq because it's used in %post
  137. * Fri Feb 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  138. - rebuild against Apache 1.3.12 and EAPI (release 8)
  139. * Mon Feb 21 2000 Preston Brown <pbrown@redhat.com>
  140. - incorporate fixes from Markus Pilzecker <mp@rhein-neckar.netsurf.de>:
  141. - Prefix: /usr
  142. - find apxs binary and package directories automatically
  143. * Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
  144. - automatically enable/disable in httpd.conf in post/postun.
  145. * Thu Feb 10 2000 Preston Brown <pbrown@redhat.com>
  146. - fix up some strange permissions
  147. * Sun Feb 06 2000 Preston Brown <pbrown@redhat.com>
  148. - rebuild to pick up gzipped man pages, new descr.
  149. * Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
  150. - changed paths for perl 5.00503 (RHL 6.1 version)
  151. * Fri Jul 09 1999 Preston Brown <pbrown@redhat.com>
  152. - added -fPIC to correct functionality on SPARC
  153. - upgrade to 1.21, removed build cruft from old buggy mod_perl days
  154. - added extra documentation that was missing
  155. * Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
  156. - bump ver. # so SWS mod_perl gets auto-upgraded
  157. * Wed Apr 07 1999 Preston Brown <pbrown@redhat.com>
  158. - bugfix 1.19 release from Doug
  159. * Wed Mar 24 1999 Preston Brown <pbrown@redhat.com>
  160. - experimental patch from Doug MacEachern <dougm@pobox.com> to fix segfault
  161. - rebuilt against apache 1.3.6
  162. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  163. - auto rebuild in the new build environment (release 3)
  164. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  165. - Injected new description and group.
  166. * Sun Feb 07 1999 Preston Brown <pbrown@redhat.com>
  167. - upgraded to mod_perl 1.18.
  168. * Mon Dec 21 1998 Preston Brown <pbrown@redhat.com>
  169. - Upgraded to mod_perl 1.16.
  170. * Thu Sep 03 1998 Preston Brown <pbrown@redhat.com>
  171. - disabled stacked_handlers. They still seem busted!
  172. - minor updates so no conflicts with either apache / secureweb
  173. - fixed bug building on multiple architectures
  174. * Wed Sep 02 1998 Preston Brown <pbrown@redhat.com>
  175. - Updates for apache 1.3.x, and mod_perl 1.15
  176. * Fri Feb 27 1998 Cristian Gafton <gafton@redhat.com>
  177. - added a patch to compile it as a shared object for the apache/ssl (and
  178. future revisions of apache)