moonlight-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346
  1. %define mono_dir %{_prefix}/lib/mono
  2. %define monodoc_dir %{_prefix}/lib/monodoc
  3. %define moonlight_dir %{_prefix}/lib/moonlight
  4. %define pkgconfigdir %{_datadir}/pkgconfig
  5. %define included_mono 2.6.1
  6. %define included_basic 2.6
  7. Summary: An open source implementation of Silverlight
  8. Summary(ja): Silverlight のオープンソースによる実装
  9. Name: moonlight
  10. Version: 2.3
  11. Release: 2%{?_dist_release}
  12. Group: Applications/Multimedia
  13. License: LGPL v2.0 only ; MIT License (or similar) ; Ms-Pl
  14. URL: http://go-mono.com/moonlight/
  15. Source0: ftp://ftp.novell.com/pub/mono/sources/moon/%{version}/moonlight-%{version}.tar.bz2
  16. Source1: ftp://ftp.novell.com/pub/mono/sources/moon/%{version}/mono-%{included_mono}.tar.bz2
  17. Source2: ftp://ftp.novell.com/pub/mono/sources/moon/%{version}/mono-basic-%{included_basic}.tar.bz2
  18. Patch0: bad-register.patch
  19. Patch1: r159607.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: mono-devel >= 2.6
  22. BuildRequires: gtk-sharp2
  23. BuildRequires: rsvg2-sharp
  24. BuildRequires: wnck-sharp
  25. BuildRequires: gcc-c++
  26. BuildRequires: gtk2-devel
  27. BuildRequires: alsa-lib-devel
  28. BuildRequires: xulrunner-devel
  29. BuildRequires: bison
  30. BuildRequires: autoconf
  31. ExclusiveArch: %ix86 x86_64
  32. %description
  33. Moonlight is an open source implementation of Microsoft Silverlight for
  34. Unix systems.
  35. %description -l ja
  36. Moonlight は Unix 系システムのための,Microsoft Silverlight のオープン
  37. ソースな実装です.
  38. %package libs
  39. Summary: Moonlight libmoon
  40. Group: System Environment/Libraries
  41. License: LGPL v2.0 only
  42. Requires: mono-core >= 2.6
  43. %description libs
  44. Moonlight libmoon
  45. %package devel
  46. Summary: Moonlight libmoon C/C++ development files
  47. Group: Development/Libraries
  48. License: LGPL v2.0 only
  49. Requires: %{name}-libs == %{version}
  50. %description devel
  51. Development files for libmoon
  52. %package tools
  53. Summary: Moonlight tools
  54. Group: Development/Tools
  55. Requires: %{name}-libs == %{version}
  56. %description tools
  57. Moonlight tools (mopen, xamlg, xaml2html, mxap, respack, svg2xaml)
  58. %package plugin
  59. Summary: Moonlight browser plugin
  60. Group: Applications/Internet
  61. Requires: %{name}-libs == %{version}
  62. Requires: mono-core >= 2.6
  63. %description plugin
  64. Browser plugin for Novell Moonlight
  65. %package web-devel
  66. Summary: Development files for Moonlight Web
  67. Group: Development/Libraries
  68. License: MIT License (or similar) ; Ms-Pl
  69. Requires: %{name}-plugin == %{version}
  70. %description web-devel
  71. Development files for creating Moonlight web applications.
  72. %package desktop
  73. Summary: Mono bindings for Moonlight Desktop
  74. Group: Development/Libraries
  75. License: MIT License (or similar) ; Ms-Pl
  76. Requires: %{name}-libs == %{version}
  77. %description desktop
  78. Mono bindings for Novell Moonlight.
  79. %package desktop-devel
  80. Summary: Development files for Moonlight Desktop
  81. Group: Development/Libraries
  82. License: MIT License (or similar) ; Ms-Pl
  83. Requires: %{name}-libs == %{version}
  84. Requires: glib2-devel
  85. Requires: gtk-sharp2
  86. Requires: %{name}-desktop == %{version}
  87. Requires: %{name}-tools == %{version}
  88. %description desktop-devel
  89. Development files for Moonlight Desktop.
  90. %package sharp
  91. Summary: Moonlight sharp
  92. Group: Development/Libraries
  93. Requires: %{name}-libs == %{version}
  94. %description sharp
  95. Provides a gtk-sharp object that can be used to embed a moonlight surface in a desktop application.
  96. %prep
  97. %setup -q
  98. %setup -q -T -D -b 1 -n %{name}-%{version}
  99. %setup -q -T -D -b 2 -n %{name}-%{version}
  100. pushd ../mono-%{included_mono}
  101. %patch0
  102. popd
  103. %patch1
  104. %build
  105. # The plugin requires a complete build of it's own mono
  106. pushd ../mono-%{included_mono}
  107. ./configure \
  108. --prefix=%{_builddir}/install \
  109. --with-mcs-docs=no \
  110. --with-ikvm-native=no \
  111. ;
  112. # mono is not strictly -j safe
  113. %{__make} EXTERNAL_MCS=false EXTERNAL_RUNTIME=false
  114. %{__make} install
  115. find %{_builddir}/install -name \*.la -delete
  116. popd
  117. # Configure against the junk install of mono
  118. export PATH=%{_builddir}/install/bin:${PATH}
  119. export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
  120. export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
  121. # Only needed when there are Makefile.am or configure.ac patches
  122. autoreconf -f -i -Wnone
  123. %configure \
  124. --with-ffmpeg=no \
  125. --with-cairo=system \
  126. --with-curl=system \
  127. --with-mcspath=%{_builddir}/mono-%{included_mono}/mcs \
  128. --with-mono-basic-path=%{_builddir}/mono-basic-%{included_basic} \
  129. --with-ff3=yes \
  130. --with-testing=no \
  131. --with-performance=no \
  132. --with-examples=no \
  133. --with-debug=no \
  134. --with-sanity-checks=no \
  135. --without-testing \
  136. --without-performance \
  137. --without-examples \
  138. --disable-debug \
  139. --disable-sanity \
  140. ;
  141. export MONO_GAC_PREFIX=%{_builddir}/install:%{_prefix}
  142. %{__make} %{?_smp_mflags}
  143. %install
  144. rm -rf %{buildroot}
  145. export PATH=%{_builddir}/install/bin:${PATH}
  146. export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
  147. export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
  148. make install DESTDIR=%{buildroot} pkgconfigdir=%{pkgconfigdir}
  149. install -m 644 %{_builddir}/install/lib/libmono.so.0 %{buildroot}%{_libdir}/moonlight/
  150. chrpath -r %{_libdir}/moonlight %{buildroot}%{_libdir}/moonlight/plugin/libmoonplugin.so
  151. chrpath -r %{_libdir}/moonlight %{buildroot}%{_libdir}/moonlight/plugin/libmoonplugin.so
  152. mkdir -p %{buildroot}%{_libdir}/mozilla/plugins
  153. ln -s %{_libdir}/moonlight/plugin/libmoonloader.so \
  154. %{buildroot}%{_libdir}/mozilla/plugins/libmoonloader.so
  155. # remove unuse files
  156. rm -f %{buildroot}%{_libdir}/libshocker.so
  157. find %{buildroot} -name \*.la -delete
  158. %post libs -p /sbin/ldconfig
  159. %postun libs -p /sbin/ldconfig
  160. %clean
  161. rm -rf %{buildroot}
  162. %files libs
  163. %defattr(-, root, root)
  164. %doc AUTHORS COPYING ChangeLog README TODO NEWS
  165. %{_libdir}/libmoon.so.*
  166. %dir %{_libdir}/moonlight
  167. %{_libdir}/moonlight/libmono.so.0
  168. %files devel
  169. %defattr(-, root, root)
  170. %{_libdir}/libmoon.so
  171. %files tools
  172. %defattr(-, root, root)
  173. %{_bindir}/mopen
  174. %{_bindir}/munxap
  175. %{_bindir}/mxap
  176. %{_bindir}/respack
  177. %{_bindir}/sockpol
  178. %{_bindir}/unrespack
  179. %{_bindir}/xaml2html
  180. %{_bindir}/xamlg
  181. %{_libdir}/moonlight/mopen.exe*
  182. %{_libdir}/moonlight/munxap.exe
  183. %{_libdir}/moonlight/mxap.exe
  184. %{_libdir}/moonlight/respack.exe
  185. %{_libdir}/moonlight/xaml2html.exe
  186. %{_libdir}/moonlight/xamlg.exe
  187. %{_libdir}/moonlight/sockpol.exe
  188. %{_mandir}/man1/mopen.1.gz
  189. %{_mandir}/man1/mxap.1.gz
  190. %{_mandir}/man1/respack.1.gz
  191. %{_mandir}/man1/svg2xaml.1.gz
  192. %{_mandir}/man1/xamlg.1.gz
  193. %{_mandir}/man1/sockpol.1.gz
  194. %files plugin
  195. %defattr(-, root, root)
  196. %dir %{_libdir}/moonlight/plugin
  197. %{_libdir}/moonlight/plugin/Microsoft.VisualBasic.dll
  198. %{_libdir}/moonlight/plugin/System.Core.dll*
  199. %{_libdir}/moonlight/plugin/System.Net.dll*
  200. %{_libdir}/moonlight/plugin/System.Runtime.Serialization.dll*
  201. %{_libdir}/moonlight/plugin/System.ServiceModel.Web.dll*
  202. %{_libdir}/moonlight/plugin/System.ServiceModel.dll*
  203. %{_libdir}/moonlight/plugin/System.Windows.Browser.dll*
  204. %{_libdir}/moonlight/plugin/System.Windows.dll*
  205. %{_libdir}/moonlight/plugin/System.Xml.dll*
  206. %{_libdir}/moonlight/plugin/System.dll*
  207. %{_libdir}/moonlight/plugin/libmoonloader.so
  208. %{_libdir}/moonlight/plugin/libmoonplugin-curlbridge.so
  209. %{_libdir}/moonlight/plugin/libmoonplugin-ff3bridge.so
  210. %{_libdir}/moonlight/plugin/libmoonplugin.so
  211. %{_libdir}/moonlight/plugin/mscorlib.dll*
  212. %{_libdir}/mozilla/plugins/libmoonloader.so
  213. %files web-devel
  214. %defattr(-, root, root)
  215. %{_bindir}/smcs
  216. %dir %{moonlight_dir}/2.0-redist
  217. %{moonlight_dir}/2.0-redist/System.Windows.Controls.Data.dll*
  218. %{moonlight_dir}/2.0-redist/System.Windows.Controls.dll*
  219. %{moonlight_dir}/2.0-redist/System.Xml.Linq.dll*
  220. %dir %{moonlight_dir}/2.0
  221. %{moonlight_dir}/2.0/Microsoft.VisualBasic.dll*
  222. %{moonlight_dir}/2.0/Mono.CompilerServices.SymbolWriter.dll*
  223. %{moonlight_dir}/2.0/System.Core.dll*
  224. %{moonlight_dir}/2.0/System.Net.dll*
  225. %{moonlight_dir}/2.0/System.Runtime.Serialization.dll*
  226. %{moonlight_dir}/2.0/System.ServiceModel.Web.dll*
  227. %{moonlight_dir}/2.0/System.ServiceModel.dll*
  228. %{moonlight_dir}/2.0/System.Windows.Browser.dll*
  229. %{moonlight_dir}/2.0/System.Windows.dll*
  230. %{moonlight_dir}/2.0/System.Xml.dll*
  231. %{moonlight_dir}/2.0/System.dll*
  232. %{moonlight_dir}/2.0/mscorlib.dll*
  233. %{moonlight_dir}/2.0/respack.exe*
  234. %{moonlight_dir}/2.0/smcs
  235. %{moonlight_dir}/2.0/smcs.exe*
  236. %{moonlight_dir}/2.0/buildversion
  237. %{pkgconfigdir}/moonlight-web-2.0.pc
  238. %files desktop
  239. %defattr(-, root, root)
  240. %{mono_dir}/gac/Moon.Windows.Desktop
  241. %{mono_dir}/gac/Moonlight.Gtk
  242. %{mono_dir}/gac/System.Windows
  243. %{mono_dir}/gac/System.Windows.Browser
  244. %{mono_dir}/gac/System.Windows.Controls
  245. %{mono_dir}/gac/System.Windows.Controls.Data
  246. %files desktop-devel
  247. %defattr(-, root, root)
  248. %dir %{mono_dir}/moonlight
  249. %{mono_dir}/moonlight/Moon.Windows.Desktop.dll*
  250. %{mono_dir}/moonlight/System.Windows.Browser.dll*
  251. %{mono_dir}/moonlight/System.Windows.Controls.Data.dll*
  252. %{mono_dir}/moonlight/System.Windows.Controls.dll*
  253. %{mono_dir}/moonlight/System.Windows.dll*
  254. %{pkgconfigdir}/moonlight-desktop-2.0.pc
  255. # It may make sense in the future to have a moonlight-gtk package
  256. %{mono_dir}/moonlight/Moonlight.Gtk.dll*
  257. %{monodoc_dir}/sources/moonlight-gtk.source
  258. %{monodoc_dir}/sources/moonlight-gtk.tree
  259. %{monodoc_dir}/sources/moonlight-gtk.zip
  260. %{pkgconfigdir}/moonlight-gtk-2.0.pc
  261. %changelog
  262. * Sun Oct 10 2010 Shu KONNO <owa@bg.wakwak.com> 2.3-2
  263. - rebuilt with mono-2.8
  264. - added bad-register.patch, r159607.patch (from suse)
  265. - added BR: autoconf (use autoreconf in %%build)
  266. - installed %%{_libdir}/moonlight/libmono.so.0 (obsoleted in mono-2.8)
  267. * Tue Oct 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.3-1
  268. - updated moonlightautoconf to 2.3
  269. - updated mono to 2.6.1
  270. - updated mono-basic to 2.6
  271. - added BR: bison
  272. * Wed Sep 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.0-3
  273. - export PATH, LD_LIBRARY_PATH, PKG_CONFIG_PATH, MONO_GAC_PREFIX
  274. * Sat Sep 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-2
  275. - fixed Group
  276. - added BR: wnck-sharp
  277. * Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
  278. - updated moonlight to 2.0
  279. * Thu Jul 09 2009 Shu KONNO <owa@bg.wakwak.com> 1.0.1-1
  280. - updated moon to 1.0.1
  281. - dropt missing-files.patch (included in source)
  282. - built with latest rpm to update mono-dependencies
  283. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.1-2
  284. - changed plugin Group to Applications/Internet
  285. - changed other sub packages Group to Development/Libraries
  286. - added %%pkgconfigdir macro
  287. * Sat Sep 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1
  288. - new upstream release
  289. - added missing-files.patch from suse
  290. - added --with-managed=desktop
  291. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 0.8-1
  292. - initial build for VineSeed
  293. - moonlight 0.8
  294. - vine versioning policy
  295. - spec in utf-8