nas-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280
  1. Name: nas
  2. Summary: The Network Audio System (NAS)
  3. Summary(ja): ネットワークオーディオシステム (NAS)
  4. Version: 1.9.3
  5. Release: 4%{?_dist_release}
  6. URL: http://radscan.com/nas.html
  7. License: Public Domain
  8. Group: System Environment/Daemons
  9. Source0: http://nas.codebrilliance.com/nas/nas-%{version}.src.tar.gz
  10. Source1: http://apt.kde-redhat.org/apt/kde-redhat/SOURCES/nas/nasd.init
  11. Source2: http://apt.kde-redhat.org/apt/kde-redhat/SOURCES/nas/nasd.sysconfig
  12. Patch0: %{name}-1.9.3-Move-AuErrorDB-to-SHAREDIR.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: bison flex
  15. BuildRequires: imake
  16. BuildRequires: libX11-devel libXau-devel libXaw-devel libXext-devel
  17. BuildRequires: libXpm-devel libXp-devel libXt-devel
  18. %define libdir_x11 %{_libdir}/X11
  19. Requires(preun): chkconfig /sbin/service
  20. Requires(post): chkconfig
  21. Requires: %{name}-libs = %{version}-%{release}
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. In a nutshell, NAS is the audio equivalent of an X display server.
  26. The Network Audio System (NAS) was developed by NCD for playing,
  27. recording, and manipulating audio data over a network. Like the
  28. X Window System, it uses the client/server model to separate
  29. applications from the specific drivers that control audio input
  30. and output devices.
  31. Key features of the Network Audio System include:
  32. o Device-independent audio over the network
  33. o Lots of audio file and data formats
  34. o Can store sounds in server for rapid replay
  35. o Extensive mixing, separating, and manipulation of audio data
  36. o Simultaneous use of audio devices by multiple applications
  37. o Use by a growing number of ISVs
  38. o Small size
  39. o Free! No obnoxious licensing terms
  40. %description -l ja
  41. 簡単にいうと、NAS は X ディスプレイサーバのオーディオ版です。
  42. NCD (Network Computing Devices) 社で開発されたネットワークオーディオシステム
  43. (NAS) は、ネットワーク越しにオーディオデータを再生・録音・操作するための
  44. ものです。X Window System と同様にクライアント/サーバモデルを採用し、
  45. アプリケーションをオーディオ入出力デバイスおよび特定のドライバから切り離す
  46. 設計になっています。
  47. NAS の特徴は以下の通りです:
  48. o デバイスに依存しない、ネットワーク越しのオーディオ
  49. o 多数のオーディオファイルやデータフォーマットに対応
  50. o サーバ上にサウンドを保持、すばやくリプレイが可能
  51. o オーディオデータのミキシング、セパレーション、操作が可能
  52. o 複数のアプリケーションからのオーディオデバイス同時利用が可能
  53. o 多数のソフトウェアメーカーによる利用実績
  54. o コンパクトで小さなサイズ
  55. o フリーです!面倒なライセンス条件はありません
  56. %package devel
  57. Summary: Development and doc files for the NAS
  58. Summary(ja): NAS 用開発ファイルとドキュメント
  59. Group: Development/Libraries
  60. Requires: %{name}-libs = %{version}-%{release}
  61. %description devel
  62. Development files and the documentation
  63. %description devel -l ja
  64. NAS 用開発ファイルとドキュメント
  65. %package libs
  66. Summary: Runtime libraries for NAS
  67. Summary(ja): NAS のランタイムライブラリ
  68. Group: System Environment/Libraries
  69. %description libs
  70. %{summary}.
  71. %prep
  72. %setup -q
  73. %patch0 -p1 -b .move_AuErrorDB
  74. iconv --from-code=ISO_8859-15 --to-code=UTF-8 HISTORY >HISTORY.tmp
  75. mv HISTORY.tmp HISTORY
  76. %build
  77. xmkmf
  78. find . -name Makefile \
  79. | xargs sed -i -e 's/^\(\s*CDEBUGFLAGS\s*=.*\)/\1 $(RPM_OPT_FLAGS)/'
  80. make %{?_smp_mflags} World MFLAGS="IRULESRC=%{_datadir}/X11/config"
  81. %install
  82. rm -rf %{buildroot}
  83. make MFLAGS="IRULESRC=%{_datadir}/X11/config" \
  84. DESTDIR=%{buildroot} BINDIR=%{_bindir} INCROOT=%{_includedir} \
  85. LIBDIR=%{libdir_x11} SHLIBDIR=%{_libdir} USRLIBDIR=%{_libdir} MANPATH=%{_mandir} \
  86. INSTALLFLAGS='-p' \
  87. install install.man
  88. install -p -m755 -D %{SOURCE1} %{buildroot}%{_initrddir}/nasd
  89. install -p -m644 -D %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/nasd
  90. # remove static lib
  91. rm -f %{buildroot}%{_libdir}/*.a
  92. # rename cofigfile
  93. mv %{buildroot}/etc/nas/nasd.conf.eg %{buildroot}/etc/nas/nasd.conf
  94. %post
  95. /sbin/chkconfig --add nasd
  96. %preun
  97. if [ $1 = 0 ] ; then
  98. /sbin/chkconfig --del nasd
  99. /sbin/service nasd stop >/dev/null 2>&1 ||:
  100. fi
  101. %post libs -p /sbin/ldconfig
  102. %postun libs -p /sbin/ldconfig
  103. %clean
  104. rm -rf %{buildroot}
  105. %files
  106. %defattr(-,root,root,-)
  107. %dir %{_sysconfdir}/nas
  108. %config(noreplace) %{_sysconfdir}/nas/nasd.conf
  109. %config(noreplace) %{_sysconfdir}/sysconfig/nasd
  110. %{_initrddir}/nasd
  111. %{_bindir}/*
  112. %{_mandir}/man1/*
  113. %{_mandir}/man5/*
  114. %files libs
  115. %defattr(-,root,root,-)
  116. %doc README FAQ HISTORY TODO
  117. %{_libdir}/libaudio.so.*
  118. %{_datadir}/X11/AuErrorDB
  119. %files devel
  120. %defattr(-,root,root,-)
  121. %{_includedir}/audio/
  122. %{_libdir}/libaudio.so
  123. %{_mandir}/man3/*
  124. %changelog
  125. * Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.9.3-4
  126. - moved nas to System Environment/Daemons Group
  127. * Sun May 27 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.9.3-3
  128. - add Japanese summary and description to libs subpackage
  129. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.3-2
  130. - add Japanese summary and description
  131. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.3-1
  132. - new upstream release
  133. - add Patch0 (move AuErrorDB to sharedir)
  134. * Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.9.1-7
  135. - Initial build for Vine Linux
  136. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-6
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  138. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-5
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  140. * Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.9.1-4
  141. - -libs subpkg (f9+, #438547)
  142. - %%install: INSTALLFLAGS='-p' (preserve timestamps)
  143. - fixup %%changelog whitespace
  144. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.9.1-3
  145. - Autorebuild for GCC 4.3
  146. * Sun Nov 11 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9.1-2
  147. - fix spec file
  148. * Sun Nov 11 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9.1-1
  149. - update to 1.9.1
  150. - remove unneeded patches
  151. * Fri Nov 02 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9a-3
  152. - add better patch for #247468
  153. * Fri Nov 02 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9a-2
  154. - add patch to fix #247468
  155. * Sun Oct 28 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9a-1
  156. - update to 1.9a to fix #245712
  157. * Sat Aug 18 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9-4
  158. - fix for bug #245712
  159. * Sat Aug 11 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9-3
  160. - fix for bug #250453
  161. * Fri May 04 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9-2%{?dist}
  162. - rebuild for the new ppc64 arch
  163. * Sun Apr 08 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9-1%{?dist}
  164. - update to 1.9
  165. - remove old patch file
  166. * Mon Mar 26 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8b-1%{?dist}
  167. - update to 1.8b
  168. * Thu Mar 22 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8a-2%{?dist}
  169. - use the SVN version of 1.8a
  170. * Wed Mar 21 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8a-1%{?dist}
  171. - fix bug 233353
  172. * Thu Feb 09 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8-13%{?dist}
  173. - use the corrected patch
  174. * Thu Feb 08 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8-11%{?dist}
  175. - fix bug 227759
  176. * Tue Sep 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 1.8-10
  177. - don't rely-on/use potentially broken %%_libdir/X11 symlink (#207180)
  178. * Mon Sep 11 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-9%{?dist}
  179. - second rebuild for FC6
  180. * Mon Jul 24 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-8%{?dist}
  181. - fix ugly output when starting the daemon
  182. * Fri Jul 21 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-7%{?dist}
  183. - disable build for EMT64 on FC4
  184. * Thu Jul 13 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-6%{?dist}
  185. - fix build on EMT64
  186. * Wed Jul 12 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-5%{?dist}
  187. - fix include dir
  188. * Fri Jul 7 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-4%{?dist}
  189. - add Requires(preun): chkconfig /sbin/service
  190. - add Requires(post): chkconfig
  191. - add remarks for FC4
  192. * Fri Jul 7 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-3%{?dist}
  193. - move man3 to devel
  194. - rename nasd.conf.eg to .conf
  195. - add build depend for libXext-devel libXt-devel
  196. - change license to Public Domain
  197. - add path to make intall
  198. - add rc.d/sysconfig files
  199. * Fri Jul 7 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-2%{?dist}
  200. - move libaudio.so.2 to main package
  201. - switch package name from NAS to nas
  202. - fix depend for devel package
  203. - fix version
  204. - add nas subdir in etc to main package
  205. - set license to Distributable
  206. - add readme file
  207. * Fri Jul 7 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-1%{?dist}
  208. - start