neon-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: neon
  3. Summary: An HTTP and WebDAV client library.
  4. Summary(ja): HTTP と WebDAV クライアントのライブラリ
  5. Version: 0.31.2
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://notroj.github.io/neon/
  12. Source0: https://notroj.github.io/neon/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: expat
  15. Requires: zlib >= 1.1.4
  16. Requires: krb5-libs
  17. BuildRequires: expat-devel
  18. BuildRequires: gnutls-devel
  19. BuildRequires: krb5-devel
  20. BuildRequires: libxml2-devel
  21. BuildRequires: sed
  22. BuildRequires: zlib-devel
  23. BuildRequires: keyutils-libs-devel
  24. %description
  25. neon is an HTTP and WebDAV client library, with a C interface;
  26. providing a high-level interface to HTTP and WebDAV methods along
  27. with a low-level interface for HTTP request handling. neon
  28. supports persistent connections, proxy servers, basic, digest and
  29. Kerberos authentication, and has complete SSL support.
  30. %package devel
  31. Summary: Development libraries and C header files for the neon library
  32. Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
  33. Group: programming
  34. Requires: %{name} = %{version}
  35. Requires: zlib-devel
  36. #Requires: openssl-devel
  37. Requires: expat-devel
  38. Requires: gnutls-devel
  39. Requires: krb5-devel
  40. Requires: keyutils-libs-devel
  41. %description devel
  42. The development library for the C language HTTP and WebDAV client library.
  43. %description devel -l ja
  44. C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
  45. ## to build compat32 for x86_64 architecture support
  46. %package -n compat32-%{name}
  47. Summary: C language HTTP and WebDAV client library.
  48. Group: system
  49. Requires: expat
  50. Requires: zlib >= 1.1.4
  51. %description -n compat32-%{name}
  52. A C language HTTP and WebDAV client library.
  53. %package -n compat32-%{name}-devel
  54. Summary: A C language HTTP and WebDAV client library.
  55. Group: programming
  56. Requires: compat32-%{name} = %{version}
  57. Requires: compat32-zlib-devel
  58. #Requires: compat32-openssl-devel
  59. Requires: compat32-expat-devel
  60. Requires: compat32-keyutils-libs-devel
  61. Requires: compat32-krb5-devel
  62. %description -n compat32-%{name}-devel
  63. The development library for the C language HTTP and WebDAV client library.
  64. %debug_package
  65. %prep
  66. %setup -q
  67. # for GnuTLS 3.4
  68. #sed -e 's/client_set/set/' \
  69. # -e 's/gnutls_retr/&2/' \
  70. # -e 's/type = t/cert_&/' \
  71. # -i src/ne_gnutls.c
  72. %build
  73. %configure \
  74. --with-expat \
  75. --with-ssl=gnutls \
  76. --enable-threadsafe-ssl=posix \
  77. --enable-shared \
  78. --disable-static \
  79. --with-force-ssl
  80. %__make %{?_smp_mflags}
  81. %install
  82. %__rm -rf %{buildroot}
  83. %makeinstall
  84. sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
  85. $RPM_BUILD_ROOT%{_libdir}/libneon.la
  86. %find_lang %{name}
  87. ## remove unuse files
  88. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  89. %clean
  90. rm -rf $RPM_BUILD_ROOT
  91. %ldconfig_scriptlets
  92. %ldconfig_scriptlets -n compat32-%{name}
  93. %files -f %{name}.lang
  94. %defattr(-,root,root)
  95. %doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
  96. %doc doc/html
  97. %{_libdir}/*.so.*
  98. %files devel
  99. %defattr(-,root,root)
  100. %{_bindir}/*
  101. %{_includedir}/*
  102. %{_mandir}/man1/*
  103. %{_mandir}/man3/*
  104. #{_libdir}/*.a
  105. #{_libdir}/*.la
  106. %{_libdir}/*.so
  107. %{_libdir}/pkgconfig/*.pc
  108. %if %{build_compat32}
  109. %files -n compat32-%{name}
  110. %defattr(-,root,root)
  111. %{_libdir}/*.so.*
  112. %files -n compat32-%{name}-devel
  113. %defattr(-,root,root)
  114. #{_libdir}/*.a
  115. #{_libdir}/*.la
  116. %{_libdir}/pkgconfig/*.pc
  117. %endif
  118. %changelog
  119. * Sun Feb 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.31.2-1
  120. - new upstream release.
  121. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.2-1
  122. - new upstream release.
  123. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.1-1
  124. - new upstream release.
  125. - built with gnutls-3.4.x.
  126. * Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 0.30.0-1
  127. - update to 0.30.0
  128. * Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
  129. - rebuild with VineSeed environment
  130. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
  131. - update to 0.29.6
  132. * Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
  133. - add BuildRequires: keyutils-libs-devel
  134. - add Requires: krb5-devel, keyutils-libs-devel (-devel package)
  135. * Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
  136. - new upstream release
  137. * Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
  138. - rebuilt with krb5-libs-1.8.2
  139. - removed BR: openssl-devel
  140. - removed static library from devel package
  141. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
  142. - rebuilt with rpm-4.8.1 for pkg-config
  143. * Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
  144. - new upstream release with security fix (CVE-2009-2473, 2474)
  145. * Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
  146. - rebuild with gnutls-2.6.3
  147. * Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
  148. - add Requires/BuildRequires krb5-libs/krb5-devel tags
  149. - add _smp_mflags into make section
  150. * Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
  151. - new upstream release with security fix (CVE-2008-3746)
  152. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
  153. - removed *.la
  154. - spec in utf-8
  155. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
  156. - added --with-ssl=gnutls --enable-threadsafe-ssl
  157. - added BuildRequires: gnutls-devel
  158. * Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
  159. - new upstream release
  160. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
  161. - removed %%if !%%{build_compat32} case condition
  162. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
  163. - rebuild with expat-2.0.1
  164. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
  165. - new upstream release
  166. * Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
  167. - add Requires: zlib-devel, openssl-devel, expat-devel
  168. * Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
  169. - move %%configure from %%prep to %%build
  170. - remove unneeded locales.patch (for neon-0.26.x or later)
  171. * Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
  172. - new upstream release
  173. - drop doc.patch (patch0)
  174. - use more macros
  175. - drop BuildRequires: autoconf, automake
  176. - add *.pc to -devel (and compat32's) package
  177. - change group
  178. - add Requires: %%{name} = %%{version} to -devel (and compat32's) package
  179. - add doc/html instead of doc/* to %%doc
  180. - move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
  181. - run ldconfig in %%post,postun
  182. - add locales.patch (patch0)
  183. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
  184. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  185. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
  186. - added compat32- packages for x86_64 architecture support
  187. - added --libdir=%{_libdir} option to configure
  188. * Sun Sep 5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
  189. - new upstream release
  190. * Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
  191. - upstream release
  192. - update URL and Source0 tag: valid URL
  193. * Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
  194. - upstream release
  195. - add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
  196. - add Japanese Summary and %%description
  197. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
  198. - build VineLinux
  199. * Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
  200. - Updated to 0.23.5.
  201. * Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
  202. - Upgraded to 0.23.2.
  203. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
  204. - Upgraded to 0.22.0.
  205. - Fixed compilation from CVS.
  206. - Took out man pages until I can figure out xmlto program.
  207. * Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
  208. - Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
  209. to RedHat 7.3 versions and fixing bug in spec file.
  210. - Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
  211. work.
  212. * Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
  213. - Fixed file ownership problems. Made them owned by root.
  214. * Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
  215. - Updated to neon 0.21.3.
  216. * Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
  217. - Updated to neon 0.21.2.
  218. * Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
  219. - Updated to neon 0.21.1.
  220. - Now requires zlib >= 1.1.4.
  221. - Broke into zlib and zlib-devel.
  222. - Now builds shared library.
  223. * Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
  224. - Updated to neon 0.19.4.
  225. * Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
  226. - Updated to neon 0.19.2.
  227. * Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
  228. - Updated to neon 0.18.2.
  229. * Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
  230. - Took out dependency on libxml and w3c-libwww packages.
  231. - Added dependency on expat.
  232. * Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
  233. - Release 0.17.2-1: Updated neon.
  234. * Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
  235. - Release 2: Fixed prefix to be /usr instead of /usr/local.
  236. * Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
  237. - Release 2001-10-20: Initial Version.