ngraph-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. Summary: A software for drawing scientific graphs
  2. Summary(ja): 2次元グラフ作成プログラム
  3. Name: ngraph
  4. Version: 6.3.30
  5. Release: 2%{?_dist_release}
  6. License: distributable, Copyright(C)Satoshi ISHIZAKA,1997-2004
  7. Group: Applications/Engineering
  8. Source: Ngraph-%{version}-src.tar.gz
  9. Source1: http://www2e.biglobe.ne.jp/~isizaka/bin/ileaf-widgets.tar.Z
  10. Source2: ngraph.sh
  11. Source3: Ngraph-6.3.30-doc.tar.gz
  12. URL: http://www2e.biglobe.ne.jp/~isizaka/
  13. Patch: Ngraph-install.diff
  14. Patch1: Ngraph-6.3.14-lesstif-make.diff
  15. Patch2: Ngraph-6.3.14-lesstif-make-ppc.diff
  16. #Requires: glibc >= 2.2.4, lesstif
  17. #Exclusivearch: i386 ppc
  18. Buildroot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: libICE-devel
  20. BuildRequires: libSM-devel
  21. BuildRequires: libX11-devel
  22. BuildRequires: libXext-devel
  23. BuildRequires: libXt-devel
  24. BuildRequires: openMotif-devel
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. Ngraph is a software drawing scientific graphs for students,
  29. researchers, and engineers. Ngraph makes a graph from data files written
  30. in a general ASCII format. Fitting by a n-th polynomial, user-defined
  31. functionals is available. Furthermore, masking invalid data, evaluation
  32. of plotted data points, a transformation by a mathematical expression are
  33. also available.Ngraph will assist making a scientific graph for the purpose
  34. of your presentation, and also analysing data.Copyright (C) Satoshi ISHIZAKA.
  35. Motif or Lesstif libraries must be required to build the binaries.
  36. This package include ileaf-widgets.tar.Z (Copyright 1993 Interleaf, Inc.),
  37. codes for ComboBox Widget, which are required when ngraph is build with
  38. Motif 1.2 or Lesstif. The copyright and permission notice of this widget
  39. are written in a document file, TODO.jis.
  40. %description -l ja
  41. Ngraphは理工系学生、研究者、技術者のために作られた2次元グラフ作成プログ
  42. ラムです。 汎用性のあるASCII形式のテキストファイルから数値デ−タを読み込
  43. みグラフにプロットすることができます。 またn次関数・ユ−ザ定義関数による
  44. 最小二乗フィットができるほか、 プロットされたデ−タの評価・マスク・変更も
  45. 可能であり、 さらに指定した数式で入力デ−タを加工する高度な数式変換機能な
  46. どを備えるなど、 プレゼンテ−ション用グラフ作成の目的のみに留まらずデ−タ
  47. 解析をアシストします。(作者:石坂 智(いしざか さとし)さんのドキュメントより)
  48. バイナリをビルトするためには Motif または Lesstif を使用します。Motif 1.2
  49. または Lesstif の場合、さらに ComboBox Widget (Copyright 1993 Interleaf,Inc.)
  50. を使用し、このパッケージはこれを含みます。この Widget の著作権や許諾権に
  51. 関しては TODO.jis に書かれています。
  52. %prep
  53. %setup -q -a 3 -n Ngraph-%{version}-src
  54. %patch -p1
  55. %build
  56. if [ -n "`rpm -qa | grep lesstif`" ]
  57. then
  58. %ifarch i386
  59. patch -p0 <%{PATCH1}
  60. %else
  61. patch -p0 <%{PATCH2}
  62. %endif
  63. cd combo
  64. tar -zxf ${RPM_SOURCE_DIR}/ileaf-widgets.tar.Z
  65. gcc -c -o ComboBox.o ComboBox.c -I/usr/X11R6/include
  66. cd ..
  67. fi
  68. %ifnarch %{ix86}
  69. sed -e "s/-m486//g" Makefile > Makefile.new
  70. mv -f Makefile.new Makefile
  71. %endif
  72. make
  73. %install
  74. rm -rf ${RPM_BUILD_ROOT}
  75. mkdir -p ${RPM_BUILD_ROOT}/usr/{lib,bin}
  76. make INSTALLDIR=/usr/lib/Ngraph BINDIR=/usr/bin install
  77. mv $RPM_BUILD_ROOT/usr/bin/ngraph $RPM_BUILD_ROOT/usr/bin/ngraph.exe
  78. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT/usr/bin/ngraph
  79. pushd ${RPM_BUILD_ROOT}/usr/lib/Ngraph
  80. rmdir doc
  81. ln -s /usr/doc/ngraph-%{version}/doc .
  82. popd
  83. %clean
  84. rm -rf ${RPM_BUILD_ROOT}
  85. %files
  86. %defattr(-,root,root)
  87. %doc INSTALL.jis TODO.jis doc/
  88. /usr/bin/ngraph*
  89. /usr/lib/Ngraph/
  90. %changelog
  91. * Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.30-2vl5
  92. - added BuildRequires
  93. * Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.3.30-1vl5
  94. - applied new versioning policy, spec in utf-8
  95. * Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.3.30-0vl3
  96. - do not pass "-m486" option on non-i386 archtectures
  97. * Sat Oct 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.30-0vl2
  98. - s/Copyright/License/
  99. - built with openMotif instead of lesstif
  100. * Wed Mar 30 2005 Jun Nishii <jun@vinelinux.org> 6.3.30-0vl1
  101. - ver.up
  102. * Wed Mar 27 2002 Jun Nishii <jun@vinelinux.org> 6.3.14-0vl1
  103. - ver.up source and doc
  104. - make symlink to doc from /usr/lib/Ngraph to call Help file
  105. * Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
  106. - 6.3.06-0vl1
  107. - added %defattr
  108. * Wed Sep 27 2000 Jun Nishii <jun@vinelinux.org>
  109. - 6.3.06-0vl1
  110. * Tue Jan 11 2000 Amane Tanaka <amane@bd5.so-net.ne.jp>
  111. - Build section was changed to execute correct patch for compiling with
  112. - Lesstif by using S.Sakoda's patch information. Thanks, Mr.Sakoda!
  113. * Sat Jan 8 2000 Amane Tanaka <amane@bd5.so-net.ne.jp>
  114. - Compiled with Motif-2.1.0 on i386 support
  115. - Packager: Seiji Sakoda <sakoda@cc.nda.ac.jp> --> AT
  116. * Mon Nov 8 1999 Seiji Sakoda <sakoda@cc.nda.ac.jp>
  117. - update to version 6.3.06
  118. - Compiled with Lesstif-0.89.4 with ComboBox support
  119. - Packager: Amane Tanaka <amane@bd5.so-net.ne.jp> ---> SS