ninja-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. Name: ninja
  2. Version: 1.10.2
  3. Release: 1%{?_dist_release}
  4. Summary: A small build system with a focus on speed
  5. Summary(ja): スピードを重視した小さなビルドシステム
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: ASL 2.0
  10. URL: https://ninja-build.org/
  11. Source0: https://github.com/martine/ninja/archive/v%{version}.tar.gz#/ninja-%{version}.tar.gz
  12. Source1: macros.ninja
  13. Source2: ninja.vim
  14. BuildRequires: asciidoc
  15. BuildRequires: gtest-devel
  16. BuildRequires: python-devel
  17. BuildRequires: re2c >= 0.11.3
  18. %description
  19. Ninja is a small build system with a focus on speed. It differs from other
  20. build systems in two major respects: it is designed to have its input files
  21. generated by a higher-level build system, and it is designed to run builds as
  22. fast as possible.
  23. %package vim
  24. Summary: macros and syntax files of ninja for vim
  25. Summary(ja): VIM用のninjaマクロ・文法ファイル
  26. Group: programming
  27. Requires: vim-common
  28. %description vim
  29. This package contains macros and syntax files of ninja for vim.
  30. %debug_package
  31. %prep
  32. %setup -qn ninja-%{version}
  33. %build
  34. CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" \
  35. %{__python} configure.py --bootstrap --verbose
  36. ./ninja -v manual
  37. ./ninja -v ninja_test
  38. %install
  39. # TODO: Install ninja_syntax.py?
  40. mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/bash-completion/completions,%{_datadir}/emacs/site-lisp,%{_datadir}/vim/vimfiles/syntax,%{_datadir}/vim/vimfiles/ftdetect,%{_datadir}/zsh/site-functions}
  41. install -pm755 ninja %{buildroot}%{_bindir}/ninja
  42. ln -sf ninja %{buildroot}%{_bindir}/ninja-build
  43. install -pm644 misc/bash-completion %{buildroot}%{_datadir}/bash-completion/completions/ninja-bash-completion
  44. install -pm644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
  45. install -pm644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
  46. install -pm644 %{SOURCE2} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  47. install -pm644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
  48. install -Dpm644 %{SOURCE1} %{buildroot}%{_rpmmacrodir}/macros.ninja
  49. %check
  50. # workaround possible too low default limits
  51. ulimit -n 4096 && ulimit -u 4096
  52. ./ninja_test
  53. %files
  54. %license COPYING
  55. %doc README.md doc/manual.html
  56. %{_rpmmacrodir}/macros.ninja
  57. %{_bindir}/ninja
  58. %{_bindir}/ninja-build
  59. %dir %{_datadir}/bash-completion
  60. %dir %{_datadir}/bash-completion/completions
  61. %{_datadir}/bash-completion/completions/ninja-bash-completion
  62. %{_datadir}/emacs/site-lisp/ninja-mode.el
  63. # zsh does not have a -filesystem package
  64. %{_datadir}/zsh/
  65. %files vim
  66. %{_datadir}/vim/vimfiles/syntax/ninja.vim
  67. %{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  68. %changelog
  69. * Wed Mar 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.2-1
  70. - new upstream release.
  71. * Sun Apr 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
  72. - new upstream release.
  73. * Mon Sep 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
  74. - updated to 1.7.2.
  75. - added rpmmacros.
  76. - added a subpackage ninja-vim.
  77. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
  78. - updated to 1.7.1.
  79. * Mon Jan 18 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-1
  80. - update to 1.6.0
  81. - remove R: vim, emacsen
  82. (TODO: vim or el should be splitted to subpackage)
  83. - add ninja-build symlink to compatible with other rpm distros.
  84. * Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
  85. - initial build for Vine Linux
  86. * Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
  87. - Update to 1.4.0
  88. * Sun Nov 3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
  89. - Use special %%doc to install all docs (#994005).
  90. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  92. * Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
  93. - workaround possible too low limits for number of processes and open files,
  94. fixes build on ppc/ppc64 and s390(x)
  95. * Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
  96. - Update to 1.3.4
  97. - Run test suite
  98. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  100. * Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
  101. - Update to 1.0.0
  102. * Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
  103. - Update to new snapshot
  104. * Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
  105. - Preserve timestamps on install
  106. - Install as ninja-build to avoid conflicts with the ninja IRC package
  107. - Update snapshot
  108. * Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
  109. - Add an ftdetect file for ninja
  110. - Fix zsh-stuff directory ownership
  111. * Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
  112. - Add a Group tag
  113. * Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
  114. - Update to new snapshot
  115. * Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
  116. - Initial package