nmap-vl.spec 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312
  1. %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  2. Summary: Network exploration tool and security scanner
  3. Summary(ja): 多機能なポートスキャナー
  4. Name: nmap
  5. Version: 7.80
  6. Release: 1%{?_dist_release}
  7. Group: Applications/System
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPL
  11. URL: https://nmap.org/
  12. Source0: https://nmap.org/dist/%{name}-%{version}.tar.bz2
  13. #Source1: zenmap.desktop
  14. # Patches from Fedora rawhide
  15. #prevent possible race condition for shtool, rhbz#158996
  16. Patch1: nmap-4.03-mktemp.patch
  17. #don't suggest to scan microsoft
  18. Patch2: nmap-4.52-noms.patch
  19. # upstream provided patch for rhbz#845005, not yet in upstream repository
  20. Patch5: ncat_reg_stdin.diff
  21. Patch6: nmap-6.25-displayerror.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: libpcap-devel
  24. BuildRequires: pcre-devel
  25. BuildRequires: python-devel
  26. BuildRequires: pygtk2-devel
  27. BuildRequires: openssl-devel
  28. BuildRequires: lua-devel
  29. %description
  30. Nmap is a utility for network exploration or security auditing. It
  31. supports ping scanning (determine which hosts are up), many port
  32. scanning techniques (determine what services the hosts are offering),
  33. and TCP/IP fingerprinting (remote host operating system
  34. identification). Nmap also offers flexible target and port
  35. specification, decoy scanning, determination of TCP sequence
  36. predictability characteristics, sunRPC scanning, reverse-identd
  37. scanning, and more.
  38. %description -l ja
  39. Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
  40. ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
  41. 技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
  42. の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
  43. ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
  44. 予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
  45. 機能も提供します。
  46. %package frontend
  47. Summary: Gtk+ frontend for nmap
  48. Summary(ja): Nmap の GTK+ フロントエンド
  49. Group: Applications/System
  50. Requires: nmap = %{version}-%{release}
  51. Requires: python pygtk2 pysqlite
  52. Provides: zenmap = %{version}-%{release}
  53. %description frontend
  54. This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
  55. be installed before installing nmap-frontend.
  56. %description frontend -l ja
  57. Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
  58. する前に、nmap パッケージをインストールする必要があります。
  59. %prep
  60. %setup -q
  61. %patch1 -p1 -b .mktemp
  62. %patch2 -p1 -b .noms
  63. %patch5 -p1 -b .ncat_reg_stdin
  64. %patch6 -p1 -b .displayerror
  65. %build
  66. export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
  67. %configure
  68. make
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. make install DESTDIR=$RPM_BUILD_ROOT
  72. rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
  73. rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_ndiff
  74. cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  75. gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
  76. pushd $RPM_BUILD_ROOT%{_mandir}/man1
  77. ln -s zenmap.1.gz nmapfe.1.gz
  78. ln -s zenmap.1.gz xnmap.1.gz
  79. popd
  80. #pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
  81. #mkdir zenmap
  82. #mv *.svg zenmap
  83. #mv *.png zenmap
  84. #popd
  85. #desktop-file-install --vendor= \
  86. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  87. # %{SOURCE1};
  88. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
  89. %find_lang %{name} --with-man
  90. %clean
  91. rm -rf %{buildroot}
  92. %files -f %{name}.lang
  93. %defattr(-,root,root)
  94. %license COPYING
  95. %doc CHANGELOG README*
  96. %doc docs/nmap.usage.txt docs/nmap.dtd
  97. %{_bindir}/nmap
  98. %{_bindir}/ncat
  99. %{_bindir}/ndiff
  100. %{_bindir}/nping
  101. %{_datadir}/nmap
  102. %{_datadir}/ncat
  103. #%{_libexecdir}/nmap
  104. %{_mandir}/man1/nmap.1*
  105. %{_mandir}/man1/ncat.1*
  106. %{_mandir}/man1/ndiff.1*
  107. %{_mandir}/man1/nping.1*
  108. %files frontend
  109. %defattr(-,root,root)
  110. %{_bindir}/nmapfe
  111. %{_bindir}/xnmap
  112. %{_bindir}/zenmap
  113. %{python_sitelib}/*
  114. %{_datadir}/applications/*.desktop
  115. #%{_datadir}/icons/*
  116. #%{_datadir}/pixmaps/zenmap
  117. %{_datadir}/zenmap
  118. %{_mandir}/man1/zenmap.1*
  119. %{_mandir}/man1/nmapfe.1*
  120. %{_mandir}/man1/xnmap.1*
  121. %changelog
  122. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.80-1
  123. - new upstream release.
  124. * Sat Nov 17 2018 Toshiaki Ara <ara_t@384.jp> 7.70-1
  125. - update to 7.70
  126. - add Patches from Fedora rawhide
  127. * Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-2
  128. - rebuild with gcc-5.4.0
  129. * Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-1
  130. - new upstream release
  131. * Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
  132. - new upstream release
  133. * Thu Dec 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.01-1
  134. - new upstream release
  135. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.47-1
  136. - new upstream release
  137. * Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.25-1
  138. - new upstream release
  139. * Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-2
  140. - rebuild with pcre-8.31
  141. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-1
  142. - new upstream release
  143. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
  144. - new upstream release
  145. * Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
  146. - new upstream release
  147. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
  148. - new upstream release
  149. - fix %files to add nping
  150. * Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
  151. - new upstream release
  152. - add BuildRequires: openssl-devel, lua-devel
  153. - fix %files to add ncat and ndiff
  154. * Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
  155. - new upstream release
  156. - spec in UTF-8
  157. - added BuildRequires: libpcap-devel instead of libpcap
  158. - removed BuildRequires: desktop-file-utils
  159. * Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
  160. - rebuilt with libpcap 1.0.0
  161. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
  162. - rebuilt with python-2.5.2
  163. * Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
  164. - updated python sitelib files path
  165. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
  166. - new upstream release
  167. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
  168. - new upstream release
  169. - rebuild with new environment/toolchain
  170. * Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
  171. - new upstream release
  172. - added BuildRequires: desktop-file-utils
  173. * Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
  174. - new upstream release
  175. * Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
  176. - rebuild for VineSeed Plus
  177. * Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
  178. - new upstream release
  179. * Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
  180. - new upstream release
  181. * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
  182. - new upstream release
  183. - added Japanese summary to nmap-frontend
  184. * Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
  185. - new upstream release
  186. * Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
  187. - rebuild with new openssl
  188. * Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
  189. - new upstream release
  190. * Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
  191. - new upstream release
  192. * Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
  193. - new upstream release
  194. * Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
  195. - new upstream release
  196. * Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
  197. - merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
  198. * Sat May 3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
  199. - new upstream release
  200. - rebuild with new toolchains
  201. * Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
  202. - new upstream release
  203. - delete Version Tag from nmap-frontend package
  204. - fix BuildRoot
  205. * Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
  206. - new upstream release
  207. - 2.54BETA is developpment release, but it is more stable than 2.53.
  208. * Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
  209. - unfortunately increase release: 1vl2 from 0vl2
  210. ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
  211. - patch to build on current glibc22 system
  212. * Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
  213. - 2.53-0vl2: use better macros
  214. * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
  215. - rebuild for VineSeed based on the original site's srpm
  216. - add Japanese summary and description
  217. * Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
  218. - Updated description
  219. - Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
  220. - Fixed nmap distribution URL (source0)
  221. - Added this .rpm to base Nmap distribution
  222. * Mon Dec 13 1999 Tim Powers <timp@redhat.com>
  223. - based on origional spec file from
  224. http://www.insecure.org/nmap/index.html#download
  225. - general cleanups, removed lots of commenrts since it made the spec hard to
  226. read
  227. - changed group to Applications/System
  228. - quiet setup
  229. - no need to create dirs in the install section, "make
  230. prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
  231. - using defined %{prefix}, %{version} etc. for easier/quicker maint.
  232. - added docs
  233. - gzip man pages
  234. - strip after files have been installed into buildroot
  235. - created separate package for the frontend so that Gtk+ isn't needed for the
  236. CLI nmap
  237. - not using -f in files section anymore, no need for it since there aren't that
  238. many files/dirs
  239. - added desktop entry for gnome
  240. * Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
  241. - Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
  242. * Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
  243. - Made some changes, and merged in another .spec file sent in
  244. by Oren Tirosh <oren@hishome.net>
  245. * Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
  246. - initial build for RH 5.x