nspluginwrapper-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # Compile as a debug package
  3. %define make_debug_package 0
  4. # What gecko we use
  5. %define gecko_flavour "mozilla"
  6. %define plugin_config_version 1.9
  7. %define plugin_config_name plugin-config-%{plugin_config_version}
  8. %define plugin_config_binary plugin-config
  9. # Excluded plugins (separated by ':')
  10. %define exclude_list "libtotem*:libjavaplugin*:gecko-mediaplayer*:mplayerplug-in*:librhythmbox*:packagekit*:libnsISpicec*:libgnashplugin*:liblightsparkplugin*:libflashplayer*"
  11. # Target defines
  12. %if "%{_target_cpu}" == "i386"
  13. %define target_bits 32
  14. %endif
  15. %if "%{_target_cpu}" == "i586"
  16. %define target_bits 32
  17. %endif
  18. %if "%{_target_cpu}" == "i686"
  19. %define target_bits 32
  20. %endif
  21. %if "%{_target_cpu}" == "ppc"
  22. %define target_bits 32
  23. %endif
  24. %if "%{_target_cpu}" == "x86_64"
  25. %define target_bits 64
  26. %endif
  27. %if "%{_target_cpu}" == "ppc64"
  28. %define target_bits 64
  29. %endif
  30. # Define libraries for 32/64 arches
  31. %define lib32 lib
  32. %define lib64 lib64
  33. %define libdir32 /usr/lib
  34. %define libdir64 /usr/lib64
  35. # define nspluginswrapper libdir (invariant, including libdir)
  36. %define pkgdir32 %{libdir32}/%{name}
  37. %define pkgdir64 %{libdir64}/%{name}
  38. # define mozilla plugin dir and back up dir for 32-bit browsers
  39. %define pluginsourcedir32 %{libdir32}/mozilla/plugins
  40. %define plugindir32 %{libdir32}/mozilla/plugins-wrapped
  41. # define mozilla plugin dir and back up dir for 64-bit browsers
  42. %define pluginsourcedir64 %{libdir64}/mozilla/plugins
  43. %define plugindir64 %{libdir64}/mozilla/plugins-wrapped
  44. %define build_dir objs-%{target_bits}
  45. %if "%{target_bits}" == "32"
  46. %define lib %{lib32}
  47. %define libdir %{libdir32}
  48. %define pkgdir %{pkgdir32}
  49. %define plugindir %{plugindir32}
  50. %define pluginsourcedir %{pluginsourcedir32}
  51. %else
  52. %define lib %{lib64}
  53. %define libdir %{libdir64}
  54. %define pkgdir %{pkgdir64}
  55. %define plugindir %{plugindir64}
  56. %define pluginsourcedir %{pluginsourcedir64}
  57. %endif
  58. Summary: A compatibility layer for Netscape 4 plugins
  59. Name: nspluginwrapper
  60. Version: 1.4.4
  61. Release: 1%{?_dist_release}
  62. Source0: http://nspluginwrapper.org/download/%{name}-%{version}%{?svndate:-%{svndate}}.tar.gz
  63. Source1: %{plugin_config_name}.tar.gz
  64. Source2: plugin-config.sh.in
  65. Source3: %{name}.sh.in
  66. Patch1: nspluginwrapper-1.3.0-make.patch
  67. Patch3: nspluginwrapper-1.3.0-directory.patch
  68. Patch6: nspluginwrapper-1.3.0-compiz.patch
  69. Patch7: nspluginwrapper-1.3.0-comp.patch
  70. Patch9: nspluginwrapper-1.3.0-timeout.patch
  71. Patch100: plugin-config-setuid.patch
  72. Patch101: plugin-config-umask.patch
  73. Patch102: plugin-config-print.patch
  74. Patch103: plugin-config-native.patch
  75. Patch104: plugin-config-time-check.patch
  76. License: GPLv2+
  77. Group: Applications/Internet
  78. URL: http://nspluginwrapper.org/
  79. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  80. Provides: %{name} = %{version}-%{release}
  81. #Requires: mozilla-filesystem
  82. %ifarch x86_64
  83. Requires: compat32-%{name} = %{version}-%{release}
  84. %endif
  85. BuildRequires: pkgconfig gtk2-devel glib2-devel nspr-devel
  86. BuildRequires: libX11-devel libXt-devel cairo-devel pango-devel curl-devel
  87. BuildRequires: gecko-devel
  88. ExclusiveArch: %{ix86} x86_64 ppc
  89. %description
  90. nspluginwrapper makes it possible to use Netscape 4 compatible plugins
  91. compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
  92. This package consists in:
  93. * npviewer: the plugin viewer
  94. * npwrapper.so: the browser-side plugin
  95. * nspluginplayer: stand-alone NPAPI plugin player
  96. * mozilla-plugin-config: a tool to manage plugins installation and update
  97. ## to build compat32 for x86_64 architecture support
  98. %package -n compat32-%{name}
  99. Summary: A compatibility layer for Netscape 4 plugins
  100. Group: System Environment/Libraries
  101. %description -n compat32-%{name}
  102. nspluginwrapper makes it possible to use Netscape 4 compatible plugins
  103. compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
  104. This package consists in:
  105. * npviewer: the plugin viewer
  106. * npwrapper.so: the browser-side plugin
  107. * nspluginplayer: stand-alone NPAPI plugin player
  108. * mozilla-plugin-config: a tool to manage plugins installation and update
  109. %prep
  110. %setup -q -a 1
  111. # Installation & build patches
  112. %patch1 -p1 -b .make
  113. %patch3 -p1 -b .dir
  114. %patch6 -p1 -b .compiz
  115. %patch7 -p1 -b .comp
  116. %patch9 -p1 -b .timeout
  117. # Plugin-config patches
  118. pushd %plugin_config_name
  119. %patch100 -p2
  120. %patch101 -p2 -b .umask
  121. %patch102 -p2 -b .print
  122. %patch103 -p2 -b .native
  123. %patch104 -p2 -b .time
  124. popd
  125. %build
  126. # Build wrapper
  127. # set the propper built options
  128. %if %{make_debug_package}
  129. %if "%{target_bits}" == "64"
  130. export CFLAGS="-g -m64 -DDEBUG"
  131. %else
  132. export CFLAGS="-g -m32 -DDEBUG"
  133. %endif
  134. %else
  135. export CFLAGS="$RPM_OPT_FLAGS"
  136. %endif
  137. # set the propper built options
  138. %if "%{target_bits}" == "64"
  139. export LDFLAGS="-m64 -L%{libdir64} -ldl"
  140. %else
  141. export LDFLAGS="-m32 -L%{libdir32} -ldl"
  142. %endif
  143. %__mkdir_p %{build_dir}
  144. pushd %{build_dir}
  145. ../configure \
  146. --prefix=%{_prefix} \
  147. --target-cpu=%{_target_cpu} \
  148. --pkglibdir=%{pkgdir} \
  149. --with-lib32=%{lib32} \
  150. --with-lib64=%{lib64} \
  151. --viewer-paths=%{pkgdir} \
  152. --enable-viewer \
  153. --viewer-paths="%{pkgdir32}:%{pkgdir64}"\
  154. --disable-biarch
  155. %__make
  156. popd
  157. #Build plugin configuration utility
  158. pushd %{plugin_config_name}
  159. ./configure --prefix=%{_prefix} --libdir=%{_libdir} CFLAGS="$RPM_OPT_FLAGS"
  160. %__make
  161. popd
  162. %install
  163. %__rm -rf $RPM_BUILD_ROOT
  164. %__mkdir_p $RPM_BUILD_ROOT%{_bindir}
  165. %__mkdir_p $RPM_BUILD_ROOT%{plugindir}
  166. %__mkdir_p $RPM_BUILD_ROOT%{pluginsourcedir}
  167. %__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  168. %__make -C %{build_dir} install DESTDIR=$RPM_BUILD_ROOT
  169. %__ln_s %{pkgdir}/npwrapper.so $RPM_BUILD_ROOT/%{plugindir}/npwrapper.so
  170. # Install plugin-config utility
  171. pushd %{plugin_config_name}
  172. DESTDIR=$RPM_BUILD_ROOT %__make install
  173. popd
  174. cd $RPM_BUILD_ROOT%{_bindir}
  175. %__mv %{plugin_config_binary} $RPM_BUILD_ROOT/%{pkgdir}
  176. cd -
  177. %__rm -rf $RPM_BUILD_ROOT/usr/doc/plugin-config
  178. cat %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
  179. chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
  180. cat %{SOURCE3} | %{__sed} -e "s|EXCLUDE_LIST|%{exclude_list}|g" \
  181. > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
  182. chmod 644 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
  183. # set up nsplugin player starting script
  184. %{__cat} > $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer << EOF
  185. export MOZ_PLUGIN_PATH=%{pluginsourcedir}
  186. %{pkgdir}/npplayer "$@"
  187. EOF
  188. chmod 755 $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer
  189. # Remove conflicting files
  190. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginplayer
  191. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginwrapper
  192. ## <mozilla-filesystem>
  193. %__mkdir_p $RPM_BUILD_ROOT/usr/{lib,%{_lib}}/mozilla/{plugins,extensions}
  194. %__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/mozilla/extensions
  195. %__mkdir_p $RPM_BUILD_ROOT/etc/skel/.mozilla/{plugins,extensions}
  196. ## </mozilla-filesystem>
  197. %clean
  198. %__rm -rf $RPM_BUILD_ROOT
  199. %post
  200. /usr/bin/mozilla-plugin-config -i -f > /dev/null 2>&1 || :
  201. %preun
  202. if [ "$1" == "0" ]; then
  203. /usr/bin/mozilla-plugin-config -r > /dev/null 2>&1 || :
  204. fi;
  205. %files
  206. %defattr(-,root,root)
  207. %doc README COPYING NEWS
  208. %dir %{pkgdir}
  209. %dir %{plugindir}
  210. %{pkgdir}/%{plugin_config_binary}
  211. %{pkgdir}/npconfig
  212. %{pkgdir}/npwrapper.so
  213. %{pkgdir}/npviewer.bin
  214. %{pkgdir}/npviewer.sh
  215. %{pkgdir}/npviewer
  216. %{pkgdir}/npplayer
  217. %{pkgdir}/libnoxshm.so
  218. %{pkgdir}/nspluginplayer
  219. %{plugindir}/npwrapper.so
  220. %{_bindir}/mozilla-plugin-config
  221. %config %{_sysconfdir}/sysconfig/%{name}
  222. ## <mozilla-filesystem>
  223. /usr/lib*/mozilla
  224. %{_datadir}/mozilla
  225. /etc/skel/.mozilla
  226. ## </mozilla-filesystem>
  227. ## to build compat32 for x86_64 architecture support
  228. %if %{build_compat32}
  229. %files -n compat32-%{name}
  230. %defattr(-,root,root)
  231. %dir %{pkgdir}
  232. %dir %{plugindir}
  233. %{pkgdir}/%{plugin_config_binary}
  234. %{pkgdir}/npconfig
  235. %{pkgdir}/npwrapper.so
  236. %{pkgdir}/npviewer.bin
  237. %{pkgdir}/npviewer.sh
  238. %{pkgdir}/npviewer
  239. %{pkgdir}/npplayer
  240. %{pkgdir}/libnoxshm.so
  241. %{pkgdir}/nspluginplayer
  242. %{plugindir}/npwrapper.so
  243. %endif
  244. %changelog
  245. * Thu Oct 6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.4-1
  246. - new upstream release based on Fedora rawhide
  247. - supported native Linux x86_64 flash-plugin
  248. - added libflashplayer to ignored plugins (exclude_list)
  249. * Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-4
  250. - added spice-xpi to ignored plugins
  251. - applied some improvement patches from Fedora rawhide
  252. * Wed Mar 09 2011 Peter Hatina <phatina@redhat.coom> 1.3.0-18
  253. - Race condition patch
  254. * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
  255. - fixed patch for rhbz#523273
  256. * Mon Nov 15 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-3
  257. - applied some improvement patches from Fedora rawhide
  258. * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
  259. - fixed patch for rhbz#523273
  260. * Tue Jun 29 2010 Martin Stransky <stransky@redhat.com> 1.3.0-13
  261. - Changed RPM timeout to 10 second, should prevent
  262. long browser hangs.
  263. - Disabled debug outputs in normal build.
  264. * Mon Jun 28 2010 Martin Stransky <stransky@redhat.com> 1.3.0-12
  265. - Fixed rhbz#523273 - wrapped plugins not getting updated
  266. * Fri Dec 4 2009 Martin Stransky <stransky@redhat.com> 1.3.0-10
  267. - added Compiz workaround (#542424)
  268. * Tue Nov 10 2009 Martin Stransky <stransky@redhat.com> 1.3.0-9
  269. - added NULL check (#531669)
  270. * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-7
  271. - NPIdentifiers fix by Tristan Schmelcher (Google)
  272. * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-6
  273. - Package kit plugin is ignored now (#511385)
  274. * Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-2
  275. - changed Group to System Environment/Libraries
  276. * Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.0-1
  277. - initial release
  278. - ported from Fedora development package
  279. * Tue Mar 03 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-5
  280. - Really Fix x86 32bit build (#488308)
  281. * Sun Mar 01 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-4
  282. - Fix x86 32bit build
  283. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
  284. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  285. * Thu Jan 9 2009 Martin Stransky <stransky@redhat.com> 1.3.0-2
  286. - Fixed multilib conflicts
  287. * Thu Jan 8 2009 Martin Stransky <stransky@redhat.com> 1.3.0-1
  288. - Updated to 1.3.0 and removed some fedora build patches
  289. * Tue Dec 02 2008 Warren Togami <wtogami@redhat.com> 1.1.8-2
  290. - fix-invalid-RPC-after-NPP_Destroy fixes a crasher
  291. * Mon Dec 1 2008 Martin Stransky <stransky@redhat.com> 1.1.8-1
  292. - Updated to 1.1.8
  293. - Removed already upstreamed patches
  294. * Wed Nov 12 2008 Martin Stransky <stransky@redhat.com> 1.1.4-1
  295. - Updated to 1.1.4
  296. - Consolidated build patches
  297. * Wed Oct 22 2008 Martin Stransky <stransky@redhat.com> 1.1.2-4
  298. - Fixed #449338 - mozilla-plugin-config segfaults with -v argument
  299. * Tue Oct 21 2008 Martin Stransky <stransky@redhat.com> 1.1.2-3
  300. - Removed event patch, it blocks X events and breaks Adobe pdf plugin
  301. - Removed event limit in xt_event_polling_timer_callback
  302. * Fri Oct 17 2008 Martin Stransky <stransky@redhat.com> 1.1.2-2
  303. - added umask to plugin config (#463736)
  304. * Thu Oct 16 2008 Martin Stransky <stransky@redhat.com> 1.1.2-1
  305. - updated to 1.1.12
  306. - added librhythmbox* to ignored plugins (#467187)
  307. - removed debug prints (#467090)
  308. * Mon Oct 06 2008 Warren Togami <wtogami@redhat.com> 1.1.0-11
  309. - Unrevert patch from -7 because Warren was wrong
  310. - Concurrent rpc_method_invoke() patch
  311. * Fri Oct 03 2008 Warren Togami <wtogami@redhat.com> 1.1.0-10
  312. - Revert libcurl requires because it was done in an incorrect way
  313. - Revert patch from -7 because it made things worse
  314. * Tue Sep 30 2008 Martin Stransky <stransky@redhat.com> 1.1.0-7
  315. - Updated fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
  316. * Wed Sep 17 2008 Martin Stransky <stransky@redhat.com> 1.1.0-6
  317. - Added libcurl to requires (#460988)
  318. * Mon Aug 04 2008 Martin Stransky <stransky@redhat.com> 1.1.0-5
  319. - Added fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
  320. * Mon Jul 21 2008 Martin Stransky <stransky@redhat.com> 1.1.0-4
  321. - Removed gecko-libs from requieres (it's not needed now)
  322. * Tue Jul 18 2008 Martin Stransky <stransky@redhat.com> 1.1.0-3
  323. - Enabled experimental stand-alone plugin player
  324. * Tue Jul 15 2008 Martin Stransky <stransky@redhat.com> 1.1.0-2
  325. - Fixed build warnings in our patches
  326. * Tue Jul 8 2008 Martin Stransky <stransky@redhat.com> 1.1.0-1
  327. - update to latest upstream version (1.1.0)
  328. * Mon May 5 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-28
  329. - link pluginwrapper with stdc++ lib
  330. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 0.9.91.5-27
  331. - mozilla-filesystem now owns the plugin source dir
  332. * Tue Mar 11 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-26
  333. - /etc/sysconfig/nspluginwrapper marked as config file
  334. - exclude some player plugins
  335. * Mon Mar 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-25
  336. - updated the sleep patch
  337. * Thu Mar 06 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-24
  338. - added experimental patch for #426968 - nspluginwrapper wakes up too much
  339. * Tue Feb 26 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-23
  340. - merged exclude patch with main tarball
  341. - fixed #431095 - Typo in mozilla-plugin-config verbose output
  342. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.91.5-22
  343. - Autorebuild for GCC 4.3
  344. * Mon Jan 21 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-21
  345. - fixed #426618 - gcjwebplugin error: Failed to run
  346. (added to ignored plugins)
  347. * Mon Jan 14 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-20
  348. - fixed #426176 - Orphaned npviewer.bin processes
  349. * Thu Jan 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-19
  350. - xulrunner rebuild
  351. - fixed build script, added gthread-2.0
  352. * Mon Dec 24 2007 Warren Togami <wtogami@redhat.com> 0.9.91.5-18
  353. - Make nsviewer.bin initialized for multithreading, fixes #360891
  354. * Tue Dec 20 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-17
  355. - disabled xpcom support - it causes more troubles than advantages
  356. * Tue Dec 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-16
  357. - spec fixes
  358. - fixed xulrunner support
  359. * Mon Dec 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-15
  360. - updated configure script - gecko selection
  361. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-14
  362. - enabled xpcom support
  363. - added fix for #393541 - scripts will never fail
  364. * Fri Nov 23 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-13
  365. - rebuilt against xulrunner
  366. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-12
  367. - more fixes from review by security standards team
  368. * Wed Oct 31 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-11
  369. - added fixes from review by security standards team
  370. * Fri Oct 26 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-10
  371. - mozilla-plugin-config can be run by normal user now
  372. * Wed Oct 24 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-9
  373. - Updated config utility - removes dangling symlinks and
  374. wrapped plugins
  375. * Tue Oct 23 2007 Jeremy Katz <katzj@redhat.com> 0.9.91.5-8
  376. - Rebuild against new firefox
  377. * Mon Oct 15 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-7
  378. - added a fix for #281061 - gnash fails when wrapped, works when native
  379. * Wed Oct 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-6
  380. - removed possibble deadlock during plugin restart
  381. * Tue Oct 9 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-5
  382. - fixed browser crashes (#290901)
  383. * Mon Oct 1 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-4
  384. - quit the plugin when browser crashes (#290901)
  385. * Fri Sep 21 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-3
  386. - added original plugin dir to the package
  387. * Mon Sep 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-2
  388. - added upstream patches - RPC error handling and plugin restart
  389. * Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-1
  390. - update to the latest upstream
  391. * Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-19
  392. - converted rpc error handling code to a thread-safe variant
  393. - added a time limit to plugin restart
  394. * Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-18
  395. - implemented plugin restart (#251530)
  396. * Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-17
  397. - fixed an installation script (#251698)
  398. * Mon Aug 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-16
  399. - fixed plugins check
  400. - minor spec fixes
  401. * Fri Aug 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-15
  402. - removed mozembeded dependency
  403. - excluded totem plugins from wrapping
  404. - xpcom support is optional now
  405. * Thu Aug 9 2007 Christopher Aillon <caillon@redhat.com> 0.9.91.4-14
  406. - Rebuild against newer gecko
  407. * Wed Aug 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-13
  408. - removed unsafe plugins probe
  409. - added agruments to mozilla-plugin-config
  410. * Tue Aug 7 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-12
  411. - removed fake libxpcom
  412. * Mon Aug 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-11
  413. - added gecko dependency
  414. - added plugin configuration utility
  415. * Fri Aug 3 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-10
  416. - fixed totem-complex plugin wrapping
  417. * Mon Jul 30 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-9
  418. - added plugin dirs
  419. * Fri Jul 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-8
  420. - added switch for creating debug packages
  421. * Thu Jul 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-7
  422. - integrated with firefox / seamonkey
  423. * Tue Jul 11 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-6
  424. - added new options to the configuration utility
  425. - modified along new plug-ins concept
  426. * Thu Jun 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-5
  427. - updated nspluginsetup script
  428. - added support for x86_64 plug-ins
  429. * Thu Jun 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-4
  430. - added ppc arch
  431. - silenced installation scripts
  432. - moved configuration to /etc/sysconfig
  433. * Thu Jun 12 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-3
  434. - updated nspluginsetup script and package install/uninstall scripts
  435. - added cross-compilation support
  436. - removed binaries stripping
  437. * Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-2
  438. - added BuildRequires - pkgconfig, gtk2-devel, glib, libXt-devel
  439. * Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-1
  440. - initial build