nss_db-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192
  1. %define db_version 4.0.14
  2. Summary: An NSS library for the Berkeley DB.
  3. Summary(ja): Berkeley DB 用 NSS ライブラリ
  4. Name: nss_db
  5. Version: 2.2
  6. Release: 17vl1
  7. Source: ftp://sources.redhat.com/pub/glibc/releases/nss_db-%{version}.tar.gz
  8. Source1: http://www.sleepycat.com/update/%{db_version}/db-%{db_version}.tar.gz
  9. URL: http://sources.redhat.com/glibc/
  10. Patch0: nss_db-2.2-external.patch
  11. Patch1: nss_db-2.2-compat.patch
  12. License: GPL
  13. Group: System Environment/Libraries
  14. PreReq: /sbin/ldconfig
  15. BuildPrereq: autoconf, automake15, libtool
  16. Conflicts: glibc < 2.2
  17. Requires: make
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. %define __find_requires %{_builddir}/%{name}-%{version}/find-requires
  20. %description
  21. Nss_db is a set of C library extensions which allow Berkeley Databases
  22. to be used as a primary source of aliases, ethers, groups, hosts,
  23. networks, protocol, users, RPCs, services, and shadow passwords
  24. (instead of or in addition to using flat files or NIS). Install nss_db
  25. if your flat name service files are too large and lookups are slow.
  26. %package compat
  27. Summary: An NSS compatibility library for Berkeley Databases and glibc 2.0.x.
  28. Summary(ja): Berkeley DB と glibc 2.0.x 用 NSS 互換ライブラリ
  29. Group: System Environment/Libraries
  30. %description compat
  31. Nss_db-compat is a set of C library extensions which allow Berkeley
  32. Databases to be used as a primary source of aliases, ethers, groups,
  33. hosts, networks, protocol, users, RPCs, services, and shadow passwords
  34. (instead of or in addition to using flat files or NIS) from programs
  35. linked against glibc 2.0.x.
  36. %prep
  37. %setup -q -a 0 -a 1
  38. %patch0 -p1 -b .external
  39. libtoolize -f
  40. aclocal-1.5
  41. automake-1.5 -a
  42. autoconf
  43. mv %{name}-%{version} %{name}-compat-%{version}
  44. pushd %{name}-compat-%{version}
  45. %patch0 -p1 -b .external
  46. %patch1 -p1 -b .compat
  47. libtoolize -f
  48. aclocal-1.5
  49. automake-1.5 -a
  50. autoconf
  51. popd
  52. find_requires=`rpm --eval %%{__find_requires}`
  53. echo "$find_requires | grep -v GLIBC_PRIVATE" > find-requires
  54. chmod +x find-requires
  55. %build
  56. dbdir=`pwd`/db-instroot
  57. CFLAGS="$RPM_OPT_FLAGS" ; export CFLAGS
  58. pushd db-%{db_version}/dist
  59. ./configure --disable-shared --with-pic --with-uniquename=_nssdb --prefix=$dbdir
  60. make
  61. make install
  62. popd
  63. %configure --with-db=${dbdir}
  64. make
  65. pushd %{name}-compat-%{version}
  66. %configure --with-db=${dbdir}
  67. make
  68. popd
  69. %install
  70. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  71. install -m755 -d ${RPM_BUILD_ROOT}/{%{_lib},/var/db,%{_bindir}}
  72. install -m644 db-Makefile ${RPM_BUILD_ROOT}/var/db/Makefile
  73. install -m755 makedb ${RPM_BUILD_ROOT}/%{_bindir}/
  74. install -m755 .libs/libnss_db.so.[0-9]* ${RPM_BUILD_ROOT}/%{_lib}/
  75. pushd %{name}-compat-%{version}
  76. install -m755 .libs/libnss_db.so.[0-9]* ${RPM_BUILD_ROOT}/%{_lib}/
  77. popd
  78. %clean
  79. rm -rf ${RPM_BUILD_ROOT}
  80. %post -p /sbin/ldconfig
  81. %postun -p /sbin/ldconfig
  82. %files
  83. %defattr(-,root,root)
  84. %doc AUTHORS COPYING* ChangeLog NEWS README THANKS
  85. /%{_lib}/libnss_db*2.*
  86. %{_bindir}/makedb
  87. %config /var/db/*
  88. %ifnarch sparc64 ia64
  89. %files compat
  90. %defattr(-,root,root)
  91. /%{_lib}/libnss_db*1.*
  92. %post compat -p /sbin/ldconfig
  93. %postun compat -p /sbin/ldconfig
  94. %endif
  95. %changelog
  96. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2-17vl1
  97. - based on 2.2-17 from Rawhide and built for Vine Linux
  98. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  99. - automated rebuild
  100. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  101. - automated rebuild
  102. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-15
  103. - rebuild in new environment
  104. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-14
  105. - rebuild
  106. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-13
  107. - whoops, __set_errno() is a glibc-internal symbol as well (#63373)
  108. * Wed Apr 3 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-12
  109. - filter out dependency on glibc private symbols
  110. * Tue Apr 2 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-11
  111. - don't use libc-internal symbols and interfaces
  112. * Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-10
  113. - rebuild
  114. * Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-9
  115. - rebuild
  116. * Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-8
  117. - build using a bundled Berkeley DB with a unique name to avoid possible symbol
  118. collisions with binaries using different versions (mix multiple versions of
  119. any shared library in a single process, observe as wackiness ensues)
  120. * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-7
  121. - rebuild against db4-devel
  122. * Mon Aug 6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.2-6
  123. - require db3-devel at build-time, not db3 (#49544)
  124. * Tue May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  125. - don't include copies of the shared libraries with the soname for their names
  126. * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  127. - rebuild in new environment
  128. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  129. - don't own /var/db, the filesystem package does
  130. * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  131. - require make (#27313)
  132. - add the docs to the package
  133. * Tue Dec 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  134. - update to 2.2
  135. * Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
  136. - separate from db3