ntfs-3g-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309
  1. %bcond_with externalfuse
  2. Summary: Linux NTFS userspace driver
  3. Summary(ja): Linux NTFS ユーザ空間ドライバ
  4. Name: ntfs-3g
  5. Version: 2017.3.23
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Base
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2+
  11. URL: https://www.tuxera.com/community/open-source-ntfs-3g/
  12. Source0: https://tuxera.com/opensource/ntfs-3g_ntfsprogs-%{version}.tgz
  13. Patch0: ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
  14. Patch1: check-mftmirr.patch
  15. Patch2: ntfs-3g-big-sectors.patch
  16. # Fix for ntfsclone crash.
  17. # Discussed with upstream developer but not upstream yet, see:
  18. # https://bugzilla.redhat.com/show_bug.cgi?id=1601146#c4
  19. Patch3: ntfsclone-full-clusters-bz1601146.patch
  20. # Upstream fix for CVE-2019-9755
  21. # https://sourceforge.net/p/ntfs-3g/ntfs-3g/ci/85c1634a26faa572d3c558d4cf8aaaca5202d4e9/
  22. Patch4: ntfs-3g-CVE-2019-9755.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. BuildRequires: libtool
  25. BuildRequires: libattr-devel
  26. %if %{?_dist_release} != "vl6"
  27. BuildRequires: libconfig-devel
  28. %endif
  29. BuildRequires: libgcrypt-devel
  30. BuildRequires: gnutls-devel
  31. BuildRequires: libuuid-devel
  32. %if %{with externalfuse}
  33. BuildRequires: fuse-devel
  34. Requires: fuse
  35. %endif
  36. %description
  37. NTFS-3G is a stable, open source, GPL licensed, POSIX, read/write NTFS
  38. driver for Linux and many other operating systems. It provides safe
  39. handling of the Windows XP, Windows Server 2003, Windows 2000, Windows
  40. Vista, Windows Server 2008 and Windows 7 NTFS file systems. NTFS-3G can
  41. create, remove, rename, move files, directories, hard links, and streams;
  42. it can read and write normal and transparently compressed files, including
  43. streams and sparse files; it can handle special files like symbolic links,
  44. devices, and FIFOs, ACL, extended attributes; moreover it provides full
  45. file access right and ownership support.
  46. %package devel
  47. Summary: Development files and libraries for ntfs-3g
  48. Summary(ja): ntfs-3g の開発ファイルとライブラリ
  49. Group: Development/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: pkgconfig
  52. Provides: ntfsprogs-devel = %{version}-%{release}
  53. Obsoletes: ntfsprogs-devel < 2.0.0-3
  54. %description devel
  55. Headers and libraries for developing applications that use ntfs-3g
  56. functionality.
  57. %package -n ntfsprogs
  58. Summary: NTFS filesystem libraries and utilities
  59. Summary(ja): NTFS ファイルシステム用ライブラリおよびユーティリティ
  60. Group: System Environment/Base
  61. Provides: ntfsprogs-gnomevfs = %{version}-%{release}
  62. Obsoletes: ntfsprogs-gnomevfs < 2.0.0-3
  63. %description -n ntfsprogs
  64. The ntfsprogs package currently consists of a library and utilities
  65. such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
  66. (for a full list of included utilities see man 8 ntfsprogs after
  67. installation).
  68. %prep
  69. %setup -q -n %{name}_ntfsprogs-%{version}
  70. %patch0 -p1 -b .unsupported
  71. %patch1 -p0 -b .check-mftmirr
  72. %patch2 -p0 -b .big-sectors
  73. %patch3 -p0 -b .ntfsclone
  74. %patch4 -p1 -b .CVE-2019-9755
  75. %build
  76. export CFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64"
  77. %configure \
  78. --disable-static \
  79. --disable-ldconfig \
  80. %if %{with externalfuse}
  81. --with-fuse=external \
  82. %endif
  83. --exec-prefix=/ \
  84. --bindir=/bin \
  85. --sbindir=/sbin \
  86. --libdir=/%{_lib} \
  87. --enable-posix-acls \
  88. --enable-xattr-mappings \
  89. --enable-crypto \
  90. --enable-extras \
  91. --enable-quarantined
  92. make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
  93. %install
  94. rm -rf $RPM_BUILD_ROOT
  95. make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
  96. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
  97. rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.{la,a}
  98. mkdir -p $RPM_BUILD_ROOT/sbin
  99. # make the symlink an actual copy to avoid confusion
  100. rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  101. cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  102. # make compatibility symlinks
  103. ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
  104. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
  105. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
  106. ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
  107. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  108. ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
  109. ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
  110. # Put the .pc file in the right place.
  111. mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  112. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  113. # We get this on our own, thanks.
  114. rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README
  115. %clean
  116. rm -rf $RPM_BUILD_ROOT
  117. %post -p /sbin/ldconfig
  118. %postun -p /sbin/ldconfig
  119. %files
  120. %defattr(-,root,root,-)
  121. %license COPYING
  122. %doc AUTHORS ChangeLog CREDITS NEWS README
  123. /sbin/mount.ntfs
  124. %attr(4754,root,root) /sbin/mount.ntfs-3g
  125. /sbin/mount.ntfs-fuse
  126. /sbin/mount.lowntfs-3g
  127. /bin/lowntfs-3g
  128. /bin/ntfs-3g
  129. /bin/ntfs-3g.probe
  130. /bin/ntfsmount
  131. %{_bindir}/ntfs-3g
  132. %{_bindir}/ntfsmount
  133. /%{_lib}/libntfs-3g.so.*
  134. %{_mandir}/man8/mount.lowntfs-3g.*
  135. %{_mandir}/man8/mount.ntfs-3g.*
  136. %{_mandir}/man8/ntfs-3g*
  137. %files devel
  138. %defattr(-,root,root,-)
  139. %{_includedir}/ntfs-3g/
  140. /%{_lib}/libntfs-3g.so
  141. %{_libdir}/pkgconfig/*.pc
  142. %files -n ntfsprogs
  143. %license COPYING
  144. %doc AUTHORS CREDITS ChangeLog NEWS README
  145. /bin/ntfscat
  146. /bin/ntfscluster
  147. /bin/ntfscmp
  148. /bin/ntfsfix
  149. /bin/ntfsinfo
  150. /bin/ntfsls
  151. /bin/ntfssecaudit
  152. /bin/ntfsusermap
  153. # extras
  154. /bin/ntfsck
  155. /bin/ntfsdecrypt
  156. /bin/ntfsdump_logfile
  157. /bin/ntfsfallocate
  158. /bin/ntfsmftalloc
  159. /bin/ntfsmove
  160. /bin/ntfsrecover
  161. /bin/ntfstruncate
  162. /bin/ntfswipe
  163. /sbin/fsck.ntfs
  164. /sbin/mkfs.ntfs
  165. /sbin/mkntfs
  166. /sbin/ntfsclone
  167. /sbin/ntfscp
  168. /sbin/ntfslabel
  169. /sbin/ntfsresize
  170. /sbin/ntfsundelete
  171. %{_mandir}/man8/mkntfs.8*
  172. %{_mandir}/man8/mkfs.ntfs.8*
  173. %{_mandir}/man8/ntfs[^m][^o]*.8*
  174. %exclude %{_mandir}/man8/ntfs-3g*
  175. %changelog
  176. * Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2017.3.23-1
  177. - new upstream release.
  178. - imported Patch1-4 from rawhide.
  179. * Mon Jul 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016.2.22-1
  180. - new upstream release.
  181. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015.3.14-3
  182. - rebuilt with gnutls-3.4.x.
  183. * Fri May 8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-2
  184. - reverted file location <Vine Linux:2914>
  185. * Fri Apr 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-1
  186. - new upstream release
  187. - dropt hal files, since hal is very old
  188. * Sun Mar 02 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2014.2.15-1
  189. - new upstream release
  190. * Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2013.1.13-2
  191. - rebuilt with gnutls-3.2 and libgcrypt-1.6
  192. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.13-1
  193. - new upstream release
  194. * Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
  195. - new upstream release
  196. - merge ntfsprogs
  197. - add Obsoletes and Provides ntfsprogs*
  198. - add BR: for ntfsprogs
  199. * Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
  200. - new upstream release
  201. - fix %%files (add lowntfs-3g)
  202. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
  203. - new upstream release
  204. - use internal fuse-lite, remove BR: fuse-devel and R: fuse
  205. - move binaries to /bin
  206. - move libraries to /%%{_lib}
  207. - add fdi file to enable hal automounting
  208. * Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
  209. - new upstream release
  210. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
  211. - new upstream release
  212. * Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
  213. - new upstream release
  214. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
  215. - new upstream release
  216. * Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
  217. - initial build for Vine Linux
  218. * Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
  219. - bump to 1.516
  220. - fix bugzilla 232031
  221. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
  222. - bump to 1.417
  223. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
  224. - bump to 1.416
  225. - drop patch0, upstreamed
  226. * Wed Apr 4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
  227. - allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
  228. * Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
  229. - bump to 1.328
  230. - drop patch, use --disable-ldconfig instead
  231. * Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
  232. - 1.0 release!
  233. * Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
  234. - symlink to mount.ntfs
  235. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
  236. - bump to 20070118
  237. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
  238. - bump to latest version for all active dists
  239. * Wed Jan 3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
  240. - bump to latest version (note that upstream fixed their date mistake)
  241. * Wed Nov 1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
  242. - add an obsoletes for ntfsprogs-fuse
  243. - make some convenience symlinks
  244. * Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
  245. - add some extra Provides
  246. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
  247. - add explicit Requires on fuse
  248. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
  249. - fixed versioning (bumped epoch, since it now shows as older)
  250. - change sbin symlink to actual copy to be safe
  251. * Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
  252. - Initial package for Fedora Extras