opensource-cobol-vl.spec 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145
  1. %define pkg_name opensource-cobol
  2. %define pkg_version 1.5.2J
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: An open-source COBOL compiler
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: GPLv2
  9. Group: Development/Languages
  10. URL: https://www.osscons.jp/
  11. Source0: %{name}-%{version}-utf8.tar.gz
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. %if %{?_dist_release} == "vl6"
  14. BuildRequires: db4-devel
  15. %else
  16. BuildRequires: libdb-devel
  17. %endif
  18. BuildRequires: gmp-devel
  19. BuildRequires: ncurses-devel
  20. BuildRequires: texinfo
  21. BuildRequires: texlive-common
  22. %if %{?_dist_release} == "vl6"
  23. BuildRequires: texlive-collection-texinfo
  24. %endif
  25. %if %{?_dist_release} >= "vl7"
  26. BuildRequires: texlive-collection-plaingeneric
  27. BuildRequires: texlive-collection-fontsrecommended
  28. %endif
  29. Requires: ncurses-devel
  30. %if %{?_dist_release} == "vl6"
  31. Requires: db4-devel
  32. %else
  33. Requires: libdb-devel
  34. %endif
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: ara_t
  38. %description
  39. "opensource COBOL" is open-source COBOL compiler,
  40. an extension of the Japan-specific features.
  41. "opensource COBOL" translates COBOL program to C code
  42. and compiles it using GCC or CL.
  43. It was forked from OpenCOBOL in 2012.
  44. See also OpenCOBOL project.
  45. http://www.opencobol.org/
  46. http://sourceforge.net/projects/open-cobol/
  47. %description -l ja
  48. opensource COBOLは、オーペンソースのCOBOLコンパイラであり、
  49. COBOLプログラムをC言語のコードに翻訳し、GCCあるいはCLを用いて
  50. コンパイルします。
  51. opensource COBOLは、オープンCOBOLソリューション部会によって
  52. OpenCOBOLに日本特有のビジネス環境に即したカスタマイズ、
  53. メンテナンスを加えたものです。
  54. %prep
  55. %{__rm} -rf ${RPM_BUILD_ROOT}
  56. %setup -q -n %{name}-%{version}-utf8
  57. %build
  58. %{configure} \
  59. --enable-utf8 \
  60. --disable-static
  61. %{__make} %{?_smp_mflags}
  62. %{__make} pdf html
  63. %check
  64. %{__make} check
  65. %install
  66. %{make_install}
  67. %{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
  68. %{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
  69. %clean
  70. %{__rm} -rf ${RPM_BUILD_ROOT}
  71. %post
  72. %{_syssbindir}/install-info %{_infodir}/open-cobol.info.gz \
  73. %{_infodir}/dir 2>/dev/null
  74. %{_syssbindir}/ldconfig
  75. %preun
  76. if [ $1 = 0 ]; then
  77. %{_syssbindir}/install-info --delete %{_infodir}/open-cobol.info.gz \
  78. %{_infodir}/dir 2>/dev/null
  79. fi
  80. %postun -p %{_syssbindir}/ldconfig
  81. %files
  82. %defattr(-,root,root)
  83. %doc AUTHORS ChangeLog COPYING* NEWS README THANKS TODO
  84. %doc texi/open-cobol.pdf
  85. %doc texi/open-cobol.html/
  86. %{_bindir}/
  87. %{_includedir}/libcob.h
  88. %{_includedir}/libcob
  89. %{_libdir}/libcob.so*
  90. %{_datadir}/locale/
  91. %{_datadir}/%{name}-%{version}
  92. %{_infodir}/*.info.gz
  93. %changelog
  94. * Sun Apr 21 2019 Toshiaki Ara <ara_t@384.jp> 1.5.2J-1
  95. - new upstream release
  96. - change to BuildRequires: texlive-collection-plaingeneric
  97. * Mon Dec 12 2016 Toshiaki Ara <ara_t@384.jp> 1.5.1J-1
  98. - new upstream release
  99. * Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-3
  100. - change Group to Development/Languages
  101. * Fri Jul 29 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-2
  102. - change Requires: ncurses to ncurses-devel
  103. - change Requires: db4/libdb to db4-devel/libdb-devel
  104. - add export CFLAGS="%{optflags} -std=gnu89" for VineSeed (gcc-5)
  105. * Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-1
  106. - update to 1.5.0J
  107. - delete BuildRequires: texlive-collection-lang*
  108. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-2
  109. - rebuild under texlive 2016 pretest
  110. - add BuildRequires
  111. * Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-1
  112. - new package