os-prober-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264
  1. Name: os-prober
  2. Version: 1.77
  3. Release: 1%{?_dist_release}
  4. Summary: Probes disks on the system for installed operating systems
  5. Group: System Environment/Base
  6. # For more information about licensing, see copyright file.
  7. License: GPLv2+ and GPL+
  8. URL: http://kitenet.net/~joey/code/os-prober/
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: tomop
  12. Source0: http://ftp.us.debian.org/debian/pool/main/o/os-prober/%{name}_%{version}.tar.xz
  13. Patch0: os-prober-no-dummy-mach-kernel.patch
  14. # Sent upstream
  15. Patch1: os-prober-mdraidfix.patch
  16. Patch2: os-prober-btrfsfix.patch
  17. Patch3: os-prober-bootpart-name-fix.patch
  18. Patch4: os-prober-mounted-partitions-fix.patch
  19. Patch5: os-prober-factor-out-logger.patch
  20. # To be sent upstream
  21. Patch6: os-prober-factored-logger-efi-fix.patch
  22. Patch7: os-prober-umount-fix.patch
  23. Patch8: os-prober-grub2-parsefix.patch
  24. Patch9: os-prober-grepfix.patch
  25. Patch10: os-prober-gentoo-fix.patch
  26. Requires: udev coreutils util-linux
  27. Requires: grep /bin/sed /sbin/modprobe
  28. Requires: device-mapper
  29. BuildRequires: git
  30. %description
  31. This package detects other OSes available on a system and outputs the results
  32. in a generic machine-readable format. Support for new OSes and Linux
  33. distributions can be added easily.
  34. %prep
  35. %autosetup -n %{name}-%{version} -S git
  36. find -type f -exec sed -i -e 's|usr/lib|usr/libexec|g' {} \;
  37. sed -i -e 's|grub-probe|grub2-probe|g' os-probes/common/50mounted-tests \
  38. linux-boot-probes/common/50mounted-tests
  39. sed -i -e 's|grub-mount|grub2-mount|g' os-probes/common/50mounted-tests \
  40. linux-boot-probes/common/50mounted-tests common.sh
  41. %build
  42. %make_build CFLAGS="%{optflags}" LDFLAGS="$LDFLAGS -fPIC"
  43. %install
  44. install -m 0755 -d %{buildroot}%{_bindir}
  45. install -m 0755 -d %{buildroot}%{_var}/lib/%{name}
  46. install -m 0755 -p os-prober linux-boot-prober %{buildroot}%{_bindir}
  47. install -m 0755 -Dp newns %{buildroot}%{_libexecdir}/os-prober/newns
  48. install -m 0644 -Dp common.sh %{buildroot}%{_datadir}/%{name}/common.sh
  49. %ifarch m68k
  50. ARCH=m68k
  51. %endif
  52. %ifarch ppc ppc64
  53. ARCH=powerpc
  54. %endif
  55. %ifarch sparc sparc64
  56. ARCH=sparc
  57. %endif
  58. %ifarch %{ix86} x86_64
  59. ARCH=x86
  60. %endif
  61. for probes in os-probes os-probes/mounted os-probes/init \
  62. linux-boot-probes linux-boot-probes/mounted; do
  63. install -m 755 -d %{buildroot}%{_libexecdir}/$probes
  64. cp -a $probes/common/* %{buildroot}%{_libexecdir}/$probes
  65. if [ -e "$probes/$ARCH" ]; then
  66. cp -a $probes/$ARCH/* %{buildroot}%{_libexecdir}/$probes
  67. fi
  68. done
  69. if [ "$ARCH" = x86 ]; then
  70. install -m 755 -p os-probes/mounted/powerpc/20macosx \
  71. %{buildroot}%{_libexecdir}/os-probes/mounted
  72. fi
  73. %files
  74. %doc README TODO debian/changelog
  75. %license debian/copyright
  76. %{_bindir}/*
  77. %{_libexecdir}/*
  78. %{_datadir}/%{name}
  79. %{_var}/lib/%{name}
  80. %changelog
  81. * Fri Sep 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.77-1
  82. - new upstream release.
  83. * Wed Sep 13 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.74-4
  84. - initial build for Vine Linux.
  85. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.74-3
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  87. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.74-2
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  89. * Mon Mar 27 2017 Neal Gompa <ngompa13@gmail.com> - 1.74-1
  90. - Update to upstream version 1.74
  91. - Drop merged patches
  92. - Rediff remaining patches
  93. - Move newns to /usr/libexec/os-prober (debuginfo generation works)
  94. - Mark copyright file as license file
  95. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.71-2
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  97. * Fri Mar 04 2016 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.71-1
  98. - Update to upstream version 1.71
  99. - Use git based autosetup for applying patches
  100. * Mon Feb 15 2016 Peter Jones <pjones@redhat.com> - 1.70-3
  101. - Don't keep backups with 'patch -b'; they wind up in the ouput package.
  102. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.70-2
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  104. * Fri Nov 13 2015 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.70-1
  105. - Update to upstream version 1.70, fixes #1275641
  106. - Fix bug #1236358 - os-prober duplicates grub entries for read/write btrfs
  107. subvolumes, thanks to Helmut Horvath
  108. - Fix bug #1236649 - os-prober does not detect os on btrfs partition without
  109. any subvolume
  110. * Tue Oct 20 2015 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.68-1
  111. - Update to upstream version 1.68, bug #1267779
  112. - Support a case where a kernel named vmlinuz/x is used under Gentoo, bug #1223237
  113. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.65-3
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  115. * Tue Dec 23 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.65-2
  116. - Fix using grep for searching binary files, fixes #1172405. Thanks Paul Eggert
  117. for initial patch fixing grep usage in 83haiku
  118. * Sun Dec 07 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.65-1
  119. - Using latest upstream version tarball to be consistent with upstream
  120. versioning
  121. * Sat Oct 25 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-11
  122. - Fix parsing grub2's initrd/linux variations, rhbz #1108344
  123. * Mon Sep 08 2014 Peter Jones <pjones@redhat.com> - 1.58-10
  124. - Make os-prober output include partitions for UEFI chainloads.
  125. Resolves: rhbz#873207
  126. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.58-9
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  128. * Sun Jul 06 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-8
  129. - Fix bug in counting LVM LVs which their name contains 'btrfs' as btrfs volumes
  130. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.58-7
  131. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  132. * Tue May 06 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-6
  133. - Fix separate /usr partitions for usrmove distros (bug #1044760)
  134. - Fix umount error when directory is temporarily busy (bug #903906)
  135. * Thu Apr 24 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-5
  136. - Fixed bug #982009: fix btrfs support
  137. - Suppress some more debug messages when debug messages are disabled
  138. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.58-4
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  140. * Tue Jul 02 2013 Adam Williamson <awilliam@redhat.com> - 1.58-3
  141. - revert factored-logger-efi-fix.patch until grub2 is updated to match
  142. * Tue Jun 18 2013 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-2
  143. - Fix a bug in EFI detection because of redirecting result output
  144. * Sun May 05 2013 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-1
  145. - Update to upstream version 1.58, with UEFI support
  146. * Sat Feb 02 2013 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.57-2
  147. - Fix a bug in recent btrfs patch when an extended partition is examined.
  148. (H.J. Lu) (bug #906847)
  149. - Fix naming of /boot partitions according to their fstab entry (bug #893472)
  150. - Don't generate .btrfsfix files which will be included in final rpm
  151. - Fix wrong boot partition set by linux-boot-prober when / and /boot are
  152. mounted (bug #906886)
  153. - Factor out 'logger', so that it is run once and logs are piped to it (John
  154. Reiser) (bug #875356)
  155. * Tue Jan 22 2013 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.57-1
  156. - Update to 1.57 (#890409)
  157. - Use shell string processing rather than 'basename' (#875356)
  158. - Make it possible to disable logging debug messages by assigning a value to
  159. OS_PROBER_DISABLE_DEBUG environment variable (Gene Czarcinski) (#893997).
  160. - Detect multi btrfs pools/volumes (Gene Czarcinski) (#888341)
  161. * Thu Oct 11 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.56-1
  162. - Update to 1.56 with a bug fix and applied one of my patches
  163. * Mon Aug 27 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.55-1
  164. - Update to new upstream version: 1.55
  165. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.53-4
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  167. * Sat Jun 02 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.53-3
  168. - Consider usrmoved distribtions in fallback linux detector (bug #826754)
  169. - Remove patch backup files from final rpm package (by not creating a backup!)
  170. * Fri May 25 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.53-2
  171. - Add support for OSes installed on Linux mdraid partitions, bug #752402
  172. - Add Fedora's grub2 config path, fixes generating menu entries for other
  173. installed Fedora's
  174. - Fixed bug in parsing yaboot.conf: accept spaces around '=' for append,
  175. bug #825041
  176. * Fri May 11 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.53-1
  177. - Updated to 1.53 for a bugfix
  178. - Fixed directory name in upstream tarbal
  179. * Thu May 10 2012 Peter Jones <pjones@redhat.com> - 1.52-3
  180. - Don't detect our Mac boot blocks as OS X.
  181. Resolves: rhbz#811412
  182. * Sun Apr 29 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.52-2
  183. - use correct directory name for setup
  184. * Sun Apr 29 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.52-1
  185. - Updated to 1.52, supports win 8
  186. * Wed Mar 28 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.51-1
  187. - Update to latest upstream version, 1.51
  188. * Sat Jan 21 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.48-3
  189. - Remove dmraid and lvm2 dependency. bug #770393
  190. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.48-2
  191. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  192. * Mon Jul 25 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.48-1
  193. - Updated to 1.48 release
  194. * Thu May 19 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.47-1
  195. - Updated to the new upstream version 1.47
  196. * Wed May 04 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.46-2
  197. - Removed obsolete parts (build tag, defattr, etc)
  198. - Added a patch to move newns outside of os-prober subdirectory
  199. - Added required utilities as package requires
  200. * Sat Apr 30 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.46-1
  201. - Updated to 1.46 release
  202. * Tue Feb 22 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.42-2
  203. - Remove executable permission from common.sh
  204. * Thu Feb 17 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.42-1
  205. - Initial version