perl-IO-String-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. Name: perl-IO-String
  2. Version: 1.08
  3. Release: 4%{?_dist_release}
  4. Summary: Emulate file interface for in-core strings
  5. Group: Development/Libraries
  6. License: GPL or Artistic
  7. URL: http://search.cpan.org/dist/IO-String/
  8. Source0: http://www.cpan.org/authors/id/G/GA/GAAS/IO-String-%{version}.tar.gz
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildArch: noarch
  13. BuildRequires: perl >= 2:5.26.2
  14. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  15. %description
  16. The "IO::String" module provides the "IO::File" interface for in-core
  17. strings. An "IO::String" object can be attached to a string, and
  18. makes it possible to use the normal file operations for reading or
  19. writing data, as well as for seeking to various locations of the
  20. string. This is useful when you want to use a library module that
  21. only provides an interface to file handles on data that you have in a
  22. string variable.
  23. Note that perl-5.8 and better has built-in support for "in memory"
  24. files, which are set up by passing a reference instead of a filename
  25. to the open() call. The reason for using this module is that it makes
  26. the code backwards compatible with older versions of Perl.
  27. %prep
  28. %setup -q -n IO-String-%{version}
  29. %build
  30. perl Makefile.PL INSTALLDIRS=vendor
  31. make %{?_smp_mflags}
  32. %install
  33. rm -rf $RPM_BUILD_ROOT
  34. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  35. #find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  36. #find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  37. #chmod -R u+w $RPM_BUILD_ROOT/*
  38. find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
  39. find $RPM_BUILD_ROOT/usr -type f -print |
  40. sed "s@^$RPM_BUILD_ROOT@@g" |
  41. grep -v %{_mandir} |
  42. grep -v perllocal.pod |
  43. grep -v "\.packlist" > IO-String-%{version}-filelist
  44. if [ "$(cat IO-String-%{version}-filelist)X" = "X" ] ; then
  45. echo "ERROR: EMPTY FILE LIST"
  46. exit -1
  47. fi
  48. %check || :
  49. make test
  50. %clean
  51. rm -rf $RPM_BUILD_ROOT
  52. %files -f IO-String-%{version}-filelist
  53. %defattr(-,root,root,-)
  54. %doc Changes README
  55. %dir %{perl_vendorlib}/IO/
  56. #{perl_vendorlib}/IO/*
  57. %{_mandir}/man3/*.3*
  58. %changelog
  59. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.08-4
  60. - rebuilt with perl-5.26.
  61. * Sat Dec 20 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.08-3
  62. - rebuilt with perl 5.16.3
  63. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.08-2
  64. - rebuilt with perl-5.12.3
  65. * Tue Nov 4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-1vl5
  66. - applied new versioning policy
  67. - rebuilt with perl 5.10.0
  68. * Sat Feb 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-0vl1
  69. - new upstream release
  70. - changed Group to Development/Libraries
  71. * Sat Feb 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-0vl1
  72. - new upstream release
  73. - changed Group to Development/Libraries
  74. * Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  75. - rebuilt for Vine
  76. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  77. - rebuilt
  78. * Wed Nov 24 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.06-1
  79. - Update to 1.06.
  80. * Sun Jul 04 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.05-0.fdr.1
  81. - First build.