perl-Sub-Exporter-Progressive-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152
  1. # We need to patch the test suite if we have old versions of Test::More
  2. %global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
  3. Name: perl-Sub-Exporter-Progressive
  4. Version: 0.001013
  5. Release: 1%{?_dist_release}
  6. Summary: Only use Sub::Exporter if you need it
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/Sub-Exporter-Progressive/
  10. Source0: http://search.cpan.org/CPAN/authors/id/F/FR/FREW/Sub-Exporter-Progressive-%{version}.tar.gz
  11. Patch1: Sub-Exporter-Progressive-0.001010-old-Test::More.patch
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildArch: noarch
  16. # =============== Module Build ======================
  17. BuildRequires: perl(ExtUtils::MakeMaker)
  18. # =============== Module Runtime ====================
  19. BuildRequires: perl(Carp)
  20. BuildRequires: perl(Exporter)
  21. BuildRequires: perl(List::Util)
  22. BuildRequires: perl(Sub::Exporter)
  23. # =============== Test Suite ========================
  24. BuildRequires: perl(lib)
  25. BuildRequires: perl(Test::More)
  26. # =============== Module Runtime ====================
  27. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  28. Requires: perl(Exporter)
  29. Requires: perl(Sub::Exporter)
  30. %description
  31. Sub::Exporter is an incredibly powerful module, but with that power comes
  32. great responsibility, er- as well as some runtime penalties. This module is a
  33. Sub::Exporter wrapper that will let your users just use Exporter if all they
  34. are doing is picking exports, but use Sub::Exporter if your users try to use
  35. Sub::Exporter's more advanced features features, like renaming exports, if
  36. they try to use them.
  37. Note that this module will export @EXPORT and @EXPORT_OK package variables for
  38. Exporter to work. Additionally, if your package uses advanced Sub::Exporter
  39. features like currying, this module will only ever use Sub::Exporter, so you
  40. might as well use it directly.
  41. %prep
  42. %setup -q -n Sub-Exporter-Progressive-%{version}
  43. # We need to patch the test suite if we have old versions of Test::More
  44. %if %{old_test_more}
  45. %patch1
  46. %endif
  47. %build
  48. perl Makefile.PL INSTALLDIRS=vendor
  49. make %{?_smp_mflags}
  50. %install
  51. rm -rf %{buildroot}
  52. make pure_install DESTDIR=%{buildroot}
  53. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  54. %{_fixperms} %{buildroot}
  55. %check
  56. make test
  57. %clean
  58. rm -rf %{buildroot}
  59. %files
  60. %doc Changes README
  61. %{perl_vendorlib}/Sub/
  62. %{_mandir}/man3/Sub::Exporter::Progressive.3pm*
  63. %changelog
  64. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net>
  65. - new upstream release.
  66. - rebuilt with perl-5.26.
  67. * Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.001011-4
  68. - initial build for Vine Linux
  69. - built with perl 5.16.3
  70. * Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.001011-3
  71. - Perl 5.20 rebuild
  72. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.001011-2
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  74. * Mon Oct 28 2013 Paul Howarth <paul@city-fan.org> - 0.001011-1
  75. - Update to 0.001011
  76. - Fix in global destruction
  77. - Fix SYNOPSIS
  78. - Fix duplicate word in DESCRIPTION (CPAN RT#86072)
  79. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.001010-3
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  81. * Sun Jul 21 2013 Petr Pisar <ppisar@redhat.com> - 0.001010-2
  82. - Perl 5.18 rebuild
  83. * Wed Mar 27 2013 Paul Howarth <paul@city-fan.org> - 0.001010-1
  84. - Update to 0.001010
  85. - Fix module name in Makefile.PL (CPAN RT#83932)
  86. - Work around Exporter.pm not installable on perl < 5.8.0
  87. - Update old Test::More patch
  88. * Wed Mar 13 2013 Paul Howarth <paul@city-fan.org> - 0.001009-1
  89. - Update to 0.001009
  90. - Disallow version names in random parts of the import list for consistency
  91. with Sub::Exporter (CPAN RT#83491)
  92. - Update old Test::More patch, and apply if we have Test::More < 0.88
  93. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.001008-2
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  95. * Tue Jan 22 2013 Paul Howarth <paul@city-fan.org> - 0.001008-1
  96. - Update to 0.001008
  97. - Rewrite -tag to :tag for Exporter.pm
  98. - Fix prereqs
  99. - Update old Test::More patch, and apply if we have Test::More < 0.96
  100. - Bump perl(Exporter) version requirement to 5.58
  101. * Mon Aug 27 2012 Paul Howarth <paul@city-fan.org> - 0.001006-1
  102. - Update to 0.001006
  103. - Handle ':all' correctly
  104. - Update old Test::More patch
  105. - Drop redundant buildreq perl(Test::Pod)
  106. * Sat Aug 25 2012 Paul Howarth <paul@city-fan.org> - 0.001005-1
  107. - Update to 0.001005
  108. - Add support for tags
  109. - Warn if defaults are not in exports
  110. - Add explicit dependency on Test::More 0.89
  111. - This release by LEONT -> update source URL
  112. - Update old Test::More patch
  113. * Thu Aug 9 2012 Paul Howarth <paul@city-fan.org> - 0.001004-1
  114. - Update to 0.001004 (fix skipping when Sub::Exporter isn't installed)
  115. - This release by MSTROUT -> update source URL
  116. - No LICENSE file in this release
  117. - Update old Test::More patch
  118. * Wed Aug 1 2012 Paul Howarth <paul@city-fan.org> - 0.001003-1
  119. - Update to 0.001003 (remove warning if there are no defaults)
  120. * Wed Aug 1 2012 Paul Howarth <paul@city-fan.org> - 0.001002-2
  121. - Sanitize for Fedora submission
  122. * Wed Aug 1 2012 Paul Howarth <paul@city-fan.org> - 0.001002-1
  123. - Initial RPM build