perl-Template-Toolkit-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194
  1. Name: perl-Template-Toolkit
  2. Version: 2.26
  3. Release: 1%{?_dist_release}
  4. Summary: Template processing system
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://www.template-toolkit.org/
  8. Source0: http://search.cpan.org/CPAN/authors/id/A/AB/ABW/Template-Toolkit-%{version}.tar.gz
  9. Source1: http://tt2.org/download/TT_v224_html_docs.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  11. BuildRequires: perl(Test::More)
  12. BuildRequires: perl(AppConfig)
  13. BuildRequires: perl(Text::Autoformat)
  14. BuildRequires: perl(GD::Graph3d)
  15. BuildRequires: perl(GD::Graph)
  16. BuildRequires: perl(GD::Text)
  17. BuildRequires: perl(Image::Info)
  18. BuildRequires: perl(Image::Size)
  19. BuildRequires: perl(Pod::POM)
  20. BuildRequires: perl(XML::DOM)
  21. BuildRequires: perl(XML::RSS)
  22. BuildRequires: perl(XML::XPath)
  23. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  24. Provides: perl-Template-Toolkit-examples = %{version}-%{release}
  25. Obsoletes: perl-Template-Toolkit-examples < 2.22-1
  26. %if "%{_dist_release}" > "vl6"
  27. %global __provides_exclude %{?__provides_exclude:%__provides_exclude|}perl\\(bytes\\)
  28. %else
  29. %global provfilt /bin/sh -c "%{__perl_provides} | grep -Ev '^perl[(](bytes)[)]'"
  30. %define __perl_provides %{provfilt}
  31. %endif
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. %description
  35. The Template Toolkit is a collection of modules which implement a
  36. fast, flexible, powerful and extensible template processing system.
  37. It was originally designed and remains primarily useful for generating
  38. dynamic web content, but it can be used equally well for processing
  39. any other kind of text based documents: HTML, XML, POD, PostScript,
  40. LaTeX, and so on.
  41. %prep
  42. %setup -q -n Template-Toolkit-%{version} -a 1
  43. find lib -type f | xargs chmod -c -x
  44. find TT_v*_html_docs -depth -name .svn -type d -exec rm -rf {} \;
  45. # Convert file to UTF-8
  46. iconv -f iso-8859-1 -t utf-8 -o Changes{.utf8,}
  47. mv Changes{.utf8,}
  48. %build
  49. CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS=vendor \
  50. TT_DBI=n TT_ACCEPT=y
  51. make %{?_smp_mflags} OPTIMIZE="%{optflags}"
  52. %install
  53. rm -rf %{buildroot}
  54. # install (+ INSTALLARCHLIB) instead of pure_install to get docs
  55. # and the template library installed too
  56. make install \
  57. PERL_INSTALL_ROOT=%{buildroot} \
  58. INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
  59. TT_PREFIX=%{buildroot}%{_datadir}/tt2
  60. find %{buildroot} -type f \( -name perllocal.pod -o \
  61. -name .packlist -o -name '*.bs' -size 0 \) -exec rm -f {} ';'
  62. find %{buildroot} -depth -type d -empty -exec rmdir {} ';'
  63. chmod -R u+w %{buildroot}/*
  64. # Nuke buildroot where it hides
  65. sed -i "s|%{buildroot}||g" %{buildroot}%{perl_vendorarch}/Template/Config.pm
  66. %check
  67. make test
  68. %clean
  69. rm -rf %{buildroot}
  70. %files
  71. %defattr(-,root,root,-)
  72. %doc Changes HACKING README TODO TT_v*_html_docs/*
  73. %{_bindir}/tpage
  74. %{_bindir}/ttree
  75. %{perl_vendorarch}/Template.pm
  76. %{perl_vendorarch}/auto/Template
  77. %{perl_vendorarch}/Template
  78. %{_mandir}/man1/*.1*
  79. %{_mandir}/man3/*.3*
  80. %changelog
  81. * Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.26-1
  82. - updated Source0 to 2.26
  83. - updated Source1 to 2.24
  84. - built with perl 5.16.3
  85. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22-1
  86. - initial build for Vine Linux
  87. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22-11
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  89. * Mon Jul 25 2011 Iain Arnell <iarnell@gmail.com> 2.22-10
  90. - update filtering for rpm 4.9
  91. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 2.22-9
  92. - Perl mass rebuild
  93. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22-8
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  95. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.22-7
  96. - 661697 rebuild for fixing problems with vendorach/lib
  97. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.22-6
  98. - Mass rebuild with perl-5.12.0
  99. * Tue Feb 9 2010 Stepan Kasal <skasal@redhat.com> - 2.22-5
  100. - delete the buildroot before install
  101. * Fri Jan 15 2010 Stepan Kasal <skasal@redhat.com> - 2.22-4
  102. - use filtering macros
  103. * Fri Jan 15 2010 Stepan Kasal <skasal@redhat.com> - 2.22-3
  104. - drop build requirements for TeX; LaTeX support has been removed in 2.14a
  105. - fix the Obsoletes tag
  106. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 2.22-2
  107. - rebuild against perl 5.10.1
  108. * Sat Jul 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.22-1
  109. - update to 2.22
  110. - obsolete examples package, upstream got rid of them
  111. * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.20-1
  112. - update to 2.20
  113. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.19-5
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  115. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.19-4
  116. - Rebuild for perl 5.10 (again)
  117. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.19-3
  118. - Autorebuild for GCC 4.3
  119. * Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.19-2
  120. - rebuild for new perl
  121. * Sun Aug 26 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 2.19-1
  122. - 2.19
  123. - license tag fix
  124. - rebuild for BuildID
  125. * Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 2.18-1
  126. - go to 2.18
  127. * Fri Sep 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.15-2
  128. - bump for fc6
  129. * Mon May 29 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.15-1
  130. - bump to 2.15
  131. - gd test is gone, don't need to patch anything
  132. * Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-8
  133. - really resolve bug 173756
  134. * Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-7
  135. - use proper TT_PREFIX setting everywhere, resolve bug 173756
  136. * Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-6
  137. - bump for FC-5
  138. * Mon Jul 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-5
  139. - don't need Tie::DBI as a BuildRequires, since we're not running
  140. the tests
  141. * Mon Jul 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-4
  142. - put examples in their own subpackage
  143. * Sat Jul 9 2005 Ville Skyttä <ville.skytta at iki.fi> - 2.14-3
  144. - Filter false positive provides.
  145. - Include template library, switch to %%{_datadir}/tt2.
  146. - Tune build dependencies for full test suite coverage.
  147. - Fix and enable GD tests.
  148. - Include more documentation.
  149. - Fine tune dir ownerships and file permissions.
  150. * Fri Jul 8 2005 Tom "spot" Callaway <tcallawa@redhat.com> 2.14-2
  151. - cleanups
  152. * Wed Jul 6 2005 Tom "spot" Callaway <tcallawa@redhat.com> 2.14-1
  153. - Initial package for Fedora Extras