perl-Test-LeakTrace-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105
  1. Name: perl-Test-LeakTrace
  2. Summary: Traces memory leaks
  3. Version: 0.16
  4. Release: 1%{?_dist_release}
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. Source0: http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/Test-LeakTrace-%{version}.tar.gz
  8. URL: http://search.cpan.org/dist/Test-LeakTrace
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  10. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  11. BuildRequires: perl(Exporter)
  12. BuildRequires: perl(ExtUtils::MakeMaker)
  13. BuildRequires: perl(Test::More)
  14. BuildRequires: libxcrypt-devel
  15. Requires: perl(Exporter)
  16. %{?perl_default_filter}
  17. %{?perl_default_subpackage_tests}
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: shaolin
  21. %description
  22. 'Test::LeakTrace' provides several functions that trace memory leaks.
  23. This module scans arenas, the memory allocation system, so it can detect
  24. any leaked SVs in given blocks. *Leaked SVs* are SVs which are not
  25. released after the end of the scope they have been created. These SVs
  26. include global variables and internal caches. For example, if you call a
  27. method in a tracing block, perl might prepare a cache for the method.
  28. Thus, to trace true leaks, 'no_leaks_ok()' and 'leaks_cmp_ok()' executes
  29. a block more than once.
  30. %prep
  31. %setup -q -n Test-LeakTrace-%{version}
  32. find . -type f -exec chmod -c -x {} +
  33. %build
  34. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  35. make %{?_smp_mflags}
  36. %install
  37. rm -rf %{buildroot}
  38. make pure_install DESTDIR=%{buildroot}
  39. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  40. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  41. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  42. %{_fixperms} %{buildroot}/*
  43. %check
  44. make test
  45. %clean
  46. rm -rf %{buildroot}
  47. %files
  48. %defattr(-,root,root,-)
  49. %doc Changes README
  50. %{perl_vendorarch}/*
  51. %exclude %dir %{perl_vendorarch}/auto
  52. %{_mandir}/man3/*.3*
  53. %changelog
  54. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.16-1
  55. - new upstream release.
  56. - rebuilt with perl-5.26.
  57. - added BR:libxcrypt-devel.
  58. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.14-1
  59. - new upstream release.
  60. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.13-1
  61. - initial build for Vine Linux
  62. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-4
  63. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  64. * Wed Jun 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.13-3
  65. - Perl mass rebuild
  66. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-2
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  68. * Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.13-1
  69. - update to 0.13
  70. - use ">= 0", instead of "== 0" for no_leaks_ok()
  71. - add count_sv() to count all the SVs in a perl interpreter
  72. - fix tests broken for some perls in 0.12
  73. * Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.11-1
  74. - update to 0.11 (#654301)
  75. - fix false-positive related to XS code (CPAN RT #58133)
  76. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.10-2
  77. - Mass rebuild with perl-5.12.0
  78. * Sun Apr 04 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.10-1
  79. - specfile by Fedora::App::MaintainerTools 0.006