qt5-qtlocation-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338
  1. %global qt_module qtlocation
  2. # define to build docs, need to undef this for bootstrapping
  3. # where qt5-qttools builds are not yet available
  4. # only primary archs (for now), allow secondary to bootstrap
  5. #global bootstrap 1
  6. %if ! 0%{?bootstrap}
  7. %ifarch %{arm} %{ix86} x86_64
  8. #define docs 1
  9. %endif
  10. %endif
  11. #define prerelease
  12. %global qt5_minorver 5.15
  13. %global qt5_version 5.15.2
  14. #global qt5_patchlevel 1
  15. Summary: Qt5 - Location component
  16. Name: qt5-%{qt_module}
  17. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  18. Release: 1%{?_dist_release}
  19. Group: system
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. # See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
  23. License: LGPLv2 with exceptions or GPLv3 with exceptions
  24. Url: https://www.qt.io/
  25. Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
  26. # build failure with gcc10
  27. # various C++ runtime headers indirectly included <string> which in turn
  28. # included <local> and <cerrno>. Those indirect inclusions have been
  29. # eliminated which in turn forces packages to include the C++ headers they
  30. # actually need.
  31. Patch0: qtlocation-gcc10.patch
  32. # filter plugin/qml provides
  33. %global __provides_exclude_from ^(%{_qt5_archdatadir}/qml/.*\\.so|%{_qt5_plugind
  34. ir}/.*\\.so)$
  35. BuildRequires: cmake
  36. BuildRequires: qt5-rpm-macros
  37. BuildRequires: qt5-srpm-macros
  38. BuildRequires: qt5-qtbase-devel >= %{version}
  39. BuildRequires: qt5-qtdeclarative-devel >= %{version}
  40. # QtPositioning core-private
  41. BuildRequires: qt5-qtbase-private-devel
  42. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  43. BuildRequires: pkgconfig(icu-i18n)
  44. BuildRequires: openssl-devel
  45. BuildRequires: zlib-devel
  46. %description
  47. The Qt Location and Qt Positioning APIs gives developers the ability to
  48. determine a position by using a variety of possible sources, including
  49. satellite, or wifi, or text file, and so on.
  50. %package devel
  51. Summary: Development files for %{name}
  52. Group: programming
  53. Requires: %{name}%{?_isa} = %{version}-%{release}
  54. Requires: qt5-qtbase-devel%{?_isa}
  55. %description devel
  56. %{summary}.
  57. %if 0%{?docs}
  58. %package doc
  59. Summary: API documentation for %{name}
  60. Group: documentation
  61. Requires: %{name} = %{version}-%{release}
  62. BuildRequires: qt5-qdoc
  63. BuildRequires: qt5-qhelpgenerator
  64. BuildArch: noarch
  65. %description doc
  66. %{summary}.
  67. %endif
  68. %package examples
  69. Summary: Programming examples for %{name}
  70. Group: programming
  71. Requires: %{name}%{?_isa} = %{version}-%{release}
  72. %description examples
  73. %{summary}.
  74. %debug_package
  75. %prep
  76. %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
  77. %patch0 -p1 -b .gcc10
  78. %build
  79. mkdir %{_target_platform}
  80. pushd %{_target_platform}
  81. %{qmake_qt5} ..
  82. make %{?_smp_mflags}
  83. %if 0%{?docs}
  84. make %{?_smp_mflags} docs
  85. %endif
  86. popd
  87. %install
  88. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  89. %if 0%{?docs}
  90. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  91. %endif
  92. ## .prl/.la file love
  93. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  94. pushd %{buildroot}%{_qt5_libdir}
  95. for prl_file in libQt5*.prl ; do
  96. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  97. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  98. rm -fv "$(basename ${prl_file} .prl).la"
  99. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  100. fi
  101. done
  102. popd
  103. %files
  104. %license LICENSE.GPL* LICENSE.LGPL*
  105. %{_qt5_libdir}/libQt5Location.so.5*
  106. %{_qt5_archdatadir}/qml/QtLocation/
  107. %{_qt5_plugindir}/geoservices/
  108. %{_qt5_libdir}/libQt5Positioning.so.5*
  109. %dir %{_qt5_archdatadir}/qml/QtPositioning
  110. %{_qt5_archdatadir}/qml/QtPositioning/*
  111. %{_qt5_plugindir}/position/
  112. %{_qt5_libdir}/libQt5PositioningQuick.so.5*
  113. %dir %{_qt5_archdatadir}/qml/Qt
  114. %dir %{_qt5_archdatadir}/qml/Qt/labs
  115. %{_qt5_archdatadir}/qml/Qt/labs/location
  116. %files devel
  117. %{_qt5_headerdir}/QtLocation/
  118. %{_qt5_libdir}/libQt5Location.so
  119. %{_qt5_libdir}/libQt5Location.prl
  120. %{_qt5_headerdir}/QtPositioning/
  121. %{_qt5_libdir}/libQt5Positioning.so
  122. %{_qt5_libdir}/libQt5Positioning.prl
  123. %{_qt5_headerdir}/QtPositioningQuick/
  124. %{_qt5_libdir}/libQt5PositioningQuick.so
  125. %{_qt5_libdir}/libQt5PositioningQuick.prl
  126. %{_qt5_libdir}/pkgconfig/Qt5Location.pc
  127. %dir %{_qt5_libdir}/cmake/Qt5Location
  128. %{_qt5_libdir}/cmake/Qt5Location/Qt5Location*.cmake
  129. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_location*.pri
  130. %{_qt5_libdir}/pkgconfig/Qt5Positioning.pc
  131. %dir %{_qt5_libdir}/cmake/Qt5Positioning
  132. %{_qt5_libdir}/cmake/Qt5Positioning/Qt5Positioning*.cmake
  133. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_positioning*.pri
  134. %{_qt5_libdir}/pkgconfig/Qt5PositioningQuick.pc
  135. %dir %{_qt5_libdir}/cmake/Qt5PositioningQuick/
  136. %{_qt5_libdir}/cmake/Qt5PositioningQuick/Qt5PositioningQuick*.cmake
  137. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_positioning*.pri
  138. %if 0%{?docs}
  139. %files doc
  140. %license LICENSE.FDL
  141. %{_qt5_docdir}/qtlocation.qch
  142. %{_qt5_docdir}/qtlocation/
  143. %{_qt5_docdir}/qtpositioning.qch
  144. %{_qt5_docdir}/qtpositioning/
  145. %endif
  146. %if 0%{?_qt5_examplesdir:1}
  147. %files examples
  148. %{_qt5_examplesdir}/
  149. %endif
  150. %changelog
  151. * Tue Apr 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.15.2-1
  152. - new upstream release.
  153. - updated Patch1.
  154. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-2
  155. - rebuilt with icu-67.
  156. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
  157. - new upstream release.
  158. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
  159. - new upstream release.
  160. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  161. - new upstream release.
  162. * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
  163. - new upstream release.
  164. * Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  165. - initial build for Vine Linux.
  166. - new upstream release.
  167. * Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  168. - drop pkgconfig-style Qt5 deps
  169. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
  170. - Update to 5.6.1
  171. * Thu Apr 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
  172. - BR: qt5-qtbase-private-devel
  173. * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
  174. - rebuild
  175. * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
  176. - rebuild
  177. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
  178. - 5.6.0 final release
  179. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.10.rc
  180. - Update to final RC
  181. * Sun Feb 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.9.rc
  182. - rebuild
  183. * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8
  184. - Update RC release
  185. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.7.beta
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  187. * Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.6.beta
  188. - update source URL, use %%license, BR: cmake
  189. * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
  190. - Update to final beta release
  191. * Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-0.4
  192. - (re) add bootstrap macro support
  193. - drop geoclue(1) dep (unused at build time anyway (#1286886)
  194. - drop (deprecated) gypsy support (#1069225)
  195. * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
  196. - Official beta release
  197. * Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
  198. - (re)add bootstrap macro support
  199. * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
  200. - Start to implement 5.6.0 beta
  201. * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
  202. - Update to final release 5.5.1
  203. * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
  204. - Update to Qt 5.5.1 RC1
  205. * Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
  206. - -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
  207. * Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
  208. - tighten qtbase dep (#1233829), .spec cosmetics, (re)enable docs
  209. * Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
  210. - New final upstream release Qt 5.5.0
  211. * Wed Jun 24 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  212. - Update for official RC1 released packages
  213. * Mon Jun 15 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
  214. - Qt 5.5.0 RC1
  215. * Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
  216. - 5.4.2
  217. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
  218. - Rebuilt for GCC 5 C++11 ABI change
  219. * Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
  220. - rebuild (gcc5)
  221. * Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
  222. - 5.4.1
  223. * Mon Feb 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-3
  224. - rebuild (gcc5)
  225. * Wed Dec 31 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-2
  226. - BR: pkgconfig(Qt5Qml) > 5.4.0 (#1177986)
  227. * Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
  228. - 5.4.0 (final)
  229. * Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.rc
  230. - 5.4.0-rc
  231. * Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
  232. - out-of-tree build, use %%qmake_qt5
  233. * Sun Oct 19 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.beta
  234. - 5.4.0-beta
  235. * Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
  236. - 5.3.2
  237. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
  238. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  239. * Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
  240. - 5.3.1
  241. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
  242. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  243. * Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
  244. - 5.3.0
  245. * Mon May 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
  246. - sanitize .prl file(s)
  247. * Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
  248. - 5.2.1
  249. * Mon Jan 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
  250. - build -examples only when supported
  251. * Sun Jan 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
  252. - -examples subpkg
  253. * Thu Jan 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
  254. - first try