quota-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424
  1. %bcond_with systemd
  2. %bcond_with quota_enables_tcpwrappers
  3. Name: quota
  4. Summary: System administration tools for monitoring users' disk usage.
  5. Summary(ja): ユーザのディスク使用量をモニタするシステム管理ツール
  6. Version: 4.06
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv2 and GPLv2+
  12. URL: https://sourceforge.net/projects/linuxquota/
  13. Source0: http://downloads.sourceforge.net/linuxquota/quota-%{version}.tar.gz
  14. Source1: quota_nld.init
  15. Source2: quota_nld.sysconfig
  16. Source101: quota_nld.service
  17. Source103: rpc-rquotad.service
  18. Source104: rpc-rquotad.sysconfig
  19. # Not accepted changes (378a64006bb1e818e84a1c77808563b802b028fa), bug #680919
  20. Patch0: quota-4.06-warnquota-configuration-tunes.patch
  21. # Fix parsing a TCP port number
  22. Patch1: quota-4.03-Validate-upper-bound-of-RPC-port.patch
  23. # Remove a dead code from process_file(), in upstream after 4.06,
  24. # <https://sourceforge.net/p/linuxquota/patches/54/>
  25. Patch2: quota-4.06-quotacheck-Remove-a-dead-code-from-process_file.patch
  26. # Fix a compilation warning in quotaops.c, in upstream after 4.06
  27. Patch3: quota-4.06-quotaops-fix-compilation-warning.patch
  28. # Warn when kernel XFS large time stamp does fit into (32-bit) user-space
  29. # time_t, in upstream after 4.06
  30. Patch4: quota-4.06-quotaio_xfs-Warn-when-large-kernel-timestamps-cannot.patch
  31. # Do not use a pointless compiler-internal __P() macro, in upstream after 4.06
  32. Patch5: quota-4.06-Drop-sys-cdefs.h-usage.patch
  33. BuildRoot: %{_tmppath}/%{name}-root
  34. BuildRequires: e2fsprogs-devel, gettext
  35. BuildRequires: nss-devel
  36. BuildRequires: openldap-devel, openssl-devel, dbus-devel, libnl3-devel
  37. BuildRequires: rpcgen
  38. BuildRequires: pkgconfig(libtirpc)
  39. %if %{with quota_enables_tcpwrappers}
  40. BuildRequires: tcp_wrappers
  41. Requires: tcp_wrappers
  42. %endif
  43. Conflicts: nfs-utils < 1.0.1
  44. %if %{with systemd}
  45. BuildRequires: systemd
  46. Requires: kernel >= 4.0
  47. %{?systemd_requires}
  48. %else
  49. Requires: kernel >= 4.0, initscripts >= 6.38
  50. Requires(post): chkconfig
  51. Requires(preun): chkconfig
  52. %endif
  53. %description
  54. The quota package contains system administration tools for monitoring
  55. and limiting user and or group disk usage per filesystem.
  56. %description -l ja
  57. quota パッケージには,ユーザやグループのディスク使用量を監視したり
  58. 制限したりできるシステム管理ツールが収録されています.これらの操作
  59. はファイルシステム単位で行うことが出来ます.
  60. ユーザやグループのディスク使用量を監視/制限した場合は quota をイン
  61. ストールして下さい.
  62. %debug_package
  63. %prep
  64. %setup -q
  65. %autopatch -p1
  66. # Regenerate build scripts
  67. autoreconf -f -i
  68. %build
  69. %configure \
  70. --enable-bsd-behaviour \
  71. --enable-ext2direct=yes \
  72. --enable-ldapmail=yes \
  73. %if %{with quota_enables_tcpwrappers}
  74. --enable-libwrap=yes \
  75. %else
  76. --disable-libwrap \
  77. %endif
  78. --enable-netlink=yes \
  79. --enable-nls \
  80. --with-pid-dir=/run \
  81. --disable-rpath \
  82. --enable-rpc=yes \
  83. --enable-rpcsetquota=yes \
  84. --disable-silent-rules \
  85. --disable-xfs-roothack \
  86. --enable-rootsbin=yes \
  87. --enable-strip-binaries=no
  88. make %{?_smp_mflags}
  89. %install
  90. rm -fr %{buildroot}
  91. mkdir -p %{buildroot}/sbin
  92. mkdir -p %{buildroot}%{_sysconfdir}
  93. mkdir -p %{buildroot}%{_sbindir}
  94. mkdir -p %{buildroot}%{_bindir}
  95. mkdir -p %{buildroot}%{_mandir}/{man1,man3,man8}
  96. make install DESTDIR=%{buildroot}
  97. rm -rf %{buildroot}%{_datadir}/doc/%{name}
  98. install -p -m644 -D %{SOURCE2} \
  99. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/quota_nld
  100. install -m 644 warnquota.conf %{buildroot}%{_sysconfdir}
  101. %if %{with systemd}
  102. install -p -m644 -D %{SOURCE101} $RPM_BUILD_ROOT%{_unitdir}/quota_nld.service
  103. install -p -m644 -D %{SOURCE103} $RPM_BUILD_ROOT%{_unitdir}/rpc-rquotad.service
  104. install -p -m644 -D %{SOURCE104} \
  105. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rpc-rquotad
  106. %else
  107. install -p -m755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/quota_nld
  108. %endif
  109. mv %{buildroot}%{_sbindir}/quota{check,off,on} %{buildroot}/sbin/
  110. %find_lang %{name}
  111. %check
  112. make check
  113. %clean
  114. rm -rf %{buildroot}
  115. %post
  116. %if %{with systemd}
  117. %systemd_post quota_nld.service
  118. %systemd_post rpc-rquotad.service
  119. %else
  120. /sbin/chkconfig --add quota_nld
  121. %endif
  122. %preun
  123. %if %{with systemd}
  124. %systemd_preun quota_nld.service
  125. %systemd_preun rpc-rquotad.service
  126. %else
  127. if [ $1 = 0 -o -x /bin/systemctl ] ; then
  128. /sbin/service quota_nld stop >/dev/null 2>&1
  129. /sbin/chkconfig --del quota_nld
  130. fi
  131. %endif
  132. %if %{with systemd}
  133. %postun
  134. %systemd_postun_with_restart quota_nld.service
  135. %systemd_postun_with_restart rpc-rquotad.service
  136. %endif
  137. %files -f %{name}.lang
  138. %defattr(-,root,root)
  139. %license COPYING
  140. %doc Changelog doc/ README*
  141. %config(noreplace) %{_sysconfdir}/warnquota.conf
  142. %config(noreplace) %{_sysconfdir}/quotagrpadmins
  143. %config(noreplace) %{_sysconfdir}/quotatab
  144. /sbin/*
  145. %{_bindir}/*
  146. %{_sbindir}/*
  147. %{_includedir}/rpcsvc/*
  148. %{_mandir}/man1/*
  149. %{_mandir}/man3/*
  150. %{_mandir}/man5/*
  151. %{_mandir}/man8/*
  152. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/quota_nld
  153. %if %{with systemd}
  154. %{_unitdir}/quota_nld.service
  155. %{_unitdir}/rpc-rquotad.service
  156. %config(noreplace) %{_sysconfdir}/sysconfig/rpc-rquotad
  157. %else
  158. %{_initrddir}/quota_nld
  159. %endif
  160. %changelog
  161. * Thu Mar 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.06-1
  162. - new upstram release.
  163. - updated all patches.
  164. * Thu Aug 13 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.05-1
  165. - new upstram release.
  166. - updated all patches.
  167. - disabled tcp_wrappers as default.
  168. - added systemd support (disabled as default).
  169. * Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.04-1
  170. - new upstram release.
  171. - dropped BR:libnl-devel.
  172. - added BR:libnl3-devel.
  173. - dropped all patches.
  174. - imported patched from rawhide.
  175. * Mon Mar 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.00-1
  176. - new upstram release
  177. - add BR: tcp_wrappers, nss-devel, openldap-devel,
  178. openssl-devel, dbus-devel, libnl-devel
  179. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.15-2
  180. - rebuilt with rpm-4.8.1-3
  181. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.15-1vl5
  182. - applied new versioning policy, spec in utf-8
  183. * Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 3.15-0vl1
  184. - updated quota to 3.15
  185. * Wed Apr 27 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl2
  186. - oops, removed unnecessary Patch3
  187. * Tue Apr 26 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl1
  188. - based on 3.12-5, being merged into 3.06-7vl1
  189. - Sun Sep 26 2004 Rik van Riel <riel@redhat.com> 3.12-5
  190. - add URL (bz# 131862)
  191. - Fri Sep 24 2004 Steve Dickson <SteveD@RedHat.com>
  192. - Fixed typos in warnquota.conf patch
  193. (bz# 82250 and bz# 83974)
  194. - Mon Sep 13 2004 Steve Dickson <SteveD@RedHat.com>
  195. - upgraded to 3.12
  196. - Tue Jan 27 2004 Florian La Roche <Florian.LaRoche@redhat.de>
  197. - add -pie support
  198. - update to 3.10
  199. - Sat Aug 16 2003 Steve Dickson <SteveD@RedHat.com>
  200. - upgraded to 3.0.9
  201. - added quota-3.09-root_sbindir.patch
  202. * Sun Feb 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.06-7vl1
  203. - merged with Vine Linux package (quota-2.00stable-0vl1)
  204. - based on rawhide release 3.06-7
  205. * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
  206. - 2.00stable-0vl1
  207. - ver.up
  208. * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
  209. - 2.00pre3-8vl2
  210. - added documents
  211. * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  212. - 2.00pre3-8vl1
  213. - based on 2.00pre3-8 from Rawhide
  214. - added Japanese summary and description
  215. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  216. - rebuilt
  217. * Mon Nov 18 2002 Tim Powers <timp@redhat.com>
  218. - rebuild on all arches
  219. * Fri Sep 6 2002 Philip Copeland <bryce@redhat.com> 3.06-5
  220. - added --with-ext2direct=no to fix #73244
  221. without this users with UID's > 65535 will not
  222. be able to exist on a quota enabled FS
  223. * Wed Aug 7 2002 Philip Copeland <bryce@redhat.com> 3.06-4
  224. - Man page change. #60108
  225. * Tue Aug 6 2002 Philip Copeland <bryce@redhat.com> 3.06-3
  226. - Bah, I'd dropped epoch from the spec file but seems
  227. we need this if you want to upgrade as the epoch
  228. number has precedence over the version/release
  229. numbers.
  230. * Wed Jul 17 2002 Philip Copeland <bryce@redhat.com> 3.06-2
  231. - Lets stop the makefile from stripping the
  232. binaries as thats rpms job (apparently)
  233. * Mon Jul 01 2002 Philip Copeland <bryce@redhat.com> 3.06-1
  234. - Ditched the 3.01-pre9 src base for 3.06
  235. Rebuilt without any patchs
  236. ============================================================
  237. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  238. - automated rebuild
  239. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  240. - automated rebuild
  241. * Mon Feb 25 2002 Elliot Lee <sopwith@redhat.com>
  242. - IfArch the badkernelinclude patch for ppc-only.
  243. - Update to 3.03
  244. * Wed Dec 12 2001 Guy Streeter <streeter@redhat.com>
  245. - Make #include of kernel header file work on non-x86
  246. * Wed Sep 5 2001 Preston Brown <pbrown@redhat.com>
  247. - require new initscripts
  248. * Thu Aug 30 2001 Preston Brown <pbrown@redhat.com>
  249. - fixed bug #52075 (problem with ext2 labels)
  250. - backup data files off by default in quotacheck, optional backup flag added
  251. - fix bug where giving a bad directory or device would cause
  252. quotaon/quotacheck to simulate "-a" behaviour
  253. - if a device name (i.e /dev/hda1) is passed, look up the corresponding mount
  254. point
  255. * Wed Aug 29 2001 Preston Brown <pbrown@redhat.com>
  256. - return an error code in more cases in convertquota
  257. * Tue Aug 28 2001 Preston Brown <pbrown@redhat.com>
  258. - 3.01pre9
  259. * Fri Jul 20 2001 Preston Brown <pbrown@redhat.com>
  260. - more cleanups on 3.01pre8
  261. * Mon Jul 2 2001 Preston Brown <pbrown@redhat.com>
  262. - 3.01 version, everything has changed again. :(
  263. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  264. - Bump release + rebuild.
  265. * Fri Mar 30 2001 Preston Brown <pbrown@redhat.com>
  266. - use rpc.rquotad from here again (#33738)
  267. * Thu Mar 15 2001 Preston Brown <pbrown@redhat.com>
  268. - enable ALT_FORMAT for edquota
  269. * Tue Mar 13 2001 Preston Brown <pbrown@redhat.com>
  270. - I broke passing devices on the cmd line. Fixed.
  271. * Fri Mar 09 2001 Preston Brown <pbrown@redhat.com>
  272. - quota 3.00 is required by recent kernel 2.4 changes
  273. - no warnquota included this time, not yet ported
  274. - quite a bit of work on quotacheck to make is backwards compatible
  275. - we will likely go back to "quota 2.00" as these projects merge...
  276. * Fri Feb 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  277. - use "rm -f" instead of only "rm"
  278. * Wed Feb 7 2001 Preston Brown <pbrown@redhat.com>
  279. - fix quotacheck man page for -a option (#26380)
  280. * Thu Feb 1 2001 Preston Brown <pbrown@redhat.com>
  281. - 2.00 final, rolls in pretty much all our patches. :)
  282. - fix reporting of in use dquot entries from quotastats
  283. - change repquota man page to fix documentation of -v (#10330)
  284. - include warnquota.conf
  285. * Mon Nov 20 2000 Bill Nottingham <notting@redhat.com>
  286. - fix ia64 build
  287. * Mon Aug 21 2000 Jeff Johnson <jbj@redhat.com>
  288. - add LABEL=foo support (#16390).
  289. * Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
  290. - remote NFS quotas with different blocksize converted incorrectly (#11932).
  291. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  292. - automatic rebuild
  293. * Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
  294. - FHS packaging.
  295. * Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
  296. - apply patch5 (H.J. Lu)
  297. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  298. - fix description
  299. - man pages are compressed
  300. * Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
  301. - quota 2.00 series
  302. - removed unnecessary patches
  303. * Thu Aug 5 1999 Jeff Johnson <jbj@redhat.com>
  304. - fix man page FUD (#4369).
  305. * Thu May 13 1999 Peter Hanecak <hanecak@megaloman.sk>
  306. - changes to allow non-root users to build too (Makefile patch, %attr)
  307. * Tue Apr 13 1999 Jeff Johnson <jbj@redhat.com>
  308. - fix for sparc64 quotas (#2147)
  309. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  310. - auto rebuild in the new build environment (release 5)
  311. * Mon Dec 28 1998 Cristian Gafton <gafton@redhat.com>
  312. - don't install rpc.rquotad - we will use the one from the knfsd package
  313. instead
  314. * Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
  315. - merge ultrapenguin 1.1.9 changes.
  316. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  317. - translations modified for de, fr, tr
  318. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  319. - removed patch for mntent
  320. * Fri Mar 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  321. - updated to quota 1.66
  322. * Tue Jan 13 1998 Erik Troan <ewt@redhat.com>
  323. - builds rquotad
  324. - installs rpc.rquotad.8 symlink
  325. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  326. - removed /usr/include/rpcsvc/* from filelist
  327. - uses a buildroot and %attr
  328. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  329. - built against glibc
  330. * Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
  331. - Moved /usr/sbin/quota to /usr/bin/quota