rail-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213
  1. %define _noVersionedDependencies 1
  2. %define origver 1.2.11
  3. %define origname rail
  4. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  5. Name: %{origname}
  6. Version: %{origver}
  7. Release: 1%{?_dist_release}
  8. Summary: rail - Replace Agent-string Internal Library for emacsen
  9. Summary(ja): rail - emacsen 用 Agent 名変換ライブラリ
  10. License: GPLv2+
  11. Group: Applications/Editors/Emacs
  12. URL: http://uwabami.github.io/rail/
  13. Source0: https://github.com/uwabami/rail/archive/%{version}.tar.gz
  14. Source1: semi-1.14.6-VERSION
  15. Source2: flim-1.14.9-VERSION
  16. Source10: %{origname}-install.sh
  17. Source11: %{origname}-remove.sh
  18. Source12: %{origname}-init.el
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildArch: noarch
  21. Requires: emacsen semi
  22. Requires(post): emacsen emacsen-common semi
  23. Obsoletes: rail-xemacs
  24. Conflicts: %{origname}-el
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: shaolin
  28. %description
  29. rail is a nifty elisp, that translates codenames with latin chars
  30. of flim/semi/XEmacs/UTF-2000-Mule/Meadow to Japanese characters.
  31. It also provides a function compatible with genjis.el (a part
  32. of tm, that converts mule-version to Japanese characters).
  33. %description -l ja
  34. rail は,flim/semi/XEmacs/UTF-2000-Mule/Meadow のコードネームを
  35. 日本語化し,User-Agent: フィールドに適用するための elsp です.
  36. tm の genjis.el 互換機能 (mule-version の日本語化) も備えています.
  37. %prep
  38. %setup -q -n %{origname}-%{version}
  39. ## install newer codename file for semi
  40. cp %{SOURCE1} contrib/SEMI_VERSION
  41. cp %{SOURCE2} contrib/FLIM_VERSION
  42. %install
  43. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  44. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  45. mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
  46. #mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/install
  47. #mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/remove
  48. mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/install
  49. mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/remove
  50. ## install el files
  51. cp -a Makefile contrib *.el \
  52. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
  53. # 2004.12.13 add Irokawa
  54. cp -a %{SOURCE12} \
  55. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
  56. ## install script (bytecompile el and install elc, remove elc)
  57. %_installemacsenscript %{origname} %{SOURCE10}
  58. %_removeemacsenscript %{origname} %{SOURCE11}
  59. %clean
  60. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  61. %post
  62. ## bytecompile el and install elc
  63. if [ "$1" = 2 ] ; then
  64. %_emacsenPackageRemove %{origname}
  65. fi
  66. %_addemacsenlist %{origname}
  67. %_emacsenPackageInstall %{origname}
  68. %preun
  69. if [ "$1" = 0 ] ; then
  70. %_emacsenPackageRemove %{origname}
  71. %_removeemacsenlist %{origname}
  72. fi
  73. %files
  74. %defattr(-,root,root)
  75. %doc ChangeLog GPL-2 FAQ.rdoc README.rdoc contrib
  76. %{_datadir}/emacs/site-lisp/%{origname}
  77. #%{_libdir}/emacsen-common/packages/install/%{origname}
  78. #%{_libdir}/emacsen-common/packages/remove/%{origname}
  79. %{emacsen_pkgdir}/install/%{origname}
  80. %{emacsen_pkgdir}/remove/%{origname}
  81. %changelog
  82. * Wed Apr 15 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.11-1
  83. - updated to 1.2.11
  84. - built on current VineSeed
  85. - added URL tag
  86. * Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.2.5-2
  87. - drop defining prereq_ge macro: using Requires(post) tag
  88. - add Requires: emacsen semi
  89. - update Packager syntax
  90. * Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1vl5
  91. - applied new versioning policy, spec in utf-8
  92. - added macro %%emacsen_pkgdir
  93. * Fri Dec 7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl12
  94. - added %%{SOURCE2} for flim-1.14.9
  95. * Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.2.5-0vl11
  96. - added %%{SOURCE2} for flim-1.14.8
  97. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl10
  98. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  99. * Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.2.5-0vl9
  100. - added %%{SOURCE2} for flim-1.14.7
  101. - added %%{SOURCE12} for use /etc/$FLAVOR/site-start.d/
  102. * Wed Dec 24 2003 MATSUBAYASHI <shaolin@vinelinux.org> 1.2.5-0vl8
  103. - added %%{SOURCE1} and %%{SOURCE2} for flim-1.14.6 / semi-1.14.6
  104. * Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.2.5-0vl7
  105. - Modded %%{SOURCE2} for flim-1.14.5
  106. * Sat Dec 07 2002 MATSUBAYASHI <shaolin@vinelinux.org> 1.2.5-0vl6
  107. - added %%{SOURCE1} for semi-1.14.5
  108. * Mon Jun 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl5
  109. - added Source2 (for flim-1.14.4)
  110. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl4
  111. - package name changed rail-el -> rail again
  112. * Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl3
  113. - rail is now rail-el, thus emacsen-common aware :)
  114. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  115. - 1.2.5-0vl2
  116. - added %%{SOURCE1} for semi-1.14.3
  117. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  118. - 1.2.5-0vl1
  119. - updated to 1.2.5 release
  120. - now rail-xemacs is a sub-package
  121. - use better macros (%%{_tmppath})
  122. * Tue Mar 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  123. - 1.2.4-0vl1
  124. - updated in sync with 1.2.4 release
  125. * Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  126. - 1.0.2-2
  127. - Requires: apel, flim removed
  128. * Tue Nov 16 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  129. - 1.0.2-1
  130. - updated in sync wih 1.0.2 release
  131. * Tue Oct 26 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  132. - 0.8-1
  133. - updated in sync wih 0.8 release
  134. - added newer FLIM_VERSION file for newest CLIME release
  135. * Wed Oct 13 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  136. - 0.7-1
  137. - updated in sync wih 0.7 release
  138. * Mon Oct 4 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  139. - 0.6-1
  140. - updated in sync wih 0.6 release
  141. * Fri Oct 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  142. - 0.5-2
  143. - added newer FLIM_VERSION file for newest CLIME release
  144. * Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  145. - 0.5-1
  146. - first rpm release