rkhunter-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399
  1. Name: rkhunter
  2. Summary: A host-based tool to scan for rootkits, backdoors and local exploits
  3. Version: 1.4.6
  4. Release: 2%{?_dist_release}
  5. Group: admin-tools,security
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: GPLv2+
  9. URL: http://rkhunter.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/rkhunter/rkhunter-%{version}.tar.gz
  11. Source2: 01-rkhunter
  12. Source3: rkhunter.sysconfig
  13. Patch0: rkhunter-1.4.6-vineconfig.patch
  14. # libkeyutils is an actual legit library now, so this old check is a false positive.
  15. Patch1: rkhunter-1.4.6-drop-libkeyutils-check.patch
  16. # have ssh checks use the sshd.d directoy config files too.
  17. Patch2: rkhunter-1.4.6-ssh.d.patch
  18. BuildArch: noarch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. Requires: coreutils, binutils, findutils, grep
  21. Requires: e2fsprogs, procps, lsof, iproute, wget
  22. Requires: perl, perl(strict), perl(IO::Socket), mailx, logrotate
  23. Requires: kmod
  24. %description
  25. Rootkit Hunter (RKH) is an easy-to-use tool which checks
  26. computers running UNIX (clones) for the presence of rootkits
  27. and other unwanted tools.
  28. %prep
  29. %autosetup -p1
  30. %{__cat} <<'EOF' >%{name}.logrotate
  31. %{_localstatedir}/log/%{name}/%{name}.log {
  32. weekly
  33. notifempty
  34. create 640 root root
  35. }
  36. EOF
  37. %build
  38. # Nothing to be built
  39. %install
  40. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_bindir}
  41. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{cron.daily,sysconfig,logrotate.d}
  42. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts
  43. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_pkgdocdir}
  44. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_mandir}/man8
  45. %{__mkdir} -m700 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}
  46. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db
  47. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/log/%{name}
  48. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n
  49. %{__install} -m755 -p files/%{name} ${RPM_BUILD_ROOT}%{_bindir}/
  50. %{__install} -m644 -p files/backdoorports.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
  51. %{__install} -m644 -p files/mirrors.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
  52. %{__install} -m644 -p files/programs_bad.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
  53. %{__install} -m644 -p files/i18n/cn ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n/
  54. %{__install} -m644 -p files/i18n/en ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n/
  55. %{__install} -m644 -p files/CHANGELOG ${RPM_BUILD_ROOT}%{_pkgdocdir}
  56. %{__install} -m644 -p files/LICENSE ${RPM_BUILD_ROOT}%{_pkgdocdir}
  57. %{__install} -m644 -p files/README ${RPM_BUILD_ROOT}%{_pkgdocdir}
  58. %{__install} -m755 -p files/check_modules.pl ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
  59. %{__install} -m644 -p files/*.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  60. # Don't ship these unless we want to Require the perl modules
  61. #%{__install} -m750 -p files/filehashmd5.pl ${RPM_BUILD_ROOT}%{_prefix}/lib/%{name}/scripts/
  62. #%{__install} -m750 -p files/filehashsha1.pl ${RPM_BUILD_ROOT}%{_prefix}/lib/%{name}/scripts/
  63. %{__install} -m755 -p %{SOURCE2} ${RPM_BUILD_ROOT}%{_sysconfdir}/cron.daily/%{name}
  64. %{__install} -m644 -p %{name}.logrotate ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d/%{name}
  65. %{__install} -m640 -p files/%{name}.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/
  66. %{__install} -m640 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/%{name}
  67. %clean
  68. %{__rm} -rf $RPM_BUILD_ROOT
  69. %files
  70. %defattr(-,root,root,-)
  71. %doc %{_pkgdocdir}/*
  72. %{_bindir}/%{name}
  73. %dir %{_datadir}/%{name}
  74. %{_datadir}/%{name}/scripts
  75. %{_sysconfdir}/cron.daily/%{name}
  76. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  77. %dir %{_var}/lib/%{name}
  78. %{_var}/lib/%{name}/db
  79. %ghost %{_var}/lib/%{name}/db/mirrors.dat
  80. %ghost %{_var}/lib/%{name}/db/programs_bad.dat
  81. %{_var}/lib/%{name}/db/i18n
  82. %dir %{_var}/log/%{name}
  83. %config(noreplace) %{_sysconfdir}/%{name}.conf
  84. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  85. %{_mandir}/man8/*
  86. %changelog
  87. * Wed Mar 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.6-2
  88. - imported Patch1 and 2 from rawhide.
  89. * Mon May 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.6-1
  90. - updated to 1.4.6.
  91. - updated Patch0.
  92. * Wed Nov 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.4.2-1
  93. - update to 1.4.2
  94. * Thu Feb 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  95. - initial build for Vine Linux
  96. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-6
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  98. * Sat Oct 06 2012 Kevin Fenzi <kevin@scrye.com> 1.4.0-5
  99. - Add /dev/md/autorebuild.pid to whitelist. Fixes bug #857315
  100. * Sat Aug 18 2012 Kevin Fenzi <kevin@scrye.com> 1.4.0-4
  101. - Add /var/log/pki-ca/system to whitelist for FreeIPA. Fixes bug #849251
  102. * Wed Aug 15 2012 Kevin Fenzi <kevin@scrye.com> 1.4.0-3
  103. - Fix /bin/ad false positive. Fixes bug #831989
  104. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-2
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  106. * Tue May 08 2012 Kevin Fenzi <kevin@scrye.com> - 1.4.0-1
  107. - Update to 1.4.0
  108. * Sun Apr 15 2012 Kevin Fenzi <kevin@scrye.com> - 1.3.8-15
  109. - Add workaround for /lib/java false positive. Fixes bug #806972
  110. * Wed Feb 8 2012 Kay Sievers <kay@redhat.com> - 1.3.8-14
  111. - modutils are for Linux 2.4 and no longer provided; depend on kmod
  112. * Fri Jan 27 2012 Kevin Fenzi <kevin@scrye.com> 1.3.8-13
  113. - Drop net-tools, no longer needed. Fixes bug #784803
  114. - Add /dev/shm/spice.* to whitelist. Fixes bug #784882
  115. * Fri Jan 06 2012 Kevin Fenzi <kevin@scrye.com> 1.3.8-12
  116. - Add /etc/.java to whitelist. Fixes bug #770972
  117. * Fri Nov 25 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-11
  118. - Add /usr/share/man/man5/.k5identity.5.gz to whitelisted hidden files.
  119. * Wed Oct 12 2011 Jim Pirzyk <jim+rpm@pirzyk.org> - 1.3.8-10
  120. - Update %files section so that some .dat files are marked %ghost
  121. * Fri Aug 05 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-9
  122. - Add patch to fix ALLOWPROCDELFILE config option. fixes bug #727524
  123. * Fri Jul 08 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-8
  124. - Fix typo
  125. * Fri Jul 08 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-7
  126. - Add patch to fix out of the box warning on rkhunter script.
  127. - Fixes bug #719270
  128. - Add etckeeper and tomboy files. Fixes bug #719265 and #719259
  129. * Tue Jun 21 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-6
  130. - Change ssh check back to 2 - bug #596775
  131. - Drop hard Requires on prelink. It will be used if present - bug #714067
  132. * Thu Apr 21 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-5
  133. - Add /dev/.mount to ALLOW_HIDDENDIR - bug #697599
  134. * Wed Apr 13 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-4
  135. - Don't send warning emails anymore. They cause selinux issues and are not very helpful.
  136. - Fixes bug #660544
  137. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-3
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  139. * Tue Dec 07 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.8-2
  140. - Adjust config some - bug #596775
  141. * Fri Nov 26 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.8-1
  142. - Update to 1.3.8
  143. * Wed Nov 24 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-9
  144. - Drop /var/run as it's not used anymore - bug #656684
  145. * Wed Oct 06 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-8
  146. - Add patch to make rkhunter use unhide if installed - bug #636396
  147. * Sat Jun 05 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-7
  148. - Add ipsec.hmac exclude - bug #560594
  149. * Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-6
  150. - Add exclude for md-device-map - bug #596731
  151. - Supress ssh version check - bug #596775
  152. * Sat Mar 06 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-5
  153. - Change config to not specify XINETD_PATH - bug #560562
  154. * Sat Jan 23 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-4
  155. - Change email to just root instead of root@localhost - bug #553179
  156. - Add .k5login.5.gz to files whitelist - bug #553134
  157. * Tue Jan 05 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-3
  158. - Add some more ssh hmac files to whitelist - bug #552621
  159. - Re-add /dev/.mdadm.map to whitelisted files - bug #539405
  160. * Tue Dec 01 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.6-2
  161. - Disable apps check by default - bug #543065
  162. * Sun Nov 29 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.6-1
  163. - Update to 1.3.6
  164. * Thu Nov 26 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-9
  165. - Add exception for /dev/.mdadm file - bug #539405
  166. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-8
  167. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  168. * Fri Jul 03 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-7
  169. - Add exception for software raid udev file - bug #509253
  170. * Sat Jun 06 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-6
  171. - Add /usr/bin/.fipscheck.hmac to ok files - bug #494096
  172. * Sun Mar 08 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-5
  173. - Fix typo in patch file
  174. * Wed Mar 04 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-4
  175. - Rework spec file
  176. - Add check for the new hmac ssh files
  177. * Thu Feb 26 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-3
  178. - Update cron job to include hostname (thanks Manuel Wolfshant)
  179. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-2
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  181. * Fri Jan 02 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-1
  182. - Update to 1.3.4
  183. - Use libdir as tmp dir - bug #456340
  184. * Sat Dec 13 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-6
  185. - Fix cron job sending as attachment - bug #472679
  186. - Fix cron job trying to send with colors - bug #475916
  187. * Wed Sep 03 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-5
  188. - Patch debug tmp file issue - bug #460628
  189. * Mon Jun 16 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-4
  190. - Fix cron script to only mail on warn/error - bug #450703
  191. - Fix conditional to account for fc10 rsyslog
  192. * Mon Apr 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-3
  193. - Change cron to run after prelink - bug #438622
  194. * Wed Mar 26 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-2
  195. - Move things to more standard locations for selinux - bug #438184
  196. - Add exception for pulseaudio file - bug #438622
  197. * Thu Feb 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-1
  198. - Update to 1.3.2
  199. - Fix cron script
  200. * Thu Feb 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.0-2
  201. - Use /etc/redhat-release for EPEL and /etc/fedora release for Fedora.
  202. - Add conditionals to support EPEL
  203. - Fix man page warning.
  204. * Sun Feb 03 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.0-1
  205. - Revive package, clean up spec
  206. - Update to 1.3.0
  207. * Sat Mar 18 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-3
  208. - Made an RPM transparent change to move the sha1 canary check
  209. file out of CVS and into the external lookaside cache (whose
  210. filename changes with every new package release anyway...)
  211. * Fri Mar 17 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-2
  212. - Fixed architectural dependency during package creation eliminating
  213. use of _libdir configure macro (x86_64 /usr/lib64 mis-targeting)
  214. * Tue Mar 7 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-1
  215. - New package version release
  216. - reworked the .spec file to support optional dist tag
  217. - Updated the application check default patchfile (chunk failure)
  218. - Changed to SHA1 for optional message digest (canary check)
  219. - Added a couple of suggested skip entries to rkhunter.conf
  220. * Sat Jun 11 2005 Greg Houlette <tamaster@pobox.com> - 1.2.7-1
  221. - Added signature auto-updating to CRON scan (new script)
  222. - Removed BOOTSCAN pending rewrite to full SysV Init scan in background
  223. - Added the --append-log command line option
  224. - Added Date Stamping to output
  225. - Fixed bug in /etc/group missing report
  226. - New package version release
  227. * Sun Jan 2 2005 Greg Houlette <tamaster@tekarmory.com> - 0:1.1.9-1
  228. - New package version release
  229. - Added the --run-application-check command line option
  230. to listing in command help
  231. - Replaced 'Here' Doc editing of rkhunter.conf file
  232. with in-place Perl edit
  233. - tweaked rpmbuild -bb Autoclean
  234. * Fri Oct 15 2004 Greg Houlette - 0:1.1.8-0.fdr.1 (revisited)
  235. - Removed redundant buildrequires /bin/sh, coreutils and perl
  236. - Revise postun scriptlet
  237. - Added /usr/share/doc/rkhunter-1.1.8/ to files list
  238. * Mon Oct 11 2004 Greg Houlette - 0:1.1.8-0.fdr.1
  239. - Changed Release Tag to 0.fdr.1 (testing) for QA
  240. - Removed wget from dependencies
  241. - Hid (temporarily) the --skip-application-check command
  242. line option from being listed in help
  243. - Fixed the spec files list, again!
  244. * Fri Oct 8 2004 Greg Houlette - 0:1.1.8-0.fdr.0.2.beta2
  245. - Unified and disabled the md5 canary check in prep
  246. (check is now optional) removing the sha1 cross-check
  247. - Fixed the spec files list, adding the /var/rkhunter
  248. directory and the /usr/bin/rkhunter executable
  249. - Fixed missing dependencies (rkh uses runtime checks)
  250. - Disabled "auto-clean" for rpmbuild -bb
  251. - Changed Application version scan default to
  252. disabled awaiting backport fix in upstream sources
  253. - Fixed shared_man_search.patch, configuration files
  254. verify and added postun(install) cleanup
  255. * Fri Oct 1 2004 Greg Houlette - 0:1.1.8-0.fdr.0.1.beta1
  256. - More cosmetic patchwork
  257. - Changed Release Tag to beta1 (pre-release) for QA submit
  258. * Tue Sep 28 2004 Greg Houlette - 0:1.1.8-0.fdr.1
  259. - Removed hidden_search.patch (1.1.7) after it was
  260. merged into upstream source by Michael Boelen
  261. - Removed .spec file from md5 and sha1 file checks
  262. (it must be modifiable by Fedora QA release build)
  263. - Added BOOTSCAN description file to documentation
  264. - Restructured dynamic file creation ('Here' Docs)
  265. moving them to the "prep" stage so that *_ALL_*
  266. files are available prior to the "build" stage
  267. (for inspection purposes)
  268. - Added a /etc/sysconfig/rkhunter parameters file
  269. * Sun Aug 29 2004 Greg Houlette - 0:1.1.7-0.fdr.1
  270. - Cosmetic patchwork
  271. * Sat Aug 21 2004 Greg Houlette - 0:1.1.6-0.fdr.1
  272. - Moderate reworking of .spec file for packaging standards
  273. - Added md5 and sha1 file checks to prep procedure for source .rpm
  274. - Included an optional rc.local replacement for scan on boot (with full logging)
  275. * Tue Aug 10 2004 Michael Boelen - 1.1.5
  276. - Added update script
  277. - Extended description
  278. * Sun Aug 08 2004 Greg Houlette - 1.1.5
  279. - Changed the install procedure eliminating the specification of
  280. destination filenames (only needed if you are renaming during install)
  281. - Changed the permissions for documentation files (root only overkill)
  282. - Added the installation of the rkhunter Man Page
  283. - Added the installation of the programs_{bad, good}.dat database files
  284. - Added the installation of the LICENSE documentation file
  285. - Added the chmod for root only to the /var/rkhunter/db directory
  286. * Sun May 23 2004 Craig Orsinger (cjo) <cjorsinger@earthlink.net>
  287. - version 1.1.0-1.cjo
  288. - changed installation in accordance with new rootkit installation
  289. procedure
  290. - changed installation root to conform to LSB. Use standard macros.
  291. - added recursive remove of old build root as prep for install phase
  292. * Wed Apr 28 2004 Doncho N. Gunchev - 1.0.9-0.mr700
  293. - dropped Requires: perl - rkhunter works without it
  294. - dropped the bash alignpatch (check the source or contact me)
  295. - various file mode fixes (.../tmp/, *.db)
  296. - optimized the %%files section - any new files in the
  297. current dirs will be fine - just %%{__install} them.
  298. * Mon Apr 26 2004 Michael Boelen - 1.0.8-0
  299. - Fixed missing md5blacklist.dat
  300. * Mon Apr 19 2004 Doncho N. Gunchev - 1.0.6-1.mr700
  301. - added missing /usr/local/rkhunter/db/md5blacklist.dat
  302. - patched to align results in --cronjob, I think rpm based
  303. distros have symlink /bin/sh -> /bin/bash
  304. - added --with/--without alignpatch for conditional builds
  305. (in case previous patch breaks something)
  306. * Sat Apr 03 2004 Michael Boelen / Joe Klemmer - 1.0.6-0
  307. - Update to 1.0.6
  308. * Mon Mar 29 2004 Doncho N. Gunchev - 1.0.0-0
  309. - initial .spec file