wxGTK-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264
  1. %define name wxGTK
  2. %define wxconfig gtk2-unicode-release-2.8
  3. %define wx_ver 2.8
  4. Summary: The GTK+ 2 port of the wxWidgets library
  5. Summary(ja): wxWidgets ライブラリーの GTK+ 2 ポート
  6. Name: %{name}
  7. Version: %{wx_ver}.12
  8. Release: 8%{?_dist_release}
  9. License: wxWindows License
  10. Group: System Environment/Libraries
  11. URL: http://www.wxwidgets.org/
  12. Source0: wxGTK-%{version}.tar.bz2
  13. # https://bugzilla.redhat.com/show_bug.cgi?id=1308243
  14. # backported from https://github.com/wxWidgets/wxWidgets/commit/1780a38b7bc9a9c04d33775a3176fe8516465f50
  15. Patch1: %{name}-%{version}-char.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: cppunit-devel
  18. #BuildRequires: gstreamer-devel >= 0.10
  19. #BuildRequires: gstreamer-plugins-base-devel >= 0.10
  20. BuildRequires: gtk2-devel
  21. BuildRequires: expat-devel
  22. BuildRequires: libgnomeprintui-devel
  23. BuildRequires: libjpeg-turbo-devel
  24. BuildRequires: libpng-devel
  25. BuildRequires: libSM-devel
  26. BuildRequires: libtiff-devel
  27. BuildRequires: mesa-libGL-devel
  28. BuildRequires: mesa-libGLU-devel
  29. BuildRequires: pkgconfig
  30. BuildRequires: SDL-devel
  31. BuildRequires: zlib-devel
  32. Obsoletes: wx-gtk2 < %{version}-%{release}
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: toshi_kd
  36. %description
  37. wxWidgets is a free C++ library for cross-platform GUI development.
  38. With wxWidgets, you can create applications for different GUIs (GTK+,
  39. Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
  40. %package devel
  41. Summary: The GTK+ 2 port of the wxWidgets library
  42. Summary(ja): wxWidgets ライブラリーの開発用ファイル
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. Requires: wxBase = %{version}-%{release}
  46. Requires: gtk2-devel
  47. Requires: mesa-libGL-devel, mesa-libGLU-devel
  48. Obsoletes: wx-gtk2-devel < %{version}-%{release}
  49. %description devel
  50. The GTK+ 2 port of the wxWidgets library, header files.
  51. %package -n wxBase
  52. Summary: Non-GUI support classes from the wxWidgets library
  53. Group: System Environment/Libraries
  54. %description -n wxBase
  55. Every wxWidgets application must link against this library. It contains
  56. mandatory classes that any wxWidgets code depends on (like wxString) and
  57. portability classes that abstract differences between platforms. wxBase can
  58. be used to develop console mode applications -- it does not require any GUI
  59. libraries or the X Window System.
  60. %prep
  61. %setup -qn wxGTK-%{version}
  62. %patch1 -p1 -b .char
  63. sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
  64. # fix plugin dir for 64-bit
  65. sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
  66. # fix permissions for sources
  67. chmod a-x include/wx/{msgout.h,dcgraph.h,graphics.h}
  68. chmod a-x src/common/msgout.cpp
  69. %build
  70. %configure --enable-accel \
  71. --enable-controls \
  72. --enable-shared \
  73. --enable-unicode \
  74. --enable-sound \
  75. --enable-intl \
  76. --enable-display \
  77. --enable-geometry \
  78. --enable-graphics_ctx \
  79. --disable-rpath \
  80. --with-expat \
  81. --with-gtk \
  82. --with-libpng \
  83. --with-libjpeg \
  84. --with-libtiff \
  85. --with-libxpm \
  86. --with-opengl \
  87. --with-regex \
  88. --with-sdl \
  89. --with-zlib
  90. %{__make} %{?_smp_mflags}
  91. %install
  92. %__rm -rf %{buildroot}
  93. %makeinstall
  94. ln -sf %{_libdir}/wx/config/%{wxconfig} %{buildroot}%{_bindir}/wx-config
  95. %makeinstall -C contrib
  96. %clean
  97. %__rm -rf %{buildroot}
  98. %post -p /sbin/ldconfig
  99. %postun -p /sbin/ldconfig
  100. %post -n wxBase -p /sbin/ldconfig
  101. %postun -n wxBase -p /sbin/ldconfig
  102. %files
  103. %defattr(-,root,root,-)
  104. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  105. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  106. %{_libdir}/libwx_gtk2u_adv-*.so.*
  107. %{_libdir}/libwx_gtk2u_aui-*.so.*
  108. %{_libdir}/libwx_gtk2u_core-*.so.*
  109. %{_libdir}/libwx_gtk2u_fl-*.so.*
  110. %{_libdir}/libwx_gtk2u_gizmos-*.so.*
  111. %{_libdir}/libwx_gtk2u_gizmos_xrc*.so.*
  112. %{_libdir}/libwx_gtk2u_gl-*.so.*
  113. %{_libdir}/libwx_gtk2u_html-*.so.*
  114. %{_libdir}/libwx_gtk2u_ogl-*.so.*
  115. %{_libdir}/libwx_gtk2u_plot-*.so.*
  116. %{_libdir}/libwx_gtk2u_qa-*.so.*
  117. %{_libdir}/libwx_gtk2u_richtext-*.so.*
  118. %{_libdir}/libwx_gtk2u_stc-*.so.*
  119. %{_libdir}/libwx_gtk2u_svg-*.so.*
  120. %{_libdir}/libwx_gtk2u_xrc-*.so.*
  121. %files devel
  122. %defattr(-,root,root,-)
  123. %{_bindir}/wx-config
  124. %{_bindir}/wxrc*
  125. %{_includedir}/wx-2.8
  126. %{_libdir}/libwx_*.so
  127. %dir %{_libdir}/wx
  128. %dir %{_libdir}/wx/include
  129. %{_libdir}/wx/include/gtk2*
  130. %dir %{_libdir}/wx/config
  131. %{_libdir}/wx/config/gtk2*
  132. %{_datadir}/aclocal/*
  133. %{_datadir}/bakefile/presets/*
  134. %files -n wxBase
  135. %defattr(-,root,root,-)
  136. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  137. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  138. %{_libdir}/libwx_baseu-*.so.*
  139. %{_libdir}/libwx_baseu_net-*.so.*
  140. %{_libdir}/libwx_baseu_xml-*.so.*
  141. %changelog
  142. * Mon Oct 21 2019 Toshiaki Ara <ara_t@384.jp> 2.8.12-8
  143. - rebuilt with new toolchain.
  144. - add Patch1 from fedora
  145. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.12-7
  146. - rebuilt with new toolchain.
  147. * Fri Jul 18 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-6
  148. - rebuilt with libpng-1.6.12
  149. * Mon Jan 13 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.12-5
  150. - rebuilt with the current environment
  151. * Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-4
  152. - added configure option: --enable-accel, --enable-controls
  153. * Thu Aug 09 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.12-3
  154. - increment release number (+2)
  155. - add version-release to Obsoletes tag
  156. - O: wx-gtk2 < %{version}-%{release}
  157. - O: wx-gtk2-devel < %{version}-%{release}
  158. - remove wx-gtk2* package from repository
  159. * Sun Jul 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
  160. - redefined name, package structure and configure
  161. * Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
  162. - new upstream version
  163. * Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-2
  164. - built with rpm-4.8.1-1 for pkg-config file
  165. - changed libjpeg-devel to libjpeg-turbo-devel
  166. - added BuildRequires: libSM-devel, cppunit-devel, libgnomeprintui-devel
  167. * Tue Jun 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-1
  168. - new upstream version
  169. - dropt all patches
  170. * Tue Feb 23 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.10-4
  171. - added Patch10: wxGTK-2.8.10-gsockgtk.patch
  172. - added conrib libraries
  173. - rebuilt with new toolchain
  174. * Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.10-3
  175. - add patch100 for fix CVE-2009-2369 (Interger OF) from fc10
  176. * Mon Jun 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-2vl5
  177. - spec in UTF-8
  178. * Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-1vl5
  179. - new upstream version
  180. - built with gtk2-2.16.0
  181. * Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.9-1vl5
  182. - new upstream version
  183. - modified BuildPreReq: mesa-libGL-devel mesa-libGLU-devel (instead of XOrg-gl-devel)
  184. * Tue Feb 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.8.7-0vl5
  185. - rebuild with expat-2.0.1
  186. - add BuildPreReq: expat-devel pkgconfig
  187. * Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.7-0vl4
  188. - rebuilt with gtk2-2.12.5
  189. * Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl3
  190. - rebuilt for VineSeed
  191. * Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl2
  192. - add --enable-unicode configure option
  193. * Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> - 2.8.7-0vl1
  194. - new upstream version
  195. * Fri Jun 1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl2
  196. - rebuilt with new toolchain
  197. * Thu May 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl1
  198. - new upstream version
  199. - fixed Obsoletes tag
  200. * Fri Oct 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.2-0vl1
  201. - new upstream version
  202. - added Obsoletes: %{name}-gl %{name}-samples
  203. * Sun Jul 10 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.6.1-0vl1
  204. - new upstream version
  205. - remove private symbol patch
  206. - remove wx-gtk2-gl, wx-gtk2-samples subpackage
  207. * Tue May 25 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.4.2-0vl1
  208. - Initial build.