x-face-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1 | grep -v "is not")
  3. %define origver 1.3.6.24
  4. %define origname x-face
  5. Name: %{origname}
  6. Version: %{origver}
  7. Release: 0vl3
  8. License: GPL2
  9. URL: http://www.jpl.org/elips/
  10. Source0: ftp://ftp.jpl.org/pub/elisp/x-face-%{version}.tar.gz
  11. Source1: ftp://ftp.jpl.org/pub/elisp/make-gray-x-face.el
  12. Source2: ftp://ftp.jpl.org/pub/elisp/x-face-e21.el.gz
  13. Source10: %{origname}-install.sh
  14. Source11: %{origname}-remove.sh
  15. Group: Applications/Editors/Emacs
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildArch: noarch
  18. Summary: X-Face Utilities for XEmacs & Emacs-21,22
  19. Summary(ja): XEmacs 及び Emacs-21,22 上にて X-Face を表示するライブラリ
  20. #Requires: xemacs
  21. Requires: faces faces-xface
  22. # for make-gray-x-face.el
  23. Requires: netpbm-progs
  24. Obsoletes: x-face-xemacs
  25. PreReq: emacsen
  26. %prereq_ge emacsen-common
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  30. %description
  31. X-Face enables to display 48x48 X11 bitmap "Face" in-line
  32. for various MUAs on XEmacs.
  33. After installation, add below lines to your ~/.emacs file:
  34. (when (and window-system (module-installed-p 'x-face))
  35. (autoload 'x-face-xmas-mew-display-x-face "x-face" nil t)
  36. (setq wl-highlight-x-face-function
  37. 'x-face-xmas-mew-display-x-face)
  38. )
  39. %description -l ja
  40. X-Face を使うと、XEmacs 上で動く多くの MUA 上で
  41. 48x48 のビットマップ「Face」をインライン表示することができます。
  42. (当パッケージに同梱している)
  43. x-face-e21.el を使うと、emacs21 上で同様なことができます。
  44. (emacs21 では bitmap-mule を使うこともできますが、~/.x-face-cache
  45. をぐずぐずに崩してしまうので、bitmap-mule を使わずに必ず
  46. 当パッケージを使ってください)
  47. XEmacs の設定例 ~/.xemacs.el(~/.xemacs/init.el)
  48. ;;; XEmacs + Wanderlust の設定
  49. (when (and window-system (module-installed-p 'x-face))
  50. (autoload 'x-face-xmas-mew-display-x-face "x-face" nil t)
  51. (setq wl-highlight-x-face-function
  52. 'x-face-xmas-mew-display-x-face)
  53. )
  54. ;;; XEmacs + Mew の設定
  55. (autoload 'x-face-xmas-mew-display-x-face "x-face")
  56. (setq mew-use-highlight-x-face-function 'x-face-xmas-mew-display-x-face)
  57. 上手く表示できない場合は、付属のドキュメントを参照してみてください。
  58. (%{_defaultdocdir}/%{name}-%{version}/README.ja)
  59. Emacs-21.x の設定例(~/.emacs.el)
  60. ;;; Emacs-21.x + Wanderlust
  61. (autoload 'x-face-decode-message-header "x-face-e21")
  62. (setq wl-highlight-x-face-function 'x-face-decode-message-header)
  63. ;;; Emacs-21.x + Mew
  64. (cond ((featurep 'xemacs)
  65. ;;
  66. )
  67. ((= 21 emacs-major-version)
  68. (setq mew-use-highlight-x-face t
  69. mew-use-highlight-x-face-function 'x-face-decode-message-header)
  70. (define-key mew-summary-mode-map "\C-x4s" 'x-face-save)
  71. (define-key mew-draft-mode-map "\C-x4i" 'x-face-insert)
  72. (define-key mew-draft-header-map "\C-x4i" 'x-face-insert)
  73. (define-key mew-draft-mode-map "\M-t" 'x-face-show)
  74. (define-key mew-draft-header-map "\M-t" 'x-face-show)
  75. )
  76. )
  77. 上手く表示できない場合は、ソースを参照してみてください。
  78. (%{_sharedstatedir}/emacs/site-lisp/%{name}/x-face-e21.el)
  79. Version.1.3.6.14 以降では多階調 の X-Face を表示することが可能です。
  80. make-gray-x-face を使用することにより、多階調 X-Face を作成すること
  81. ができます。(xemacs21.4 及び emacs21 のみ)
  82. make-gray-x-face を使用するには、~/.emacs.el(~/.xemacs/init.el)に
  83. 以下を追加してください。
  84. (autoload 'convert-image-to-gray-x-face "make-gray-x-face" nil t)
  85. M-x convert-image-to-gray-x-face でもって gif か png の絵を
  86. X-Face にしたものを現在位置に挿入します。
  87. (Depth: は 2 から 8 までの値を指定するのですが、まぁ 3 位で良いのではないでしょうか)
  88. 名前(~/.xface)を付けて保存しておけばメール送信時に自動的に添付されます。
  89. また、複数の X-Face を使い分けたい場合は、select-xface を使うと便利です。
  90. (多階調 X-Face を wl で使いたい場合は必ず select-xface を使ってください。
  91. wl に http://lists.airs.net/wl/archive/200203/msg00064.html
  92. が当たってない為)
  93. %prep
  94. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  95. %setup -n x-face-%{version}
  96. cp %{SOURCE2} .
  97. gunzip x-face-e21.el.gz
  98. %install
  99. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  100. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  101. mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
  102. mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/install
  103. mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/remove
  104. cp -a Makefile *.el* *.xpm *.xbm %{SOURCE1} \
  105. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
  106. %_installemacsenscript %{origname} %{SOURCE10}
  107. %_removeemacsenscript %{origname} %{SOURCE11}
  108. %post
  109. ## bytecompile el and install elc
  110. if [ "$1" = 2 ] ; then
  111. %_emacsenPackageRemove %{origname}
  112. fi
  113. %_addemacsenlist %{origname}
  114. %_emacsenPackageInstall %{origname}
  115. %preun
  116. if [ "$1" = 0 ] ; then
  117. %_emacsenPackageRemove %{origname}
  118. %_removeemacsenlist %{origname}
  119. fi
  120. %clean
  121. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  122. %files
  123. %defattr(-,root,root)
  124. %doc ChangeLog.ja METHOD.ja README-Anim.ja README-Makefile.ja README.ja TODO.ja
  125. %doc x-face-beta-logo.xbm x-face-beta-logo.xpm x-face-logo.xbm x-face-logo.xpm
  126. %{_datadir}/emacs/site-lisp/%{origname}
  127. %{_libdir}/emacsen-common/packages/install/%{origname}
  128. %{_libdir}/emacsen-common/packages/remove/%{origname}
  129. %changelog
  130. * Mon Jun 18 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.24-0vl3
  131. - update x-face-e21(Revised:2007/03/06)
  132. - Modded x-face-install.sh, x-face-remove.sh(for emacs-22)
  133. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.6.24-0vl2
  134. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  135. * Fri Jul 9 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.24-0vl1
  136. - update
  137. - update x-face-e21(Revised:2004/05/10)
  138. * Mon Jun 30 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.23-0vl1
  139. - update
  140. * Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl5
  141. - update x-face-e21(Revised:2003/03/24)
  142. - Copyright -> License
  143. * Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl4
  144. - add Requires: netpbm-progs(for make-gray-x-face.elc)
  145. * Sat May 4 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl3
  146. - mv x-face-xemacs x-face
  147. - Modified %description
  148. * Thu Mar 28 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl2
  149. - Add x-face-e21.el.gz for Emacs-21.1
  150. - Byte Compiled make-gray-x-face.el for Emacs-21.1
  151. * Mon Mar 18 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.20-0vl1
  152. - update to 1.3.6.20
  153. - included make-gray-x-face.el
  154. * Mon Feb 25 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.19-0vl1
  155. - update to 1.3.6.19
  156. - Delete %Patch0(from Elips X-Mail-Count: 0004572)
  157. * Thu Feb 21 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.16-0vl2
  158. - Add %Patch0(from Elips X-Mail-Count: 0004572)
  159. * Wed Feb 20 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.16-0vl1
  160. - update to 1.3.6.16
  161. - Delete Requires: netpbm
  162. * Thu Feb 15 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.15-0vl1
  163. - update to 1.3.6.15
  164. - add Requires: netpbm
  165. * Sat Jan 26 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.13-0vl3
  166. - Commentout(Requires: xemacs) because name changed xemacs21.1,xemacs21.4
  167. * Sat Jan 12 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.13-0vl2
  168. - x-face-xemacs-install.sh fix(VERSION=)
  169. * Sun Dec 23 2001 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.3.6.13-0vl1
  170. - updated to 1.3.6.13
  171. * Sat Dec 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.6.12-0vl1
  172. - updated to 1.3.6.12 release
  173. - now emacsen-common aware
  174. * Sat Jan 08 2000 MATSUBAYASHI 'Shaolin' Kohji
  175. - 1.3.6.9-1
  176. - updated in sync with 1.3.6.9 release
  177. * Tue Dec 21 1999 MATSUBAYASHI 'Shaolin' Kohji
  178. - 1.3.6.8-1
  179. - updated in sync with 1.3.6.8 release
  180. * Sat Dec 18 1999 MATSUBAYASHI 'Shaolin' Kohji
  181. - 1.3.6.7-1
  182. - updated in sync with 1.3.6.7 release
  183. * Thu Nov 18 1999 MATSUBAYASHI 'Shaolin' Kohji
  184. - 1.3.6.6-1
  185. - updated in sync with 1.3.6.6 release
  186. - change Group to Applications/Editors/EmacsLisp
  187. * Thu Nov 18 1999 MATSUBAYASHI 'Shaolin' Kohji
  188. - 1.3.6.4-1
  189. - updated in sync with 1.3.6.4 release
  190. * Thu Sep 30 1999 MATSUBAYASHI 'Shaolin' Kohji
  191. - 1.3.6-1
  192. - updated to 1.3.6 release
  193. - fixed Copyright: tag
  194. * Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  195. - 1.3.5.5-3
  196. - in sync with downgraded xemacs release (21.1.4-1)
  197. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji
  198. - 1.3.5.5-2
  199. - Requires: faces, faces-xface added
  200. (compface is replaced with faces rpms from Red Hat Rawhide)
  201. * Fri Sep 10 1999 MATSUBAYASHI 'Shaolin' Kohji
  202. - 1.3.5.5-1
  203. - updated to 1.3.5.5 release
  204. * Thu Sep 2 1999 MATSUBAYASHI 'Shaolin' Kohji
  205. - 1.3.5.3-5
  206. - spec has been splitted into mule / xemacs packages
  207. * Sun Aug 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  208. - 1.3.5.3-3
  209. - slight modifications for the %prep & %clean section
  210. * Thu Aug 26 1999 MATSUBAYASHI 'Shaolin' Kohji
  211. - 1.3.5.3-2
  212. - updated for XEmacs 21.1.6
  213. * Mon Jul 12 1999 MATSUBAYASHI 'Shaolin' Kohji
  214. - 1.3.5.3-1
  215. - first RPM release