xalan-j2-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548
  1. # Copyright (c) 2000-2005, JPackage Project
  2. # All rights reserved.
  3. #
  4. # Redistribution and use in source and binary forms, with or without
  5. # modification, are permitted provided that the following conditions
  6. # are met:
  7. #
  8. # 1. Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # 2. Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the
  13. # distribution.
  14. # 3. Neither the name of the JPackage Project nor the names of its
  15. # contributors may be used to endorse or promote products derived
  16. # from this software without specific prior written permission.
  17. #
  18. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  19. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  20. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  21. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  22. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  23. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  24. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  25. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  26. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  27. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  28. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  29. #
  30. %define section free
  31. %define cvs_version 2_7_1
  32. Name: xalan-j2
  33. Summary: Java XSLT processor
  34. Summary(ja): Java XSLT プロセッサ
  35. Version: 2.7.1
  36. Release: 4%{?_dist_release}
  37. Group: Development/Libraries
  38. # src/org/apache/xpath/domapi/XPathStylesheetDOM3Exception.java is W3C
  39. License: ASL 2.0 and W3C
  40. URL: http://xalan.apache.org/
  41. # using binary for bootstrap
  42. Source0: http://archive.apache.org/dist/xml/xalan-j/xalan-j_2_7_1-src.tar.gz
  43. Source1: %{name}-serializer-MANIFEST.MF
  44. Source2: http://repo1.maven.org/maven2/xalan/xalan/2.7.1/xalan-2.7.1.pom
  45. Source3: http://repo1.maven.org/maven2/xalan/serializer/2.7.1/serializer-2.7.1.pom
  46. Source4: xsltc-%{version}.pom
  47. Source5: %{name}-MANIFEST.MF
  48. Patch0: %{name}-noxsltcdeps.patch
  49. # Fix CVE-2014-0107: insufficient constraints in secure processing
  50. # feature (oCERT-2014-002). Generated form upstream revisions 1581058
  51. # and 1581426.
  52. Patch2: %{name}-CVE-2014-0107.patch
  53. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  54. BuildArch: noarch
  55. BuildRequires: javapackages-tools
  56. BuildRequires: java-devel
  57. BuildRequires: ant
  58. BuildRequires: bcel
  59. BuildRequires: java_cup
  60. BuildRequires: regexp
  61. BuildRequires: sed
  62. #BuildRequires: tomcat-servlet-3.1-api
  63. BuildRequires: xerces-j2 >= 2.7.1
  64. BuildRequires: xml-commons-apis >= 1.3
  65. BuildRequires: xml-stylebook
  66. BuildRequires: zip
  67. Requires: xerces-j2
  68. Requires(post): /sbin/update-alternatives
  69. Requires(preun): /sbin/update-alternatives
  70. Provides: jaxp_transform_impl
  71. %description
  72. Xalan is an XSLT processor for transforming XML documents into HTML,
  73. text, or other XML document types. It implements the W3C Recommendations
  74. for XSL Transformations (XSLT) and the XML Path Language (XPath). It can
  75. be used from the command line, in an applet or a servlet, or as a module
  76. in other program.
  77. %package xsltc
  78. Summary: XSLT compiler
  79. Summary(ja): XSLT コンパイラ
  80. Group: Development/Libraries
  81. Requires: java_cup
  82. Requires: bcel
  83. Requires: regexp
  84. Requires: xerces-j2
  85. %description xsltc
  86. The XSLT Compiler is a Java-based tool for compiling XSLT stylesheets into
  87. lightweight and portable Java byte codes called translets.
  88. %package manual
  89. Summary: Manual for %{name}
  90. Group: Documentation
  91. %description manual
  92. Documentation for %{name}.
  93. %package javadoc
  94. Summary: Javadoc for %{name}
  95. Group: Documentation
  96. BuildRequires: java-javadoc
  97. %description javadoc
  98. Javadoc for %{name}.
  99. %package demo
  100. Summary: Demo for %{name}
  101. Requires: %{name} = %{epoch}:%{version}-%{release}
  102. #Requires: tomcat-servlet-3.1-api
  103. %description demo
  104. Demonstrations and samples for %{name}.
  105. %prep
  106. %setup -q -n xalan-j_%{cvs_version}
  107. %patch0 -p0
  108. %patch2 -p1
  109. find . -name '*.jar' -delete
  110. find . -name '*.class' -delete
  111. # this tar.gz contains bundled software, some of which has unclear
  112. # licensing terms (W3C Software/Document license) . We could probably
  113. # replicate this with our jars but it's too much work so just generate
  114. # non-interlinked documentation
  115. rm src/*tar.gz
  116. sed -i '/<!-- Expand jaxp sources/,/<delete file="${xml-commons-srcs.tar}"/{d}' build.xml
  117. # Remove classpaths from manifests
  118. sed -i '/class-path/I d' $(find -iname '*manifest*')
  119. # Convert CR-LF to LF-only
  120. sed -i s/ // KEYS LICENSE.txt NOTICE.txt xdocs/style/resources/script.js \
  121. xdocs/sources/xsltc/README* `find -name '*.sh'`
  122. %build
  123. if [ ! -e "$JAVA_HOME" ] ; then export JAVA_HOME="%{java_home}" ; fi
  124. pushd lib
  125. ln -sf $(build-classpath java_cup-runtime) runtime.jar
  126. ln -sf $(build-classpath bcel) BCEL.jar
  127. ln -sf $(build-classpath regexp) regexp.jar
  128. ln -sf $(build-classpath xerces-j2) xercesImpl.jar
  129. ln -sf $(build-classpath xml-commons-apis) xml-apis.jar
  130. popd
  131. pushd tools
  132. ln -sf $(build-classpath java_cup) java_cup.jar
  133. ln -sf $(build-classpath ant) ant.jar
  134. ln -sf $(build-classpath xml-stylebook) stylebook-1.0-b3_xalan-2.jar
  135. popd
  136. export CLASSPATH=$(build-classpath servlet)
  137. ant \
  138. -Djava.awt.headless=true \
  139. -Dapi.j2se=%{_javadocdir}/java \
  140. -Dbuild.xalan-interpretive.jar=build/xalan-interpretive.jar \
  141. xalan-interpretive.jar\
  142. xsltc.unbundledjar \
  143. samples \
  144. docs
  145. # javadocs \
  146. # servlet
  147. %install
  148. rm -rf $RPM_BUILD_ROOT
  149. # inject OSGi manifests
  150. mkdir -p META-INF
  151. cp -p %{SOURCE1} META-INF/MANIFEST.MF
  152. touch META-INF/MANIFEST.MF
  153. zip -u build/serializer.jar META-INF/MANIFEST.MF
  154. cp -p %{SOURCE5} META-INF/MANIFEST.MF
  155. touch META-INF/MANIFEST.MF
  156. zip -u build/xalan-interpretive.jar META-INF/MANIFEST.MF
  157. # jars
  158. install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
  159. install -p -m 644 build/xalan-interpretive.jar \
  160. $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
  161. install -p -m 644 build/xsltc.jar \
  162. $RPM_BUILD_ROOT%{_javadir}/xsltc.jar
  163. install -p -m 644 build/serializer.jar \
  164. $RPM_BUILD_ROOT%{_javadir}/%{name}-serializer.jar
  165. # POMs
  166. #install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
  167. #install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}.pom
  168. #install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}-serializer.pom
  169. #install -p -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-xsltc.pom
  170. #add_maven_depmap JPP-%{name}.pom %{name}.jar
  171. #add_maven_depmap JPP-%{name}-serializer.pom %{name}-serializer.jar
  172. #add_maven_depmap -f xsltc JPP-xsltc.pom xsltc.jar
  173. # javadoc
  174. #install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}
  175. #cp -pr build/docs/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
  176. #rm -rf build/docs/apidocs
  177. # demo
  178. install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}
  179. install -p -m 644 build/xalansamples.jar \
  180. $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
  181. #install -p -m 644 build/xalanservlet.war \
  182. # $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-servlet.war
  183. cp -pr samples $RPM_BUILD_ROOT%{_datadir}/%{name}
  184. # fix link between manual and javadoc
  185. (cd build/docs; ln -sf %{_javadocdir}/%{name} apidocs)
  186. # jaxp_transform_impl ghost symlink
  187. ln -s %{_sysconfdir}/alternatives \
  188. $RPM_BUILD_ROOT%{_javadir}/jaxp_transform_impl.jar
  189. %clean
  190. rm -rf $RPM_BUILD_ROOT
  191. %post
  192. /sbin/update-alternatives \
  193. --install %{_javadir}/jaxp_transform_impl.jar \
  194. jaxp_transform_impl %{_javadir}/%{name}.jar 30
  195. %preun
  196. if [ $1 -eq 0 ] ; then
  197. /sbin/update-alternatives --remove jaxp_transform_impl %{_javadir}/%{name}.jar
  198. fi
  199. %post javadoc
  200. rm -f %{_javadocdir}/%{name}
  201. ln -s %{name}-%{version} %{_javadocdir}/%{name}
  202. %postun javadoc
  203. if [ "$1" = "0" ]; then
  204. rm -f %{_javadocdir}/%{name}
  205. fi
  206. %files
  207. %defattr(-,root,root,-)
  208. %doc KEYS readme.html
  209. %doc LICENSE.txt NOTICE.txt
  210. %{_javadir}/%{name}.jar
  211. %{_javadir}/%{name}-serializer.jar
  212. %ghost %{_javadir}/jaxp_transform_impl.jar
  213. %files xsltc
  214. %defattr(-,root,root,-)
  215. %doc LICENSE.txt NOTICE.txt
  216. %{_javadir}/xsltc.jar
  217. %files manual
  218. %defattr(-,root,root,-)
  219. %doc LICENSE.txt NOTICE.txt
  220. %doc build/docs/*
  221. #files javadoc
  222. #defattr(-,root,root,-)
  223. #doc LICENSE.txt NOTICE.txt
  224. #doc %{_javadocdir}/%{name}
  225. %files demo
  226. %defattr(-,root,root,-)
  227. %{_datadir}/%{name}
  228. %changelog
  229. * Fri Mar 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.7.1-4
  230. - rebuilt with current VineSeed
  231. * Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-3
  232. - rebuild with Vine6 environment
  233. * Mon Aug 30 2010 Ryoichic INAGAKI <ryo1@bc.wakwak.com> 2.7.1-2
  234. - Initial build for VineLinux
  235. - using binary package for bootstrap
  236. * Wed Apr 7 2010 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-1
  237. - Update to 2.7.1.
  238. - Drop gcj_support.
  239. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-9.5
  240. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  241. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-8.5
  242. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  243. * Tue Feb 3 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.0-7.5
  244. - Add osgi manifest.
  245. * Sat Sep 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0:2.7.0-7.4
  246. - fix license tag
  247. * Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.0-7.3
  248. - drop repotag
  249. - fix license tag
  250. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.0-7jpp.2
  251. - Autorebuild for GCC 4.3
  252. * Fri Apr 20 2007 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.2.fc7
  253. - Rebuild to fix incomplete .db/so files due to broken aot-compile-rpm
  254. * Fri Aug 18 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.1
  255. - Resync with latest from JPP.
  256. * Fri Aug 11 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.3
  257. - Rebuild.
  258. * Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.2
  259. - Rebuild.
  260. * Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.1
  261. - Resync with latest from JPP.
  262. - Partially adopt new naming convention (.1 suffix).
  263. - Use ln and rm explicitly instead of core-utils in Requires(x).
  264. * Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 2.7.0-4jpp_5fc
  265. - Requires(post): coreutils
  266. * Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_4fc
  267. - Extend patch to cover all applicable MANIFEST files in src directory.
  268. * Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_3fc
  269. - Apply patch to replace serializer.jar in MANIFEST file with
  270. xalan-j2-serializer.jar.
  271. * Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.0-4jpp_2fc
  272. - Rebuilt
  273. * Fri Jul 21 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_1fc
  274. - Resync with latest JPP version.
  275. * Wed Jul 19 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-3jpp_1fc
  276. - Merge with latest version from jpp.
  277. - Undo ExcludeArch since eclipse available for all arch-es.
  278. - Remove jars from sources for new upstream version.
  279. - Purge unused patches from previous release.
  280. - Conditional native compilation with GCJ.
  281. - Use NVR macros wherever possible.
  282. * Wed Mar 8 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.6.0-3jpp_10fc
  283. - excluded s390[x] and ppc64 due to eclipse
  284. * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.6.0-3jpp_9fc
  285. - stop scriptlet spew
  286. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_8fc
  287. - bump again for double-long bug on ppc(64)
  288. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_7fc
  289. - rebuilt for new gcc4.1 snapshot and glibc changes
  290. * Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_6fc
  291. - rebuild again
  292. * Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.3
  293. - patch to not use target= in build.xml
  294. * Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.1
  295. - rebuild again with gcc-4.1
  296. * Fri Dec 09 2005 Warren Togami <wtogami@redhat.com> 0:2.6.0-3jpp_5fc
  297. - rebuild with gcc-4.1
  298. * Tue Nov 1 2005 Archit Shah <ashah at redhat.com> 0:2.6.0-3jpp_4fc
  299. - Exclude war which blocks aot compilation of main jar (#171005).
  300. * Tue Jul 19 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_3fc
  301. - Build on ia64, ppc64, s390 and s390x.
  302. - Switch to aot-compile-rpm (also BC-compiles xsltc and samples).
  303. * Tue Jun 28 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_2fc
  304. - Remove a tarball from the tarball too.
  305. - Fix demo subpackage's dependencies.
  306. * Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_1fc
  307. - Remove jarfiles from the tarball.
  308. * Fri May 27 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp
  309. - Add NOTICE file as per Apache License version 2.0.
  310. - Build with servletapi5.
  311. * Fri May 27 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_3fc
  312. - Remove now-unnecessary workaround for #130162.
  313. - Rearrange how BC-compiled stuff is built and installed.
  314. * Tue May 24 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_2fc
  315. - Add DOM3 stubs to classes that need them (#152255).
  316. - BC-compile the main jarfile.
  317. * Fri Apr 1 2005 Gary Benson <gbenson@redhat.com>
  318. - Add NOTICE file as per Apache License version 2.0.
  319. * Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_1fc
  320. - Sync with RHAPS.
  321. * Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-2jpp_1rh
  322. - Merge with latest community release
  323. * Thu Nov 4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.0-1jpp_2fc
  324. - Build into Fedora.
  325. * Thu Aug 26 2004 Ralph Apel <r.ape at r-apel.de> 0:2.6.0-2jpp
  326. - Build with ant-1.6.2
  327. - Try with -Djava.awt.headless=true
  328. * Mon Jul 26 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-1jpp_1rh
  329. - Merge with latest community version
  330. * Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.5.2-1jpp_2rh
  331. - add RHUG upgrade cleanup
  332. * Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.0-1jpp
  333. - Updated to 2.6.0
  334. - Patches supplied by <aleksander.adamowski@altkom.pl>
  335. * Thu Mar 4 2004 Frank Ch. Eigler <fche@redhat.com> - 0:2.5.2-1jpp_1rh
  336. - RH vacuuming
  337. * Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.2-1jpp
  338. - Update to 2.5.2.
  339. - Re-enable javadocs, new style versionless symlink handling, crosslink
  340. with local J2SE javadocs.
  341. - Spec cleanups.
  342. * Sat Jun 7 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.1-1jpp
  343. - Update to 2.5.1.
  344. - Fix jpackage-utils version in BuildRequires, add xerces-j2.
  345. - Non-versioned javadoc symlinking.
  346. - Add one missing epoch.
  347. - Clean up manifests from Class-Path's and other stuff we don't include.
  348. - xsltc no longer provides a jaxp_transform_impl because of huge classpath
  349. and general unsuitablity for production-use, system-installed transformer.
  350. - Own (ghost) %%{_javadir}/jaxp_transform_impl.jar.
  351. - Remove alternatives in preun instead of postun.
  352. - Disable javadoc subpackage for now:
  353. <http://issues.apache.org/bugzilla/show_bug.cgi?id=20572>
  354. * Thu Mar 27 2003 Nicolas Mailhot <Nicolas.Mailhot@One2team.com> 0:2.5.0.d1-1jpp
  355. - For jpackage-utils 1.5
  356. * Wed Jan 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.4.1-2jpp
  357. - bsf -> oldbsf.
  358. - Use non-versioned jar in alternative, don't remove it on upgrade.
  359. - Remove hardcoded packager tag.
  360. * Mon Nov 04 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4.1-1jpp
  361. - 2.4.1
  362. * Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4.0-1jpp
  363. - 2.4.0.
  364. * Thu Aug 22 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.4-0.D1.3jpp
  365. - corrected case for Group tag
  366. - fixed servlet classpath
  367. * Tue Aug 20 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4-0.D1.2jpp
  368. - Remove xerces-j1 runtime dependency.
  369. - Add bcel, jlex, regexp to xsltc runtime requirements:
  370. <http://xml.apache.org/xalan-j/xsltc_usage.html>
  371. - Build with -Dbuild.compiler=modern (IBM 1.3.1) to avoid stylebook errors.
  372. - XSLTC now provides jaxp_transform_impl too.
  373. - Earlier changes by Henri, from unreleased 2.4-D1.1jpp:
  374. Mon Jul 15 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4-D1.1jpp
  375. - 2.4D1
  376. - use the jlex 1.2.5-5jpp (patched by Xalan/XSLTC team) rpm
  377. - use the stylebook-1.0-b3_xalan-2.jar included in source file till it will
  378. be packaged in jpackage
  379. - use jaxp_parser_impl (possibly xerces-j2) instead of xerces-j1 for docs
  380. generation, since it's tuned for stylebook-1.0-b3_xalan-2.jar
  381. - build and provide xsltc in a separate rpm
  382. * Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-2jpp
  383. - provides jaxp_transform_impl
  384. - requires jaxp_parser_impl
  385. - stylebook already requires xml-commons-apis
  386. - jaxp_parser_impl already requires xml-commons-apis
  387. - use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
  388. * Wed Jun 26 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.3.1-2jpp
  389. - fix built classpath (bsf, bcel are existing jpackage rpms),
  390. - add buildrequires for javacup and JLex
  391. * Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-1jpp
  392. - 2.3.1
  393. - vendor, distribution, group tags
  394. * Mon Mar 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-2jpp
  395. - generic servlet support
  396. * Wed Feb 20 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-1jpp
  397. - 2.3.0
  398. - no more compat jar
  399. * Sun Jan 27 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-2jpp
  400. - adaptation to new stylebook1.0b3 package
  401. - used source tarball
  402. - section macro
  403. * Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-1jpp
  404. - 2.2.0 final
  405. - versioned dir for javadoc
  406. - no dependencies for manual and javadoc packages
  407. - stricter dependency for compat and demo packages
  408. - fixed package confusion
  409. - adaptation for new servlet3 package
  410. - requires xerces-j1 instead of jaxp_parser
  411. - xml-apis jar now in required xml-commons-apis external package
  412. * Wed Dec 5 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D14-1jpp
  413. - 2.2.D14
  414. - javadoc into javadoc package
  415. - compat.jar into compat package
  416. - compat javadoc into compat-javadoc package
  417. * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-2jpp
  418. - changed extension to jpp
  419. - prefixed xml-apis
  420. * Tue Nov 20 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-1jpp
  421. - 2.2.D13
  422. - removed packager tag
  423. * Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D11-1jpp
  424. - 2.2.D11
  425. * Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-2jpp
  426. - first unified release
  427. - s/jPackage/JPackage
  428. * Fri Sep 14 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-1mdk
  429. - cvs references
  430. - splitted demo package
  431. - moved demo files to %{_datadir}/%{name}
  432. - only manual package requires stylebook-1.0b3
  433. - only demo package requires servletapi3
  434. * Wed Aug 22 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D9-1mdk
  435. - 2.2.9
  436. - used new source packaging policy
  437. - added samples data
  438. * Wed Aug 08 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D6-1mdk
  439. - first Mandrake release