xanim-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167
  1. # if you want to make xanim_plus version,
  2. # uncomment below line, or rpm --with plus
  3. # % define plus 1
  4. %define plus 0
  5. %{?_with_plus:%define plus 1}
  6. %if %{plus}
  7. %define name xanim_plus
  8. %else
  9. %define name xanim
  10. %endif
  11. Summary: An X based viewer for many animation/video/audio file formats.
  12. Summary(ja): アニメーション/ビデオ/オーディオ・ビューア
  13. Name: %{name}
  14. Version: 2.80.1
  15. Release: 4%{?_dist_release}
  16. #Serial: 2
  17. License: MIT
  18. Group: Applications/Multimedia
  19. Url: http://xanim.va.pubnix.com/
  20. Source: ftp://xanim.va.pubnix.com/xanim2801.tar.gz
  21. %if %{plus}
  22. Source1: ftp://xanim.va.pubnix.com/modules/xa2.0_cvid_linuxELFg21.o.gz
  23. Source2: ftp://xanim.va.pubnix.com/modules/xa2.1_iv32_linuxELFg21.o.gz
  24. Source3: ftp://xanim.va.pubnix.com/modules/xa1.0_cyuv_linuxELFg21.o.gz
  25. %endif
  26. Patch0: xanim-libpath.patch
  27. Patch1: http://radar.sci.hokudai.ac.jp/~kato/computer/Util/xanim/xanim_wheelmouse.diff
  28. Patch2: xanim.Imakefile.mod.patch
  29. #BuildRequires: XOrg-devel zlib-devel
  30. BuildRequires: xorg-x11-devel zlib-devel
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. %if %{plus}
  35. Provides: xanim
  36. Obsoletes: xanim
  37. %endif
  38. %description
  39. The XAnim program is an animation/video/audio viewer for the X Window
  40. System. XAnim can display a large variety of animation, audio and
  41. video formats.
  42. Install the xanim package if you need a viewer for an animation, video
  43. or audio file.
  44. %description -l ja
  45. XAnim は,Xウィンドウシステム上で動作する,アニメーション/ビデオ/オーデ
  46. ィオ・ビューアです.XAnim はさまざまなアニメーション/ビデオ/オーディオの
  47. フォーマットに対応しています.
  48. 一部著作権の問題で配布ソースに含まれていないデコーダ(Radius Cinepak,
  49. Intel Indeo 3.2,Creative Technology's CYUV)があります.これも,xanim
  50. の web ページから取得し,make し直すこと によって対応することができま
  51. す.(specファイルを参照してください.)
  52. #'
  53. %prep
  54. %setup -q -n xanim2801
  55. %patch0 -p1 -b .orig
  56. %patch1 -p0 -b .wheel
  57. #mv *.readme docs || :
  58. %if %{plus}
  59. mkdir -p mods
  60. cp %SOURCE1 %SOURCE2 %SOURCE3 mods
  61. gunzip mods/*
  62. %patch2 -p0
  63. %endif
  64. %build
  65. xmkmf
  66. #make xanim INCDIR=/usr/X11R6/include/X11
  67. make xanim INCDIR=/usr/include/X11
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. make DESTDIR=$RPM_BUILD_ROOT install
  71. cp -pr docs/xanim.man .
  72. #make DESTDIR=$RPM_BUILD_ROOT install.man
  73. make DESTDIR=$RPM_BUILD_ROOT MANPATH=%{_mandir} install.man
  74. mkdir -p $RPM_BUILD_ROOT%{_libdir}/xanim
  75. %if %{plus}
  76. for codec in *.xa; do
  77. install -m755 $codec $RPM_BUILD_ROOT%{_libdir}/xanim || :
  78. done
  79. %endif
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %files
  83. %defattr(-,root,root)
  84. %doc docs/*
  85. #/usr/X11R6/bin/xanim
  86. #/usr/X11R6/man/man1/xanim.1x*
  87. %{_bindir}/xanim
  88. %{_mandir}/man1/xanim.1x*
  89. %dir %{_libdir}/xanim
  90. %if %{plus}
  91. %{_libdir}/xanim/*
  92. %endif
  93. %changelog
  94. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.80.1-4vl5
  95. - applied new versioning policy, spec in utf-8
  96. - changed path of x11
  97. - added value of MANPATH in make-install
  98. * Fri Jun 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.80.1-3vl15
  99. - rebuild with new toolchains
  100. - s/Copyright/License/
  101. * Fri Apr 20 2001 Jun Nishii <jun@vinelinux.org>
  102. - 2.80.1-3vl14
  103. - added macro:plus
  104. * Thu Jul 13 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  105. - 2.80.1-3vl13
  106. - modified %patch1 -p1 -> %patch1 -p0
  107. - fix %prep section
  108. - modified %files section to handle compressed man pages
  109. - modified BuildRoot:
  110. * Thu Dec 2 1999 Jun NISHII <jun@flatout.org>
  111. - fix defattr
  112. * Thu Nov 18 1999 Jun NISHII <jun@flatout.org>
  113. - added Japanese summary and description
  114. - added wheel mouse patch
  115. * Tue Jun 22 1999 Matt Wilson <msw@redhat.com>
  116. - removed proprietary codecs
  117. * Fri May 14 1999 Bill Nottingham <notting@redhat.com>
  118. - add alpha codecs.
  119. * Mon May 10 1999 Bill Nottingham <notting@redhat.com>
  120. - update to 2.80.1
  121. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  122. - auto rebuild in the new build environment (release 4)
  123. * Mon Mar 15 1999 Michael Maher <mike@redhat.com>
  124. - built new codecs for glibc2.1
  125. * Thu Nov 05 1998 Michael Maher <mike@redhat.com>
  126. - added binary codecs to read other formats.
  127. * Wed Sep 02 1998 Michael Maher <mike@redhat.com>
  128. - updated package
  129. * Fri Aug 7 1998 Jeff Johnson <jbj@redhat.com>
  130. - build root
  131. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  132. - translations modified for de, fr, tr
  133. * Fri Aug 22 1997 Erik Troan <ewt@redhat.com>
  134. - built against glibc