xawtv-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377
  1. # How to build xawtv-fonts
  2. # rpm -bb --target noarch xawtv.spec
  3. #
  4. Name: xawtv
  5. Summary: A TV application for video4linux compliant devices.
  6. Summary(ja): video4linux 互換デバイス用の TV アプリケーション
  7. Version: 3.95
  8. Release: 0vl1
  9. %define fontsver 1.1
  10. %define fontsrel 0vl1
  11. %define withalsa $([ -f /usr/include/linux/asound.h ] && echo enable || echo disable)
  12. %define alsa %([ "%{withalsa}" = "enable" ] && echo 1 || echo 0)
  13. %define applnkdir %([ -d %{_datadir}/applications ] && echo %{_datadir}/applications || echo /etc/X11/applnk/Multimedia )
  14. # for RedHat-6.x/Vine-2.x
  15. %define _sysconfdir /etc
  16. %define fontsdir /usr/X11R6/lib/X11/fonts/misc
  17. %define pixmapsdir %{_datadir}/pixmaps
  18. Source: http://bytesex.org/xawtv/%{name}-%{version}.tar.gz
  19. Source1: http://bytesex.org/xawtv/tv-fonts-%{fontsver}.tar.bz2
  20. Source2: v4l-conf.pam
  21. Source10: xawtvrc.JP
  22. Source11: bttv-tuneUp.sh
  23. #Patch: http://telia.dl.sourceforge.net/sourceforge/xaw-deinterlace/xaw-deinterlace-%{subver}.diff.bz2
  24. Group: Applications/Multimedia
  25. License: GPL
  26. URL: http://bytesex.org/xawtv/
  27. BuildPrereq: XFree86-devel, ncurses-devel libjpeg-devel
  28. BuildPrereq: make >= 3.80
  29. BuildPrereq: openMotif-devel >= 2.2.2
  30. PreReq: XFree86 , XFree86-xfs
  31. Requires: usermode
  32. Requires: %{name}-fonts
  33. %if %alsa
  34. Requires: alsa-driver
  35. %endif
  36. BuildRoot: %{_tmppath}/%{name}-root
  37. Excludearch: sparc s390 s390x
  38. %{?nosrc:NoSource: 0}
  39. %{?nosrc:NoSource: 1}
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. %description
  43. Xawtv is a simple xaw-based TV program which uses the bttv driver or
  44. video4linux. Xawtv contains various command-line utilities for
  45. grabbing images and .avi movies, for tuning in to TV stations, etc.
  46. Xawtv also includes a grabber driver for vic.
  47. %package motv
  48. Summary: Motif TV application
  49. Summary(ja): MOTIF 版の TV アプリケーション
  50. Requires: openMotif >= 2.2.2
  51. Requires: xawtv = %{version}-%{release}
  52. Group: Applications/Multimedia
  53. %description motv
  54. motv is a TV application which is build on Motif library.
  55. %package fonts
  56. Summary: Fonts for Xawtv
  57. Summary(ja): Xawtv 用フォント
  58. Group: Applications/Multimedia
  59. Version: %{fontsver}
  60. Release: %{fontsrel}
  61. PreReq: /usr/X11R6/bin/xset
  62. %description fonts
  63. Fonts collection for Xawtv
  64. %prep
  65. %setup -q -a 1
  66. #patch -p1
  67. %__cp %{SOURCE10} ./
  68. %__cp %{SOURCE11} ./tuneUp.sh
  69. %build
  70. %ifarch noarch
  71. # make fonts
  72. cd tv-fonts-%{fontsver}
  73. PATH=$PATH:/usr/X11R6/bin ; export PATH
  74. DISPLAY= make
  75. %else
  76. PATH=$PATH:/usr/X11R6/bin ; export PATH
  77. #configure --%{withalsa}-alsa --enable-motif --enable-xfree-ext --enable-xvideo --enable-xft
  78. %configure --enable-motif --enable-xfree-ext --enable-xvideo --enable-xft
  79. %__make
  80. %endif
  81. %install
  82. %ifarch noarch
  83. # install fonts
  84. %__mkdir -p %{buildroot}%{fontsdir}
  85. %__install tv-fonts-%{fontsver}/*.gz %{buildroot}%{fontsdir}
  86. %else
  87. %__rm -rf %{buildroot}
  88. #PATH=$PATH:/usr/X11R6/bin ; export PATH
  89. #makeinstall DESTDIR="%{buildroot}" SUID_ROOT="" install
  90. make DESTDIR="%{buildroot}" SUID_ROOT="" install
  91. %__install -d %{buildroot}%{_sbindir} \
  92. %{buildroot}%{_libdir}/%{name} \
  93. %{buildroot}%{_sysconfdir}/pam.d \
  94. %{buildroot}%{_sysconfdir}/security/console.apps \
  95. %{buildroot}%{pixmapsdir}
  96. %__install -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/pam.d/v4l-conf
  97. echo "SESSION=true" > %{buildroot}%{_sysconfdir}/security/console.apps/v4l-conf
  98. echo "USER=root" >> %{buildroot}%{_sysconfdir}/security/console.apps/v4l-conf
  99. echo "PROGRAM=%{_sbindir}/v4l-conf" >> %{buildroot}%{_sysconfdir}/security/console.apps/v4l-conf
  100. %__mv %{buildroot}%{_bindir}/v4l-conf %{buildroot}%{_sbindir}/
  101. ln -s consolehelper %{buildroot}%{_bindir}/v4l-conf
  102. %__install -d %{buildroot}%{_bindir}/X11
  103. ln -s %{_bindir}/xawtv %{buildroot}%{_bindir}/X11/xawtv
  104. %__install contrib/xawtv32x32.xpm %{buildroot}%{pixmapsdir}/%{name}.xpm
  105. #__mv %{buildroot}%{_libdir}/*.so %{buildroot}%{_libdir}/%{name}
  106. %__install -d %{buildroot}/etc/X11
  107. %__install xawtvrc.JP %{buildroot}/etc/X11/xawtvrc
  108. # prepare applnk
  109. %__install -d %{buildroot}%{applnkdir}
  110. cat > $RPM_BUILD_ROOT%{applnkdir}/%{name}.desktop <<EOF
  111. [Desktop Entry]
  112. Name=TV
  113. Comment=television
  114. Exec=xawtv
  115. Icon=%{pixmapsdir}/%{name}.xpm
  116. Terminal=false
  117. MultipleArgs=false
  118. Type=Application
  119. Categories=GNOME;Application;AudioVideo;Video
  120. EOF
  121. %endif
  122. %post
  123. %{_sbindir}/v4l-conf -q || :
  124. %post fonts
  125. {
  126. cd %{fontsdir}
  127. mkfontdir > /dev/null 2>&1
  128. cd -
  129. }
  130. if [ ".$DISPLAY" != "." ]; then
  131. xset fp rehash > /dev/null 2>&1
  132. true
  133. fi
  134. %postun fonts
  135. if [ $1 = 0 ]; then
  136. {
  137. cd %{fontsdir}
  138. /usr/X11R6/bin/mkfontdir > /dev/null 2>&1
  139. cd -
  140. }
  141. if [ ".$DISPLAY" != "." ]; then
  142. /usr/X11R6/bin/xset fp rehash > /dev/null 2>&1
  143. true
  144. fi
  145. fi
  146. %clean
  147. rm -fr $RPM_BUILD_ROOT
  148. %ifarch noarch
  149. %files fonts
  150. %defattr(-,root,root)
  151. %{fontsdir}
  152. %else
  153. %files
  154. %defattr(-,root,root)
  155. %config /usr/X11R6/lib/X11/app-defaults/Xawtv
  156. %config(noreplace) %{_sysconfdir}/pam.d/v4l-conf
  157. %config(noreplace) %{_sysconfdir}/security/console.apps/v4l-conf
  158. %{_bindir}/[^Xm]*
  159. %attr(0711,root,root) %{_sbindir}/v4l-conf
  160. %{_bindir}/X11/xawtv
  161. /usr/X11R6/lib/X11/app-defaults/mtt
  162. %{_libdir}/%{name}
  163. %{_datadir}/%{name}
  164. %{_mandir}/man?/[^m]*
  165. %{_mandir}/*/man?/[^m]*
  166. %{_mandir}/man1/mtt.1*
  167. %config(missingok) %{applnkdir}/*
  168. %config(noreplace) /etc/X11/xawtvrc
  169. %doc COPYING README* TODO Changes MAKEDEV.v4l
  170. %doc contrib
  171. %doc xawtvrc* tuneUp.sh
  172. %{pixmapsdir}/*
  173. %files motv
  174. %defattr(-,root,root)
  175. %{_bindir}/motv
  176. /usr/X11R6/lib/X11/app-defaults/MoTV
  177. /usr/X11R6/lib/X11/*/app-defaults/MoTV
  178. %{_mandir}/man1/motv.1*
  179. %endif
  180. %changelog
  181. * Wed Nov 22 2006 Masaki Shinomiya <shino@pos.to> 3.95-0vl1
  182. - new upstream release, desktop launcher, buildprereq libjpeg-devel
  183. - files (motv was both in xawtv and in xawtv-motv package before)
  184. * Wed Aug 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.93-0vl1
  185. - new upstream release
  186. * Thu Apr 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.91-0vl2
  187. - rebuild with libdv-0.102
  188. * Sun Feb 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.91-0vl1
  189. - new upstream release
  190. - add motv subpackage, requires openMotif
  191. - build with openMotif for motv
  192. * Thu Dec 18 2003 Masaki Shinomiya <shino@pos.to> -3.90-0vl1
  193. - source update, xawtv-fonts, remove deinterlace.patch
  194. - 'rpm -bb --target noarch xawtv.spec'
  195. - will make xawtv-fonts package.
  196. - buildrequire make version 3.80 or later
  197. - use %%{buildroot} and some rewrite
  198. * Fri Dec 12 2003 Masaki Shinomiya <shino@pos.to> -3.74-0vl3
  199. - some mannual pages missing even in 0vl2, alsa detecting
  200. * Wed Dec 10 2003 Masaki Shinomiya <shino@pos.to> -3.74-0vl2
  201. - xawtvrc, tuneUp.sh, MAKEDEV.v4l in doc
  202. - some mannual pages used to be missing
  203. - v4l-conf in post install script
  204. - bugfix in rebuild with alsa
  205. * Sun Jan 19 2003 Masaki Shinomiya <shino@pos.to>
  206. -3.74-0vl1: update source, doc, deinterlace patch, Japan.xawtv, URL
  207. - auto detect alsa 0.5x/0.9x, prereq
  208. * Fri Apr 5 2002 Masaki Shinomiya <shino@pos.to>
  209. - 3.73-0vl1: for Vine Linux-2.5
  210. * Sun Mar 31 2002 <shino@pos.to>
  211. - 3.73-0: install libraries in %{_libdir}/xawtv
  212. * Sat Mar 23 2002 <shino@pos.to>
  213. - 3.60-0.1: make symlink, .destop, correct file list
  214. * Fri Aug 17 2001 <sagami@vinelinux.org>
  215. - 3.60-0vl1: initial release for VineSeedPlus
  216. * Sun Aug 5 2001 Nalin Dahyabhai <nalin@redhat.com> 3.54-3
  217. - tweak PAM setup so that v4l-conf can access the display properly
  218. * Tue Jul 10 2001 Elliot Lee <sopwith@redhat.com> 3.54-2
  219. - Rebuild to remove libXv/libXxf86dga deps
  220. * Mon Jul 02 2001 Than Ngo <than@redhat.com>
  221. - update to 3.54
  222. * Fri Jun 22 2001 Than Ngo <than@redhat.com>
  223. - update to 3.53
  224. - add buildprereq
  225. - remove some uneeeded patches
  226. * Tue Jun 19 2001 Karsten Hopp <karsten@redhat.de>
  227. - excludearch s390 s390x
  228. * Wed Jun 13 2001 Than Ngo <than@redhat.com>
  229. - update to 3.51
  230. * Thu Jun 07 2001 Than Ngo <than@redhat.com>
  231. - update to 3.50
  232. * Thu May 31 2001 Than Ngo <than@redhat.com>
  233. - udate to 3.49
  234. * Tue May 22 2001 Than Ngo <than@redhat.com>
  235. - update to 3.48
  236. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  237. - built for the distro
  238. * Wed May 18 2001 Karsten Hopp <karsten@redhat.de>
  239. - make xawtv work with kernel-2.4
  240. * Wed May 16 2001 Than Ngo <than@redhat.com>
  241. - update to 3.47
  242. * Mon May 07 2001 Than Ngo <than@redhat.com>
  243. - update to 3.45
  244. - add missing fonts
  245. * Tue Feb 13 2001 Than Ngo <than@redhat.com>
  246. - update to 3.34
  247. - use consolehelper for v4l-conf
  248. - add excludearch sparc, bdftopcf is broken on sparc
  249. * Wed Jan 24 2001 Than Ngo <than@redhat.com>
  250. - updated to 3.30
  251. - use /dev/video0 instead /dev/video (bug #24871)
  252. - fixed dependencies (Bug #24881)
  253. * Sun Nov 19 2000 Than Ngo <than@redhat.com>
  254. - update to 3.24
  255. - add missing tools (rootv,scantv)
  256. - add missing prereq on xset and mkfontdir
  257. * Fri Nov 3 2000 Than Ngo <than@redhat.com>
  258. - update to 3.23
  259. * Wed Aug 23 2000 Tim Powers <timp@redhat.com>
  260. - rebuilt against new XFree86 to fix DGA problems
  261. * Mon Aug 21 2000 Than Ngo <than@redhat.com>
  262. - update to 3.18 (Bugfix release)
  263. - option -nodga to disable DGA (Bug #16577, #15702)
  264. - compress fonts with gzip
  265. * Mon Aug 07 2000 Tim Powers <timp@redhat.com>
  266. - fixed bug #15435
  267. * Mon Aug 07 2000 Than Ngo <than@redhat.de>
  268. - rebuilt against the new DGA
  269. - fixed in post and postun, so that it does not
  270. emits to console (Bug #15436)
  271. * Sat Jul 29 2000 Than Ngo <than@redhat.de>
  272. - update to 3.17
  273. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  274. - rebuilt
  275. * Wed Jul 12 2000 Than Ngo <than@redhat.de>
  276. - FHS fixes
  277. * Mon Jul 03 2000 Prospector <bugzilla@redhat.com>
  278. - automatic rebuild
  279. * Sun May 28 2000 Ngo Than <than@redhat.de>
  280. - update to 3.14 for 7.0
  281. - put man page in correct place
  282. - add webcam
  283. - bzip2 source
  284. - cleanup specfile
  285. * Wed Jan 19 2000 Preston Brown <pbrown@redhat.com>
  286. - font fix (#8610) in post and postun
  287. - add missing files in bin
  288. * Sun Jan 16 2000 Preston Brown <pbrown@redhat.com>
  289. - whoops! 3.07 already bugfix release
  290. * Fri Jan 14 2000 Ngo Than <than@redhat.de>
  291. - updated to 3.06
  292. * Mon Jul 26 1999 Tim Powers <timp@redhat.com>
  293. - updated to 2.46
  294. - built for 6.1
  295. * Wed Apr 28 1999 Preston Brown <pbrown@redhat.com>
  296. - initial build for Powertools 6.0