xchat-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597
  1. # Nobody likely uses this so we disable it
  2. %define with_tclplugin 0
  3. %define name xchat
  4. %define version 2.8.8
  5. %define release 3%{?_dist_release}
  6. Summary: GTK2 based graphical IRC client
  7. Summary(ja): GTK2 ベースのグラフィカル IRC クライアント
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Group: Applications/Internet
  12. License: GPL
  13. URL: http://www.xchat.org/
  14. Source0: http://www.xchat.org/files/source/2.8/xchat-%{version}.tar.xz
  15. # Patches 0-9 reserved for official xchat.org patches
  16. Patch12: xchat-1.8.7-use-sysconf-to-detect-cpus.patch
  17. # see #241923
  18. Patch35: xchat-2.8.4-disable-tray-icon-by-default.patch
  19. # Upstream XChat 2.8.6 defaults to Latin1 (what upstream calls the "IRC"
  20. # encoding). Default to UTF-8 instead (as previous versions did, at least when
  21. # running under a UTF-8 locale).
  22. # Both the "IRC" and "UTF-8" settings will try to accept both Latin1 and UTF-8
  23. # when it comes in, however "IRC" sends Latin1, "UTF-8" sends UTF-8.
  24. Patch41: xchat-2.8.6-default-utf8.patch
  25. # patch to add ability to change to tab with most recent activity
  26. # See http://sourceforge.net/tracker/?func=detail&aid=2022871&group_id=239&atid=350239
  27. Patch50: xchat-2.8.6-change-page-activity.patch
  28. # add port numbers for Freenode (Debarshi Ray)
  29. Patch51: xchat-2.8.6-freenode-ports.patch
  30. # work with libnotify 0.7
  31. # https://sourceforge.net/tracker/?func=detail&aid=3109838&group_id=239&atid=100239
  32. Patch52: xchat-2.8.8-libnotify07.patch
  33. # Vine
  34. #Source100: xchat-2.4.5-ja.po
  35. Patch100: http://takuo.jp/junk/xchat/99_plus.dpatch
  36. Patch110: http://takuo.jp/junk/xchat/99_x_dialog.dpatch
  37. Patch200: xchat-2.8.6_defaultserver-vine.patch
  38. Patch201: xchat-2.8.8-glib.patch
  39. # xchat MUST have the version of perl installed which was used to compile
  40. # it, or else the embeded perl interpreter will break.
  41. Requires: %(perl -le 'use Config; print $Config{archlibexp}')
  42. BuildRequires: glib2-devel >= 2.2.0
  43. BuildRequires: gtk2-devel >= 2.2.0
  44. BuildRequires: bison >= 1.35
  45. BuildRequires: gettext, sed
  46. BuildRequires: perl, python-devel, openssl-devel, pkgconfig
  47. BuildRequires: autoconf
  48. BuildRequires: GConf2-devel
  49. BuildRequires: dbus-glib-devel >= 0.60
  50. BuildRequires: tcl
  51. Requires(post): GConf2 >= 2.14
  52. Requires(preun): GConf2 >= 2.14
  53. Buildroot: %{_tmppath}/%{name}-%{version}-root
  54. %description
  55. X-Chat is an easy to use graphical IRC chat client for the X Window
  56. System.
  57. %description -l ja
  58. X-ChatはGTK2ベースのXウィンドウシステム用のIRCクライアントです。
  59. %prep
  60. %setup -q
  61. ##%patch10 -p1
  62. %patch12 -p0 -b .use-sysconf-to-detect-cpus
  63. %patch35 -p1 -b .tray-icon
  64. %patch41 -p1 -b .default-utf8
  65. %patch50 -p1 -b .active-channel-switch
  66. %patch51 -p1 -b .freenode-ports
  67. %patch52 -p1 -b .libnotify07
  68. %patch100 -p1 -b .plus
  69. %patch110 -p1 -b .dialog
  70. %patch200 -p1 -b .servlist
  71. %patch201 -p1 -b .glib
  72. sed -i -e 's/#define GTK_DISABLE_DEPRECATED//g' src/fe-gtk/*.c
  73. sed -i -e 's/GETTEXT_MACRO_VERSION = 0\.17/GETTEXT_MACRO_VERSION = 0.18/g' po/Makefile.in.in
  74. %build
  75. touch NEWS ABOUT-NLS
  76. libtoolize --copy --force
  77. aclocal
  78. automake
  79. autoconf
  80. # Remove CVS files from source dirs so they're not installed into doc dirs.
  81. find . -name CVS -type d | xargs rm -rf
  82. export CFLAGS="$RPM_OPT_FLAGS $(perl -MExtUtils::Embed -e ccopts)"
  83. export LDFLAGS=$(perl -MExtUtils::Embed -e ldopts)
  84. if pkg-config openssl ; then
  85. export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
  86. export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
  87. export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
  88. fi
  89. %configure --disable-textfe \
  90. --enable-openssl \
  91. --enable-python \
  92. --disable-spell \
  93. --enable-glibtest \
  94. %if %{with_tclplugin}
  95. i --enable-tcl \
  96. %endif
  97. --enable-ipv6
  98. make %{?_smp_mflags}
  99. %install
  100. rm -rf $RPM_BUILD_ROOT
  101. make DESTDIR=$RPM_BUILD_ROOT install
  102. # Remove unwanted stuff
  103. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  104. rm -f $RPM_BUILD_ROOT%{_libdir}/xchat/plugins/*.la
  105. #rm -f $RPM_BUILD_ROOT%{_datadir}/applications/xchat.desktop
  106. #rm -f $RPM_BUILD_ROOT/etc/X11/applnk/Internet/xchat.desktop
  107. %find_lang %name
  108. %files -f %{name}.lang
  109. %defattr(-,root,root)
  110. %doc README ChangeLog
  111. %{_sysconfdir}/gconf/schemas/*
  112. %{_bindir}/xchat
  113. %{_libdir}/xchat/plugins/*.so
  114. %{_datadir}/applications/xchat.desktop
  115. %{_datadir}/dbus-1/services/*
  116. %{_datadir}/pixmaps/*
  117. %clean
  118. rm -rf $RPM_BUILD_ROOT
  119. %post
  120. # Install schema
  121. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  122. gconftool-2 --makefile-install-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
  123. %pre
  124. if [ "$1" -gt 1 -a -f "/etc/gconf/schemas/apps_xchat_url_handler.schemas" ]; then
  125. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  126. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
  127. fi
  128. %preun
  129. if [ "$1" -eq 0 ]; then
  130. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  131. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
  132. fi
  133. %changelog
  134. * Tue Jul 1 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.8-3
  135. - rebuild with perl-5.16-3
  136. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.8-2
  137. - rebuild with tcl-8.5.15
  138. - add Patch201 (xchat-2.8.8-glib.patch)
  139. - change BuildRequires: dbus-glib-devel instead of dbus-devel
  140. * Sun Mar 27 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.8-1
  141. - new upstream release.
  142. - shipped some patches from Fedora development.
  143. * Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-5
  144. - rebuild with openssl-1.0.0c
  145. - add BuildRequires: tcl
  146. - add Patch201 (xchat-2.8.6-x86_64.patch)
  147. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.6-4
  148. - rebuilt with python-2.6.4-3
  149. * Tue Nov 03 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-3
  150. - updated Patch200 (Vine channel's default encoding to UTF-8)
  151. * Wed Apr 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-2
  152. - rebuilt with gtk2-2.16.0
  153. - don't #define GTK_DISABLE_DEPRECATED (fixes build against current GTK+)
  154. - add Patch200 (set default server connection for Vine people)
  155. - TODO: update ja.po
  156. * Mon Sep 01 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-1
  157. - updated to 2.8.6
  158. - drop/add patches
  159. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-1
  160. - new versioning policy
  161. - rebuilt with perl-5.10.0
  162. - spec in UTF-8
  163. * Tue Jan 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-0vl1
  164. - updated to 2.8.4 with updated plus patch and upstream patches (14-16)
  165. * Tue Jun 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.2-0vl1
  166. - updated to 2.8.2 with plus patch
  167. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.8-0vl4
  168. - rebuild with dbus-1.0
  169. * Wed Nov 29 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.6.8-0vl3
  170. - build without libsexy.
  171. * Thu Nov 23 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl2
  172. - added Patch10 and Patch20 for possible crashes under certain environments
  173. * Thu Oct 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl1
  174. - updated to 2.6.8 with plus patch
  175. * Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl1
  176. - new upstream release
  177. - updated ja.po
  178. - added Patch1 from http://www.xchat.org/files/source/2.4/patches/
  179. - added Patches from Fedora
  180. * Sun May 15 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-3
  181. - Prevent interception of down arrow during Input Method (#144588 tagoh)
  182. * Thu Apr 14 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-2
  183. - fix plugins on lib64 (#113188 Ville Skytta)
  184. * Tue Jan 4 2005 Christopher Aillon <caillon@redhat.com> 1:2.4.1-2
  185. - Add Dan Reed's CTCP patch to support multiline messages (#136545)
  186. * Tue Aug 17 2004 Daniel Reed <djr@redhat.com> 1:2.4.0-2
  187. - #125846 Change xchat.desktop names to "IRC"
  188. * Sun Jan 09 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
  189. - rebuild with perl-5.8.6-0vl2
  190. * Tue Jul 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl3
  191. - rebuild with perl-5.8.2-0vl2
  192. - updated ja.po
  193. * Mon Jun 21 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl2
  194. - resume othersview patch (Patch21)
  195. * Sun Jun 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl1
  196. - new upstream release
  197. - updated Patch10
  198. - dropped unneeded patches
  199. - updated ja.po
  200. * Fri Nov 7 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl5
  201. - build with perl-5.8.2
  202. * Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl4
  203. - build with perl-5.8.1
  204. - change spec file's encoding: shift_jis -> euc-jp
  205. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl3
  206. - add ja.po
  207. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl2
  208. - add patch21 from debian to support othersview.
  209. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl1
  210. - build for Vine Linux based on rawhide
  211. - some parts is merged with Vine Linux 1.8.10-0vl2
  212. * Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.10-0vl2
  213. - rebuilt against gnome-libs-1.4.2-0vl2 (for db1/db4 matters)
  214. - add BuildRequires: automake14, autoconf213
  215. - modified source10 (openprojects has been renamed to freenode)
  216. * Tue Aug 13 2002 IWAI Masaharu <iwai@alib.jp> 1.8.10-0vl1
  217. - upstream update
  218. - updated plus patch
  219. - moved xchat.desktop to %%{_sysconfdir}/X11/applnk/Internet by upstream
  220. * Thu Jul 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl3
  221. - use source10 instead of patch10 for server list
  222. - default server for #VineUsers changed to OpenProjects Network's
  223. * Wed Mar 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl2
  224. - now with 1.8.8 plus patch
  225. * Sat Mar 16 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.8-0vl1
  226. - upstream release
  227. - updated vine-serverlist.patch
  228. - stop to apply plus patch
  229. ( xchat-1.8.4 has the security hole... )
  230. * Tue Oct 2 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl3
  231. - removed backup files for %%patch0 in Document Directory
  232. * Sun Sep 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.4-0vl2
  233. - updated to 1.8.4 release with plus patch :-)
  234. * Sun Sep 30 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl1
  235. - upstream release
  236. * Mon Sep 3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
  237. - 1.8.3-0vl1
  238. - upstream release
  239. - add xchat-text
  240. - add docs: COPYING FAQ plugins/* scripts-perl/* scripts-python/*
  241. * Fri Aug 3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
  242. - 1.8.2-0vl1
  243. - upstream release
  244. * Sat Jul 21 2001 <iwaim@cc.mbn.or.jp>
  245. - 1.8.1-0vl1
  246. - upstream release
  247. - modified server.vine patch
  248. * Sun Jul 15 2001 <sagami@vinelinux.org>
  249. - 1.6.4.1-0vl3: prefix -> _prefix
  250. - OLD_PO_FILE_INPUT=yes to build with new gettext
  251. - use %%{find_lang}
  252. * Wed Apr 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  253. - 1.6.4.1-0vl2
  254. - fix CFLAGS for e-paned
  255. * Tue Feb 6 2001 Takuo KITAME <kitame@northeye.org>
  256. - 1.6.3.1-0vl1
  257. - New upstream release
  258. * Tue Oct 31 2000 Jun Nishii <jun@vinelinux.org>
  259. - 1.5.9.4-0vl1
  260. - This is the first release of xchat-plus.
  261. * Mon Jul 3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  262. - added w3m patch
  263. * Wed Apr 12 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  264. - updated to 1.4.2
  265. * Thu Mar 14 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  266. - updated to 1.4.1
  267. - separated ja_nls patch to more_ja_nls and libjcode patches.
  268. * Sat Mar 04 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  269. - modified mb_fix patch for cut & paste.
  270. * Fri Feb 11 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  271. - updated to 1.4.0
  272. * Wed Feb 2 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  273. - updated to 1.3.13
  274. * Mon Jan 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  275. - modified mb_fix patch
  276. * Wed Jan 5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  277. - updated to 1.3.10
  278. * Wed Dec 8 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
  279. - updated to 1.3.8
  280. - added mb_fix patch
  281. * Tue Nov 9 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
  282. - update to 1.3.6
  283. * Sun Oct 17 1999 Jun NISHII <jun@flatout.org>
  284. - merge ja-patch
  285. * Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-7
  286. - Added back BuildRequires autoconf, and call autoconf prior to ./configure
  287. as it seems to make xchat build successfully. Have not bothered to figure
  288. out why calling autoconf is needed. Something for a rainy day.
  289. * Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-6
  290. - Removed gnome-libs BuildRequires as it is bogus now
  291. - Removed autoconf BuildRequires and usage, as it should be unneeded
  292. - Added new BuildRequires on gettext, bison >= 1.35, glib2-devel >= 2.0.3,
  293. gtk2-devel >= 2.0.3, /bin/sed (#91676 - Warren Togami)
  294. - Removed dead patches: xchat-1.8.9-perlcrypt.patch, xchat-1.8.9-korean-fontset.patch
  295. * Wed May 21 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-5
  296. - Removed xchat.desktop file, as it was earlier replacedwith a patch
  297. - Converted xchat-2.0.2-redhat-desktop-file.patch to be UTF-8 clean now,
  298. instead of the various random legacy mix of encodings it was, updating
  299. the following: es, ko, uk, zh_TW
  300. * Tue May 20 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-4
  301. - Replace explicit perl package name-epoch-version Requires added in 2.0.2-3
  302. with a more robust and generic solution of querying perl for the archlibexp
  303. dir during building, and requiring it instead
  304. * Tue May 20 2003 Bill Nottingham <notting@redhat.com> 2.0.2-3
  305. - rebuild against new (old?) perl, add epoch to dependency
  306. * Sat May 17 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-1
  307. - Updated to new xchat 2.0.2 based on GTK2
  308. - Dropped unneeded patches xchat-1.8.1-konqueror.patch,
  309. xchat-1.8.4-fix-USE_GNOME.patch
  310. - Updated xchat-2.0.2-freenode.patch to refer to Openprojects.net
  311. - Removed doc/xchat.sgml doc/*.html scripts-python scripts-perl from %%doc
  312. - Added xchat-2.0.2-redhat-desktop-file.patch to patch the supplied xchat
  313. desktop file, instead of replacing it and trying to stay in sync
  314. - Added xchat-2.0.2-lib64-cleanup-for-python.patch which fixes build problems
  315. on lib64 archs, and replaces xchat-multilib.patch
  316. - Added with_tclplugin macro and default it to disabled
  317. * Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-8
  318. - Added xchat-1.8.11-nickall.patch which was written by Fabio Olive Leite,
  319. sent to me by Rik van Riel
  320. * Wed Feb 19 2003 Bill Nottingham <notting@redhat.com> 1.8.11-7
  321. - ship single desktop in %{_datadir}/applications, not /etc/X11/applnk
  322. * Fri Jan 31 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-6
  323. - Added xchat-1.8.11-freenode.patch to rename all openprojects.net entries
  324. to freenode.net in the default server list. Patch courtesy of Dan Burcaw
  325. from bug (#81704)
  326. * Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-5
  327. - Removed double .desktop file (#81874,82315)
  328. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 1.8.11-4
  329. - rebuilt
  330. * Tue Jan 7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-3
  331. - Add bugfix from xchat.org xc1811fixststint.diff
  332. * Tue Jan 7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-2
  333. - Remove CVS files from source dirs so they're not installed into doc dirs.
  334. * Tue Jan 7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-1
  335. - Update to xchat 1.8.11 bugfix release, fixes various runtime crashes
  336. - Remove now included patches: xchat-1.8.10-urlhandler-open-in-new-tab.patch,
  337. xchat-1.8.10-beep-beep-beep.patch
  338. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.8.10-13
  339. - Pick up OpenSSL configuration from pkgconfig, if available
  340. - Add openssl-devel and pkgconfig as buildreqs
  341. * Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.8.10-12
  342. - Fix broken libpython path on multilibbed systems (patch13)
  343. - _smp_mflags
  344. * Tue Nov 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-11
  345. - Added xchat-1.8.10-urlhandler-open-in-new-tab.patch to offer the option of
  346. opening a URL in a new tab of an existing browser window rather than a new
  347. window
  348. * Sat Nov 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-10
  349. - Added BuildRequires: python-devel to hopefully pick up a missing dep
  350. causing package build failure in timp's nightly builds.
  351. - Removed dead patches
  352. - Updated package summary and description to be more user friendly by
  353. rewording, and removing scary words like GNOME, GTK and other irrelevance
  354. * Wed Nov 13 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-9
  355. - Made sure {_sysconfdir}/X11/applnk/Internet/xchat.desktop gets packaged
  356. - Removed some conditional weirdness in %%files list. This may break xchat
  357. erratum releases on Red Hat Linux 7.x. May need to be fixed in future.
  358. * Fri Aug 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-7
  359. - Added Requires line so that xchat requires the exact version of perl
  360. be installed, that was used to compile it, since the embedded perl
  361. interpreter will break, if you upgrade perl
  362. * Thu Aug 15 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-6
  363. - Fix Bill's beep beep beep bug (#71651)
  364. * Wed Aug 14 2002 Jonathan Blandford <jrb@redhat.com> 1.8.10-5
  365. - actually install the desktop file.
  366. * Fri Aug 9 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-3
  367. - Added http://xchat.org/files/source/1.8/patches/xc1810fixme.diff to fix
  368. bug with using /ME in a /QUERY window. (#71179)
  369. * Wed Aug 7 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-2
  370. - Updated to xchat 1.8.10 to fix a few bugs where a remote ircd could cause
  371. the xchat client to crash. This is a bugfix only release.
  372. * Tue Aug 6 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-10
  373. - Added Korean fontset support to fix bug (#69771)
  374. * Mon Aug 5 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-9
  375. - Enabled python scripting which was somehow disabled somewhere along the
  376. line by default in upstream sources, and we missed catching it. (#70816)
  377. * Sun Aug 4 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-8
  378. - Created new-style net-xchat.desktop file (#69541)
  379. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.8.9-7
  380. - automated rebuild
  381. * Tue Jun 18 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-6
  382. - updated the package description
  383. - Added CFLAGS and LDFLAGS export vars before configure to fix rpath problem
  384. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  385. - automated rebuild
  386. * Mon May 20 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-2
  387. - Updated to xchat 1.8.9
  388. * Mon Apr 8 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-5
  389. - Re-enabled GNOME support due to user complaints of pixmaps missing, key
  390. bindings, and other fairly important features no longer working.
  391. * Wed Mar 27 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-4
  392. - Disabled GNOME support since it doesn't seem too useful anyways, and forces
  393. all xchat users to install GNOME libs even if they use KDE. (#59626)
  394. - Updated URL and source lines in spec.
  395. * Wed Mar 6 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-1
  396. - Updated to xchat 1.8.8
  397. * Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-6
  398. - Built in new buildroot
  399. * Tue Feb 5 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-5
  400. - Added xchat-1.8.7-use-sysconf-to-detect-cpus.patch to use glibc's sysconf()
  401. to detect the number of processors available.
  402. * Mon Feb 4 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-4
  403. - Enabled IPv6 support as per the request for enhancement (#52124)
  404. * Thu Jan 24 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-3
  405. - Rebuilt in new build environment
  406. * Thu Jan 10 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-2
  407. - Updated to xchat 1.8.7
  408. - New release fixes security vulnerability in CTCP reply
  409. - Built erratum for all supported releases (1.8.7-1.62.0, 1.8.7-1.70.0,
  410. 1.8.7-1.71.0, 1.8.7-1.72.0)
  411. - Removed konqueror patch as it is integrated now.
  412. * Sat Jan 5 2002 Mike A. Harris <mharris@redhat.com> 1.8.6-2
  413. - Enabled ssl support with --enable-openssl
  414. - Also built releases 1.72.0, 1.71.0, 1.70.0, 1.62.0 for erratum release
  415. * Mon Dec 10 2001 Mike A. Harris <mharris@redhat.com> 1.8.6-1
  416. - Updated to xchat 1.8.6
  417. * Tue Nov 13 2001 Mike A. Harris <mharris@redhat.com> 1.8.5-1
  418. - Updated to xchat 1.8.5
  419. - Added f to rm -r in install and clean sections
  420. * Sun Oct 7 2001 Mike A. Harris <mharris@redhat.com> 1.8.4-1
  421. - Updated to 1.8.4, now using tar.bz2
  422. - Removed kanjiconv-fix patch as it is integrated now
  423. - Added xchat-1.8.4-fix-USE_GNOME.patch to fix simple ifdef USE_GNOME typo
  424. * Fri Jul 13 2001 Akira TAGOH <tagoh@redhat.com> 1.8.1-2
  425. - fixed check locale.
  426. - don't save kanji_conv.
  427. always check locale. however anyone can change the option from
  428. the settings menu.
  429. * Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
  430. - upgrade to 1.8.1
  431. - remove autoconnect patch since it's upstream
  432. - remove japanese patch, upstream seems to have applied
  433. parts of it and changelog says there's upstream support.
  434. (this patch was pretty huge to maintain in an SRPM anyway...)
  435. - put scripts-python scripts-perl in docs bug #28521
  436. - remove patch to include locale.h, gone upstream
  437. - upgrade konqueror patch
  438. * Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
  439. - nevermind, BuildRequires gnome-libs, that should
  440. close #48923
  441. * Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
  442. - fix file list to not include absolute path "/usr/share/..."
  443. no idea how that ever worked at all. closes #48923
  444. * Mon Jun 25 2001 Karsten Hopp <karsten@redhat.de>
  445. - use konqueror, not kfmclient on URLs
  446. * Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  447. - langify
  448. - use %%{_tmppath}
  449. - make it compile
  450. * Tue Feb 13 2001 Akira TAGOH <tagoh@redhat.com>
  451. - Added Japanese patch.
  452. * Tue Feb 13 2001 Havoc Pennington <hp@redhat.com>
  453. - patch that may fix autoconnections (bug 27093)
  454. * Mon Jan 22 2001 Havoc Pennington <hp@redhat.com>
  455. - 1.6.3
  456. - remove patch to desktop file (Internet->Application), seems to
  457. have gone upstream
  458. * Sat Dec 9 2000 Havoc Pennington <hp@redhat.com>
  459. - Remove security fix which has been merged upstream
  460. - upgrade to 1.6.1
  461. * Sat Aug 19 2000 Havoc Pennington <hp@redhat.com>
  462. - Don't use /bin/sh to interpret URLs from the net
  463. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  464. - Updated Epoch
  465. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  466. - automatic rebuild
  467. * Mon Jun 19 2000 Havoc Pennington <hp@redhat.com>
  468. - Install HTML docs
  469. * Fri Jun 16 2000 Preston Brown <pbrown@redhat.com>
  470. - fix desktop entry
  471. * Fri May 19 2000 Havoc Pennington <hp@redhat.com>
  472. - rebuild for the Winston tree, update to 1.4.2