xerces-c-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162
  1. Summary: Validating XML Parser
  2. Name: xerces-c
  3. Version: 3.1.4
  4. Release: 1%{?_dist_release}
  5. License: ASL 2.0
  6. Group: System Environment/Libraries
  7. URL: http://xml.apache.org/xerces-c/
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Source0: http://www.apache.org/dist/xerces/c/3/sources/xerces-c-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: dos2unix
  13. %description
  14. Xerces-C is a validating XML parser written in a portable subset of
  15. C++. Xerces-C makes it easy to give your application the ability to
  16. read and write XML data. A shared library is provided for parsing,
  17. generating, manipulating, and validating XML documents. Xerces-C is
  18. faithful to the XML 1.0 recommendation and associated standards:
  19. XML 1.0 (Third Edition), XML 1.1 (First Edition), DOM Level 1, 2, 3
  20. Core, DOM Level 2.0 Traversal and Range, DOM Level 3.0 Load and Save,
  21. SAX 1.0 and SAX 2.0, Namespaces in XML, Namespaces in XML 1.1, XML
  22. Schema, XML Inclusions).
  23. %package devel
  24. Summary: Header files, libraries and development documentation for %{name}
  25. Summary(ja): %{name} のヘッダファイル、ライブラリ、開発用ドキュメント
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. %description devel
  29. This package contains the header files, static libraries and development
  30. documentation for %{name}. If you like to develop programs using %{name},
  31. you will need to install %{name}-devel.
  32. %package doc
  33. Summary: Documentation for Xerces-C++ validating XML parser
  34. Group: Documentation
  35. BuildArch: noarch
  36. %description doc
  37. Documentation for Xerces-C++.
  38. Xerces-C++ is a validating XML parser written in a portable subset of C++.
  39. Xerces-C++ makes it easy to give your application the ability to read and
  40. write XML data. A shared library is provided for parsing, generating,
  41. manipulating, and validating XML documents.
  42. %prep
  43. %setup -q
  44. # Copy samples before build to avoid including built binaries in -doc package
  45. mkdir -p _docs
  46. cp -a samples/ _docs/
  47. %build
  48. # --disable-sse2 makes sure explicit -msse2 isn't passed to gcc so
  49. # the binaries would be compatible with non-SSE2 i686 hardware.
  50. # This only affects i686, as on x86_64 the compiler uses SSE2 by default.
  51. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  52. export CXXFLAGS="$CFLAGS"
  53. %configure --disable-static \
  54. --disable-pretty-make \
  55. --disable-sse2
  56. make %{?_smp_mflags}
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. make install DESTDIR="$RPM_BUILD_ROOT"
  60. # Correct errors in encoding
  61. iconv -f iso8859-1 -t utf-8 CREDITS > CREDITS.tmp && mv -f CREDITS.tmp CREDITS
  62. # Correct errors in line endings
  63. pushd doc; dos2unix -k *.xml; popd
  64. # Remove unwanted binaries
  65. rm -rf $RPM_BUILD_ROOT%{_bindir}
  66. # Remove .la files
  67. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  68. %post -p /sbin/ldconfig
  69. %postun -p /sbin/ldconfig
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %files
  73. %defattr(-,root,root,-)
  74. %license LICENSE
  75. %{_libdir}/libxerces-c-3.*.so
  76. %files devel
  77. %defattr(-,root,root,-)
  78. %{_libdir}/libxerces-c.so
  79. %{_libdir}/pkgconfig/xerces-c.pc
  80. %{_includedir}/xercesc/
  81. %files doc
  82. %defattr(-,root,root,-)
  83. %license LICENSE
  84. %doc README NOTICE CREDITS doc _docs/*
  85. %changelog
  86. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.4-1
  87. - updated to 3.1.4.
  88. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-2
  89. - rebuilt with new toolchain.
  90. * Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-1
  91. - updated to 3.1.3.
  92. * Sat Jan 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.1.1-1
  93. - updated to 3.1.1
  94. * Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
  95. - rebuild with Vine6 environment
  96. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.0-2
  97. - rebuilt with new toolchain
  98. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
  99. - initial build for Vine Linux
  100. * Mon Jun 30 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-2
  101. - Spec cleanups ( https://bugzilla.redhat.com/show_bug.cgi?id=435132 )
  102. * Sun Feb 10 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-1
  103. - Ver. 2.8.0
  104. * Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-6
  105. - typo fix
  106. * Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-5
  107. - fixed some rpmlint warnings
  108. * Fri Nov 24 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-4
  109. - Added samples to docs-package
  110. * Sat Nov 18 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-3
  111. - improvements suggested by Aurelien Bompard
  112. * Sat Oct 14 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-2
  113. - Disabled package 'samples'
  114. * Fri Oct 13 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-1
  115. - initial build for FE
  116. * Fri Jan 06 2006 Dag Wieers <dag@wieers.com> - 2.7.0-1 - 3891/dag
  117. - Cleaned SPEC file.
  118. * Tue Jan 03 2006 Dries Verachtert <dries@ulyssis.org> - 2.7.0-1
  119. - Updated to release 2.7.0.
  120. * Thu Sep 22 2005 C.Lee Taylor <leet@leenx.co.za> 2.6.1-1
  121. - Update to 2.6.1
  122. - Build for FC4 32/64bit
  123. * Sat Aug 20 2005 Che
  124. - initial rpm release