xlockmore-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279
  1. %define orgname xlockmore
  2. # if you want to make kterm_plus version,
  3. # uncomment below line, or rpm --define withgl:1
  4. # % define withgl 1
  5. %define name %{orgname}%{?withgl:_gl}
  6. %define version 5.47
  7. %define release 1%{?_dist_release}
  8. Summary: An X terminal locking program.
  9. Summary(ja): X 端末をロックするためのプログラム
  10. Name: %{name}
  11. Version: %{version}
  12. Release: %{release}
  13. License: MIT
  14. Group: User Interface/X
  15. URL: http://www.tux.org/~bagleyd/xlockmore.html
  16. Source0: http://www.tux.org/~bagleyd/xlock/xlockmore-%{version}/xlockmore-%{version}.tar.xz
  17. Source1: m-redhat.xpm
  18. Source2: m-redhat.xbm
  19. Source3: s-redhat.xpm
  20. Source4: s-redhat.xbm
  21. Source5: xlock.pamd
  22. Patch0: xlockmore-5.02-sounddir.patch
  23. BuildRequires: audiofile-devel
  24. Requires: pam >= 0.59, audiofile, fortune-mod
  25. Requires: xorg-x11-jpfonts
  26. BuildRequires: flex
  27. BuildRequires: pam-devel
  28. BuildRequires: libX11-devel
  29. BuildRequires: libXt-devel
  30. BuildRequires: libXinerama-devel
  31. BuildRequires: libXext-devel
  32. %{?withgl:BuildRequires: libGLU-devel}
  33. %{?withgl:Provides: xlockmore}
  34. BuildRequires: gtk2-devel
  35. Conflicts: %{orgname}%{!?withgl:_gl}
  36. Buildroot: %{_tmppath}/%{name}-%{version}-root
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. %define gldesc %{?withgl:This package has MesaGL feature.}
  40. %define gldescja %{?withgl:このパッケージは MesaGL 対応になっています.}
  41. %description
  42. The xlockmore utility is an enhanced version of the standard xlock
  43. program, which allows you to lock an X session so that other users
  44. can't access it. Xlockmore runs a provided screensaver until you type
  45. in your password.
  46. Install the xlockmore package if you need a locking program to secure
  47. X sessions.
  48. %{gldesc}
  49. %description -l ja
  50. xlockmore は 標準的な xlock の機能拡張版です.あなたが席をはずすときに
  51. X セッションをロックし,あなたがパスワードを入力するまで他の人がアク
  52. セスできないようにします.
  53. %{gldescja}
  54. %prep
  55. %setup -q -n %{orgname}-%{version}
  56. %patch0 -p1 -b .sounddir
  57. cp %{_sourcedir}/m-redhat.xpm pixmaps/m-redhat.xpm
  58. cp %{_sourcedir}/m-redhat.xbm bitmaps/m-redhat.xbm
  59. cp %{_sourcedir}/m-redhat.xpm pixmaps/l-redhat.xpm
  60. cp %{_sourcedir}/m-redhat.xbm bitmaps/l-redhat.xbm
  61. cp %{_sourcedir}/s-redhat.xpm pixmaps/s-redhat.xpm
  62. cp %{_sourcedir}/s-redhat.xbm bitmaps/s-redhat.xbm
  63. sed -i 's|XLOCKLDFLAGS = @XLOCKLDFLAGS@ $(CHECKLDFLAG)|XLOCKLDFLAGS = @XLOCKLDFLAGS@ $(CHECKLDFLAG) -laudiofile|' modes/Makefile.in
  64. %build
  65. #autoconf-2.13
  66. %define nglflag %{!?withgl:--without-opengl --without-mesa --without-gltt}
  67. %define glflag %{?withgl:--with-mesa --with-gltt}
  68. #%configure --prefix=/usr --exec-prefix=/usr/X11R6/ --bindir=/usr/X11R6/bin \
  69. # --mandir=/usr/X11R6/man/man1 --without-motif --without-gtk --enable-pam \
  70. # --with-esound %{glflag} %{nglflag}
  71. %configure --without-motif --without-gtk --without-gtk2 --enable-pam --without-esound %{glflag} %{nglflag}
  72. make
  73. # recompile xlockgen for each architecture
  74. make -C etc/genlauncher xlockgen
  75. %install
  76. rm -rf %{buildroot}
  77. mkdir -p %{buildroot}/etc/pam.d
  78. #%%makeinstall \
  79. # exec_prefix=%{buildroot}/usr/X11R6/ \
  80. # bindir=%{buildroot}/usr/X11R6/bin \
  81. # mandir=%{buildroot}/usr/X11R6/man/man1 \
  82. # xapploaddir=%{buildroot}/usr/X11R6/lib/X11/app-defaults/ \
  83. # INSTPGMFLAGS="-m 755"
  84. %makeinstall \
  85. mandir=%{buildroot}%{_mandir}/man1 \
  86. xapploaddir=%{buildroot}%{_datadir}/X11/app-defaults/ \
  87. INSTPGMFLAGS="-m 755"
  88. install -m 644 %{_sourcedir}/xlock.pamd %{buildroot}/etc/pam.d/xlock
  89. mkdir -p %{buildroot}%{_datadir}/sounds/xlockmore/
  90. install -m 644 -p sounds/*.au %{buildroot}%{_datadir}/sounds/xlockmore/
  91. (cd etc
  92. sed -e 's|/usr/X11/bin/wish|/usr/bin/wish|g' xlock.tcl > xlock.tcl.new
  93. mv xlock.tcl.new xlock.tcl
  94. # chmod +x xlock.tcl
  95. )
  96. # eliminate executable bit in %doc
  97. find etc/ -type f -perm +111 | xargs -r chmod -x
  98. %clean
  99. rm -rf %{buildroot}
  100. %files
  101. %defattr(-,root,root)
  102. %doc README docs/ etc/
  103. %attr(4111,root,root)%{_bindir}/xlock
  104. %config %{_sysconfdir}/pam.d/xlock
  105. %config %{_datadir}/X11/app-defaults/XLock
  106. %{_datadir}/sounds/xlockmore/
  107. %{_mandir}/man1/xlock.*
  108. %changelog
  109. * Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.47-1
  110. - new upstream release
  111. - remove BuildRequires: esound-devel
  112. * Sun Feb 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.45-1
  113. - new upstream release
  114. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.32-1
  115. - new upstream release
  116. - add Requires: xorg-x11-jpfonts
  117. - add BuildRequires: gtk2-devel
  118. * Sun Aug 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.31-2
  119. - changed Group to User Interface/X
  120. - added Japanese summary
  121. * Sat Jul 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.31-1
  122. - new upstream release
  123. * Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.29.1-3
  124. - rebuilt with ftgl-2.1.3-1.rc5
  125. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-2
  126. - add BuildRequires: libXinerama-devel, libXext-devel (for Vine Linux 5.0)
  127. - fix xlock.pamd (required pam_unix.so -> include system-auth)
  128. * Sat Jan 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-1
  129. - new upstream release
  130. - add configure option: --without-gtk2
  131. - add BuildRequires: flex, pam-devel, libX11-devel, libXt-devel
  132. - fixed xlock.pamd (pam_stack.so -> pam_unix.so)
  133. - comment out: autoconf-2.13
  134. * Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 5.03-1vl5
  135. - applied new versioning policy, spec in utf-8
  136. - fixed autoconf version
  137. - modified install directories
  138. * Wed Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 5.03-0vl1
  139. - updated to current stable release 5.03
  140. - use %%configure, %%makeinstall
  141. - added patch for DEFALUT_SOUND_DIR
  142. * Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.01.2-0vl3
  143. - typo fixed: --without-mesagl -> --without-mesa
  144. * Sat Aug 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  145. - add Conflicts tag
  146. * Fri Aug 17 2001 <sagami@vinelinux.org>
  147. - 5.01.2-0vl1: bump up release
  148. * Wed Jul 18 2001 <sagami@vinelinux.org>
  149. - 5.01.2-0vl0: updated to current stable release 5.01.2
  150. * Mon Apr 2 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl8
  151. - bug fix for withgl option
  152. * Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl7
  153. - bug fix in Provides for withgl
  154. - build with gle
  155. * Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl6
  156. - added switch withgl
  157. * Mon Jan 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 4.17.2-0vl5
  158. - recompile %%{_docdir}/xlockmore-%{version}/etc/genlauncher/xlockgen
  159. for each architecture (to resolve unmet dependency)
  160. * Sat Jan 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  161. - 4.17.2-0vl4
  162. - eliminate executable bit in %doc (requierment for /bin/ksh etc.)
  163. * Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 4.17.2-0vl3
  164. - build on gcc-2.95.3
  165. - partialy used rpmmacros
  166. * Tue Nov 7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 4.17.2-0vl2
  167. - change filedepend to package name depend
  168. * Sat Sep 2 2000 Jun Nishii <jun@vinelinux.org>
  169. - 4.17.2-0vl1
  170. * Fri Sep 1 2000 Jun Nishii <jun@vinelinux.org>
  171. - 4.17.1-0vl1
  172. - upgrade and build without GL
  173. - added docs etc
  174. * Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
  175. - wmconfig gone.
  176. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  177. - handle compressed man pages
  178. * Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
  179. - fun with GL
  180. * Tue Nov 9 1999 Bill Nottingham <notting@redhat.com>
  181. - update to 4.15
  182. * Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
  183. - update to 4.13.1
  184. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  185. - auto rebuild in the new build environment (release 2)
  186. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  187. - update to 4.12
  188. * Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
  189. - take out some modules to avoid TMv
  190. * Fri Sep 18 1998 Bill Nottingham <notting@redhat.com>
  191. - turned PAM support on in ./configure
  192. * Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
  193. - Upgraded to 4.11
  194. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  195. - translations modified for de, fr, tr
  196. * Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
  197. - upgraded to 4.09
  198. - removed Michael's PAM patch (it's now available in the sources)
  199. * Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
  200. - upgrade to 4.05
  201. - add wmconfig
  202. * Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
  203. - Upgraded to 4.04
  204. - Changed pam to new conventions
  205. - Use configure instead of imake
  206. - buildroot
  207. * Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
  208. - built against glibc
  209. * Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
  210. - moved from pam.conf to pam.d