xml-stylebook-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176
  1. Name: xml-stylebook
  2. Version: 1.0
  3. Release: 1%{?_dist_release}
  4. Summary: Apache XML Stylebook
  5. Summary(ja): Apache XML スタイルブック
  6. Group: Development/Libraries
  7. License: ASL 1.1
  8. URL: http://xml.apache.org/
  9. # How to generate this tarball:
  10. # $ svn export http://svn.apache.org/repos/asf/xml/stylebook/trunk/@313293 xml-stylebook-1.0
  11. # $ tar zcf xml-stylebook-1.0.tar.gz xml-stylebook-1.0
  12. Source0: %{name}-%{version}.tar.gz
  13. # Patch to fix an NPE in Xalan-J2's docs generation (from JPackage)
  14. Patch0: %{name}-image-printer.patch
  15. # Patch the build script to build javadocs
  16. Patch1: %{name}-build-javadoc.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildArch: noarch
  19. BuildRequires: java-devel >= 1.6.0
  20. BuildRequires: java-javadoc
  21. BuildRequires: jpackage-utils
  22. BuildRequires: ant
  23. BuildRequires: xml-commons-apis
  24. BuildRequires: xerces-j2
  25. BuildRequires: TrueType-dejavu-sans
  26. #BuildRequires: dejavu-sans-fonts
  27. Requires: java-headless
  28. Requires: jpackage-utils
  29. Requires: xml-commons-apis
  30. Requires: xerces-j2
  31. %description
  32. Apache XML Stylebook is a HTML documentation generator.
  33. %package javadoc
  34. Summary: API documentation for %{name}
  35. Summary(ja): %{name} の API ドキュメント
  36. Group: Documentation
  37. Requires: java-javadoc
  38. %description javadoc
  39. %{summary}.
  40. %package demo
  41. Summary: Examples for %{name}
  42. Summary(ja): %{name} のデモ集
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description demo
  46. Examples demonstrating the use of %{name}.
  47. %prep
  48. %setup -q
  49. %patch0 -p0
  50. %patch1 -p0
  51. # Remove bundled binaries
  52. rm -r bin/*.jar
  53. # Don't include this sample theme because it contains an errant font
  54. rm -r styles/christmas/
  55. # Make sure upstream hasn't sneaked in any jars we don't know about
  56. JARS=""
  57. for j in `find -name "*.jar"`; do
  58. if [ ! -L $j ]; then
  59. JARS="$JARS $j"
  60. fi
  61. done
  62. if [ ! -z "$JARS" ]; then
  63. echo "These jars should be deleted and symlinked to system jars: $JARS"
  64. exit 1
  65. fi
  66. %build
  67. ant
  68. # Build the examples (this serves as a good test suite)
  69. pushd docs
  70. rm run.bat
  71. java -classpath "$(build-classpath xml-commons-apis):$(build-classpath jaxp_parser_impl):../bin/stylebook-%{version}-b3_xalan-2.jar" \
  72. org.apache.stylebook.StyleBook "targetDirectory=../results" book.xml ../styles/apachexml
  73. popd
  74. %install
  75. rm -rf %{buildroot}
  76. # jars
  77. install -pD -T bin/stylebook-%{version}-b3_xalan-2.jar \
  78. %{buildroot}%{_javadir}/%{name}.jar
  79. # javadoc
  80. install -d %{buildroot}%{_javadocdir}/%{name}
  81. cp -pr build/javadoc/* %{buildroot}%{_javadocdir}/%{name}
  82. # examples
  83. install -d %{buildroot}%{_datadir}/%{name}
  84. cp -pr docs %{buildroot}%{_datadir}/%{name}
  85. cp -pr styles %{buildroot}%{_datadir}/%{name}
  86. cp -pr results %{buildroot}%{_datadir}/%{name}
  87. %clean
  88. rm -rf %{buildroot}
  89. %files
  90. %doc LICENSE.txt
  91. %{_javadir}/*
  92. %files javadoc
  93. %doc LICENSE.txt
  94. %{_javadocdir}/%{name}
  95. %files demo
  96. %{_datadir}/%{name}
  97. %changelog
  98. * Fri Mar 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0-1
  99. - Initial build for Vine Linux
  100. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.16.b3_xalan2.svn313293
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  102. * Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.0-0.15.b3_xalan2.svn313293
  103. - Use Requires: java-headless rebuild (#1067528)
  104. * Mon Aug 12 2013 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.14.b3_xalan2.svn313293
  105. - Prefer xerces-j2 instead of gcj for providing jaxp_parser_impl
  106. * Sat Aug 10 2013 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.13.b3_xalan2.svn313293
  107. - Update for newer guidelines
  108. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.12.b3_xalan2.svn313293
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  110. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.11.b3_xalan2.svn313293
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  112. * Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.10.b3_xalan2.svn313293
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  114. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.9.b3_xalan2.svn313293
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  116. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.8.b3_xalan2.svn313293
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  118. * Sun Dec 12 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.7.b3_xalan2.svn313293
  119. - Really fix FTBFS this time.
  120. * Sun Dec 12 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.6.b3_xalan2.svn313293
  121. - Fix FTBFS due to ant upgrade.
  122. * Sat Jun 12 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.5.b3_xalan2.svn313293
  123. - Link to local java API docs properly and fix requires on javadoc package.
  124. - Build with source and target levels of 1.5 so we don't have to require 1.6.
  125. * Thu Apr 22 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.4.b3_xalan2.svn313293
  126. - Remove font from demo package to comply with guidelines. RHBZ #567912
  127. * Mon Jan 11 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.3.b3_xalan2.svn313293
  128. - Build the examples (this serves as a good test suite.)
  129. - Patch the build script to build javadocs.
  130. - Add a build dep on a font package because the JDK is missing a dependency
  131. to function correctly in headless mode. See RHBZ #478480 and #521523.
  132. * Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.2.b3_xalan2.svn313293
  133. - Add patch from JPackage to fix NPE in Xalan-J2 doc generation.
  134. * Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.1.b3_xalan2.svn313293
  135. - Initial stab at packaging trunk version of stylebook.