xmlsec1-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348
  1. Summary: Library providing support for "XML Signature" and "XML Encryption" standards
  2. Name: xmlsec1
  3. Version: 1.2.29
  4. Release: 1%{?_dist_release}
  5. License: MIT
  6. Group: System Environment/Libraries
  7. URL: https://www.aleksey.com/xmlsec/
  8. Source: https://www.aleksey.com/xmlsec/download/xmlsec1-%{version}.tar.gz
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: libxml2-devel >= 2.6.0
  13. BuildRequires: libxslt-devel >= 1.1.0
  14. BuildRequires: openssl-devel >= 0.9.6
  15. BuildRequires: libgcrypt-devel >= 1.4.0
  16. BuildRequires: gnutls-devel >= 1.0.20
  17. BuildRequires: nss-devel >= 3.2
  18. BuildRequires: nspr-devel
  19. BuildRequires: libtool-ltdl-devel
  20. # extra build deps needed for autoreconf after above patch
  21. BuildRequires: autoconf
  22. BuildRequires: automake
  23. BuildRequires: gettext-devel
  24. BuildRequires: libtool
  25. %description
  26. XML Security Library is a C library based on LibXML2 and OpenSSL.
  27. The library was created with a goal to support major XML security
  28. standards "XML Digital Signature" and "XML Encryption".
  29. %package devel
  30. Summary: Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
  31. Group: Development/Libraries
  32. Requires: xmlsec1 = %{version}-%{release}
  33. Requires: libxml2-devel >= 2.6.0
  34. Requires: libxslt-devel >= 1.1.0
  35. Requires: openssl-devel >= 0.9.6
  36. Requires: zlib-devel
  37. Requires: pkgconfig
  38. %description devel
  39. Libraries, includes, etc. you can use to develop applications with XML Digital
  40. Signatures and XML Encryption support.
  41. %package openssl
  42. Summary: OpenSSL crypto plugin for XML Security Library
  43. Group: System Environment/Libraries
  44. Requires: xmlsec1 = %{version}-%{release}
  45. %description openssl
  46. OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
  47. for the xmlsec library
  48. %package openssl-devel
  49. Summary: OpenSSL crypto plugin for XML Security Library
  50. Group: Development/Libraries
  51. Requires: xmlsec1-devel = %{version}-%{release}
  52. Requires: xmlsec1-openssl = %{version}-%{release}
  53. %description openssl-devel
  54. Libraries, includes, etc. for developing XML Security applications with OpenSSL
  55. %package gcrypt
  56. Summary: GCrypt crypto plugin for XML Security Library
  57. Group: System Environment/Libraries
  58. Requires: xmlsec1 = %{version}-%{release}
  59. %description gcrypt
  60. GCrypt plugin for XML Security Library provides GCrypt based crypto services
  61. for the xmlsec library.
  62. %package gcrypt-devel
  63. Summary: GCrypt crypto plugin for XML Security Library
  64. Group: Development/Libraries
  65. Requires: xmlsec1-devel = %{version}-%{release}
  66. Requires: xmlsec1-gnutls-devel = %{version}-%{release}
  67. %description gcrypt-devel
  68. Libraries, includes, etc. for developing XML Security applications with GCrypt.
  69. %package gnutls
  70. Summary: GNUTls crypto plugin for XML Security Library
  71. Group: System Environment/Libraries
  72. Requires: xmlsec1 = %{version}-%{release}
  73. %description gnutls
  74. GNUTls plugin for XML Security Library provides GNUTls based crypto services
  75. for the xmlsec library
  76. %package gnutls-devel
  77. Summary: GNUTls crypto plugin for XML Security Library
  78. Group: Development/Libraries
  79. Requires: xmlsec1 = %{version}
  80. Requires: xmlsec1-devel = %{version}
  81. Requires: xmlsec1-openssl = %{version}
  82. Requires: libgcrypt-devel >= 1.2.0
  83. Requires: gnutls-devel >= 1.0.20
  84. %description gnutls-devel
  85. Libraries, includes, etc. for developing XML Security applications with GNUTls
  86. %package nss
  87. Summary: NSS crypto plugin for XML Security Library
  88. Group: System Environment/Libraries
  89. Requires: xmlsec1 = %{version}-%{release}
  90. %description nss
  91. NSS plugin for XML Security Library provides NSS based crypto services
  92. for the xmlsec library
  93. %package nss-devel
  94. Summary: NSS crypto plugin for XML Security Library
  95. Group: Development/Libraries
  96. Requires: xmlsec1-devel = %{version}-%{release}
  97. Requires: xmlsec1-nss = %{version}-%{release}
  98. Requires: nss-devel >= 3.2
  99. Requires: nspr-devel
  100. %description nss-devel
  101. Libraries, includes, etc. for developing XML Security applications with NSS
  102. %prep
  103. %setup -q
  104. %build
  105. autoreconf -if
  106. %configure --enable-silent-rules --disable-static
  107. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  108. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  109. make
  110. # positively ugly but only sane way to get around #192756
  111. sed 's+/lib64+/$archlib+g' < xmlsec1-config | sed 's+/lib+/$archlib+g' | sed 's+ -DXMLSEC_NO_SIZE_T++' > xmlsec1-config.$$ && mv xmlsec1-config.$$ xmlsec1-config
  112. %install
  113. rm -rf $RPM_BUILD_ROOT
  114. mkdir -p $RPM_BUILD_ROOT/usr/bin
  115. mkdir -p $RPM_BUILD_ROOT/usr/include/xmlsec1
  116. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  117. mkdir -p $RPM_BUILD_ROOT/usr/man/man1
  118. make install DESTDIR=$RPM_BUILD_ROOT
  119. #make prefix=$RPM_BUILD_ROOT%{prefix} mandir=$RPM_BUILD_ROOT%{_mandir} install
  120. rm -fv $RPM_BUILD_ROOT%{_libdir}/*.la
  121. #rm -fv $RPM_BUILD_ROOT%{_libdir}/*.a
  122. rm -rf docs-to-install
  123. mkdir -p docs-to-install
  124. cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1/* docs-to-install
  125. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1
  126. %clean
  127. rm -fr %{buildroot}
  128. %post -p /sbin/ldconfig
  129. %postun -p /sbin/ldconfig
  130. %post openssl -p /sbin/ldconfig
  131. %postun openssl -p /sbin/ldconfig
  132. %post gcrypt -p /sbin/ldconfig
  133. %postun gcrypt -p /sbin/ldconfig
  134. %post gnutls -p /sbin/ldconfig
  135. %postun gnutls -p /sbin/ldconfig
  136. %post nss -p /sbin/ldconfig
  137. %postun nss -p /sbin/ldconfig
  138. %files
  139. %defattr(-, root, root)
  140. %license Copyright
  141. %doc AUTHORS ChangeLog NEWS README
  142. %doc %{_mandir}/man1/xmlsec1.1*
  143. %{_libdir}/libxmlsec1.so.*
  144. %{_bindir}/xmlsec1
  145. %files devel
  146. %defattr(-, root, root)
  147. %{_bindir}/xmlsec1-config
  148. %{_includedir}/xmlsec1
  149. %exclude %{_includedir}/xmlsec1/xmlsec/gcrypt
  150. %exclude %{_includedir}/xmlsec1/xmlsec/gnutls
  151. %exclude %{_includedir}/xmlsec1/xmlsec/nss
  152. %exclude %{_includedir}/xmlsec1/xmlsec/openssl
  153. %{_libdir}/libxmlsec1.so
  154. %{_libdir}/pkgconfig/xmlsec1.pc
  155. %{_libdir}/xmlsec1Conf.sh
  156. %{_datadir}/aclocal/*.m4
  157. %license Copyright
  158. %doc AUTHORS HACKING ChangeLog NEWS README
  159. %doc docs-to-install/*
  160. %doc %{_mandir}/man1/xmlsec1-config.1*
  161. %files openssl
  162. %defattr(-, root, root)
  163. %{_libdir}/libxmlsec1-openssl.so
  164. %{_libdir}/libxmlsec1-openssl.so.*
  165. %files openssl-devel
  166. %defattr(-, root, root)
  167. %{_includedir}/xmlsec1/xmlsec/openssl
  168. %{_libdir}/pkgconfig/xmlsec1-openssl.pc
  169. %files gcrypt
  170. %defattr(-, root, root, -)
  171. %{_libdir}/libxmlsec1-gcrypt.so
  172. %{_libdir}/libxmlsec1-gcrypt.so.*
  173. %files gcrypt-devel
  174. %defattr(-, root, root, -)
  175. %{_includedir}/xmlsec1/xmlsec/gcrypt
  176. %{_libdir}/pkgconfig/xmlsec1-gcrypt.pc
  177. %files gnutls
  178. %defattr(-, root, root)
  179. %{_libdir}/libxmlsec1-gnutls.so
  180. %{_libdir}/libxmlsec1-gnutls.so.*
  181. %files gnutls-devel
  182. %defattr(-, root, root)
  183. %{_includedir}/xmlsec1/xmlsec/gnutls
  184. %{_libdir}/pkgconfig/xmlsec1-gnutls.pc
  185. %files nss
  186. %defattr(-, root, root)
  187. %{_libdir}/libxmlsec1-nss.so
  188. %{_libdir}/libxmlsec1-nss.so.*
  189. %files nss-devel
  190. %defattr(-, root, root)
  191. %{_includedir}/xmlsec1/xmlsec/nss
  192. %{_libdir}/pkgconfig/xmlsec1-nss.pc
  193. %changelog
  194. * Mon Mar 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.29-1
  195. - new upstream release.
  196. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.27-1
  197. - new upstream release.
  198. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.22-1
  199. - new upstream release.
  200. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-3
  201. - rebuilt with gnutls-3.4.x.
  202. * Fri Jul 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-2
  203. - fixed %%files.
  204. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.20-1
  205. - new upstream release
  206. - moved gcrypt to System Environment/Libraries Group
  207. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.16-1
  208. - new upstream release
  209. - add BuildRequires: libtool-ltdl-devel
  210. - add -gcrypt,-gcrypt-devel package
  211. * Fri Jul 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-1
  212. - new upstream release with security fix (CVE-2009-0217)
  213. - remove *.a files
  214. * Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-2
  215. - rebuilt with gnutls-2.6.3
  216. * Wed Jul 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-1
  217. - new upstream release
  218. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
  219. - initial build for Vine Linux
  220. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-8.1
  221. - rebuild
  222. * Wed Jun 14 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.9-8
  223. - rebuilt with new gnutls
  224. * Thu Jun 8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-7
  225. - oops libxmlsec1.la was still there, should fix #171410 and #154142
  226. * Thu Jun 8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-6
  227. - Ugly patch and sed based changes to work around #192756 xmlsec1-config
  228. multilib problem
  229. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.9-5
  230. - move .so symlinks to -devel subpackage
  231. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.2
  232. - bump again for double-long bug on ppc(64)
  233. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.1
  234. - rebuilt for new gcc4.1 snapshot and glibc changes
  235. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 1.2.9-4
  236. - NSS has been split out of the mozilla package, so require that now
  237. and update separate_nspr.patch to account for the new NSS as well
  238. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  239. - rebuilt
  240. * Wed Nov 23 2005 Tomas Mraz <tmraz@redhat.com> 1.2.9-3
  241. - rebuilt due to gnutls library revision
  242. * Wed Nov 9 2005 <veillard@redhat.com> 1.2.9-2
  243. - rebuilt due to openssl library revision
  244. * Tue Sep 20 2005 <veillard@redhat.com> 1.2.9-1
  245. - update from upstream, release done in July
  246. - apparently nss is now available on ppc64
  247. * Mon Aug 8 2005 <veillard@redhat.com> 1.2.8-3
  248. - rebuilt with new gnutls
  249. - nspr has been split to a separate package
  250. * Fri Jul 8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-2
  251. - Enabling the mozilla-nss crypto backend
  252. * Fri Jul 8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-1
  253. - update from upstream, needed for openoffice
  254. * Tue Mar 8 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-4
  255. - rebuilt with gcc4
  256. * Wed Feb 23 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-1
  257. - Upstream release of 1.2.7, mostly bug fixes plus new functions
  258. to GetKeys from simple store and X509 handling.
  259. * Wed Feb 9 2005 Daniel Veillard <veillard@redhat.com> 1.2.6-4
  260. - Adding support for GNUTls crypto backend
  261. * Wed Sep 1 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-3
  262. - adding missing ldconfig calls
  263. * Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-2
  264. - updated with upstream release from Aleksey
  265. * Mon Jun 21 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-2
  266. - rebuilt
  267. * Mon Apr 19 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-1
  268. - updated with upstream release from Aleksey
  269. * Wed Feb 11 2004 Daniel Veillard <veillard@redhat.com> 1.2.4-1
  270. - updated with upstream release from Aleksey
  271. * Tue Jan 6 2004 Daniel Veillard <veillard@redhat.com> 1.2.3-1
  272. - updated with upstream release from Aleksey
  273. * Wed Nov 12 2003 Daniel Veillard <veillard@redhat.com> 1.2.2-1
  274. - updated with upstream release from Aleksey, specific patches should
  275. have been integrated now.
  276. * Thu Nov 6 2003 Daniel Veillard <veillard@redhat.com> 1.2.1-1
  277. - initial packaging based on the upstream one and libxml2 one.
  278. - desactivated mozilla-nss due to detection/architecture problems