xmobar-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170
  1. %define pkg_name xmobar
  2. %define pkg_version 0.29.3
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: a minimalistic text based status bar
  5. Summary(ja): テキストを基礎とした最小のステータスバー
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: BSD3
  10. Group: User Interface/Desktops
  11. URL: http://hackage.haskell.org
  12. Source0: packages
  13. # # Patch for building with hinotify-3.10
  14. # Source2: xmobar-0.26_with_hinotify-3.10.patch
  15. Source11: hinotify-0.4.tar.gz
  16. Source12: hinotify.cabal
  17. Source13: parsec-numbers-0.1.0.tar.gz
  18. Source14: parsec-numbers.cabal
  19. Source15: timezone-series-0.1.9.tar.gz
  20. Source16: timezone-series.cabal
  21. Source17: timezone-olson-0.1.9.tar.gz
  22. Source18: timezone-olson.cabal
  23. Source19: xmobar-0.29.3.tar.gz
  24. Source20: xmobar.cabal
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. BuildRequires: ghc haskell-platform
  27. BuildRequires: xmonad xmonad-contrib
  28. BuildRequires: libXScrnSaver-devel
  29. BuildRequires: libffi-devel gmp-devel zlib-devel
  30. BuildRequires: xorg-x11-devel
  31. BuildRequires: libXpm-devel
  32. Requires: haskell-platform-dep
  33. Requires: xmonad xmonad-contrib
  34. Requires: libXpm
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: ara_t
  38. %description
  39. Xmobar is a minimalistic text based status bar.
  40. Inspired by the Ion3 status bar, it supports similar features,
  41. like dynamic color management, output templates, and extensibility
  42. through plugins.
  43. %description -l ja
  44. Xmobarはテキストを基礎とした最小のステータスバーです。
  45. %prep
  46. %{__rm} -rf ${RPM_BUILD_ROOT}
  47. %build
  48. %ghc_pkg_init
  49. cd %{_builddir}
  50. for pkg in `sed '$d' %{SOURCE0}`; do
  51. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  52. pushd ${pkg}
  53. %ghc_fix_dependencies ${pkg}
  54. %cabal_configure2 %{name} ${pkg}
  55. %cabal_build
  56. %cabal_haddock
  57. %cabal_copy_resister %{name}_${pkg}
  58. popd
  59. done
  60. cd %{_builddir}
  61. for pkg in `tail -n 1 %{SOURCE0}`; do
  62. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  63. pushd ${pkg}
  64. %ghc_fix_dependencies ${pkg}
  65. # # Patch for building with hinotify-3.10
  66. # %{__patch} -p1 < %{SOURCE2}
  67. %cabal_configure2 %{name} ${pkg} \
  68. --flags="with_utf8" --flags="with_xft" \
  69. --flags="with_threaded" --flags="with_inotify" \
  70. --flags="with_datazone" --flags="with_xpm"
  71. %cabal_build
  72. %cabal_haddock
  73. %cabal_copy_resister %{name}_${pkg}
  74. popd
  75. done
  76. %install
  77. # copy documents
  78. pushd %{_builddir}/%{name}-%{version}
  79. %{__cp} readme.md \
  80. ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
  81. popd
  82. %clean
  83. %{__rm} -rf ${RPM_BUILD_ROOT}
  84. %post
  85. %ghc_pkg_recache
  86. %postun
  87. %ghc_pkg_recache
  88. %files
  89. %defattr(-, root, root)
  90. %{_bindir}/
  91. %{_libdir}/ghc-%{ghc_version}/
  92. %{_libdir}/ghc-lib/
  93. %{_docdir}/%{name}/
  94. %changelog
  95. * Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.29.3-1
  96. - update to 0.29.3
  97. - build using ghc-8.6.3
  98. * Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.27-2
  99. - build using ghc-8.4.3-2
  100. - add BuildRequires: libXScrnSaver-devel
  101. - correct BuildRequires
  102. * Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.27-1
  103. - update to 0.27
  104. - drop Patch2 (fixed at upstream)
  105. - build using ghc-8.4.3
  106. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.26-1
  107. - update to 0.26
  108. - rebuild using ghc-8.4.2
  109. - add Patch for building with hinotify-3.10 (Source2)
  110. - rewrite using macro
  111. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.24.5-2
  112. - update to 0.24.5
  113. - rebuild using ghc-8.2.2
  114. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.24.3-1
  115. - update to 0.24.3
  116. - build using ghc-8.0.1
  117. * Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-6
  118. - rebuilt
  119. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-5
  120. - rebuild under xmonad-0.12-3 and xmonad-contrib-0.12-4
  121. - correct SPEC file
  122. * Sun Mar 06 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-4
  123. - correct SPEC file
  124. * Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-3
  125. - rebuild under xmonad-0.12-2 and xmonad-contrib-0.12-3
  126. * Sun Feb 28 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-2
  127. - add configure option and required libraries
  128. * Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-1
  129. - new package