xmonad-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. %define pkg_name xmonad
  2. %define pkg_version 0.15
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: Lightweight X11 window manager written in Haskell
  5. Summary(ja): Haskellで書かれたタイル型ウィンドウマネージャ
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: BSD3
  10. Group: User Interface/Desktops
  11. URL: http://hackage.haskell.org
  12. Source0: packages
  13. Source1: xmonad.desktop
  14. # # Patch for building ghc-8.4
  15. # Source2: xmonad-0.13_using_ghc-8.4.patch
  16. Source11: X11-1.9.tar.gz
  17. Source12: X11.cabal
  18. Source13: extensible-exceptions-0.1.1.4.tar.gz
  19. Source14: extensible-exceptions.cabal
  20. Source15: setlocale-1.0.0.8.tar.gz
  21. Source16: setlocale.cabal
  22. Source17: utf8-string-1.0.1.1.tar.gz
  23. Source18: utf8-string.cabal
  24. Source19: xmonad-0.15.tar.gz
  25. Source20: xmonad.cabal
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: ghc haskell-platform
  28. BuildRequires: libffi-devel gmp-devel zlib-devel
  29. BuildRequires: libghc-data-default-class
  30. BuildRequires: libghc-dlist
  31. BuildRequires: libghc-old-locale
  32. BuildRequires: libghc-data-default
  33. BuildRequires: libghc-semigroups
  34. BuildRequires: xorg-x11-devel
  35. BuildRequires: libXrandr-devel libXinerama-devel
  36. BuildRequires: libXScrnSaver-devel
  37. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  38. Requires: libXrandr-devel libXinerama-devel
  39. Requires: libXScrnSaver-devel
  40. Requires: haskell-platform-dep
  41. Requires: libghc-data-default-class
  42. Requires: libghc-dlist
  43. Requires: libghc-old-locale
  44. Requires: libghc-data-default
  45. Requires: libghc-semigroups
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. Packager: ara_t
  49. %description
  50. Xmonad is a minimalist tiling window manager for X, written in Haskell.
  51. Windows are managed using automatic layout algorithms, which can be dynamically
  52. reconfigured. At any time windows are arranged so as to maximise the use of
  53. screen real estate. All features of the window manager are accessible purely
  54. from the keyboard: a mouse is entirely optional.
  55. Xmonad is configured in Haskell, and custom layout algorithms may be implemented
  56. by the user in config files.
  57. A principle of Xmonad is predictability: the user should know in advance
  58. precisely the window arrangement that will result from any action.
  59. Please sample configure file as follows.
  60. `cp %{_docdir}/%{name}/%{name}-%{version}/xmonad.hs ~/.xmonad/`
  61. %description -l ja
  62. XmonadはHaskellで書かれたタイル型ウィンドウマネージャです。
  63. ウィンドウは自動的レイアウトアルゴリズムによって管理されており、
  64. ウィンドウはいつでも最大化されて配置されます。
  65. 純粋にキーボード操作だけで操作することが可能であり、
  66. マウスの使用は単にオプションです。
  67. XmonadはHaskellで設定され、ユーザーが設定ファイルを書くことで
  68. レイアウトをカスタマイズすることができます。
  69. 設定ファイルの例が
  70. %{_docdir}/%{name}/%{name}-%{version}/xmonad.hs
  71. にあるため、
  72. ~/.xmonad 以下にコピーして使用して下さい。
  73. %prep
  74. %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %build
  76. %ghc_pkg_init
  77. cd %{_builddir}
  78. for pkg in `sed '$d' %{SOURCE0}`; do
  79. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  80. pushd ${pkg}
  81. %ghc_fix_dependencies ${pkg}
  82. %cabal_configure2 %{name} ${pkg}
  83. %cabal_build
  84. %cabal_haddock
  85. %cabal_copy_resister %{name}_${pkg}
  86. popd
  87. done
  88. # build xmonad
  89. for pkg in `tail -n 1 %{SOURCE0}`; do
  90. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  91. pushd ${pkg}
  92. %ghc_fix_dependencies ${pkg}
  93. %cabal_configure2 %{name} %{name}-%{version}
  94. %cabal_build
  95. %cabal_haddock
  96. %cabal_copy_resister %{pkg_name}-%{version}
  97. popd
  98. done
  99. %install
  100. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/man/man1
  101. # copy man file
  102. pushd %{_builddir}/%{name}-%{version}/man
  103. %{__mv} xmonad.1 ${RPM_BUILD_ROOT}%{_datadir}/man/man1
  104. %{__mv} xmonad.1.html xmonad.1.markdown xmonad.hs \
  105. ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
  106. popd
  107. %{__rm} -rf ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/man
  108. # xsession desktop entry
  109. %{__mkdir_p} %{buildroot}%{_datadir}/xsessions/
  110. %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/xsessions/
  111. # copy documents
  112. pushd %{_builddir}/%{name}-%{version}
  113. %{__cp} CHANGES.md LICENSE README.md STYLE \
  114. ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
  115. popd
  116. %clean
  117. %{__rm} -rf ${RPM_BUILD_ROOT}
  118. %post
  119. %ghc_pkg_recache
  120. %postun
  121. %ghc_pkg_recache
  122. %files
  123. %defattr(-, root, root)
  124. %{_bindir}/
  125. %{_libdir}/ghc-%{ghc_version}/
  126. %{_libdir}/ghc-lib/
  127. %{_datadir}/xsessions/
  128. %{_docdir}/%{name}
  129. %{_mandir}/man1/
  130. %changelog
  131. * Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.15-1
  132. - update to 0.15
  133. - build using ghc-8.6.3
  134. * Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.14-2
  135. - add Requires: libXScrnSaver-devel
  136. * Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.14-1
  137. - update to 0.14
  138. - add BuildRequires: libXScrnSaver-devel for X11-1.9
  139. - drop Patch2
  140. * Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.13-3
  141. - build using ghc-8.4.3
  142. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.13-2
  143. - rebuild using ghc-8.4.2
  144. - add Patch for building with ghc-8.4 (Source2)
  145. - add BuildRequires: libghc-old-locale
  146. - add BuildRequires: libghc-semigroups
  147. - rewrite using macro
  148. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.13-1
  149. - update to 0.13
  150. - build using ghc-8.2.2
  151. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.12-5
  152. - rebuild using ghc-8.0.1
  153. * Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.12-4
  154. - rebuilt
  155. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.12-3
  156. - correct SPEC file
  157. * Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.12-2
  158. - rebuild under dependent rpm packages
  159. * Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.12-1
  160. - new package