xorg-x11-xfs-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373
  1. Summary: X.Org X11 xfs font server
  2. Summary(ja): X.Org X11 xfs フォントサーバ
  3. Name: xorg-x11-xfs
  4. Version: 1.1.4
  5. Release: 2%{?_dist_release}
  6. License: MIT/X11
  7. Group: System Environment/Daemons
  8. URL: http://www.x.org
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. Source0: ftp://ftp.x.org/pub/individual/app/xfs-%{version}.tar.bz2
  11. Source1: ftp://ftp.x.org/pub/individual/app/xfsinfo-1.0.5.tar.bz2
  12. Source2: ftp://ftp.x.org/pub/individual/app/fslsfonts-1.0.5.tar.bz2
  13. Source3: ftp://ftp.x.org/pub/individual/app/fstobdf-1.0.6.tar.bz2
  14. Source4: ftp://ftp.x.org/pub/individual/app/showfont-1.0.5.tar.bz2
  15. Source10: xfs.init
  16. Source11: xfs.config
  17. BuildRequires: pkgconfig
  18. # xfs needs 'fontsproto' to build, as indicated by ./configure
  19. BuildRequires: xorg-x11-proto-devel
  20. # FIXME: xfs needs xtrans to build, but autotools doesn't detect it missing
  21. BuildRequires: xorg-x11-xtrans-devel
  22. BuildRequires: xorg-x11-util-macros
  23. BuildRequires: libFS-devel
  24. BuildRequires: libXfont-devel
  25. BuildRequires: libX11-devel
  26. # FIXME: xfs needs freetype-devel to build, but autotools doesn't detect it missing
  27. BuildRequires: freetype2-devel
  28. BuildRequires: libfontenc-devel
  29. # Make sure libXfont provides the catalogue FPE.
  30. Requires: libXfont
  31. Obsoletes: XFree86-xfs, XOrg-xfs
  32. Provides: xfs
  33. Provides: XOrg-xfs = 7.0
  34. Requires(pre): util-linux, shadow-utils
  35. Requires(post): initscripts, grep, sed, coreutils
  36. Requires(preun): initscripts, chkconfig
  37. Requires(postun): initscripts
  38. # xfs initscript runtime dependencies
  39. Requires: initscripts, fontconfig, sed, findutils
  40. Requires: coreutils
  41. Requires: mkfontdir, mkfontscale, ttmkfdir
  42. # end of xfs initscript runtime dependencies
  43. %description
  44. X.Org X11 xfs font server
  45. %package utils
  46. Summary: X.Org X11 font server utilities
  47. Summary(ja): X.Org X11 フォントサーバユーティリティ
  48. Group: User Interface/X
  49. Conflicts: XOrg-xfs < 7.0
  50. %description utils
  51. X.Org X11 font server utilities
  52. %prep
  53. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
  54. %build
  55. # Build xfs
  56. {
  57. pushd xfs-*
  58. %configure --disable-devel-docs
  59. make configdir=%{_sysconfdir}/X11/fs
  60. popd
  61. }
  62. for pkg in xfsinfo fslsfonts fstobdf showfont ; do
  63. pushd ${pkg}-*
  64. %configure
  65. make
  66. popd
  67. done
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. # Install xfs
  71. {
  72. pushd xfs-*
  73. %makeinstall configdir=$RPM_BUILD_ROOT%{_sysconfdir}/X11/fs
  74. popd
  75. }
  76. for pkg in xfsinfo fslsfonts fstobdf showfont ; do
  77. pushd ${pkg}-*
  78. make install DESTDIR=$RPM_BUILD_ROOT
  79. popd
  80. done
  81. # Install the modified xfs config file and initscript
  82. {
  83. mkdir -p $RPM_BUILD_ROOT/etc/{X11/fs,rc.d/init.d}
  84. install -c -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/xfs
  85. install -c -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/X11/fs/config
  86. }
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %triggerpostun -- XFree86-xfs
  90. {
  91. /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
  92. /sbin/chkconfig --add xfs
  93. /sbin/service xfs condrestart || :
  94. } &> /dev/null || :
  95. %triggerpostun -- XOrg-xfs
  96. {
  97. /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
  98. /sbin/chkconfig --add xfs
  99. /sbin/service xfs condrestart || :
  100. } &> /dev/null || :
  101. %pre
  102. {
  103. /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
  104. # Upgrade path:
  105. if [ "$1" -gt "1" ] ; then
  106. if [ -e "/usr/X11R6/lib/X11/fs/config" ] ; then
  107. cat <<-EOF > "/etc/X11/fs/xfs-migrate"
  108. On upgrades, we now must determine if we are upgrading from monolithic
  109. xfs or modular xfs by checking for the existance of the old monolithic
  110. xfs config file. If found, we know it is a monolith->modular upgrade,
  111. so we set this flag file in order for xfs.init to perform a "restart"
  112. instead of a "reload" in the 'condrestart'. See bug #173271 for
  113. details.
  114. EOF
  115. fi
  116. fi
  117. } &> /dev/null || : # Silence output, and ignore errors (Bug #91822)
  118. %post
  119. {
  120. # Install section
  121. /sbin/chkconfig --add xfs
  122. #------------------------------------------------------------------------
  123. # Upgrade section
  124. if [ "$1" -gt "1" ] ; then
  125. XORG_CONFIG=/etc/X11/xorg.conf
  126. XFSCONFIG=/etc/X11/fs/config
  127. # XFS config file upgrade munging
  128. if [ -f $XFSCONFIG ] ; then
  129. # Remove Speedo font directories from xfs config if present to avoid
  130. # bug reports about xfs complaining about empty directories in syslog.
  131. perl -p -i -e 's#^.*/.*/Speedo.*\n##' $XFSCONFIG
  132. # On upgrades, remove /usr/X11R6 font path elements from the XFS config file
  133. if grep -q "/usr/X11R6/lib/X11/fonts" $XFSCONFIG &> /dev/null ; then
  134. for fpe in misc:unscaled 75dpi:unscaled 100dpi:unscaled Type1 ; do
  135. perl -p -i -e "s#/usr/X11R6/lib/X11/fonts/${fpe}#%{_x11fontdir}/${fpe}#g" $XFSCONFIG
  136. done
  137. fi
  138. fi
  139. fi ; # End Upgrade section
  140. }
  141. %preun
  142. {
  143. if [ "$1" = "0" ]; then
  144. /sbin/service xfs stop &> /dev/null || :
  145. /sbin/chkconfig --del xfs || :
  146. fi
  147. }
  148. %postun
  149. {
  150. if [ "$1" -gt "1" ]; then
  151. /sbin/service xfs condrestart &> /dev/null || :
  152. fi
  153. }
  154. %files
  155. %defattr(-,root,root,-)
  156. %doc xfs-%{version}/AUTHORS xfs-%{version}/COPYING
  157. %doc xfs-%{version}/NEWS xfs-%{version}/README xfs-%{version}/ChangeLog
  158. %{_bindir}/xfs
  159. %dir %{_sysconfdir}/X11
  160. %dir %{_sysconfdir}/X11/fs
  161. %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/X11/fs/config
  162. %{_mandir}/man1/xfs.1*
  163. %{_sysconfdir}/rc.d/init.d/xfs
  164. %files utils
  165. %{_bindir}/fslsfonts
  166. %{_bindir}/fstobdf
  167. %{_bindir}/showfont
  168. %{_bindir}/xfsinfo
  169. %{_mandir}/man1/fslsfonts.1*
  170. %{_mandir}/man1/fstobdf.1*
  171. %{_mandir}/man1/showfont.1*
  172. %{_mandir}/man1/xfsinfo.1*
  173. %changelog
  174. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-2
  175. - xfsinfo-1.0.5
  176. - fslsfonts-1.0.5
  177. - fstobdf-1.0.6
  178. - showfont-1.0.5
  179. * Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
  180. - update to 1.1.4
  181. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-2
  182. - xfsinfo-1.0.4
  183. - showfont-1.0.4
  184. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
  185. - update to 1.1.3
  186. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
  187. - fslsfonts-1.0.3
  188. - fstobdf-1.0.4
  189. * Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-1
  190. - xfs-1.1.2
  191. - add BuildRequires: xorg-x11-util-macros
  192. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
  193. - xfs-1.1.1
  194. - xfsinfo-1.0.3
  195. - fslsfonts-1.0.3
  196. - fstobdf-1.0.4
  197. - showfont-1.0.3
  198. * Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  199. - xfs-1.1.0
  200. * Sun May 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.8-1
  201. - new upstream release
  202. - xfs-1.0.8, xfsinfo-1.0.2, fslsfont-1.0.2,
  203. fstobdf-1.0.3, showfont-1.0.2
  204. * Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
  205. - add version-release to Obsoletes: XOrg-xfs
  206. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-3
  207. - add version-release to Provides: XOrg-xfs
  208. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
  209. - add Provides: XOrg-xfs for compatibility
  210. * Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
  211. - initial build for Vine Linux
  212. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.0.5-2
  213. - Autorebuild for GCC 4.3
  214. * Tue Oct 02 2007 Adam Jackson <ajax@redhat.com> 1:1.0.5-1
  215. - xfs 1.0.5
  216. * Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 1:1.0.4-2
  217. - Rebuild for ppc toolchain bug
  218. * Fri Jul 27 2007 Bill Nottingham <notting@redhat.com> - 1:1.0.4-2
  219. - don't run by default any more, as it's not used by default
  220. - remove explicit restorecon dependency (#215142)
  221. * Fri Jun 22 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 1:1.0.4-1
  222. - Require catalogue capable libXfont.
  223. - Drop xfs.config.in, just use catalogue font path.
  224. - Stop xorg.conf munging madness.
  225. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1:1.0.2-4
  226. - Don't install INSTALL
  227. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.0.2-3.1
  228. - rebuild
  229. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.2-3
  230. - Added xfs documentation to doc macro.
  231. - Use "make install" instead of makeinstall macro.
  232. - Clean up source file URLs.
  233. * Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
  234. - Fix BuildRequires (#191856).
  235. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-1
  236. - Update xfs and fstobdf
  237. * Wed Mar 01 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-4
  238. - Fix all rpm scriptlets "upgrade" tests to only execute on upgrades.
  239. * Sat Feb 25 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
  240. - Redirect output of "rm -rf fonts.dir" to /dev/null in xfs.init
  241. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-2.1
  242. - bump again for double-long bug on ppc(64)
  243. * Thu Feb 09 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
  244. - Removed invocation of fc-cache from xfs initscript for bug (#179362)
  245. - Redirect stderr to /dev/null to squelch an unwanted error xfs.init (#155349)
  246. - Replace "s#^/.*:[a-z]*$##g" with "s#:unscaled$##g" in xfs.init for (#179491)
  247. - Cosmetic cleanups to spec file to satiate the banshees.
  248. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
  249. - rebuilt for new gcc4.1 snapshot and glibc changes
  250. * Mon Jan 16 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
  251. - Updated all tarballs to version 1.0.1 from X11R7.0
  252. * Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> 1:1.0.0-2
  253. - fix rpm post script (#176009, <ville.skytta@iki.fi>)
  254. * Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
  255. - Updated all tarballs to version 1.0.0 from X11R7 RC4.
  256. - Get default X font directory with font-utils package 'fontdir' pkgconfig
  257. variable.
  258. - Change manpage dir from man1x back to man1 to match upstream.
  259. * Tue Nov 15 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.2-4
  260. - require initscripts instead of /etc/init.d/functions
  261. * Tue Nov 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
  262. - Updated xfs pre script to check for the existance of the old monolithic
  263. /usr/X11R6/lib/X11/fs/config xfs config file, and set a migration flag
  264. file.
  265. - Updated xfs.init to check for the existance of the migration flag file,
  266. and perform an xfs 'restart' instead of a 'reload' if migrating. Users
  267. will now have to restart their X server, or reconnect the xfs server to
  268. the X server after a migration to modular X.
  269. - Changed upgrade comparison typo from 2 to 1 in xfs post script.
  270. * Mon Nov 14 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
  271. - Added temporary "BuildRequires: libXfont-devel >= 0.99.2-3" and
  272. "Requires: libXfont-devel >= 0.99.2-3" to ensure early-testers of
  273. pre-rawhide modular X have installed the work around for (#172997).
  274. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  275. - Updated to xfs-0.99.2 and fstobdf-0.99.2 from X11R7 RC2
  276. - Added Epoch 1 to package, and set the version number to the xfs 0.99.2
  277. version.
  278. * Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
  279. - Added showfont-0.99.1 from X11R7 RC1 release.
  280. * Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
  281. - Updated all packages to version 0.99.1 from X11R7 RC1.
  282. - Bump package version to 6.99.99.901 (the RC1 CVS tag).
  283. - Change manpage location to 'man1x' in file manifest.
  284. - Converted xfs.config to xfs.config.in, and added code to spec file to
  285. generate xfs.config depending on what the system _x11fontdir is.
  286. - Complete and total rewrite of xfs postinstall script to use "sed -i"
  287. and complete restructuring, which removed a lot of the super craptasticness
  288. that had been sitting there for years.
  289. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-4
  290. - Use Fedora-Extras style BuildRoot tag
  291. - Update BuildRequires to use new library package names
  292. - Remove unnecessary BuildRequires on 'install', and fix pkgconfig dep
  293. * Thu Aug 25 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-3
  294. - Install the initscript and xfs config file in the correct location as they
  295. were inadvertently interchanged in previous builds.
  296. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-2
  297. - Ported the xfs related rpm scripts over from monolithic packaging, and
  298. added up to date Requires(*) dependencies for all of them.
  299. - Flagged xfs config file as config(noreplace)
  300. - Added build and runtime dependencies to xfs subpackage as best as could be
  301. determined by analyzing ./configure output, and building in minimalized
  302. build root environment.
  303. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
  304. - Initial build.