xsp-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. %define mono_dir %{_prefix}/lib/mono
  2. Summary: Small Web Server Hosting ASP.NET
  3. Summary(ja): ASP.NET を提供する小さなウェブサーバ
  4. Name: xsp
  5. Version: 3.0.11
  6. Release: 1%{?_dist_release}
  7. License: MIT
  8. Group: Applications/Services
  9. URL: http://www.mono-project.com/docs/web/aspnet/
  10. Source0: https://github.com/mono/%{name}/archive/%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildArch: noarch
  13. BuildRequires: mono-devel mono-web
  14. BuildRequires: mono-data-sqlite mono-data-oracle mono-extras mono-nunit
  15. BuildRequires: monodoc
  16. BuildRequires: pkgconfig
  17. # One of the test runs requires this
  18. BuildRequires: sqlite3
  19. BuildRequires: automake autoconf libtool
  20. # This must be manually entered according to xsp's protocol version
  21. # Since this package is currently noarch, and mod_mono's name is different
  22. # on different distros, we can't use this... yet
  23. #Requires: mod_mono >= %{version}
  24. Distribution: Vine Linux
  25. Vendor: Project Vine
  26. Packager: owa
  27. %description
  28. The XSP server is a small Web server that hosts the Mono System.Web
  29. classes for running what is commonly known as ASP.NET.
  30. %package devel
  31. Summary: Development files for %{name}
  32. Summary(ja): %{name} の開発用ファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. Requires: pkgconfig
  36. %description devel
  37. The %{name}-devel package contains development files for %{name}.
  38. %prep
  39. %setup -q
  40. %build
  41. ./autogen.sh
  42. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  43. # Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
  44. ./configure \
  45. --prefix=%{_prefix} \
  46. --libexecdir=%{_prefix}/lib \
  47. --libdir=%{_prefix}/lib \
  48. --mandir=%{_prefix}/share/man \
  49. --infodir=%{_prefix}/share/info \
  50. --sysconfdir=%{_sysconfdir}
  51. make
  52. %install
  53. rm -rf $RPM_BUILD_ROOT
  54. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  55. make install DESTDIR=$RPM_BUILD_ROOT
  56. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
  57. mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
  58. %clean
  59. rm -rf $RPM_BUILD_ROOT
  60. %files
  61. %defattr(-,root,root)
  62. %doc ChangeLog COPYING NEWS README
  63. %{_bindir}/*
  64. %{_prefix}/lib/xsp
  65. %{mono_dir}/gac/Mono.WebServer2
  66. %{mono_dir}/gac/fastcgi-mono-server2
  67. %{mono_dir}/gac/fastcgi-mono-server4
  68. %{mono_dir}/gac/mod-mono-server2
  69. %{mono_dir}/gac/mod-mono-server4
  70. %{mono_dir}/gac/xsp2
  71. %{mono_dir}/gac/xsp4
  72. %{mono_dir}/2.0/Mono.WebServer2.dll
  73. %{mono_dir}/2.0/fastcgi-mono-server2.exe
  74. %{mono_dir}/2.0/mod-mono-server2.exe
  75. %{mono_dir}/2.0/xsp2.exe
  76. %{mono_dir}/4.5/Mono.WebServer2.dll
  77. %{mono_dir}/4.5/fastcgi-mono-server4.exe
  78. %{mono_dir}/4.5/mod-mono-server4.exe
  79. %{mono_dir}/4.5/xsp4.exe
  80. %{_mandir}/*/*
  81. %files devel
  82. %defattr(-,root,root,-)
  83. %{_prefix}/lib/monodoc/sources/Mono.WebServer.*
  84. %{_prefix}/lib/monodoc/sources/Mono.FastCGI.*
  85. %{_datadir}/pkgconfig/*
  86. %changelog
  87. * Wed Apr 15 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.11-1
  88. - updated to 3.0.11
  89. - added BR: monodoc
  90. - split development files into devel subpackage
  91. - built with mono 3.12.1
  92. * Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.2-1
  93. - updated xsp to 2.10.2
  94. * Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 2.10-2
  95. - rebuilt with mono-2.10.1-3
  96. * Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10-1
  97. - updated xsp to 2.10
  98. * Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
  99. - updated xsp to 2.8.2
  100. * Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
  101. - updated xsp to 2.8.1
  102. * Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
  103. - updated xsp to 2.8
  104. - rebuilt with mono-2.8
  105. - dropt BR: mono-jscript
  106. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-2
  107. - rebuild with rpm-4.8.1 for pkg-config file
  108. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
  109. - updated xsp to 2.6.5
  110. * Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
  111. - updated xsp to 2.6.4
  112. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
  113. - updated xsp to 2.6.3
  114. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
  115. - updated to 2.6
  116. - rebuilt with new toolchain
  117. * Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
  118. - updated to 2.4.3
  119. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
  120. - changed Group to Applications/Internet
  121. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
  122. - updated to 2.4
  123. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
  124. - initial build for VineSeed
  125. - updated xsp to 2.0
  126. - added japanese summary
  127. - applied vine versioning policy
  128. - spec in utf-8
  129. * Tue Apr 22 2008 wberrier@suse.de
  130. - update to 1.9.1 (bugfix release)
  131. - Output date header (instead of asp.net doing it)
  132. * Tue Mar 25 2008 wberrier@suse.de
  133. - update to 1.9
  134. - minor test updates
  135. - BaseRequestBroker fix: Check if the request ID is valid inside
  136. the lock.
  137. * Mon Jan 14 2008 wberrier@suse.de
  138. - update to 1.2.6
  139. - FastCGI support
  140. * Thu Aug 30 2007 wberrier@suse.de
  141. - xsp_1.2.5_p5_final.patch: Fix for regression in the request
  142. broker
  143. * Fri Aug 17 2007 wberrier@suse.de
  144. - xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
  145. - bugs: 81699, 81906, 82379, 82057
  146. - fixes ability to handle large (GB) uploads (needed for iFolder)
  147. * Fri Aug 3 2007 wberrier@suse.de
  148. - Update to 1.2.5
  149. - More robust exception handling
  150. - Fixed permissions bits for non executable scripts
  151. - virtual host support
  152. - New Documentation for Mono.WebServer
  153. - Improved event handling
  154. * Tue Jun 5 2007 wberrier@novell.com
  155. - Remove unnecessary path defines (prefix, sysconfdir)
  156. - Update to 1.2.4
  157. - fix some race conditions and crashes
  158. - add tracing support
  159. * Fri Apr 13 2007 wberrier@novell.com
  160. - add %%debug_package so debug packages get created
  161. * Wed Apr 11 2007 wberrier@novell.com
  162. - Add mono dep/req for older distros
  163. * Thu Mar 1 2007 wberrier@suse.de
  164. - Update Update to 1.2.3
  165. - Bug fix #80230 (prevents possible nullref)
  166. - Support for response header encoding
  167. * Mon Jan 22 2007 ro@suse.de
  168. - drop requires for gnome-filesystem
  169. * Sat Dec 2 2006 wberrier@suse.de
  170. - Update to 1.2.1 (Fate #301111)
  171. - Bugfixes:
  172. - close the connection if there's an error reading the headers
  173. (including assembly loading exceptions due to a bad installation).
  174. - kill the warning that everyone is worried about.
  175. * Fri Oct 20 2006 wberrier@suse.de
  176. - Update to 1.1.18
  177. - 2.0 updates
  178. * Thu Oct 19 2006 wberrier@suse.de
  179. - Add mono-devel to fix bnc #213576 (missing provides)
  180. * Tue Sep 5 2006 wberrier@suse.de
  181. - Update to 1.1.17.1 bugfix release
  182. - Read from the stream, not the socket as the socket data is
  183. encrypted when using SSL.
  184. * Wed Aug 30 2006 wberrier@suse.de
  185. - Update to 1.1.17
  186. - Added support for X.509 client certificates
  187. - Update to handle newly created AppDomains
  188. * Mon Jul 31 2006 wberrier@suse.de
  189. - update to 1.1.16.1
  190. - better connection handling
  191. - fixes bugs: 77698,78034,78621
  192. * Tue Apr 25 2006 wberrier@suse.de
  193. - Security update (remove all the duplicated slashes
  194. and don't do an extra Replace on non-windows.) and minor fix for
  195. [#78034].
  196. * Wed Jan 25 2006 mls@suse.de
  197. - converted neededforbuild to BuildRequires
  198. * Fri Jan 6 2006 wberrier@suse.de
  199. - Update to 1.1.13, clean up deps
  200. * Thu Nov 10 2005 wberrier@suse.de
  201. - Update to 1.1.10, set libdir to lib/
  202. * Fri Oct 7 2005 wberrier@suse.de
  203. - Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
  204. libexec, so I disabled the patch)
  205. * Tue Jul 19 2005 sbrabec@suse.cz
  206. - Build as noarch (#81109).
  207. * Fri Jul 15 2005 sbrabec@suse.cz
  208. - Updated to version 1.0.9 (#96776).
  209. * Mon Feb 21 2005 clahey@suse.de
  210. - Updated to 1.0.6.
  211. * Sun Feb 6 2005 ro@suse.de
  212. - use /usr/lib/mono
  213. * Mon Dec 13 2004 clahey@suse.de
  214. - New package.