xulrunner-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746
  1. # Minimal required versions
  2. %global nspr_version 4.8.9
  3. %global nss_version 3.13.1
  4. %global cairo_version 1.10.2
  5. %global freetype_version 2.1.9
  6. %global libnotify_version 0.7.0
  7. # gecko_dir_ver should be set to the version in our directory names
  8. # alpha_version should be set to the alpha number if using an alpha, 0 otherwise
  9. # beta_version should be set to the beta number if using a beta, 0 otherwise
  10. # rc_version should be set to the RC number if using an RC, 0 otherwise
  11. %global gecko_dir_ver %{version}
  12. %global alpha_version 0
  13. %global beta_version 0
  14. %global rc_version 0
  15. %global mozappdir %{_libdir}/%{name}
  16. %global tarballdir mozilla-esr17
  17. Summary: XUL Runtime for Gecko Applications
  18. Summary(ja): Gecko アプリケーションのための XUL ランタイム
  19. Name: xulrunner
  20. Version: 17.0.2
  21. Release: 1%{?_dist_release}
  22. URL: http://developer.mozilla.org/En/XULRunner
  23. License: MPLv1.1 or GPLv2+ or LGPLv2+
  24. Group: Applications/Internet
  25. # You can get sources at ftp://ftp.mozilla.org/pub/firefox/releases/%{version}/source
  26. Source0: %{name}-%{version}esr.source.tar.bz2
  27. Source10: %{name}-mozconfig-vine
  28. Source12: %{name}-redhat-default-prefs.js
  29. Source21: %{name}.sh.in
  30. # build patches
  31. Patch1: xulrunner-install-dir.patch
  32. Patch2: mozilla-build.patch
  33. Patch14: xulrunner-2.0-chromium-types.patch
  34. Patch17: xulrunner-15.0-gcc47.patch
  35. # https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
  36. Patch18: xulrunner-16.0-jemalloc-ppc.patch
  37. # Fedora specific patches
  38. Patch20: mozilla-193-pkgconfig.patch
  39. # Upstream patches
  40. Patch49: mozilla-746112.patch
  41. Patch50: mozilla-813997.patch
  42. # ---------------------------------------------------
  43. BuildRequires: nspr-devel >= %{nspr_version}
  44. BuildRequires: nss-devel >= %{nss_version}
  45. BuildRequires: cairo-devel >= %{cairo_version}
  46. BuildRequires: libpng-devel
  47. BuildRequires: libjpeg-turbo-devel
  48. BuildRequires: zip
  49. BuildRequires: bzip2-devel
  50. BuildRequires: zlib-devel
  51. BuildRequires: libIDL-devel
  52. BuildRequires: gtk2-devel
  53. BuildRequires: krb5-devel
  54. BuildRequires: pango-devel
  55. BuildRequires: freetype2-devel >= %{freetype_version}
  56. BuildRequires: libXt-devel
  57. BuildRequires: libXrender-devel
  58. BuildRequires: startup-notification-devel
  59. BuildRequires: alsa-lib-devel
  60. BuildRequires: libnotify-devel >= %{libnotify_version}
  61. BuildRequires: mesa-libGL-devel
  62. BuildRequires: curl-devel
  63. BuildRequires: yasm
  64. Requires: nspr
  65. Requires: nss
  66. Provides: gecko-libs = %{gecko_verrel}
  67. Conflicts: firefox < 3.6
  68. Vendor: Project Vine
  69. Distribution: Vine Linux
  70. Packager: daisuke
  71. %description
  72. XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM
  73. applications that are as rich as Firefox and Thunderbird. It provides mechanisms
  74. for installing, upgrading, and uninstalling these applications. XULRunner also
  75. provides libxul, a solution which allows the embedding of Mozilla technologies
  76. in other projects and products.
  77. %package devel
  78. Summary: Development files for Gecko
  79. Summary(ja): Geckoの開発ファイル
  80. Group: Development/Libraries
  81. Obsoletes: mozilla-devel < 1.9
  82. Obsoletes: firefox-devel < 2.1
  83. Obsoletes: xulrunner-devel-unstable
  84. Provides: gecko-devel = %{gecko_verrel}
  85. Provides: gecko-devel-unstable = %{gecko_verrel}
  86. Requires: xulrunner = %{version}-%{release}
  87. Requires: nspr-devel
  88. Requires: nss-devel
  89. Requires: cairo-devel
  90. Requires: libjpeg-devel
  91. Requires: zip
  92. Requires: bzip2-devel
  93. Requires: zlib-devel
  94. Requires: libIDL-devel
  95. Requires: gtk2-devel
  96. Requires: krb5-devel
  97. Requires: pango-devel
  98. Requires: freetype-devel
  99. Requires: libXt-devel
  100. Requires: libXrender-devel
  101. Requires: startup-notification-devel
  102. Requires: alsa-lib-devel
  103. Requires: libnotify-devel
  104. Requires: mesa-libGL-devel
  105. %description devel
  106. This package contains the libraries amd header files that are needed
  107. for writing XUL+XPCOM applications with Mozilla XULRunner and Gecko.
  108. #---------------------------------------------------------------------
  109. %prep
  110. %setup -q -c
  111. cd %{tarballdir}
  112. %patch1 -p1
  113. %patch2 -p1 -b .build
  114. %patch14 -p2 -b .chromium-types
  115. %patch17 -p2 -b .gcc47
  116. %patch18 -p2 -b .jemalloc-ppc
  117. %patch20 -p2 -b .pk
  118. %patch49 -p2 -b .746112
  119. %patch50 -p1 -b .813997
  120. %{__rm} -f .mozconfig
  121. %{__cp} %{SOURCE10} .mozconfig
  122. echo "ac_add_options --disable-system-sqlite" >> .mozconfig
  123. %ifarch armv7hl
  124. echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
  125. echo "ac_add_options --with-float-abi=hard" >> .mozconfig
  126. echo "ac_add_options --with-fpu=vfpv3-d16" >> .mozconfig
  127. echo "ac_add_options --disable-elf-hack" >> .mozconfig
  128. %endif
  129. %ifarch armv7hnl
  130. echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
  131. echo "ac_add_options --with-float-abi=hard" >> .mozconfig
  132. echo "ac_add_options --with-fpu=neon" >> .mozconfig
  133. echo "ac_add_options --disable-elf-hack" >> .mozconfig
  134. %endif
  135. %ifarch armv5tel
  136. echo "ac_add_options --with-arch=armv5te" >> .mozconfig
  137. echo "ac_add_options --with-float-abi=soft" >> .mozconfig
  138. echo "ac_add_options --disable-elf-hack" >> .mozconfig
  139. %endif
  140. %ifnarch %{ix86} x86_64
  141. echo "ac_add_options --disable-methodjit" >> .mozconfig
  142. echo "ac_add_options --disable-monoic" >> .mozconfig
  143. echo "ac_add_options --disable-polyic" >> .mozconfig
  144. echo "ac_add_options --disable-tracejit" >> .mozconfig
  145. %endif
  146. #---------------------------------------------------------------------
  147. %build
  148. cd %{tarballdir}
  149. # -fpermissive is needed to build with gcc 4.6+ which has become stricter
  150. #
  151. # Mozilla builds with -Wall with exception of a few warnings which show up
  152. # everywhere in the code; so, don't override that.
  153. #
  154. # Disable C++ exceptions since Mozilla code is not exception-safe
  155. #
  156. MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
  157. %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
  158. export CFLAGS=$MOZ_OPT_FLAGS
  159. export CXXFLAGS=$MOZ_OPT_FLAGS
  160. export PREFIX='%{_prefix}'
  161. export LIBDIR='%{_libdir}'
  162. MOZ_SMP_FLAGS=-j1
  163. # On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
  164. # however builds tend to fail on other arches when building in parallel.
  165. %ifarch %{ix86} x86_64
  166. [ -z "$RPM_BUILD_NCPUS" ] && \
  167. RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
  168. [ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
  169. [ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
  170. %endif
  171. make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS" MOZ_SERVICES_SYNC="1"
  172. #---------------------------------------------------------------------
  173. %install
  174. cd %{tarballdir}
  175. # set up our prefs before install, so it gets pulled in to omni.jar
  176. %{__cp} -p %{SOURCE12} dist/bin/defaults/pref/all-redhat.js
  177. DESTDIR=$RPM_BUILD_ROOT make install
  178. # Start script install
  179. %{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
  180. %{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{gecko_dir_ver},g' > \
  181. $RPM_BUILD_ROOT%{_bindir}/%{name}
  182. %{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
  183. %{__rm} -f $RPM_BUILD_ROOT%{mozappdir}/%{name}-config
  184. # Copy pc files (for compatibility with 1.9.1)
  185. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
  186. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
  187. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
  188. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
  189. # Fix multilib devel conflicts...
  190. function install_file() {
  191. genheader=$*
  192. mv ${genheader}.h ${genheader}%{__isa_bits}.h
  193. cat > ${genheader}.h << EOF
  194. /* This file exists to fix multilib conflicts */
  195. #if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__) || (defined(__sparc__) && defined(__arch64__))
  196. #include "${genheader}64.h"
  197. #else
  198. #include "${genheader}32.h"
  199. #endif
  200. EOF
  201. }
  202. INTERNAL_APP_NAME=%{name}-%{gecko_dir_ver}
  203. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
  204. install_file "mozilla-config"
  205. install_file "js-config"
  206. popd
  207. # Link libraries in sdk directory instead of copying them:
  208. pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-devel-%{gecko_dir_ver}/sdk/lib
  209. for i in *.so; do
  210. rm $i
  211. ln -s %{mozappdir}/$i $i
  212. done
  213. popd
  214. # Library path
  215. #LD_SO_CONF_D=%{_sysconfdir}/ld.so.conf.d
  216. #LD_CONF_FILE=xulrunner-%{__isa_bits}.conf
  217. #%{__mkdir_p} ${RPM_BUILD_ROOT}${LD_SO_CONF_D}
  218. #%{__cat} > ${RPM_BUILD_ROOT}${LD_SO_CONF_D}/${LD_CONF_FILE} << EOF
  219. #%{mozappdir}
  220. #EOF
  221. # Copy over the LICENSE
  222. %{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT%{mozappdir}
  223. # Install xpcshell
  224. %{__cp} dist/bin/xpcshell $RPM_BUILD_ROOT/%{mozappdir}
  225. # Install run-mozilla.sh
  226. %{__cp} dist/bin/run-mozilla.sh $RPM_BUILD_ROOT/%{mozappdir}
  227. # ghost files
  228. %{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/components
  229. touch $RPM_BUILD_ROOT%{mozappdir}/components/compreg.dat
  230. touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
  231. #---------------------------------------------------------------------
  232. %post -p /sbin/ldconfig
  233. %postun -p /sbin/ldconfig
  234. %preun
  235. # is it a final removal?
  236. if [ $1 -eq 0 ]; then
  237. %{__rm} -rf %{mozappdir}/components
  238. fi
  239. %files
  240. %defattr(-,root,root,-)
  241. %{_bindir}/xulrunner
  242. %dir %{mozappdir}
  243. %doc %attr(644, root, root) %{mozappdir}/LICENSE
  244. %doc %attr(644, root, root) %{mozappdir}/README.xulrunner
  245. %{mozappdir}/chrome
  246. %{mozappdir}/chrome.manifest
  247. %{mozappdir}/dictionaries
  248. %dir %{mozappdir}/components
  249. %ghost %{mozappdir}/components/compreg.dat
  250. %ghost %{mozappdir}/components/xpti.dat
  251. %{mozappdir}/components/*.so
  252. %{mozappdir}/components/*.manifest
  253. %{mozappdir}/omni.ja
  254. %{mozappdir}/plugins
  255. %{mozappdir}/*.so
  256. %{mozappdir}/mozilla-xremote-client
  257. %{mozappdir}/run-mozilla.sh
  258. %{mozappdir}/xulrunner
  259. %{mozappdir}/xulrunner-stub
  260. %{mozappdir}/platform.ini
  261. %{mozappdir}/dependentlibs.list
  262. #%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
  263. %{mozappdir}/plugin-container
  264. %files devel
  265. %defattr(-,root,root,-)
  266. %dir %{_libdir}/%{name}-devel-*
  267. %{_datadir}/idl/%{name}*%{gecko_dir_ver}
  268. %{_includedir}/%{name}*%{gecko_dir_ver}
  269. %{_libdir}/%{name}-devel-*/*
  270. %{_libdir}/pkgconfig/*.pc
  271. %{mozappdir}/xpcshell
  272. #---------------------------------------------------------------------
  273. %changelog
  274. * Fri Jan 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 17.0.2-1
  275. - update to 17.0.2esr
  276. - remove /etc/ld.so.conf.d/xulrunner*.conf
  277. * Wed Oct 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.8-1
  278. - update to 10.0.8esr
  279. * Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.6-1
  280. - update to 10.0.6 (based on firefox-10.0.6esr source)
  281. * Wed Mar 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.3-1
  282. - update to 10.0.3 (based on firefox-10.0.3esr source)
  283. - clean up spec
  284. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-3
  285. - rebuild with libnotify-0.7
  286. * Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-2
  287. - modify gre.conf to promote internal gecko version.
  288. * Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
  289. - update to 2.0.1 (sync with firefox-4.0.1)
  290. * Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
  291. - update to 2.0 (sync with firefox-4.0)
  292. - BR: libjpeg-turbo-devel >= 1.1.0
  293. - BR: nspr-devel >= 4.8.7
  294. - BR: nss-devel >= 3.12.9
  295. - BR: cairo-devel >= 1.10.2-2
  296. - add Patch130 to use omni.jar (upstream patch)
  297. * Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
  298. - update to 1.9.2.15 (sync with firefox-3.6.15)
  299. * Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
  300. - update to 1.9.2.14 (sync with firefox-3.6.14)
  301. * Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
  302. - update to 1.9.2.13 (sync with firefox-3.6.13)
  303. * Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
  304. - update to 1.9.2.11 (sync with firefox-3.6.11)
  305. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
  306. - rebuild with rpm-4.8.1 for pkg-config file
  307. * Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
  308. - update to 1.9.2.9 (sync with firefox-3.6.9)
  309. - add patch10 to build with libjpeg-turbo
  310. - build with sqlite-3.7.2
  311. - BR: nspr >= 4.8.6
  312. * Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
  313. - update tp 1.9.2.8 (sync with firefox-3.6.8)
  314. * Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
  315. - update tp 1.9.2.7 (sync with firefox-3.6.7)
  316. * Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
  317. - enable ipc only on ix86/x86_64 arches
  318. * Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
  319. - update to 1.9.2.4 (sync with firefox-3.6.4)
  320. - add patch10 to fix build failure
  321. * Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
  322. - update to 1.9.2.3 (sync with firefox-3.6.3)
  323. * Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
  324. - update to 1.9.2.2 (sync with firefox-3.6.2)
  325. - add patch7,9 for fix build failure
  326. * Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
  327. - enable libnotify support
  328. - add ac_add_options --enable-libnotify
  329. - disable Necko wifi monitor
  330. - add ac_add_options --disable-necko-wifi
  331. - remove BR: wireless-tools-devel
  332. - fix %%files devel
  333. - add patch3,5 to fix jemalloc alignment assertion
  334. - add Patch8 to fix mozilla-plugin.pc
  335. * Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
  336. - add BR: libnotify-devel, wireless-tools-devel
  337. * Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  338. - update to 1.9.2 (sync with firefox-3.6)
  339. - obsoletes xulrunner-devel-unstable
  340. * Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
  341. - use internal sqlite3 on vine5
  342. * Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
  343. - update to 1.9.1.7
  344. * Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
  345. - update to 1.9.1.6
  346. - build with sqlite3-3.6.21
  347. * Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
  348. - update to 1.9.1.5
  349. * Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
  350. - update to 1.9.1.3
  351. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
  352. - really update to 1.9.1.2 (<BTS:0748>)
  353. * Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
  354. - update to 1.9.1.2 (sync with firefox-3.5.2)
  355. * Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
  356. - update to 1.9.1.1 (sync with firefox-3.5.1)
  357. - add missing Requires to -devel
  358. - add missing BR
  359. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
  360. - enable-system-cairo
  361. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
  362. - update to 1.9.1 (based on firefox 3.5)
  363. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
  364. - update to 1.9.1rc3 (sync with firefox 3.5rc3)
  365. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
  366. - update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
  367. - remove old patches
  368. - require nspr >= 4.8
  369. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
  370. - new upstream release
  371. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
  372. - update mozconfig
  373. - disable-system-cairo for stability
  374. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
  375. - new upstream release
  376. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
  377. - new upstream release
  378. - add ja locale
  379. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
  380. - new upstream release
  381. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
  382. - new upstream release
  383. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
  384. - add Patch3
  385. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
  386. - update to xulrunner 1.9.0.2 byild 6
  387. - build with gnome-2.24
  388. * Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
  389. - new upstream release
  390. * Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
  391. - initial build for Vine Linux
  392. * Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
  393. - Update to 1.9 final
  394. * Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
  395. - Simplify PS/PDF operators
  396. * Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
  397. - Upstream patch to fsync() less
  398. * Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
  399. - Ensure we enable startup notification; add BR and modify config
  400. (bug #445543)
  401. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
  402. - Some files moved to mozilla-filesystem; kill them and add the Req
  403. * Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
  404. - Clean up the %%files list and get rid of the executable bit on some files
  405. * Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
  406. - Fix font scaling
  407. * Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
  408. - Enabled phishing protection (#443403)
  409. * Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
  410. - Changed "__ppc64__" to "__powerpc64__",
  411. "__ppc64__" doesn't work anymore
  412. - Added fix for #443725 - Critical hanging bug with fix
  413. available upstream (mozbz#429903)
  414. * Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
  415. - Fixed multilib issues, added starting script instead of a symlink
  416. to binary (#436393)
  417. * Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
  418. - Add upstream patches for dpi, toolbar buttons, and invalid keys
  419. - Re-enable system cairo
  420. * Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
  421. - Spec cleanups
  422. * Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
  423. - Beta 5
  424. * Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
  425. - Beta 5 RC2
  426. * Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
  427. - Update to latest trunk (2008-03-27)
  428. * Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
  429. - Update to latest trunk (2008-03-26)
  430. * Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
  431. - Update to latest trunk (2008-03-25)
  432. * Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
  433. - Update to latest trunk (2008-03-24)
  434. * Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
  435. - Update to latest trunk (2008-03-20)
  436. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
  437. - Update to latest trunk (2008-03-17)
  438. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
  439. - Revert to trunk from the 15th to fix crashes on HTTPS sites
  440. * Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
  441. - Update to latest trunk (2008-03-16)
  442. - Add patch to negate a11y slowdown on some pages (#431162)
  443. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
  444. - Update to latest trunk (2008-03-15)
  445. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
  446. - Avoid conflicts between gecko debuginfo packages
  447. * Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
  448. - Update to latest trunk (2008-03-12)
  449. * Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
  450. - Update to latest trunk (2008-03-11)
  451. * Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
  452. - Update to latest trunk (2008-03-10)
  453. * Sun Mar 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
  454. - Update to latest trunk (2008-03-09)
  455. * Fri Mar 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
  456. - Update to latest trunk (2008-03-07)
  457. * Thu Mar 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
  458. - Update to latest trunk (2008-03-06)
  459. * Tue Mar 4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
  460. - Update to latest trunk (2008-03-04)
  461. * Sun Mar 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
  462. - Update to latest trunk (2008-03-02)
  463. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
  464. - Update to latest trunk (2008-03-01)
  465. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
  466. - Update to latest trunk (2008-02-29)
  467. * Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
  468. - Update to latest trunk (2008-02-28)
  469. * Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
  470. - Update to latest trunk (2008-02-27)
  471. * Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
  472. - Update to latest trunk (2008-02-26)
  473. * Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
  474. - Update to latest trunk (2008-02-23)
  475. * Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
  476. - Update to latest trunk (2008-02-22)
  477. * Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
  478. - Update to latest trunk (2008-02-21)
  479. * Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
  480. - Update to latest trunk (2008-02-20)
  481. * Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
  482. - Update to latest trunk (2008-02-17)
  483. * Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
  484. - Update to latest trunk (2008-02-15)
  485. * Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
  486. - Update to latest trunk (2008-02-14)
  487. - Use system hunspell
  488. * Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
  489. - Update to latest trunk (2008-02-11)
  490. * Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
  491. - STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
  492. you know, debuginfo.
  493. * Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
  494. - Update to latest trunk (2008-02-10)
  495. * Sat Feb 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
  496. - Update to latest trunk (2008-02-09)
  497. * Wed Feb 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
  498. - Update to latest trunk (2008-02-06)
  499. * Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
  500. - Update to latest trunk (2008-01-30)
  501. * Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
  502. - rebuild agains new nss
  503. - enabled gnome vfs
  504. * Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
  505. - fixed stable pkg-config files (#429654)
  506. - removed sqlite patch
  507. * Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
  508. - Update to latest trunk (2008-01-21)
  509. * Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
  510. - Update to latest trunk (2008-01-15)
  511. - Now with system extensions directory support
  512. * Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
  513. - Update to latest trunk (2008-01-13)
  514. - Use CFLAGS instead of configure arguments
  515. - Random cleanups: BuildRequires, scriptlets, prefs, etc.
  516. * Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
  517. - Provide gecko-devel-unstable as well
  518. * Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
  519. - divided devel package to devel and devel-unstable
  520. * Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
  521. - removed fedora specific pkg-config files
  522. - updated to the latest trunk (2008-01-07)
  523. - removed unnecessary patches
  524. - fixed idl dir (#427965)
  525. * Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
  526. - Re-enable camellia256 support now that NSS supports it
  527. * Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
  528. - updated to the latest trunk (2008-01-03)
  529. * Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
  530. - Don't Provide webclient (xulrunner is not itself a webclient)
  531. - Don't Obsolete old firefox, only firefox-devel
  532. - Kill legacy obsoletes (phoenix, etc) that were never in rawhide
  533. * Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
  534. - added java and plugin subdirs to plugin includes
  535. * Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
  536. - dependency fixes, obsoletes firefox < 3 and firefox-devel now
  537. * Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
  538. - updated to Beta 2.
  539. - moved SDK to xulrunner-sdk
  540. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
  541. - fixed mozilla-plugin.pc (#412971)
  542. * Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
  543. - export /etc/gre.d/gre.conf (it's used by python gecko applications)
  544. * Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
  545. - added xulrunner/js include dir to xulrunner-js
  546. * Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
  547. - update to beta 1
  548. * Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
  549. - packed all gecko libraries (#389391)
  550. * Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
  551. - registered xulrunner libs system-wide
  552. - added xulrunner-gtkmozembed.pc
  553. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
  554. - added proper nss/nspr dependencies
  555. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
  556. - more build fixes, use system nss libraries
  557. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
  558. - build fixes
  559. * Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
  560. - updated to the latest trunk
  561. * Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
  562. - build fixes for ppc/ppc64
  563. * Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
  564. - removed conflicts with the current gecko-based apps
  565. - added updated ppc64 patch
  566. * Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
  567. - build fixes
  568. * Wed Sep 5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
  569. - Initial cut at XULRunner 1.9 Alpha 7
  570. - Temporarily revert camellia 256 support since our nss doesn't support it yet