llvm-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # Build options:
  3. # Components skipped by default:
  4. %bcond_with doxygen
  5. # Documentation install path
  6. %global llvmdocdir() %{_docdir}/%1-%{version}
  7. Name: llvm
  8. Version: 3.5.1
  9. Release: 1%{?_dist_release}
  10. Summary: The Low Level Virtual Machine
  11. Summary(ja): LLVM - 低レベルバーチャルマシン
  12. Group: Development/Languages
  13. License: NCSA
  14. URL: http://llvm.org/
  15. Source0: http://llvm.org/releases/%{version}/llvm-%{version}.src.tar.xz
  16. Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
  17. Source2: http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
  18. Source3: http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
  19. # multilib fixes
  20. Source10: llvm-Config-config.h
  21. Source11: llvm-Config-llvm-config.h
  22. # patches
  23. Patch1: llvm-3.5.0-build-fix.patch
  24. Patch2: 0001-data-install-preserve-timestamps.patch
  25. # newish glibc hides the definition of __extern_always_inline behind
  26. # a check for gcc 4.3, clang pretends to be gcc 4.2. a proper fix would
  27. # be to build everything herein with gcc, but i don't have the patience
  28. # atm, so in the interest of bootstrapping...
  29. Patch100: clang-fake-gcc43.patch
  30. # http://llvm.org/bugs/show_bug.cgi?id=22625
  31. Patch101: clang-pr22625.patch
  32. Patch200: lldb-python.patch
  33. Patch201: lldb-fix-expression-parser.patch
  34. Patch202: lldb-python-module-symlink.patch
  35. # Vine Patch
  36. Patch1000: clang-3.5.0-driver-ld.gold.patch
  37. Patch1001: clang-3.5.0-driver-lib64.patch
  38. Patch1002: clang-3.5.0-driver-vine.patch
  39. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  40. BuildRequires: binutils-devel
  41. BuildRequires: bison
  42. BuildRequires: chrpath
  43. BuildRequires: flex
  44. BuildRequires: gcc-c++ >= 3.4
  45. BuildRequires: groff
  46. BuildRequires: libffi-devel
  47. BuildRequires: libtool-ltdl-devel
  48. BuildRequires: ocaml
  49. BuildRequires: perl
  50. # for DejaGNU test suite
  51. BuildRequires: dejagnu tcl python
  52. %if %{with doxygen}
  53. BuildRequires: doxygen graphviz
  54. %endif
  55. # lldb
  56. BuildRequires: swig
  57. BuildRequires: libedit-devel
  58. BuildRequires: python-devel
  59. Requires: llvm-libs = %{version}-%{release}
  60. # LLVM is not supported on PPC64
  61. # http://llvm.org/bugs/show_bug.cgi?id=3729
  62. ExcludeArch: ppc64
  63. %description
  64. LLVM is a compiler infrastructure designed for compile-time,
  65. link-time, runtime, and idle-time optimization of programs from
  66. arbitrary programming languages. The compiler infrastructure includes
  67. mirror sets of programming tools as well as libraries with equivalent
  68. functionality.
  69. %package devel
  70. Summary: Libraries and header files for LLVM
  71. Summary(ja): LLVM のライブラリおよびヘッダファイル
  72. Group: Development/Libraries
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: libstdc++-devel
  75. Requires: libffi-devel
  76. Provides: llvm-static = %{version}-%{release}
  77. %description devel
  78. This package contains library and header files needed to develop new
  79. native programs that use the LLVM infrastructure.
  80. %package doc
  81. Summary: Documentation for LLVM
  82. Summary(ja): LLVM のドキュメント
  83. Group: Documentation
  84. BuildArch: noarch
  85. Requires: %{name} = %{version}-%{release}
  86. # might seem redundant, but needed to kill off the old arch-ed -doc subpackage
  87. Obsoletes: %{name}-doc < %{version}-%{release}
  88. %description doc
  89. Documentation for the LLVM compiler infrastructure.
  90. %package libs
  91. Summary: LLVM shared libraries
  92. Summary(ja): LLVM 共有ライブラリ
  93. Group: System Environment/Libraries
  94. %description libs
  95. Shared libraries for the LLVM compiler infrastructure.
  96. %package -n clang
  97. Summary: A C language family front-end for LLVM
  98. Summary(ja): LLVM の C 言語フロントエンド
  99. License: NCSA
  100. Group: Development/Languages
  101. Requires: %{name} = %{version}-%{release}
  102. # clang requires gcc, clang++ requires libstdc++-devel
  103. Requires: libstdc++-devel
  104. # remove clang-doc pacakge
  105. Obsoletes: clang-doc < %{version}-%{release}
  106. %description -n clang
  107. clang: noun
  108. 1. A loud, resonant, metallic sound.
  109. 2. The strident call of a crane or goose.
  110. 3. C-language family front-end toolkit.
  111. The goal of the Clang project is to create a new C, C++, Objective C
  112. and Objective C++ front-end for the LLVM compiler. Its tools are built
  113. as libraries and designed to be loosely-coupled and extensible.
  114. %Package -n clang-libs
  115. Summary: Runtime library for clang
  116. Summary(ja): Clang のランタイムライブラリ
  117. Group: System Environment/Libraries
  118. %description -n clang-libs
  119. Runtime library for clang.
  120. %package -n clang-devel
  121. Summary: Header files for clang
  122. Summary(ja): Clang のヘッダファイル
  123. Group: Development/Libraries
  124. Requires: clang = %{version}-%{release}
  125. %description -n clang-devel
  126. This package contains header files for the Clang compiler.
  127. %package -n clang-analyzer
  128. Summary: A source code analysis framework
  129. Summary(ja): ソースコー分析フレームワーク
  130. License: NCSA
  131. Group: Development/Languages
  132. Requires: clang = %{version}-%{release}
  133. # not picked up automatically since files are currently not instaled
  134. # in standard Python hierarchies yet
  135. Requires: python
  136. %description -n clang-analyzer
  137. The Clang Static Analyzer consists of both a source code analysis
  138. framework and a standalone tool that finds bugs in C and Objective-C
  139. programs. The standalone tool is invoked from the command-line, and is
  140. intended to run in tandem with a build of a project or code base.
  141. #%package -n clang-doc
  142. #Summary: Documentation for Clang
  143. #Summary(ja): Clang のドキュメント
  144. #Group: Documentation
  145. #Requires: %{name} = %{version}-%{release}
  146. #
  147. #%description -n clang-doc
  148. #Documentation for the Clang compiler front-end.
  149. %package -n lldb
  150. Summary: Next generation high-performance debugger
  151. Summary(ja): 高性能デバッガー
  152. License: NCSA
  153. Group: Development/Debuggers
  154. Requires: %{name} = %{version}-%{release}
  155. %description -n lldb
  156. LLDB is a next generation, high-performance debugger. It is built as a set
  157. of reusable components which highly leverage existing libraries in the
  158. larger LLVM Project, such as the Clang expression parser and LLVM
  159. disassembler.
  160. %package -n lldb-devel
  161. Summary: Header files for LLDB
  162. Summary(ja): LLDB のヘッダファイル
  163. Group: Development/Libraries
  164. Requires: lldb = %{version}-%{release}
  165. %description -n lldb-devel
  166. This package contains header files for the LLDB debugger.
  167. %if %{with doxygen}
  168. %package apidoc
  169. Summary: API documentation for LLVM
  170. Summary(ja): LLVM の API ドキュメント
  171. Group: Documentation
  172. BuildArch: noarch
  173. Requires: %{name}-docs = %{version}-%{release}
  174. %description apidoc
  175. API documentation for the LLVM compiler infrastructure.
  176. %package -n clang-apidoc
  177. Summary: API documentation for Clang
  178. Summary(ja): Clang の API ドキュメント
  179. Group: Documentation
  180. BuildArch: noarch
  181. %description -n clang-apidoc
  182. API documentation for the Clang compiler.
  183. %endif
  184. %package ocaml
  185. Summary: OCaml binding for LLVM
  186. Summary(ja): LLVM の OCaml バインディング
  187. Group: System Environment/Libraries
  188. Requires: %{name} = %{version}-%{release}
  189. Requires: ocaml
  190. %description ocaml
  191. OCaml binding for LLVM.
  192. %package ocaml-devel
  193. Summary: Development files for %{name}-ocaml
  194. Summary(ja): %{name}-ocaml の開発ファイル
  195. Group: Development/Libraries
  196. Requires: %{name}-devel = %{version}-%{release}
  197. Requires: %{name}-ocaml = %{version}-%{release}
  198. Requires: ocaml
  199. %description ocaml-devel
  200. The %{name}-ocaml-devel package contains libraries and signature files
  201. for developing applications that use %{name}-ocaml.
  202. %package ocaml-doc
  203. Summary: Documentation for %{name}-ocaml
  204. Summary(ja): %{name}-ocaml のドキュメント
  205. Group: Documentation
  206. BuildArch: noarch
  207. Requires: %{name}-ocaml = %{version}-%{release}
  208. # might seem redundant, but needed to kill off the old arch-ed -doc subpackage
  209. Obsoletes: %{name}-ocaml-doc < %{version}-%{release}
  210. %description ocaml-doc
  211. HTML documentation for LLVM's OCaml binding.
  212. # compat32'
  213. %package -n compat32-%{name}-libs
  214. Summary: LLVM shared libraries
  215. Summary(ja): LLVM 共有ライブラリ
  216. Group: System Environment/Libraries
  217. Requires: %{name}-libs = %{version}-%{release}
  218. %description -n compat32-%{name}-libs
  219. Shared libraries for the LLVM compiler infrastructure.
  220. %prep
  221. %setup -q -a1 -a2 -a3 -n llvm-%{version}.src
  222. rm -rf tools/clang tools/lldb projects/compiler-rt
  223. mv cfe-%{version}.src tools/clang
  224. mv compiler-rt-%{version}.src projects/compiler-rt
  225. mv lldb-%{version}.src tools/lldb
  226. %patch1 -p1
  227. %patch2 -p1
  228. # clang
  229. pushd tools/clang
  230. %patch100 -p1
  231. %patch101 -p0
  232. popd
  233. # lldb
  234. pushd tools/lldb
  235. # careful when recreating this patch...
  236. %patch200 -p1 -b .python
  237. %patch201 -p2
  238. %patch202 -p1
  239. sed -i s/@lib@/%{_lib}/g scripts/Python/modules/readline/Makefile
  240. popd
  241. # Vine Linux
  242. %patch1000 -p1 -b .driver-ld.gold
  243. %ifarch x86_64
  244. %patch1001 -p1 -b .driver-lib64
  245. %endif
  246. %patch1002 -p1 -b .driver-vine
  247. # fix library paths
  248. sed -i 's|/lib /usr/lib $lt_ld_extra|%{_libdir} $lt_ld_extra|' configure
  249. sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}/%{name}|g' Makefile.config.in
  250. sed -i 's|/lib\>|/%{_lib}/%{name}|g' tools/llvm-config/llvm-config.cpp
  251. %build
  252. export CC=/usr/bin/gcc
  253. export CXX=/usr/bin/g++
  254. # -fno-devirtualize shouldn't be necessary, but gcc has scary template-related
  255. # bugs that make it so. gcc 5 ought to be fixed.
  256. %configure \
  257. --with-extra-options="-fno-devirtualize" \
  258. --with-extra-ld-options=-Wl,-Bsymbolic \
  259. --libdir=%{_libdir}/%{name} \
  260. --datadir=%{_libdir}/%{name} \
  261. %if %{with doxygen}
  262. --enable-doxygen \
  263. %else
  264. --disable-doxygen \
  265. %endif
  266. %ifarch armv7hl armv7l
  267. --with-cpu=cortex-a8 \
  268. --with-tune=cortex-a8 \
  269. --with-arch=armv7-a \
  270. --with-float=hard \
  271. --with-fpu=vfpv3-d16 \
  272. --with-abi=aapcs-linux \
  273. %endif
  274. --enable-targets=host \
  275. --disable-assertions \
  276. --enable-optimized \
  277. --enable-jit \
  278. --enable-libffi \
  279. --enable-shared \
  280. --enable-pic \
  281. --with-c-include-dirs=%{_includedir}:$(echo %{_prefix}/lib/gcc/%{_target_cpu}*/*/include) \
  282. --with-binutils-include=%{_includedir} \
  283. --enable-targets=x86,powerpc,arm,aarch64,cpp,nvptx \
  284. --enable-experimental-targets=R600 \
  285. --with-optimize-option=-O3
  286. make %{?_smp_mflags} REQUIRES_RTTI=1 VERBOSE=1
  287. %install
  288. rm -rf %{buildroot}
  289. make install DESTDIR=%{buildroot} \
  290. PROJ_docsdir=/moredocs
  291. # you have got to be kidding me
  292. rm -f %{buildroot}%{_bindir}/{FileCheck,count,not}
  293. # multilib fixes
  294. mv %{buildroot}%{_bindir}/llvm-config{,-%{__isa_bits}}
  295. pushd %{buildroot}%{_includedir}/llvm/Config
  296. mv config.h config-%{__isa_bits}.h
  297. cp -p %{SOURCE10} config.h
  298. mv llvm-config.h llvm-config-%{__isa_bits}.h
  299. cp -p %{SOURCE11} llvm-config.h
  300. popd
  301. # Create ld.so.conf.d entry
  302. mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
  303. cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf << EOF
  304. %{_libdir}/llvm
  305. EOF
  306. # Static analyzer not installed by default:
  307. # http://clang-analyzer.llvm.org/installation#OtherPlatforms
  308. # scan-view
  309. mkdir -p %{buildroot}%{_libexecdir}/clang-analyzer/
  310. cp -pr tools/clang/tools/scan-view %{buildroot}%{_libexecdir}/clang-analyzer/
  311. # scan-build
  312. mkdir -p %{buildroot}%{_libexecdir}/clang-analyzer/scan-build
  313. for file in c++-analyzer ccc-analyzer scan-build scanview.css sorttable.js; do
  314. cp -p tools/clang/tools/scan-build/$file \
  315. %{buildroot}%{_libexecdir}/clang-analyzer/scan-build/
  316. done
  317. # scan-build manual page
  318. mkdir -p %{buildroot}%{_mandir}/man1
  319. cp -p tools/clang/tools/scan-build/scan-build.1 %{buildroot}%{_mandir}/man1/
  320. # scan-build requires clang in search path
  321. ln -s ../../../bin/clang %{buildroot}%{_libexecdir}/clang-analyzer/scan-build/clang
  322. # launchers in /bin
  323. for f in scan-{build,view}; do
  324. ln -s %{_libexecdir}/clang-analyzer/$f/$f %{buildroot}%{_bindir}/$f
  325. done
  326. # Get rid of erroneously installed example files.
  327. rm %{buildroot}%{_libdir}/%{name}/*LLVMHello.*
  328. # remove executable bit from static libraries
  329. find %{buildroot}%{_libdir} -name "*.a" -type f -print0 | xargs -0 chmod -x
  330. # Install man page for LLDB
  331. mkdir -p %{buildroot}%{_mandir}/man1
  332. cp tools/lldb/docs/lldb.1 %{buildroot}%{_mandir}/man1/
  333. # llvm-doc
  334. mkdir -p %{buildroot}%{llvmdocdir %{name}-doc}
  335. cp -ar examples %{buildroot}%{llvmdocdir %{name}-doc}/examples
  336. find %{buildroot}%{llvmdocdir %{name}-doc} -name Makefile -o -name CMakeLists.txt -o -name LLVMBuild.txt -print0 | xargs -0 rm -f
  337. # llvm-apidoc
  338. %if %{with doxygen}
  339. mv %{buildroot}/moredocs/html/doxygen %{buildroot}%{llvmdocdir %{name}-apidoc}
  340. %endif
  341. # llvm-ocaml-doc
  342. mv %{buildroot}/moredocs/ocamldoc/html %{buildroot}%{llvmdocdir %{name}-ocaml-doc}
  343. # clang
  344. mkdir -p %{buildroot}%{llvmdocdir clang}
  345. for f in LICENSE.TXT NOTES.txt README.txt CODE_OWNERS.TXT; do
  346. cp tools/clang/$f %{buildroot}%{llvmdocdir clang}/
  347. done
  348. # clang-apidoc
  349. %if %{with doxygen}
  350. cp -ar tools/clang/docs/doxygen/html %{buildroot}%{llvmdocdir clang-apidoc}
  351. %endif
  352. # lldb
  353. mkdir -p %{buildroot}%{llvmdocdir lldb}
  354. cp tools/lldb/LICENSE.TXT %{buildroot}%{llvmdocdir lldb}/
  355. # delete the rest of installed documentation (because it's bad)
  356. rm -rf %{buildroot}/moredocs
  357. # install CMake modules
  358. mkdir -p %{buildroot}%{_datadir}/llvm/cmake/
  359. cp -p cmake/modules/*.cmake %{buildroot}%{_datadir}/llvm/cmake/
  360. # remove RPATHs
  361. file %{buildroot}/%{_bindir}/* | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
  362. file %{buildroot}/%{_libdir}/%{name}/*.so | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
  363. %check
  364. make check 2>&1 | tee ../llvm-testlog.txt
  365. make -C tools/clang/test 2>&1 | tee ../llvm-testlog.txt
  366. %clean
  367. rm -rf %{buildroot}
  368. %post libs -p /sbin/ldconfig
  369. %postun libs -p /sbin/ldconfig
  370. %post -n clang-libs -p /sbin/ldconfig
  371. %postun -n clang-libs -p /sbin/ldconfig
  372. %post -n lldb -p /sbin/ldconfig
  373. %postun -n lldb -p /sbin/ldconfig
  374. %posttrans devel
  375. # link llvm-config to the platform-specific file;
  376. # use ISA bits as priority so that 64-bit is preferred
  377. # over 32-bit if both are installed
  378. alternatives \
  379. --install \
  380. %{_bindir}/llvm-config \
  381. llvm-config \
  382. %{_bindir}/llvm-config-%{__isa_bits} \
  383. %{__isa_bits}
  384. %postun devel
  385. if [ $1 -eq 0 ]; then
  386. alternatives --remove llvm-config \
  387. %{_bindir}/llvm-config-%{__isa_bits}
  388. fi
  389. exit 0
  390. %files
  391. %defattr(-,root,root,-)
  392. %doc CREDITS.TXT README.txt
  393. %{_bindir}/bugpoint
  394. %{_bindir}/llc
  395. %{_bindir}/lli
  396. %{_bindir}/lli-child-target
  397. %exclude %{_bindir}/llvm-config-%{__isa_bits}
  398. %{_bindir}/llvm*
  399. %{_bindir}/macho-dump
  400. %{_bindir}/opt
  401. %dir %{_datadir}/llvm
  402. %exclude %{_mandir}/man1/clang.1.*
  403. %exclude %{_mandir}/man1/scan-build.1.*
  404. %exclude %{_mandir}/man1/lldb.1.*
  405. %doc %{_mandir}/man1/*.1.*
  406. %files devel
  407. %defattr(-,root,root,-)
  408. #doc %{llvmdocdir %{name}-devel}/
  409. %{_bindir}/llvm-config-%{__isa_bits}
  410. %{_includedir}/%{name}
  411. %{_includedir}/%{name}-c
  412. %{_libdir}/%{name}/*.a
  413. %{_datadir}/%{name}/cmake
  414. %files libs
  415. %defattr(-,root,root,-)
  416. %doc LICENSE.TXT
  417. %config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
  418. %dir %{_libdir}/%{name}
  419. %exclude %{_libdir}/%{name}/libclang.so
  420. %exclude %{_libdir}/%{name}/liblldb.so
  421. %{_libdir}/%{name}/*.so
  422. %files -n clang
  423. %defattr(-,root,root,-)
  424. %doc %{llvmdocdir clang}/
  425. %{_bindir}/clang*
  426. %{_bindir}/c-index-test
  427. %{_prefix}/lib/clang
  428. %doc %{_mandir}/man1/clang.1.*
  429. %files -n clang-libs
  430. %defattr(-,root,root,-)
  431. %{_libdir}/%{name}/libclang.so
  432. %files -n clang-devel
  433. %defattr(-,root,root,-)
  434. #doc %{llvmdocdir clang-devel}/
  435. %{_includedir}/clang
  436. %{_includedir}/clang-c
  437. %files -n clang-analyzer
  438. %defattr(-,root,root,-)
  439. %{_bindir}/scan-build
  440. %{_bindir}/scan-view
  441. %{_libexecdir}/clang-analyzer
  442. %{_mandir}/man1/scan-build.1.*
  443. %files -n lldb
  444. %defattr(-,root,root,-)
  445. %doc %{llvmdocdir lldb}/
  446. %{_bindir}/lldb
  447. %{_bindir}/lldb-*
  448. %{_libdir}/%{name}/liblldb.so
  449. # XXX double check this
  450. %{python_sitearch}/*
  451. %doc %{_mandir}/man1/lldb.1.*
  452. %files -n lldb-devel
  453. %defattr(-,root,root,-)
  454. %{_includedir}/lldb
  455. %files doc
  456. %defattr(-,root,root,-)
  457. %doc %{llvmdocdir %{name}-doc}/
  458. %files ocaml
  459. %defattr(-,root,root,-)
  460. %{_libdir}/ocaml/*.cma
  461. %{_libdir}/ocaml/*.cmi
  462. %{_libdir}/ocaml/*.so
  463. %{_libdir}/ocaml/META.llvm*
  464. %files ocaml-devel
  465. %defattr(-,root,root,-)
  466. %{_libdir}/ocaml/*.a
  467. %{_libdir}/ocaml/*.cmx*
  468. %{_libdir}/ocaml/*.mli
  469. %files ocaml-doc
  470. %defattr(-,root,root,-)
  471. %doc %{llvmdocdir %{name}-ocaml-doc}/
  472. %if 0%{?_with_doxygen}
  473. %files apidoc
  474. %defattr(-,root,root,-)
  475. %doc %{llvmdocdir %{name}-apidoc}/
  476. %files -n clang-apidoc
  477. %defattr(-,root,root,-)
  478. %doc %{llvmdocdir clang-apidoc}/
  479. %endif
  480. %if %{build_compat32}
  481. %files -n compat32-%{name}-libs
  482. %defattr(-,root,root)
  483. %doc LICENSE.TXT
  484. %config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
  485. %dir %{_libdir}/%{name}
  486. %exclude %{_libdir}/%{name}/libclang.so
  487. %exclude %{_libdir}/%{name}/liblldb.so
  488. %{_libdir}/%{name}/*.so
  489. %endif
  490. %changelog
  491. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  492. - updated to 3.5.1
  493. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  494. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  495. - obsoleted clang-doc
  496. - built with ocaml 4.02.1
  497. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  498. - fix <BTS:2832>
  499. - fix configure option "--with-c-include-dirs"
  500. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  501. - update Patch1001: clang-3.5.0-driver-lib64.patch
  502. - update Patch1002: clang-3.5.0-driver-vine.patch
  503. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  504. - update to 3.5.0
  505. - remove Patch11 (clang-hardfloat-hack.patch)
  506. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  507. - rebuild with libffi-3.0.13
  508. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  509. - update to 3.3
  510. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  511. - ld.gold (patch1000,1001)
  512. - add /%{_lib} to ld search path
  513. - add support *-vine-linux gcc (patch1002)
  514. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  515. - update to 3.1
  516. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  517. - updated to 3.0 release
  518. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  519. - added patch 2-4 to support -O4 link-time optimization
  520. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  521. - disable -fno-var-tracking-assignments on ppc
  522. (seems like gcc-4.4.5 still doesn't support this)
  523. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  524. - new upstream release
  525. - add BR: libffi-devel
  526. - add R: libffi-devel to -devel
  527. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  528. - initial build for Vine Linux
  529. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  530. - Update to final 2.7 release
  531. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  532. - Update to first 2.7 pre-release
  533. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  534. - Update to 2.6 pre-release2
  535. - -devel subpackage now virtually provides -static
  536. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  537. - Disable var tracking assignments on PPC
  538. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  539. - Don't adjust clang include dir; files there are noarch (bz#521893)
  540. - Enable clang unit tests
  541. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  542. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  543. - Package Clang's static analyzer tools
  544. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  545. - PIC is now enabled by default; explicitly disable on %%{ix86}
  546. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  547. - First 2.6 prerelease
  548. - Enable Clang front-end
  549. - Enable debuginfo generation
  550. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  551. - Disable assertions (needed by OpenGTL, bz#521261)
  552. - Align spec file with upstream build instructions
  553. - Enable unit tests
  554. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  555. - Only disable PIC on %%ix86; ppc actually needs it
  556. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  557. - Disable use of position-independent code on 32-bit platforms
  558. (buggy in LLVM <= 2.5)
  559. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  560. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  561. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  562. - Remove build scripts; they require the build directory to work
  563. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  564. - Update to 2.5
  565. - Package build scripts (bug #457881)
  566. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  567. - Patched build process for the OCaml binding
  568. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  569. - Update to 2.4
  570. - Package Ocaml binding
  571. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  572. - Add dependency on groff
  573. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  574. - LLVM 2.3
  575. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  576. - fix license tags
  577. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  578. - Fix compilation problems with gcc 4.3
  579. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  580. - Autorebuild for GCC 4.3
  581. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  582. - Fix review comments
  583. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  584. - Initial version