libgpod-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. %define with_mono 1
  2. Summary: Library to access the iPod
  3. Summary(ja): iPod にアクセスするためのライブラリ
  4. Name: libgpod
  5. Version: 0.8.3
  6. Release: 5%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.gtkpod.org/libgpod.html
  10. Source0: %{name}-%{version}.tar.bz2
  11. # Vine Patch
  12. Patch100: %{name}-0.8.3-python-uncomment.patch
  13. Buildroot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: docbook-style-xsl
  15. BuildRequires: glib2-devel
  16. BuildRequires: gtk2-devel
  17. BuildRequires: gettext
  18. BuildRequires: intltool
  19. BuildRequires: libimobiledevice-devel >= 1.1.4
  20. BuildRequires: libplist-devel >= 1.0
  21. BuildRequires: libusb1-devel
  22. BuildRequires: libxml2-devel
  23. BuildRequires: libxslt
  24. BuildRequires: libffi-devel
  25. BuildRequires: perl(XML::Parser)
  26. BuildRequires: pygobject-devel
  27. BuildRequires: python-devel
  28. BuildRequires: python-mutagen
  29. BuildRequires: sg3_utils-devel
  30. BuildRequires: sqlite3-devel
  31. BuildRequires: taglib-devel
  32. BuildRequires: swig
  33. %if %{with_mono}
  34. BuildRequires: mono-devel
  35. BuildRequires: gtk-sharp2-devel
  36. %endif
  37. Requires: udev
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. Packager: daisuke
  41. %description
  42. libgpod is a library meant to abstract access to an iPod content. It
  43. provides an easy to use API to retrieve the list of files and playlist
  44. stored on an iPod, to modify them and to save them back to the iPod.
  45. %description -l ja
  46. libgpod は iPod のコンテンツにアクセスするためのライブラリです。
  47. iPod に格納されているファイルリストやプレイリストを取得し、変更し、
  48. iPod に書き戻すための API が提供されています。
  49. %package devel
  50. Summary: Support files necessary to compile applications with libgpod.
  51. Summary(ja): libgpod を使うアプリケーションのコンパイルに必要なファイル.
  52. Group: Development/Libraries
  53. Requires: libgpod = %{version}-%{release}
  54. Requires: glib2-devel
  55. Requires: gtk2-devel
  56. %description devel
  57. Libraries, headers, and support files necessary to compile applications using libgpod.
  58. %description -l ja devel
  59. libgpod を使ったアプリケーションのコンパイルに必要なライブラリ,ヘッダファイルなどが含まれています.
  60. %package -n python-gpod
  61. Summary: Python module to access iPod content
  62. Summary(ja): iPod にアクセスするための Python モジュール
  63. Group: Development/Libraries
  64. Requires: %{name} = %{version}-%{release}
  65. Requires: python-mutagen
  66. %description -n python-gpod
  67. A python module to access iPod content. This module provides bindings to the libgpod library.
  68. %if %{with_mono}
  69. %package sharp
  70. Summary: C#/.NET library to access iPod content
  71. Summary(ja): iPod にアクセスするための C#/.NET ライブラリ
  72. Group: System Environment/Libraries
  73. Requires: %{name} = %{version}-%{release}
  74. %description sharp
  75. C#/.NET library to access iPod content. Provides bindings to the libgpod library.
  76. %package sharp-devel
  77. Summary: Development files for libgpod-sharp
  78. Summary(ja): libgpod-sharp の開発用ファイル
  79. Group: Development/Libraries
  80. Requires: %{name}-sharp = %{version}-%{release}
  81. Requires: pkgconfig
  82. %description sharp-devel
  83. C#/.NET library to access iPod content. Provides bindings to the libgpod library.
  84. This package contains the files required to develop programs that will use
  85. libgpod-sharp.
  86. %endif
  87. %prep
  88. %setup -q
  89. %patch100 -p1 -b .uncomment
  90. chmod -x bindings/python/examples/*.py
  91. %build
  92. %configure \
  93. --without-hal \
  94. --enable-udev \
  95. --with-temp-mount-dir=%{_localstatedir}/run/%{name}
  96. make %{?_smp_mflags}
  97. %install
  98. if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
  99. make DESTDIR=%{buildroot} install
  100. %find_lang %{name}
  101. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  102. rm -f $RPM_BUILD_ROOT%{python_sitearch}/gpod/*.{a,la}
  103. %clean
  104. if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
  105. %post -p /sbin/ldconfig
  106. %postun -p /sbin/ldconfig
  107. %files -f %{name}.lang
  108. %defattr(-, root, root, 0755)
  109. %doc AUTHORS ChangeLog COPYING README
  110. %{_bindir}/*
  111. %{_libdir}/lib*.so.*
  112. %dir %{_localstatedir}/run/%{name}
  113. /lib/udev/iphone-set-info
  114. /lib/udev/ipod-set-info
  115. /lib/udev/rules.d/*.rules
  116. %files devel
  117. %defattr(-, root, root, 0755)
  118. %{_libdir}/lib*.so
  119. %{_libdir}/pkgconfig/%{name}-1.0.pc
  120. %{_includedir}/gpod-1.0/
  121. %{_datadir}/gtk-doc/html/%{name}
  122. %files -n python-gpod
  123. %defattr(-, root, root, 0755)
  124. %doc COPYING bindings/python/README bindings/python/examples
  125. %{python_sitearch}/gpod
  126. %if %{with_mono}
  127. %files sharp
  128. %defattr(-, root, root, 0755)
  129. %{_libdir}/%{name}/%{name}-sharp*
  130. %files sharp-devel
  131. %defattr(-, root, root, 0755)
  132. %{_libdir}/pkgconfig/%{name}-sharp.pc
  133. %endif
  134. %changelog
  135. * Sat Mar 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-5
  136. - rebuilt with mono 3.12.1
  137. * Sun Mar 8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-4
  138. - added patch100 to build swig 3.0.5
  139. - moved %%{_libdir}/pkgconfig/libgpod-sharp.pc to sharp subpackage
  140. * Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-3
  141. - moved sharp subpackage to System Environment/Libraries Group
  142. - moved sharp-devel subpackage to Development/Libraries Group
  143. * Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.8.3-2
  144. - rebuild with new libplist, libimobiledevice
  145. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
  146. - new upstream release
  147. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-2
  148. - rebuild with libimobiledevice-1.1.5
  149. * Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
  150. - update to 0.8.2
  151. - remove Patch0
  152. - add BuildRequires: mono-devel, gtk-sharp2, taglib-devel
  153. - create sharp and sharp-devel package
  154. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-4
  155. - rebuild with libimobiledevice-1.1.4
  156. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-3
  157. - rebuild with python-2.7.2
  158. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
  159. - rebuild with libimobiledevice-1.1.1
  160. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-1
  161. - update to 0.8.0
  162. * Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.93-2
  163. - rebuilt with rpm-4.8.1 for pkg-config
  164. * Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.93-1
  165. - new upstream release
  166. - add configure option (disable hal, enable udev, specify temp mount dir)
  167. - add python subpackage
  168. - add BR:
  169. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
  170. - new upstream release
  171. - remove static library
  172. * Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-3vl5
  173. - added BuildRequires: libffi-devel
  174. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2vl5
  175. - spec in utf-8
  176. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1vl5
  177. - applied new versioning policy
  178. * Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 0.6.0-0vl1
  179. - new upstream release
  180. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4.2-0vl2
  181. - for VineSeedPlus
  182. - new upstream release
  183. - built with new toolchain
  184. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  185. - new upstream release
  186. - build with dbus-0.62
  187. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
  188. - new upstream release
  189. - build with dbus-0.61
  190. * Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  191. - initial package